Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android) Details »
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android)
Mod Version: 1.0.3, by dartho (Coder/Designer) dartho is offline
Developer Last Online: Aug 2020 I like it Show Printable Version Email this Page

vB Version: 4.1.8 Rating: (98 votes - 4.82 average) Installs: 895
Released: 25 Aug 2010 Last Update: 16 Dec 2011 Downloads: 6248
Not Supported Re-usable Code  

A lightweight *forum only style aimed at small screen devices such as Windows Smartphones, Nokias and even iPhones. It has VERY low bandwidth requirements - 15 times less on my site - 20K as opposed to 300K for forumhome.

*forum only - I have done a very small amount of rough work on CMS templates, a simple single column CMS *could* be created to work with this style without too much effort. However I am not sure if you can have a different CMS layout dependent on which style you are using?

This is an update to the mobile style I have previously released.

The changes are predominantly aesthetic to take advantage of larger screens.

It is also much easier to change colour schemes by editing the commented CSS file.


Demo: http://vbdev.org/forum.php?styleid=7

This is a a lightweight style and as such has much reduced functionality/information over the default vBulletin style.

Install instructions:
  • Firstly, if upgrading, I recommend installing this as a new style rather than overwriting your previous install. This way you get to test it first without trashing your existing style.
  • BACKUP YOUR EXISTING lightweight.css.php FILE IF YOU HAVE CSS CUSTOMISATIONS
  • Download ZIP file
  • Unzip to a local/temp directory
  • Edit lightweight.css.php file to customise colours if required
  • Upload contents of the upload directory in the zip file folder to your forum root.
  • Install style XML via Style Manager in your ADMINCP
  • **Install and configure "LightWeight Style Options"
  • See post 2 for a FAQ
  • Click "Mark as Installed"
  • Test it out
  • Leave a rating
  • Leave feedback
  • Enjoy checking your site from your mobile phone without the need to pinch/zoom/wait etc...
Version Control:
1.0.0 - 25 AUG 2010 - Initial Release on vBulletin.org
1.0.1 - 26 AUG 2010 - Fixed "Mark All Forums Read" link in Search results. Released Lightweight Style Options to customise this
1.0.2 - 21 MAR 2011 - Updated to 4.1.2, removed short tags from CSS, fixed some issues discovered since last release, added some stuff.
1.0.3 - 16 DEC 2011 - Updated to 1.0.3, tried to fix all known issues. Nothing new. If you have updated your site as bugs have been found, probably no need to upgrade. But if you're upgrading your site from to 4.1.9, might be worthwhile.
1.0.3a - 16 DEC 2011 - remove test ad hook code accidently left in postbit_legacy template
Branding Free:
The style is free to use. However I ask that you keep links in the footer. If you want to remove them - send me a donation of an amount you can afford, or that you think is fair/reasonable, it's up to you how much.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	lightweight-screenshot.png
Views:	41573
Size:	30.6 KB
ID:	121268  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.8 Add-ons 147 23 Jun 2020 14:30
Forum Display Enhancements Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.7 Add-ons 407 19 Mar 2015 15:53
Mobile, Cell, Phone, PDA, iPhone Style dartho vBulletin 3.7 Styles 795 16 Aug 2012 14:39
Mobile/Cell Phone Style dartho vBulletin 3.6 Styles 313 21 Aug 2011 23:04

  #256  
Old 17 Jan 2011, 15:21
dhemitz's Avatar
dhemitz dhemitz is offline
 
Join Date: Oct 2007
I'm install in vbulletin 4.1.1

It's work...!

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Big thanks @dartho......
Reply With Quote
  #257  
Old 17 Jan 2011, 16:02
BadgerDog BadgerDog is offline
 
Join Date: Oct 2006
Real name: Doug
Originally Posted by dartho View Post
@BadgerDog -

First - if you have the Lightweight STyule Options add-on installed, try adding this:
$vbulletin->options['dt_separate_sticky_normal_active']=0;
$vbulletin->options['dt_separate_sticky_normal_remove']=0;

to the code to disable add-ons section.

If that doesn't work, try editing the Separate Sticky and Normal Threads plugin for for seperate sticky/normal threads and wrap it in

if (STYLEID!=n){

existing pluginin code

}

where n is the lightweight style ID

As for teh Ads stuff, try deleting teh entire contents of the forumhome_ads_code template in the lightweight style
Thanks very much Dartho

For the Separate Sticky and Normal Threads mod that some people here may be using, I didn't bother trying your fix below as I didn't quite understand where to put it, so I don't know whether it would work or not

$vbulletin->options['dt_separate_sticky_normal_active']=0;
$vbulletin->options['dt_separate_sticky_normal_remove']=0;

========================================

I DID DO this:

if (STYLEID!=n){

existing pluginin code

}
adding it to these plugins, wrapping both plugins it your code:

Product : Separate Sticky and Normal Threads

Separate Sticky and Normal Threads parse_templates
Separate Sticky and Normal Threads threadbit_display
It worked PERFECT !!!


For the ads, I did locate the forumhome_ads_code template in your lightweight style and emptied it so it was blank.

It worked PERFECT as well !!

See attached pic as to how a forum with ads and stickies now appears. NO graphic ads in lightweight style now and the stickies seem fine now, yet the ads and stickies are also fine in the main default site graphics style.

Thank you very much !!!

I have sent a second PayPal donation for you help in solving these integration issues with your lightweight style

Regards,
Doug
Attached Images
File Type: jpg Screen shot 2011-01-17 at 11.00.57 AM.jpg (100.0 KB, 28 views)
Reply With Quote
  #258  
Old 18 Jan 2011, 00:18
dartho dartho is offline
 
Join Date: Sep 2005
Originally Posted by Mark Hewitt View Post
I've got it working now. The only difference to the above was that I uploaded the style from my PC rather then specifying a file on the server. Shouldn't make any difference but it seemed to do so in this case!
It wasn't you Mark - it is a confirmed bug in vbuilletin (which they consider "trivial") that has been there since 4.0 http://tracker.vbulletin.com/browse/VBIV-3801


@Badgerdog - much appreciated
Reply With Quote
  #259  
Old 19 Jan 2011, 05:51
PSC001 PSC001 is offline
 
Join Date: Jul 2010
I just installed this style and it completely broke my forum. All my forums are completely messed up now. I tried deleting the mobile style I imported in Style Manager, but that didn't help. I don't know what I did wrong, but can someone please help?
Reply With Quote
  #260  
Old 19 Jan 2011, 06:37
PSC001 PSC001 is offline
 
Join Date: Jul 2010
I added the mobile style via Style Manager in vBulletin, but it destroyed everything. Everything is messed up horribly. All my styling was gone, everything was stripped down and all out of wack.

I tried to re-import my old style but that reverted everything to the standard vbulletin styling.

Worse, when I go to certain subforums now, I get a blank screen, sometimes even when I try my home page.

I deleted the mobile style and deleted the css file from my root forum directory but neither changed anything.

Looking at my old main style in Style Manager, everything is in red meaning it's been overwritten.

I have no idea what do here.
Reply With Quote
  #261  
Old 19 Jan 2011, 07:08
PSC001 PSC001 is offline
 
Join Date: Jul 2010
Figured out that the blank screen was being caused by one of the child styles I had was royally messed up. I switched that forum to a different style that seemed to be working and it's coming up now. It's just that all the styling I had done previously is gone. I've started fixing a couple things manually to create some semblance of normalcy, but it's still a giant mess.
Reply With Quote
  #262  
Old 19 Jan 2011, 19:08
baghdad4ever baghdad4ever is offline
 
Join Date: May 2007
Real name: husam
Originally Posted by PSC001 View Post
Figured out that the blank screen was being caused by one of the child styles I had was royally messed up. I switched that forum to a different style that seemed to be working and it's coming up now. It's just that all the styling I had done previously is gone. I've started fixing a couple things manually to create some semblance of normalcy, but it's still a giant mess.
i think it is vbulletin bug see this

http://tracker.vbulletin.com/browse/VBIV-8302
Reply With Quote
  #263  
Old 19 Jan 2011, 19:32
PSC001 PSC001 is offline
 
Join Date: Jul 2010
Thanks. Looks like that's what happened. Unfortunately, I'm not sure I can follow their fix. Since what I originally did completely broke everything, I tried to re-import the Master style so I could at least read the board. Unfortunately, it seems doing that over-wrote all my custom styling and I have no idea how to get it back.
Reply With Quote
  #264  
Old 21 Jan 2011, 06:00
anupam_luv anupam_luv is offline
 
Join Date: Feb 2007
do we need 2 rename lightweight.css.php back to lightweight.css after install???????
__________________
Health & Fitness News And Discussion Forum
http://www.fitnessmatter.com
D'Street Community For Traders And Investors
http://www.dstreetdirect.com
Reply With Quote
  #265  
Old 21 Jan 2011, 08:02
dartho dartho is offline
 
Join Date: Sep 2005
no - the php file generates the CSS output. Have a look inside and you'll see what I mean.

@PSC001 - sorry to hear about the grief. Can't believe this is still not fixed after a year ...
Reply With Quote
  #266  
Old 21 Jan 2011, 13:02
NNJJ NNJJ is offline
 
Join Date: Dec 2001
its not working for me
__________________
We are not Creators, but we have the Magic of Creation
Reply With Quote
  #267  
Old 21 Jan 2011, 22:40
dartho dartho is offline
 
Join Date: Sep 2005
Your site looks OK to me?
Reply With Quote
  #268  
Old 22 Jan 2011, 17:23
BadgerDog BadgerDog is offline
 
Join Date: Oct 2006
Real name: Doug
Is there some way of having external pics that people refer to using the IMG code, be shown smaller so they don't overflow the right side of the screen causing the display to have to be scrolled sideways?

We use SevenSkins Image Resizer which works for all our other regular PC screen skins, but doesn't seem to be present in this Lightweight Style.

Thanks for any feedback ..

Regards,
Doug
Reply With Quote
  #269  
Old 23 Jan 2011, 17:09
DaffyDuck DaffyDuck is offline
 
Join Date: Jul 2006
For some reason the mobilelogo.png does not display in the header, and apparently there is no reference to $Logo anywhere in the code, as it is. It is specified in the definitions, but beyond there, it's not in the page generation code.

How do I place the logo in the header?
Reply With Quote
  #270  
Old 24 Jan 2011, 00:43
dartho dartho is offline
 
Join Date: Sep 2005
@Daffy - The logo is defined in the CSS so you can change there or overwrite the existing image file "images/misc/mobilelogo.png"

If you can;t see it being rendered, it could be that your brower doesn't support it, or if you have the options addon for this style you have enetered in text for the header which replaces the logo.

@BadgerDog - could you link me to a page where it's not working. I think I might need admin logo to sort this out, but don't imagine it would take long.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 11:00.

Layout Options | Width: Wide Color: