Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android) Details »
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android)
Mod Version: 1.0.3, by dartho (Coder/Designer) dartho is offline
Developer Last Online: Aug 2020 I like it Show Printable Version Email this Page

vB Version: 4.1.8 Rating: (98 votes - 4.82 average) Installs: 895
Released: 25 Aug 2010 Last Update: 16 Dec 2011 Downloads: 6248
Not Supported Re-usable Code  

A lightweight *forum only style aimed at small screen devices such as Windows Smartphones, Nokias and even iPhones. It has VERY low bandwidth requirements - 15 times less on my site - 20K as opposed to 300K for forumhome.

*forum only - I have done a very small amount of rough work on CMS templates, a simple single column CMS *could* be created to work with this style without too much effort. However I am not sure if you can have a different CMS layout dependent on which style you are using?

This is an update to the mobile style I have previously released.

The changes are predominantly aesthetic to take advantage of larger screens.

It is also much easier to change colour schemes by editing the commented CSS file.


Demo: http://vbdev.org/forum.php?styleid=7

This is a a lightweight style and as such has much reduced functionality/information over the default vBulletin style.

Install instructions:
  • Firstly, if upgrading, I recommend installing this as a new style rather than overwriting your previous install. This way you get to test it first without trashing your existing style.
  • BACKUP YOUR EXISTING lightweight.css.php FILE IF YOU HAVE CSS CUSTOMISATIONS
  • Download ZIP file
  • Unzip to a local/temp directory
  • Edit lightweight.css.php file to customise colours if required
  • Upload contents of the upload directory in the zip file folder to your forum root.
  • Install style XML via Style Manager in your ADMINCP
  • **Install and configure "LightWeight Style Options"
  • See post 2 for a FAQ
  • Click "Mark as Installed"
  • Test it out
  • Leave a rating
  • Leave feedback
  • Enjoy checking your site from your mobile phone without the need to pinch/zoom/wait etc...
Version Control:
1.0.0 - 25 AUG 2010 - Initial Release on vBulletin.org
1.0.1 - 26 AUG 2010 - Fixed "Mark All Forums Read" link in Search results. Released Lightweight Style Options to customise this
1.0.2 - 21 MAR 2011 - Updated to 4.1.2, removed short tags from CSS, fixed some issues discovered since last release, added some stuff.
1.0.3 - 16 DEC 2011 - Updated to 1.0.3, tried to fix all known issues. Nothing new. If you have updated your site as bugs have been found, probably no need to upgrade. But if you're upgrading your site from to 4.1.9, might be worthwhile.
1.0.3a - 16 DEC 2011 - remove test ad hook code accidently left in postbit_legacy template
Branding Free:
The style is free to use. However I ask that you keep links in the footer. If you want to remove them - send me a donation of an amount you can afford, or that you think is fair/reasonable, it's up to you how much.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	lightweight-screenshot.png
Views:	41576
Size:	30.6 KB
ID:	121268  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.8 Add-ons 147 23 Jun 2020 14:30
Forum Display Enhancements Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.7 Add-ons 407 19 Mar 2015 15:53
Mobile, Cell, Phone, PDA, iPhone Style dartho vBulletin 3.7 Styles 795 16 Aug 2012 14:39
Mobile/Cell Phone Style dartho vBulletin 3.6 Styles 313 21 Aug 2011 23:04

  #901  
Old 01 May 2012, 20:51
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
Originally Posted by djbaxter View Post
When you say "disabled" do you mean uninstall? or how exactly did you disable the vB options? I am also on 4.1.12 PL1.
Just put it to None, you have two options in ACP->Settings->Options->Style & Language Settings:

Default Style for Old Mobile Browsers
Default Style for Modern Mobile Browsers

There you can choose style you want automatically selected when user's browsing from mobile. Put it to none (or use it, than you don't need mod from dartho). In some vB versions there was bug and this didn't worked. Not sure in which version it was corrected if it is corrected. I'm using dartho's mod and it works.
Reply With Quote
  #902  
Old 08 May 2012, 05:19
Merriweather Merriweather is offline
 
Join Date: Nov 2006
Something is going on with the pagenav. For instance, I am seeing:

Thread Title Here > (25) ()

Where "25" is the number of posts, and the parenthesis is supposed to have the page navigation links, but it's showing up blank. It will show (...Last Page) if there are at least 50 posts, but for 10 - 49 posts, I get blank parenthesis.

Ideas?
Reply With Quote
  #903  
Old 08 May 2012, 14:46
dartho dartho is offline
 
Join Date: Sep 2005
If you red over the last couple pages, there have been some issues reported which seem to be resolved by reinstalling as a new style?
Reply With Quote
  #904  
Old 10 May 2012, 06:23
semprot semprot is offline
 
Join Date: Mar 2010
Real name: Jeremy
Originally Posted by Merriweather View Post
Something is going on with the pagenav. For instance, I am seeing:

Thread Title Here > (25) ()

Where "25" is the number of posts, and the parenthesis is supposed to have the page navigation links, but it's showing up blank. It will show (...Last Page) if there are at least 50 posts, but for 10 - 49 posts, I get blank parenthesis.

Ideas?
Don't forget to use 4.1.12 PL 1. And reinstall the style
__________________
Best regards,

Jeremy
Reply With Quote
  #905  
Old 15 May 2012, 01:46
Merriweather Merriweather is offline
 
Join Date: Nov 2006
I tried that to no avail. I'm thinking it might be because I installed it as a mobile style vs a regular style?
Reply With Quote
  #906  
Old 16 May 2012, 01:55
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
after updating to vb4.1.12 pl1 it's not caching any templates.

I have 8WayRun.Com - Micro Debug Stats installed since day one and you can see if a template is not being cached.. as so

this is 8wayrun's screenshot from his mod as a example of whats happening


this only start to display a long list of stock and mod template after the latest..

I am not sure what vb changed for this to happen..

any ideas ?
Reply With Quote
  #907  
Old 16 May 2012, 02:26
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Hippy View Post
after updating to vb4.1.12 pl1 it's not caching any templates.

I have 8WayRun.Com - Micro Debug Stats installed since day one and you can see if a template is not being cached.. as so

this is 8wayrun's screenshot from his mod as a example of whats happening


this only start to display a long list of stock and mod template after the latest..

I am not sure what vb changed for this to happen..

any ideas ?
Yep. Re-import the XML for the style.
Reply With Quote
  #908  
Old 16 May 2012, 02:33
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
I did and lost all the templates that where not edited from when we did the post thanks..
I had to add them back manually
but that did not fix it
I even deleted it and imported it again...
Reply With Quote
  #909  
Old 16 May 2012, 09:42
dartho dartho is offline
 
Join Date: Sep 2005
I think the way to resolve the uncached templates would be to deleted those templates from the XML file before importing the style. I've been pretty busy lately and haven;t had teh time to sit down and have a proper look as yet ...
Reply With Quote
  #910  
Old 18 May 2012, 22:59
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
thanks .. But seems they are missing .. I think one of the vb updated moved it to a mobile style and if it wasn't a edited template it did away with it
so adding them back I think will fix it ..
Not sure if thats the correct way tho..
life first .. and see what you come up with

thanks for the support
Reply With Quote
  #911  
Old 19 May 2012, 15:44
S_E_A S_E_A is offline
 
Join Date: Nov 2010
Receive an Array error message when checking users online on 4.1.12. Anyone else had this problem?

Cheers
Reply With Quote
  #912  
Old 20 May 2012, 15:41
The Rocketeer's Avatar
The Rocketeer The Rocketeer is offline
 
Join Date: Jun 2010
@Dartho, Update the style after vB 4.1.2 , that should fix most bugs. also please take the time to view and consider including or improving upon my edited cms templates from here, http://www.vbulletin.org/forum/showp...&postcount=889

it should help a lot of people and a great add on for this style out of the box. (no credits needed)
Reply With Quote
  #913  
Old 26 May 2012, 22:47
edytwinky edytwinky is offline
 
Join Date: Sep 2007
Dartho,
Is there any way to include a box on posting replies or threads for users to insert images from their phone?
Reply With Quote
  #914  
Old 28 May 2012, 00:20
semprot semprot is offline
 
Join Date: Mar 2010
Real name: Jeremy
Question

Originally Posted by The Rocketeer View Post
@Dartho, Update the style after vB 4.1.2 , that should fix most bugs. also please take the time to view and consider including or improving upon my edited cms templates from here, http://www.vbulletin.org/forum/showp...&postcount=889

it should help a lot of people and a great add on for this style out of the box. (no credits needed)
For some reason i reinstalled this style as mobile-no-parent after upgrading to 4.2.0..
  • Quoting message works.
  • Add reputation page doesn't work.
  • Add infraction page doesn't work.

Will they fixed if the stylevar on the template is changed?
__________________
Best regards,

Jeremy
Reply With Quote
  #915  
Old 28 May 2012, 01:19
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
Originally Posted by semprot View Post
For some reason i reinstalled this style as mobile-no-parent after upgrading to 4.2.0..
  • Quoting message works.
  • Add reputation page doesn't work.
  • Add infraction page doesn't work.

Will they fixed if the stylevar on the template is changed?
it removes templates when you did that
I would add it back to the normal style group
or you have to add those templates it's missing back..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 12:17.

Layout Options | Width: Wide Color: