Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Commbull (Community Bulletin) 5.1a for vBulletin 4.01 Details »
Commbull (Community Bulletin) 5.1a for vBulletin 4.01
Mod Version: 4.5F for 4, by djbaxter (Coder/Designer) djbaxter is offline
Developer Last Online: Sep 2019 I like it Show Printable Version Email this Page

vB Version: 4.0.4 Rating: (1 vote - 5.00 average) Installs: 59
Released: 21 Jan 2010 Last Update: 14 Jul 2010 Downloads: 310
Not Supported DB Changes Uses Plugins Template Edits Auto-Template Additional Files  

This not the CommBull product itself. This is simply instructions for adapting it to work with vBulletin 4.x.

Download CommBull from: Commbull (Community Bulletin) 5.1a for vBulletin 3.8x

grandeur_69 has released his latest version of CommBull as a free add-on, indicating that he no longer has time to continue developing it. I am posting this here for the benefit of other vBulletin 4.x who don't want to lose the newsletter feature (grandeur_69 has approved this).

At http://www.vbulletin.org/forum/showp...6&postcount=71 a member asks:

Hi, the version 5.1a work fine with vbulletin 4.0.1 ?
My response is posted at http://www.vbulletin.org/forum/showp...5&postcount=72 and reproduced here...

I have the previous (commercial) version, 4.5f, which does run successfully via a cron job, running on 4.01. It required some modification of the installation instructions but it does work. I expect you should be able to get this version running as well, although as the coder noted the cron capability won't work.

1. Edit product-Commbull.xml and find the following line:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change to:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


2. Upload the files and import the product.

3. Now you need to do the template edits so that members can opt-in or opt-out of your newsletter. The current instructions are as follows:

4. Template modifications
--------------------------------------

Template: "Modify User Option" -> "modifyoptions"

After:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Add:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Now, obviously this won't work in 4.x. These need to be modified as follows:

1. Edit Template: "Modify User Option" -> "modifyoptions"

FIND:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


ADD AFTER:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

That first part (above) is the option to receive or not receive the newsletters.

Next would be the option for HTML or plain text emails, which should be:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Update:

This now works. I had a ( instead of a { on the previous code. Thanks to grandeur_69 for pointing this out!

Notes:
  1. The product is not mine so I can't offer any support for CommBull itself. However, I have been using the paid versions of this mod for some time and I'm happy to offer what support I can for making the changes necessary to get it running on 4.x.

  2. I have been in communication with grandeur_69. He has indicated that he has no objections to this thread and that as he gets time he will be trying to develop this add-on further as a free product.

Update July 12, 2010: Product XML file provided by grandeur_69 for vBulletin 4.x.

NOTE:
  1. If you have already done the manual edits, do NOT use the XML file. And if you import the XML file, you should not need to do the manual edits.
  2. Some people are encountering problems using the XML file. If you are one of them, uninstall the product and use the manual edits. Those seem to work just fine.


Update July 14, 2010: Error in XML file corrected.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	top-custom-text.jpg
Views:	3320
Size:	61.4 KB
ID:	110697   Click image for larger version

Name:	top-new-threads.jpg
Views:	2671
Size:	51.1 KB
ID:	110698   Click image for larger version

Name:	articles.jpg
Views:	1827
Size:	48.6 KB
ID:	110699  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Administrative and Maintenance Tools Commbull (Community Bulletin) 5.1b grandeur_69 vBulletin 3.8 Add-ons 288 11 Jul 2014 04:19
Commbull (Community Bulletin) grandeur_69 vBulletin 3.5 Add-ons 116 19 Aug 2012 14:59
CommBull (Community Bulletin) grandeur_69 vBulletin 3.0 Full Releases 449 24 Feb 2009 04:16

  #61  
Old 20 Jul 2010, 01:02
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by asuccar View Post
Hey guys,

I downloaded & installed this great mod without a hitch...I configured the html to look exactly as I wanted it to.

When I was ready, I went to the send page and clicked on the 'send' button below...then the mod done its thing and listed all my user (blu blu...user...html ok) and way at the bottom it says 'All Done!.

Problem: None of my users got the email! And there's no way (that I know of) to verify delivery (something like 'sent mail')...can anyone tell me what's going on?
I see you also posted this in the CommBull thread at http://www.vbulletin.org/forum/showthread.php?t=230359 - you'll need to get grandeur_69 to help you with this. I'm just trying to provide support for adapting the add-on to 4.x but I'm not using version 5.1.
Reply With Quote
  #62  
Old 22 Jul 2010, 13:15
robbiefritz robbiefritz is offline
 
Join Date: Oct 2008
Real name: Robert
So just to make sure that I understand, I download v5.1 from that page then use the xml file here to install?
Reply With Quote
  #63  
Old 22 Jul 2010, 13:30
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by robbiefritz View Post
So just to make sure that I understand, I download v5.1 from that page then use the xml file here to install?
I used the manual ediots and they are working well for me.

grandeur_69 provided the XML file but I have not personally tested it. However, if you're installing 5.1, by all means give the XML product file here a shot. If it doesn't work for you, try the manual edits instead.
Reply With Quote
  #64  
Old 22 Jul 2010, 13:52
robbiefritz robbiefritz is offline
 
Join Date: Oct 2008
Real name: Robert
Originally Posted by djbaxter View Post
I used the manual ediots and they are working well for me.

grandeur_69 provided the XML file but I have not personally tested it. However, if you're installing 5.1, by all means give the XML product file here a shot. If it doesn't work for you, try the manual edits instead.
Thanks m8! Appreciate your efforts.
Reply With Quote
  #65  
Old 08 Aug 2010, 15:59
jiffylb1's Avatar
jiffylb1 jiffylb1 is offline
 
Join Date: Aug 2006
Real name: pokerlife
get this dtatabase error when trying to send news letter now did not happend before

Database error in vBulletin 4.0.5:
Invalid SQL:
UPDATE forum SET replycount=replycount+1,threadcount=threadcount+1,lastpost='1281283070',lastpost er='Diablo' WHERE forumid IN ();
MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
Error Number : 1064
Request Date : Sunday, August 8th 2010 @ 11:57:50 AM
Error Date : Sunday, August 8th 2010 @ 11:57:50 AM
Script : http://www.clearwaterbiker.biz/forum...ll.php?do=send
Referrer : http://www.clearwaterbiker.biz/forum...p/commbull.php
IP Address :
Username : admin
Classname : vB_Database
MySQL Version : 5.1.48-ius
__________________
Reply With Quote
  #66  
Old 08 Aug 2010, 16:08
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by jiffylb1 View Post
get this dtatabase error when trying to send news letter now did not happend before

Database error in vBulletin 4.0.5:
Invalid SQL:
UPDATE forum SET replycount=replycount+1,threadcount=threadcount+1,lastpost='1281283070',lastpost er='Diablo' WHERE forumid IN ();
MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
Error Number : 1064
Request Date : Sunday, August 8th 2010 @ 11:57:50 AM
Error Date : Sunday, August 8th 2010 @ 11:57:50 AM
Script : http://www.clearwaterbiker.biz/forum...ll.php?do=send
Referrer : http://www.clearwaterbiker.biz/forum...p/commbull.php
IP Address :
Username : admin
Classname : vB_Database
MySQL Version : 5.1.48-ius
Please post thisv at http://www.vbulletin.org/forum/showthread.php?t=230359 - this thread is just about how to adapt CommBull to 4.x.
Reply With Quote
  #67  
Old 09 Aug 2010, 14:06
Noerenberg Noerenberg is offline
 
Join Date: Mar 2009
i used your xml

my problem is, all my settings are right, i got the newsletter but NOT the users
Reply With Quote
  #68  
Old 09 Aug 2010, 15:13
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by Noerenberg View Post
i used your xml

my problem is, all my settings are right, i got the newsletter but NOT the users
Check and make sure you selected the correct Usergroups
Also, make sure your users are set to receive email from Admins & to get the Newsletter
Reply With Quote
  #69  
Old 09 Aug 2010, 15:15
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Noerenberg View Post
i used your xml

my problem is, all my settings are right, i got the newsletter but NOT the users
Originally Posted by Dragonsys View Post
Check and make sure you selected the correct Usergroups
Also, make sure your users are set to receive email from Admins & to get the Newsletter
Thanks, Dragonsys.

Noerenberg, if you still have problems, try uninstalling the product and using the manual edits instead of the XML product file.
Reply With Quote
  #70  
Old 02 Nov 2010, 19:12
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
I know to ask in the other forum but I just wondered if there were any mods known to interfere with this mod?




Thankls
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.


Last edited by RichieBoy67; 14 Feb 2011 at 21:29.
Reply With Quote
  #71  
Old 03 Nov 2010, 02:09
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
That's a server error. You'll need to contact tech support for your hosting service.
Reply With Quote
  #72  
Old 04 Dec 2010, 18:32
racingsolution racingsolution is offline
 
Join Date: Feb 2007
Installed this on my 4.x forums and it's working great.. thank you
Reply With Quote
  #73  
Old 31 Jan 2011, 02:21
asuccar asuccar is offline
 
Join Date: Dec 2009
Great add-on...work perfectly

Request though, i can sent latest posts, polls, b'days, events...but can we also send out latest blogs and articles? Does anyone knows how?

oh, just one more question

I want to greet the user as 'Dear Username', where i want the username to appear, to '\$vbphrase[username]' or just '$username'...or is it something different?
Reply With Quote
  #74  
Old 31 Jan 2011, 11:59
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by asuccar View Post
Great add-on...work perfectly

Request though, i can sent latest posts, polls, b'days, events...but can we also send out latest blogs and articles? Does anyone knows how?
No. This add-on was originally created for vBulletin 3.x, before the Suite was released. It will work on 4.x with the modifications outlined here but I know of no way to include articles and blogs.

Originally Posted by asuccar View Post
oh, just one more question

I want to greet the user as 'Dear Username', where i want the username to appear, to '\$vbphrase[username]' or just '$username'...or is it something different?
Not sure I understand your question but if you want it to appear as "Dear asuccar:" you would use:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Last edited by djbaxter; 31 Jan 2011 at 21:24.
Reply With Quote
  #75  
Old 31 Jan 2011, 21:10
asuccar asuccar is offline
 
Join Date: Dec 2009
Cheers dude...and yep, that was exactly what i was asking
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:32.

Layout Options | Width: Wide Color: