Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
8WayRun.Com - Media Library Details »
8WayRun.Com - Media Library
Mod Version: 4.1.7, by Jaxel (Coder) Jaxel is offline
Developer Last Online: Sep 2013 I like it Show Printable Version Email this Page

This modification is currently quarantined.
vB Version: 4.0.x Rating: (131 votes - 4.73 average) Installs: 916
Released: 17 Apr 2010 Last Update: 27 Oct 2010 Downloads: 7899
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations External Content  

Don't forget to click INSTALL!
I'm an unemployed computer programmer... if you appreciate the work I have done on this mod, please don't hesitate in offering me a donation by clicking the "Support Developer" link to the right of this text. A donation of $50 or more automatically gives you the right to remove the copyright footer for this modification from a single forum.

This is a new modification, spawning from the old VB 3.x Video Directory modifications.
For all intents and purposes, both my old Video Directory Remixed mod, and Survivor's original Video Directory mod have been discontinued. Neither of us are maintaining these older versions, they will not receive any future updates and we will not be providing any support. This version has a new name because it has been completely rewritten from scratch and is not being built on Survivor's old code. Because of this, if you are upgrading to this new version, from the old version, be sure to read this entire post in order to understand the upgrade process.

What is this mod?
Simply put, this mod is a directory for media. It supports URL inputs, in order to extract meta data and directorize media into a simple and easy to understand library. Users can add their favorite media from a select few online distribution centers (such as Youtube or Vimeo) and categorize and tag them as they see fit. This mod offers rudimentary support for the hosting of local media. An administrator can upload a media to the /customVID/ (default) directory; then add the media to the library using the URL code of "local:filename". Media hosted locally will be displayed using JWPlayer, but will not provide meta data, so that kind of information will need to be entered manually.

Demo:
http://www.8wayrun.com/media.php

Features:
  • Integrated directly into the vBulletin user database and product manager.
  • Fully phrased and built on tempaltes for easy re-skinning and styling.
  • Simple to use administration features and usergroup permission settings.
  • Landing page with the most recent, most popular and highest rated media.
  • Ability to add media into a single category, while adding multiple tags.
  • Ability to browse media through categories, tags, and user contributions.
  • Summary tag cloud with a link to the entire list of tags in the system.
  • Comment and rating system based on AJAX including graceful degredation.
  • Individual RSS Feeds for newest videos, categories, tags and user media.
  • Search function for titles and descriptions.
Installation:
If you are upgrading from before version 1.1, please install that version first.
  1. Upload all the files in the "upload" directory of the attached zip file to your forum root.
  2. CHMOD the /customVID/thumbs/ directory to full read/write/execute 777 permissions.
  3. CHMOD the /customVID/sitemap/ directory to full read/write/execute 777 permissions.
  4. Import the product file called "product-medialibrary.xml" in the Product Manager of vBulletin.
  5. Set your usergroup permissions and media library settings in your administration control panel.
  6. OPTIONAL: Enable the "Generate XML Media Sitemap" scheduled task in your administration control panel.

    NOTES: Make sure you decide what you wish to use for your thumbnail quality setting. By default, thumbnails are saved at 50% quality. At 50%, thumbnails will only be 2kb in size, but at the expense of quality. At 100%, thumbnails will be about 15kb in size, but will have the highest quality. I recommend setting it to 80%, which would leave thumbnails at 5kb in size with still excellent quality.

    Every time you change your thumbnail quality setting, you will need to run the "Rebuild Media Thumbnails" to see any changes.
Upgrading from VDR:
  1. The "video*" tables from your previous installation of VDR need to exist in your database.
  2. Enable the "media ADMIN import" plugin in the plugin manager of your control panel.
  3. Run the "Import Media from VDR" process in your update counters menu in maintenance.
  4. Disable the "media ADMIN import" plugin in the plugin manager of your control panel.
  5. Run the "Rebuild Media Thumbnails" process in your update counters menu in maintenance.
  6. You may now uninstall VDR once you confirm everything has been imported as intended.

    NOTES: You will mostly likely get at least one error while rebuilding media thumbnails...

    When you get an error, click the details link for that media. If the media displays some sort of error such as "This video has been removed" or "This video no longer exist", then that means that media is gone and you'll be unable to generate a thumbnail for that particular media. Use the available options on that media's detail page to DELETE it from your library. Then go back to your browser window which is rebuilding thumbnails and click the "retry from this position" link.

    If you got an error for a media, but after clicking the details link you can find no obvious error with the video; then the error could have just been a simple syn/ack failure. Just click the "retry from this position" link and the system will try to rebuild that thumbnail again.
Known Bugs:
There is a conflict with this modification and some of Valter's VSA modifications that will prevent navbar permissions from being handled correctly. I don't know exactly who's fault it is; but I'm pretty sure there are no errors in my code that would be causing this problem. There is a work around for this however.

Admin Control Panel > Plugins & Products > Plugin Manager > "media NAVTAB"

Find the code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	product-screenshot1.jpg
Views:	10617
Size:	89.6 KB
ID:	116041   Click image for larger version

Name:	product-screenshot2.jpg
Views:	5286
Size:	91.5 KB
ID:	116042   Click image for larger version

Name:	product-screenshot3.jpg
Views:	4544
Size:	81.3 KB
ID:	116043   Click image for larger version

Name:	product-screenshot4.jpg
Views:	7473
Size:	82.6 KB
ID:	116044  

Click image for larger version

Name:	product-screenshot5.jpg
Views:	5369
Size:	87.1 KB
ID:	116045   Click image for larger version

Name:	product-screenshot6.jpg
Views:	3938
Size:	113.6 KB
ID:	116046   Click image for larger version

Name:	product-screenshot7.jpg
Views:	4054
Size:	103.7 KB
ID:	116047   Click image for larger version

Name:	product-screenshot8.jpg
Views:	3415
Size:	107.9 KB
ID:	116048  

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Mini Mods 8WayRun.Com - Random Header Jaxel vBulletin 4.x Add-ons 47 11 Jan 2013 23:26
Add-On Releases Media Block for DnP Instant! Musicbox - Display the fun media list anywhere ! silveryhat vBulletin 3.8 Add-ons 2 19 Jan 2011 14:12
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #721  
Old 11 May 2010, 23:34
LouisB LouisB is offline
 
Join Date: Jan 2010
Hi Jaxel. I've noticed 2 errors so far:

I'm using the recent update and when i try to go to a members profile who have added media i get this error:

Fatal error: Call to a member function register() on a non-object in /home/user/public_html/media/media_functions_constructs.php on line 270
every other members profile who haven't added any media is okay. and... When i go to maintenance and try to update media information i get this:

Warning: require_once([path]/media/media_functions_href.php) [function.require-once]: failed to open stream: No such file or directory in [path]/admincp/misc.php(2067) : eval()'d code on line 99

Fatal error: require_once() [function.require]: Failed opening required '/home/user/public_html/media/media_functions_href.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/user/public_html/admincp/misc.php(2067) : eval()'d code on line 99
__________________
Call of Duty Forums
Reply With Quote
  #722  
Old 11 May 2010, 23:38
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Originally Posted by LouisB View Post
Hi Jaxel. I've noticed 2 errors so far:

I'm using the recent update and when i try to go to a members profile who have added media i get this error:



every other members profile who haven't added any media is okay. and... When i go to maintenance and try to update media information i get this:
Both those bugs have been fixed within the past 2 hours... please download and install the current version of 0.8
Reply With Quote
  #723  
Old 11 May 2010, 23:43
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Originally Posted by Delilahs View Post
tried that and it doesn't work still
Try disabling each Media Library plugin 1 by one, until your CMS starts working again. Then tell me which one fixed it and I will look into it.
Reply With Quote
  #724  
Old 11 May 2010, 23:47
Delilahs Delilahs is offline
 
Join Date: Mar 2009
It's BBCode fetch thatg knocks it out
Reply With Quote
  #725  
Old 12 May 2010, 01:32
bluecat's Avatar
bluecat bluecat is offline
 
Join Date: Apr 2002
Hi,

I'm using a force www in my htaccess (since users don't stay logged in if they don't type the www, plus the duplicate content factor). However, when I active your SEO URL's option and add the code to my htaccess file, I get an error blank page if I don't type in the www., and it says Permanent Redirect. Can you tell me how to fix this so I can use the SEO option?

Thank you
Reply With Quote
  #726  
Old 12 May 2010, 02:45
Veer Veer is offline
 
Join Date: Feb 2006
Updated to latest version, works superbly.

Tried MySpace videos, its just fine now but it do not get length for media automatically.

On Sitemap page (media.php?do=sitemap) I got this error message (before generating XML Media Sitemap):
Warning: file_get_contents([path]/customVID/sitemap/media.xml) [function.file-get-contents]: failed to open stream: No such file or directory in [path]/media/media_rss.php on line 109

I checked media xml file, it is getting wrong information:
<video:content_loc>http://www.domain.com/customVID/TFvKeZPAnNo</video:content_loc>
under the customVID folder there is nothing called TFvKeZPAnNo.

Last edited by Veer; 12 May 2010 at 03:08.
Reply With Quote
  #727  
Old 12 May 2010, 05:08
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Originally Posted by Veer View Post
Updated to latest version, works superbly.

Tried MySpace videos, its just fine now but it do not get length for media automatically.
If you look at the MySpace service file, you will see for svcLength it is marked as NULL. This is because MySpace's built in xml data does not have a DESCRIPTION (wtf?!); so I had to use their meta information, which has a description, but doesn't have length.

Originally Posted by Veer View Post
On Sitemap page (media.php?do=sitemap) I got this error message (before generating XML Media Sitemap):
Warning: file_get_contents([path]/customVID/sitemap/media.xml) [function.file-get-contents]: failed to open stream: No such file or directory in [path]/media/media_rss.php on line 109
Of course you got that error... because you didn't generate the sitemap yet. You can't retrieve information from a file that doesn't exist.

Originally Posted by Veer View Post
I checked media xml file, it is getting wrong information:
<video:content_loc>http://www.domain.com/customVID/TFvKeZPAnNo</video:content_loc>
under the customVID folder there is nothing called TFvKeZPAnNo.
This reason alone is why I originally chose only to include LOCAL media in the sitemap. This tag is asking for the direct link to the video itself... something that we don't have, because the video isn't local. We are embedding from external sources.

Originally Posted by bluecat View Post
Hi,

I'm using a force www in my htaccess (since users don't stay logged in if they don't type the www, plus the duplicate content factor). However, when I active your SEO URL's option and add the code to my htaccess file, I get an error blank page if I don't type in the www., and it says Permanent Redirect. Can you tell me how to fix this so I can use the SEO option?

Thank you
Please send me the contents of your HTACCESS file.

Originally Posted by Delilahs View Post
It's BBCode fetch thatg knocks it out
I dont see anything in that plugin that would cause this problem. Its probably a conflict with another mod on your website.
Reply With Quote
  #728  
Old 12 May 2010, 05:33
Veer Veer is offline
 
Join Date: Feb 2006
Originally Posted by Jaxel View Post
This reason alone is why I originally chose only to include LOCAL media in the sitemap. This tag is asking for the direct link to the video itself... something that we don't have, because the video isn't local. We are embedding from external sources.
Alright, so is there any way to switch off LOCAL media for sitemap? because I think the media library is originally designed for external sources media, personally I don't use LOCAL media, not only me most of all use this for external media sharing.
Reply With Quote
  #729  
Old 12 May 2010, 09:15
sontran sontran is offline
 
Join Date: May 2006
Originally Posted by Jaxel View Post
Both those bugs have been fixed within the past 2 hours... please download and install the current version of 0.8
Fatal error: Call to a member function register() on a non-object in /PATH/public_html/vbb/media/media_functions_constructs.php on line 270


I 've just downloaded and installed the lastest version but still got the above error. Please check
Reply With Quote
  #730  
Old 12 May 2010, 10:49
Mulle Mulle is offline
 
Join Date: Feb 2008
When I submit a new video from this page: http://www.streetrace402.com/v4/media.php I get this error:
Forbidden
You don't have permission to access /v4/media.php on this server.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
It seems that the "submit media" button have wrong link.
Reply With Quote
  #731  
Old 12 May 2010, 11:19
Gn_Snake Gn_Snake is offline
 
Join Date: Feb 2006
Originally Posted by Gn_Snake View Post
You're doing a fantastic job Jaxel, but I still have trouble viewing the video metacafe with Explorer and if active AdminCP vBSEO gives me page not found when I click on video

You have a solution to this?

Anyway thank you very much
Nothing Jaxel ?
Reply With Quote
  #732  
Old 12 May 2010, 11:21
mobe00 mobe00 is offline
 
Join Date: Jan 2010
Same problem here the bb-code plugin knocks my cms out also. disabling it and my cms works
Attached Images
File Type: jpg bbcode.jpg (61.1 KB, 25 views)
Reply With Quote
  #733  
Old 12 May 2010, 11:45
kho91 kho91 is offline
 
Join Date: Dec 2007
i upgraded to the last version but i can't import google video?
Reply With Quote
  #734  
Old 12 May 2010, 14:43
bluecat's Avatar
bluecat bluecat is offline
 
Join Date: Apr 2002
Jaxel, I sent it in a pm, thank you for looking.
Reply With Quote
  #735  
Old 12 May 2010, 15:09
kho91 kho91 is offline
 
Join Date: Dec 2007
i hav a problem with bbcode media fetish , the cms is out
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:10.

Layout Options | Width: Wide Color: