Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 24 Nov 2016, 16:11
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
Email not working

Confirmation emails aren't going out on the MoparStyle site, and I can't figure out why

I've tried all of the following without success:
  • Tried the -f setting
  • Tried adjusting every combination of the mail settings with batch, batch size, cron, delay between messages etc. (even though they're technically not suppose to affect the confirmation emails going out immediately). When I use diagnostics to send an email to my gmail account, it says it passes - but no email in my in box, spam box or trash
  • I tried using SMTP with a pop3 email account I've created in my Cpanel. Every diagnostic test fails - even tried all three secured connection settings
  • I updated the php on the hosting account to the most current version, no change
  • I found Vbulletin instructions on using gmail for SMTP, create a throw down gmail account, created a two step log in, add an Other app for Vbulletin; and set up the Forim's SMTP exactly like the instructions say http://www.vbulletin.com/forum/blogs...-gmail-account but I get an diagnostic message that Gmail refused. I verified I have the app, revoked it, recreated it, and tried again with the same results.
I'm at a complete loss at what I'm doing wrong. It is fifteen hours later and still haven't received any emails, so I doubt it is a delay issue. If I can make the Gmail thing work, that might be the best way as I have Go Daddy hosting (prepaid for three years) and don't want to touch the limited resources threshold.
__________________
Reply With Quote
  #2  
Old 24 Nov 2016, 16:18
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Have you checked the mail/exim logs on your server? Maybe that will tell you what's going wrong.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #3  
Old 24 Nov 2016, 17:11
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
let me see if I can gain access to that after dinner

I went from a dedicated server to cheap Go Daddy hosting a couple months ago, and need to get a handle on what I actually have access to.

Given my preference, I'd like to use a throwdown gmail account to be my SMTP if possible. The settings I used were:

- "SMTP Email" to Yes.
- "SMTP Host" to smtp.gmail.com
- "SMTP Port" to 587
- "SMTP Username" to your gmail email address ex. [email protected]
- "SMTP Password" to the App Password you created above.
- "SMTP Secure Connection" should be set to TLS.


I cut and pasted the App generated 16 digit password, which pasted without the spaces. I assume that would be correct. Is anyone else doing this?

--------------- Added 24 Nov 2016 at 17:47 ---------------

this is what I get in diagnostics trying the Gmail SMTP method after getting an app password

Pertinent SMTP Settings
SMTP: tls://smtp.gmail.com:587
SMTP Username: [email protected]

Results
The mailing function returned an error while trying to send the mail.
The following errors were outputted by PHP when attempting to send mail:

Warning: fsockopen(): unable to connect to tcp://smtp.gmail.com:587 (Connection refused) in .../vb/mail/smtp.php on line 181 Warning: Unable to connect to SMTP server in .../vb/mail/smtp.php on line 147
__________________
Reply With Quote
  #4  
Old 24 Nov 2016, 18:22
Seven Skins's Avatar
Seven Skins Seven Skins is offline
 
Join Date: Sep 2008
May be this can help .. https://support.google.com/accounts/.../6010255?hl=en
Reply With Quote
  #5  
Old 24 Nov 2016, 18:51
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
It's also possible that your server host blocks incoming/outgoing SMTP traffic in order to avoid spam, might have to reach out to them if that's the case.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #6  
Old 24 Nov 2016, 19:25
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
Actually I found this piece of returned mail in the New Mail directory of my System default mail directory. I'm going to assume I'm erroneously being blocked by server IP or domain as a spammer on the php generated email, and need to find a good SMTP solution.

Return-Path: <>
Delivered-To: [email protected]
Received: from a2plxxxxxxxx.prod.iad2.secureserver.net
by a2plxxxxxxxx.prod.iad2.secureserver.net (Dovecot) with LMTP id aXxVDOE8N1gZhQEAJcPNEw
for <[email protected]>; Thu, 24 Nov 2016 12:17:53 -0700
Return-path: <>
Envelope-to: [email protected]
Delivery-date: Thu, 24 Nov 2016 12:17:53 -0700
Received: from mailnull by a2plxxxxxxxx.prod.iad2.secureserver.net with local (Exim 4.87)
id 1c9zWr-000VHR-48
for [email protected]; Thu, 24 Nov 2016 12:17:53 -0700
X-Failed-Recipients: [email protected]
Auto-Submitted: auto-replied
From: Mail Delivery System <[email protected]>
To: [email protected]
Content-Type: multipart/report; report-type=delivery-status; boundary=1480015073-eximdsn-1011465036
MIME-Version: 1.0
Subject: Mail delivery failed: returning message to sender
Message-Id: <[email protected]>
Date: Thu, 24 Nov 2016 12:17:53 -0700

--1480015073-eximdsn-1011465036
Content-type: text/plain; charset=us-ascii

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected]
host a2nlsmtpcp-v01.shr.prod.iad2.secureserver.net [xxx.71.232.0]
SMTP error from remote mail server after end of data:
552 5.2.0 9zWrcjTRPrxKJ :: CPANEL :: Message rejected for spam or virus content ::
Please include this entire message when contacting support ::
v=2.1 cv=WJ7fJiYR c=1 sm=1 tr=0 p=qtIuigrTrmoA:10 p=mGY6Kf0_zQgA:10 a=3wOngBlNSV9P3E4YkMav9w==:117 a=L9H7d07YOLsA:10 a=9cW_t1CCXrUA:10 a=s5jvgZ67dGcA:10 a=9+rZDBEiDlHhcck0kWbJtElFXBc=:19 a=8nJEP1OIZ-IA:10 a=L24OOQBejmoA:10 a=1SRa-O0TrnEA:10 a=0-H72qg4231gaUi91ysA:9 a=wPNLvfGTeEIA:10 ::
100.00

--1480015073-eximdsn-1011465036
Content-type: message/delivery-status

Reporting-MTA: dns; a2plcpnl0757.prod.iad2.secureserver.net

Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0
Remote-MTA: dns; a2nlsmtpcp-v01.shr.prod.iad2.secureserver.net
Diagnostic-Code: smtp; 552 5.2.0 9zWrcjTRPrxKJ :: CPANEL :: Message rejected for spam or virus content :: Please include this entire message when contacting support :: v=2.1 cv=WJ7fJiYR c=1 sm=1 tr=0 p=qtIuigrTrmoA:10 p=mGY6Kf0_zQgA:10 a=3wOngBlNSV9P3E4YkMav9w==:117 a=L9H7d07YOLsA:10 a=9cW_t1CCXrUA:10 a=s5jvgZ67dGcA:10 a=9+rZDBEiDlHhcck0kWbJtElFXBc=:19 a=8nJEP1OIZ-IA:10 a=L24OOQBejmoA:10 a=1SRa-O0TrnEA:10 a=0-H72qg4231gaUi91ysA:9 a=wPNLvfGTeEIA:10 :: 100.00

--1480015073-eximdsn-1011465036
Content-type: message/rfc822

Return-path: <[email protected]>
Received: from moparstyle by a2plxxxxxxxx.prod.iad2.secureserver.net with local (Exim 4.87)
(envelope-from <[email protected]>)
id 1c9zWq-000VHF-U9
for [email protected]; Thu, 24 Nov 2016 12:17:52 -0700
To: [email protected]
Subject: vBulletin Email Test
X-PHP-Script: www.moparstyle.com/forums/index.php for xxx.201.4.33
X-PHP-Filename: /home/moparstyle/public_html/forums/index.php
From: "[email protected]" <[email protected]>
Message-ID: <[email protected]>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: 8bit
X-Mailer: vBulletin Mail via PHP
Date: Thu, 24 Nov 2016 12:17:52 -0700

You are receiving this email because your email address was entered as an email test at MoparStyle.

The first step of this email test script has been completed. However, a formatting test is still necessary:

A paragraph break.
A single line break.

Another paragraph break.
Another single line break.
Another single line break.

If the above lines look correct, you are finished. The email features on your server are setup correctly.
If this email is run together on one line, there is possibly a configuration error with your mail server. Please ensure it is configured correctly.

--1480015073-eximdsn-1011465036--
--------------- Added 24 Nov 2016 at 19:46 ---------------

another problem that I think is unrelated, but you never know

Wordfence and wordfence-waf.php

I use to have a Wordpress install on the MoparStyle site, but uninstalled and deleted when I upgraded to VB5. I had the Wordfence plugin installed.

That plugin installed a .user.ini, a wordfence-waf.php and modified my .htacess

i created a new .htaccess to redirect the sites root (formerly the Wordpress install) that has no reference to Wordfence.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

However, if I remove the ini or php file every url in domain gets me an Error 500 page. I'm figuring it must have an entry in the php.ini file, but I can't figure out how to access and modify with the limited Cpanel I have with O Addy hare hosting.

the .user.ini


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I'm wondering if Wordfence or the php.ini is hosing mail from php
__________________
Reply With Quote
  #7  
Old 24 Nov 2016, 19:53
Replicant's Avatar
Replicant Replicant is offline
 
Join Date: Sep 2014
Real name: Mel
Just my 2 cents. I would grab a monthly plan with Siteground or Nuwebhosting for around $4 bucks a month and setup your own email server. This way, you have total control over "spam banning" issues and never have to worry about whether or not you are complying with some Terms of Service agreement.
__________________
VB5 mods - RepliClock VB4 mods - Member Online Status
Reply With Quote
  #8  
Old 24 Nov 2016, 21:09
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Try mailgun.com for sending emails, they give you 10.000 emails for free every month.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #9  
Old 25 Nov 2016, 00:23
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
Originally Posted by Seven Skins View Post
I'll give it (less secure) a try, but that's not the error I'm getting

--------------- Added 25 Nov 2016 at 00:23 ---------------

Originally Posted by Dave View Post
Try mailgun.com for sending emails, they give you 10.000 emails for free every month.
Are VB forums using that as their SMPT?

--------------- Added 25 Nov 2016 at 00:53 ---------------

Ok, I signed up with Mail Gun and made the required DNS adds they required so they can verify. Says it takes 24/48 hours.

We've just jumped above my paygrade as I've never messed with DNS and MX entries before. I'm pretty sure I properly followed the destructions
__________________
Reply With Quote
  #10  
Old 25 Nov 2016, 02:06
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
I've been using mailgun.com for about a year now on my vBulletin forum and other projects, works pretty well.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #11  
Old 26 Nov 2016, 22:27
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
Must be something wrong with the SMTP portion of the program as Mail Gun didn't work either

SMTP: tls://smtp.mailgun.org:465
SMTP Username: [email protected]
Help Results
The mailing function returned an error while trying to send the mail.
The following errors were outputted by PHP when attempting to send mail:

Warning: fsockopen(): unable to connect to tcp://smtp.mailgun.org:465 (Connection refused) in .../vb/mail/smtp.php on line 181 Warning: Unable to connect to SMTP server in .../vb/mail/smtp.php on line 147
Powered by vBulletin® Version 5.2.5 Copyright © 2016 vBulletin Solutions, Inc. All rights reserved.
__________________
Reply With Quote
  #12  
Old 26 Nov 2016, 22:41
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Then I'm pretty sure it's caused by:

Originally Posted by Dave View Post
It's also possible that your server host blocks incoming/outgoing SMTP traffic in order to avoid spam, might have to reach out to them if that's the case.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #13  
Old 26 Nov 2016, 22:52
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
Originally Posted by Dave View Post
Then I'm pretty sure it's caused by:
but by using Mail Gun's SMTP, aren't I completely bypassing my host's SMTP's server?
__________________
Reply With Quote
  #14  
Old 26 Nov 2016, 23:11
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
No, your host can block outgoing traffic that is sent to specific ports.
I've been in this situation before at a host, they had SMTP traffic completely disabled on new servers and only removed the port limitation upon request.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #15  
Old 27 Nov 2016, 00:13
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
ah man I've got Go Daddy Shared hosting, the first layer of support is strictly denial - but I'll give it a shot.

--------------- Added 27 Nov 2016 at 01:39 ---------------

Ok didn't get any help on the SMTP part. They said they ain't blocking anything, but I did find in the MX settings on cPanel that outgoing mail was set to localhost. I change it first to Remote Exchange and while I couldn't send via SMTP, mail did go out when I turned SMTP off. I then set to auto detect, and got same results.

While it would be nice to send via SMTP, at least confirmation mails are now going out.

Thanks for the help
__________________
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:46.

Layout Options | Width: Wide Color: