Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
8WayRun.Com - Media Library Details »
8WayRun.Com - Media Library
Mod Version: 4.1.7, by Jaxel (Coder) Jaxel is offline
Developer Last Online: Sep 2013 I like it Show Printable Version Email this Page

This modification is currently quarantined.
vB Version: 4.0.x Rating: (131 votes - 4.73 average) Installs: 915
Released: 17 Apr 2010 Last Update: 27 Oct 2010 Downloads: 7899
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations External Content  

Don't forget to click INSTALL!
I'm an unemployed computer programmer... if you appreciate the work I have done on this mod, please don't hesitate in offering me a donation by clicking the "Support Developer" link to the right of this text. A donation of $50 or more automatically gives you the right to remove the copyright footer for this modification from a single forum.

This is a new modification, spawning from the old VB 3.x Video Directory modifications.
For all intents and purposes, both my old Video Directory Remixed mod, and Survivor's original Video Directory mod have been discontinued. Neither of us are maintaining these older versions, they will not receive any future updates and we will not be providing any support. This version has a new name because it has been completely rewritten from scratch and is not being built on Survivor's old code. Because of this, if you are upgrading to this new version, from the old version, be sure to read this entire post in order to understand the upgrade process.

What is this mod?
Simply put, this mod is a directory for media. It supports URL inputs, in order to extract meta data and directorize media into a simple and easy to understand library. Users can add their favorite media from a select few online distribution centers (such as Youtube or Vimeo) and categorize and tag them as they see fit. This mod offers rudimentary support for the hosting of local media. An administrator can upload a media to the /customVID/ (default) directory; then add the media to the library using the URL code of "local:filename". Media hosted locally will be displayed using JWPlayer, but will not provide meta data, so that kind of information will need to be entered manually.

Demo:
http://www.8wayrun.com/media.php

Features:
  • Integrated directly into the vBulletin user database and product manager.
  • Fully phrased and built on tempaltes for easy re-skinning and styling.
  • Simple to use administration features and usergroup permission settings.
  • Landing page with the most recent, most popular and highest rated media.
  • Ability to add media into a single category, while adding multiple tags.
  • Ability to browse media through categories, tags, and user contributions.
  • Summary tag cloud with a link to the entire list of tags in the system.
  • Comment and rating system based on AJAX including graceful degredation.
  • Individual RSS Feeds for newest videos, categories, tags and user media.
  • Search function for titles and descriptions.
Installation:
If you are upgrading from before version 1.1, please install that version first.
  1. Upload all the files in the "upload" directory of the attached zip file to your forum root.
  2. CHMOD the /customVID/thumbs/ directory to full read/write/execute 777 permissions.
  3. CHMOD the /customVID/sitemap/ directory to full read/write/execute 777 permissions.
  4. Import the product file called "product-medialibrary.xml" in the Product Manager of vBulletin.
  5. Set your usergroup permissions and media library settings in your administration control panel.
  6. OPTIONAL: Enable the "Generate XML Media Sitemap" scheduled task in your administration control panel.

    NOTES: Make sure you decide what you wish to use for your thumbnail quality setting. By default, thumbnails are saved at 50% quality. At 50%, thumbnails will only be 2kb in size, but at the expense of quality. At 100%, thumbnails will be about 15kb in size, but will have the highest quality. I recommend setting it to 80%, which would leave thumbnails at 5kb in size with still excellent quality.

    Every time you change your thumbnail quality setting, you will need to run the "Rebuild Media Thumbnails" to see any changes.
Upgrading from VDR:
  1. The "video*" tables from your previous installation of VDR need to exist in your database.
  2. Enable the "media ADMIN import" plugin in the plugin manager of your control panel.
  3. Run the "Import Media from VDR" process in your update counters menu in maintenance.
  4. Disable the "media ADMIN import" plugin in the plugin manager of your control panel.
  5. Run the "Rebuild Media Thumbnails" process in your update counters menu in maintenance.
  6. You may now uninstall VDR once you confirm everything has been imported as intended.

    NOTES: You will mostly likely get at least one error while rebuilding media thumbnails...

    When you get an error, click the details link for that media. If the media displays some sort of error such as "This video has been removed" or "This video no longer exist", then that means that media is gone and you'll be unable to generate a thumbnail for that particular media. Use the available options on that media's detail page to DELETE it from your library. Then go back to your browser window which is rebuilding thumbnails and click the "retry from this position" link.

    If you got an error for a media, but after clicking the details link you can find no obvious error with the video; then the error could have just been a simple syn/ack failure. Just click the "retry from this position" link and the system will try to rebuild that thumbnail again.
Known Bugs:
There is a conflict with this modification and some of Valter's VSA modifications that will prevent navbar permissions from being handled correctly. I don't know exactly who's fault it is; but I'm pretty sure there are no errors in my code that would be causing this problem. There is a work around for this however.

Admin Control Panel > Plugins & Products > Plugin Manager > "media NAVTAB"

Find the code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	product-screenshot1.jpg
Views:	10618
Size:	89.6 KB
ID:	116041   Click image for larger version

Name:	product-screenshot2.jpg
Views:	5287
Size:	91.5 KB
ID:	116042   Click image for larger version

Name:	product-screenshot3.jpg
Views:	4545
Size:	81.3 KB
ID:	116043   Click image for larger version

Name:	product-screenshot4.jpg
Views:	7474
Size:	82.6 KB
ID:	116044  

Click image for larger version

Name:	product-screenshot5.jpg
Views:	5370
Size:	87.1 KB
ID:	116045   Click image for larger version

Name:	product-screenshot6.jpg
Views:	3939
Size:	113.6 KB
ID:	116046   Click image for larger version

Name:	product-screenshot7.jpg
Views:	4054
Size:	103.7 KB
ID:	116047   Click image for larger version

Name:	product-screenshot8.jpg
Views:	3415
Size:	107.9 KB
ID:	116048  

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 22:44
Mini Mods 8WayRun.Com - Random Header Jaxel vBulletin 4.x Add-ons 47 11 Jan 2013 22:26
Add-On Releases Media Block for DnP Instant! Musicbox - Display the fun media list anywhere ! silveryhat vBulletin 3.8 Add-ons 2 19 Jan 2011 13:12
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 05:45

  #2986  
Old 05 Jun 2013, 18:32
Chadi's Avatar
Chadi Chadi is offline
 
Join Date: May 2004
Originally Posted by Chadi View Post
I keep getting this error whenever I try to rebuild media thumbnails

ERROR CONSTRUCTING THUMBNAIL

I checked each video, absolutely nothing wrong with them at all.

I click retry, and it repeatedly gets stuck at "Processing 3"

Also nothing wrong with that third video either, at all.
Anyone else know how to rectify this?

Also, anyway to make this mobile friendly? Example: when I post the link to my FB page, it doesn't work on mobile phones (comes up blank) because the site is using the mobile theme.
__________________
...............................
Talk Jesus Forums: Christian Chat
games . chat . gallery . bible . videos
Reply With Quote
  #2987  
Old 23 Jun 2013, 18:23
KorsatH KorsatH is offline
 
Join Date: Apr 2007
tnx for your amazing work.
you also plan to work on your addon for the stream like your site?
Reply With Quote
  #2988  
Old 24 Jun 2013, 17:07
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Originally Posted by KorsatH View Post
tnx for your amazing work.
you also plan to work on your addon for the stream like your site?
Jaxel no longer develops for vB, so there's no plans for upgrading this mod at this time.
__________________
Reply With Quote
  #2989  
Old 07 Jul 2013, 09:39
Toxic2 Toxic2 is offline
 
Join Date: Jul 2009
NO way to set Permisions,

there is no media tab in ACP so I can not set permissions vb 4.1.10
Reply With Quote
  #2990  
Old 08 Jul 2013, 02:54
tbworld tbworld is offline
 
Join Date: Oct 2008
@Toxic, you need to read the entire thread. You will not get this mod working if you do not. Take your time it is a nice mod, but it has to be carefully setup.

Last edited by tbworld; 08 Jul 2013 at 03:10.
Reply With Quote
  #2991  
Old 09 Jul 2013, 15:49
DGrey2011 DGrey2011 is offline
 
Join Date: Dec 2010
I have installed the edited version (with comments and description issues fixed) on vB 4.2.0.

I can type the description exactly when I add the video and it's saved.

However, if I notice some mistakes or I want to add something in the description later, the changes aren't saved and I just get the message 'Leave' or 'Stay on page'. No matter which you click on, the changes aren't saved.
I tried on Chrome, FF, Safari, Comodo and in all browsers it's the same.

Does anyone know how to fix this?
Reply With Quote
  #2992  
Old 17 Jul 2013, 05:51
vietfancy's Avatar
vietfancy vietfancy is offline
 
Join Date: Mar 2005
this is no good for 4.2.1. I can't seem to submit a youtube video.
Reply With Quote
  #2993  
Old 25 Jul 2013, 17:35
KorvinGump KorvinGump is offline
 
Join Date: Aug 2012
Originally Posted by DGrey2011 View Post
I have installed the edited version (with comments and description issues fixed) on vB 4.2.0.

I can type the description exactly when I add the video and it's saved.

However, if I notice some mistakes or I want to add something in the description later, the changes aren't saved and I just get the message 'Leave' or 'Stay on page'. No matter which you click on, the changes aren't saved.
I tried on Chrome, FF, Safari, Comodo and in all browsers it's the same.

Does anyone know how to fix this?
I can confirm this bug. If you try to add video on front media page with retrieve information it works good and you can submit video. After this you can edit your description of media. But if you try to submit media with button "Submit media" you can't edit description and when you click on button submit it sends to you message 'Leave' or 'Stay on page'. Please someone needs to fix this for 4.2.1.
Reply With Quote
  #2994  
Old 25 Jul 2013, 20:09
michal72 michal72 is offline
 
Join Date: Nov 2010
Originally Posted by DGrey2011 View Post
I have installed the edited version (with comments and description issues fixed) on vB 4.2.0.

I can type the description exactly when I add the video and it's saved.

However, if I notice some mistakes or I want to add something in the description later, the changes aren't saved and I just get the message 'Leave' or 'Stay on page'. No matter which you click on, the changes aren't saved.
I tried on Chrome, FF, Safari, Comodo and in all browsers it's the same.

Does anyone know how to fix this?
Originally Posted by KorvinGump View Post
I can confirm this bug. If you try to add video on front media page with retrieve information it works good and you can submit video. After this you can edit your description of media. But if you try to submit media with button "Submit media" you can't edit description and when you click on button submit it sends to you message 'Leave' or 'Stay on page'. Please someone needs to fix this for 4.2.1.
For me my fixes work well for 4.2.0. I can add new video using "Retrieve information" or "Submit media". I can also edit description of the existing media.

I can't check on 4.2.1 because I don't use this version

Regards
__________________
8WayRun.Com - Media Library - Fixes and Services
Reply With Quote
  #2995  
Old 13 Aug 2013, 21:45
mamaveve mamaveve is offline
 
Join Date: Jan 2011
I try to edit the activity stream template so that latest media showing in activity stream..., but still no good

anyone can help
Reply With Quote
  #2996  
Old 20 Aug 2013, 19:03
Chadi's Avatar
Chadi Chadi is offline
 
Join Date: May 2004
Having two issues:

First, using the [media] tag in forum posts, works in preview but once I submit the post the video disappears and the only the title shows, linked.

I use this


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Second issue: for whatever reason, when I click edit in the administrative > services area for any service it redirects me to the homepage.

This is what I have in the htaccess file

# Media Library
ReWriteRule ^media/m(\d+).*/tags$ media.php?do=tags_edit&mid=$1 [QSA]
ReWriteRule ^media/m(\d+).*/edit$ media.php?do=details_edit&mid=$1 [QSA]
ReWriteRule ^media/m(\d+).*/report$ media.php?do=report&mid=$1 [QSA]
ReWriteRule ^media/m(\d+).*/c(\d+)$ media.php?do=comment_edit&cmt=$2 [QSA]
ReWriteRule ^media/m(\d+).*/p(\d+).*$ media.php?do=details&mid=$1&pid=$2 [QSA]
ReWriteRule ^media/m(\d+).* media.php?do=details&mid=$1 [QSA]
ReWriteRule ^media/p(\d+).*/edit$ media.php?do=playlist_edit&pid=$1 [QSA]
ReWriteRule ^media/p(\d+).* media.php?do=playlist&pid=$1 [QSA]
ReWriteRule ^media/c(\d+).* media.php?do=category&cid=$1 [QSA]
ReWriteRule ^media/u(\d+).* media.php?do=user&uid=$1 [QSA]
ReWriteRule ^media/tag/(.*) media.php?do=tag&tid=$1 [QSA]
ReWriteRule ^media/results/(.*) media.php?do=results&query=$1 [QSA]
ReWriteRule ^media/advresults/(.*) media.php?do=advresults&query=$1 [QSA]
ReWriteRule ^media/letter/(.*) media.php?do=letter&query=$1 [QSA]
ReWriteRule ^media/browse.* media.php?do=browse [QSA]
ReWriteRule ^media/search.* media.php?do=search [QSA]
ReWriteRule ^media/random.* media.php?do=random [QSA]
ReWriteRule ^media/submit.* media.php?do=submit [QSA]
ReWriteRule ^media/tagcloud.* media.php?do=tagcloud [QSA]
ReWriteRule ^media/playlists.* media.php?do=playlists [QSA]
ReWriteRule ^media/pcreate.* media.php?do=playlists_create [QSA]
ReWriteRule ^media/pmine.* media.php?do=playlists_mine [QSA]
ReWriteRule ^media/favorites.* media.php?do=favorites [QSA]
ReWriteRule ^media/subscriptions.* media.php?do=subscriptions [QSA]
ReWriteRule ^media/admin/edit/s(\d+).* media.php?do=admin_host_edit&sid=$1 [QSA]
ReWriteRule ^media/admin/delete/s(\d+).* media.php?do=admin_host_delete&sid=$1 [QSA]
ReWriteRule ^media/admin/export/s(\d+).* media.php?do=admin_host_export&sid=$1 [QSA]
ReWriteRule ^media/admin/(\w+).* media.php?do=admin_$1 [QSA]

# Media Library from Video Directory
RewriteCond %{QUERY_STRING} do=viewdetails&videoid=(\d+)
RewriteRule ^video\.php$ media.php?do=details&mid=%1
RewriteCond %{QUERY_STRING} viewcategory&categoryid=(\d+)
RewriteRule ^video\.php$ media.php?do=category&cid=%1
RewriteCond %{QUERY_STRING} viewuser&userid=(\d+)
RewriteRule ^video\.php$ media.php?do=user&uid=%1
RewriteCond %{QUERY_STRING} viewtag&tag=(.*)
RewriteRule ^video\.php$ media.php?do=tag&tid=%1
ReWriteRule ^video\.php$ media.php
__________________
...............................
Talk Jesus Forums: Christian Chat
games . chat . gallery . bible . videos
Reply With Quote
  #2997  
Old 25 Aug 2013, 04:25
motorhaven motorhaven is offline
 
Join Date: Jul 2002
Originally Posted by vietfancy View Post
this is no good for 4.2.1. I can't seem to submit a youtube video.
Works fine for me on 3 different 4.2.1 installations.
Reply With Quote
  #2998  
Old 26 Aug 2013, 03:54
fleshy66 fleshy66 is offline
 
Join Date: Jul 2006
Originally Posted by motorhaven View Post
Works fine for me on 3 different 4.2.1 installations.
Did you just add the original to 4.2.1 ? Its been a long time since I used VB so just getting back in to using it again.
Reply With Quote
  #2999  
Old 26 Aug 2013, 04:08
AndrewSimm's Avatar
AndrewSimm AndrewSimm is offline
 
Join Date: Sep 2006
make sure your not using https youtube links
Reply With Quote
  #3000  
Old 26 Aug 2013, 13:25
motorhaven motorhaven is offline
 
Join Date: Jul 2002
And also there are two types of youtube links (youtube.com and youtu.be) make sure you have both defined.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 09:12.

Layout Options | Width: Wide Color: