Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Advanced Guest Posting & Registration - Get more members! Details »
Advanced Guest Posting & Registration - Get more members!
Mod Version: 1.2.2, by tpearl5 (Coder/Designer) tpearl5 is offline
Developer Last Online: Feb 2021 I like it Show Printable Version Email this Page

vB Version: 4.1.x Rating: (3 votes - 5.00 average) Installs: 25
Released: 21 Jun 2014 Last Update: 24 Jun 2014 Downloads: 137
Supported DB Changes Uses Plugins Auto-Template Additional Files  

Advanced Guest Posting & Registration allows guests to post a reply or a new thread in the forums, then register to publish their reply. This system encourages participation by calling on the user to write something before the option of registering even enters their mind.

Similar modifications have been made previously, but none as feature packed as this that are sure to bring new registrations to your forum. With the modification installed on cellphoneforums.net there was a 9% increase of new registrations (Results will vary depending on your traffic and subject matter).

Features:
  • Compatible with vBulletin 4.1.4 +
  • Works with quickreply & advanced reply
  • Settings to change which editor is displayed, including a basic text box (without loading large CKEditor files) to cut down on page load time for guests
  • E-mail verification compatibility
  • When guest post is published (before or after e-mail verification)
  • Human Verification on/off for quick/advanced reply & post
  • User is only asked to enter one Human Verification/CAPTCHA - they will not have to enter another one on the register page
  • Default subscription options for quick reply, or the option they pick on the new thread/reply is saved automatically
  • Works with Facebook registration
  • Compatible with the default vbulletin mobile style
  • Message after user registration to tell them their post has been posted with a link, or that it has been put in the moderation queue if determined to be spam by a spam system (akismet)
  • If a user posts, creating new posts is disabled until they register - notification of this is in the header
  • Guest posts are saved in the moderation queue under 'unregistered' until the system automatically removes (admin setting) the post or the user registers. This allows admins/moderators to see what is being posted.
  • Header message to users that they have a 'saved post', even if they come back later (cookie based)
  • (Pro Only) Reporting feature that tracks total posts / replies, abandonment (guest creates a post but never registers), posts marked as spam, and successful posts / replies (register)

Some sites that have this installed:
Installation
  • Unzip the package
  • Upload all files in the upload directory to your forum root
  • Install the product.xml
  • You'll see a new admincp menu item for the modification - click it to choose your options

Notes:
  • New threads or replies posted by guests will be seen by admins and moderators as moderated posts - they should not approve these posts if you do not want them to potentially be removed by the system if the user does not register.
  • A message is added above the message editor "If you are already a member, please login above." - If you find that your logged out members are getting confused you may want to edit the phrases "vbpagr_if_member_logic_above" & "vbpagr_if_you_are_a_member" to stand out more in order to prevent confusion.

Release Log
  • 1.2.1 - 6/21/14 - initial release
  • 1.2.2 - 6/24/14 - fixed "Post Pending Post/Thread..." not saving - only a reimport of product xml required

This modification adds a link to ForumSetup.net in the footer of thread pages only. If you wish to remove this link and get the reporting feature, please see this page for details.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	guest_registration2.gif
Views:	443
Size:	144.6 KB
ID:	149443   Click image for larger version

Name:	guest_registration4.gif
Views:	439
Size:	15.1 KB
ID:	149444   Click image for larger version

Name:	guest_registration5.gif
Views:	470
Size:	23.6 KB
ID:	149445   Click image for larger version

Name:	guest_registration7.gif
Views:	439
Size:	14.2 KB
ID:	149446  

Click image for larger version

Name:	vbpagr_settings.jpg
Views:	325
Size:	88.8 KB
ID:	149447  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #31  
Old 10 Jul 2014, 18:05
Morrus Morrus is offline
 
Join Date: Jan 2002
Just installed and tried it. After hitting submit no a etst thread while not logged in I get this error:

Errors

The following errors occurred with your submission
That username is already in use or does not meet the administrator's standards. If you are Unregistered and you have forgotten your password, click here.
__________________
www.enworld.org
Reply With Quote
  #32  
Old 10 Jul 2014, 18:53
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by Morrus View Post
Just installed and tried it. After hitting submit no a etst thread while not logged in I get this error:
Submit on posting a thread or registering? Do you have any other modifications installed that modify the register form?
__________________
John
Reply With Quote
  #33  
Old 11 Jul 2014, 00:49
cric2k cric2k is offline
 
Join Date: Jan 2010
This looks very promising - unfortunately on my 4.1.9 installation it breaks showthread.php - when I turn it on only a blank page is rendered in all threads (with absolutely no html upon source inspection).
Reply With Quote
  #34  
Old 11 Jul 2014, 01:20
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by cric2k View Post
This looks very promising - unfortunately on my 4.1.9 installation it breaks showthread.php - when I turn it on only a blank page is rendered in all threads (with absolutely no html upon source inspection).
Other mods installed that modify showthread? What version of PHP? You should see something in your error logs if you're getting a white screen.
__________________
John
Reply With Quote
  #35  
Old 11 Jul 2014, 02:37
cric2k cric2k is offline
 
Join Date: Jan 2010
Originally Posted by tpearl5 View Post
Other mods installed that modify showthread? What version of PHP? You should see something in your error logs if you're getting a white screen.
PHP Version 5.3.3.

It's most likely some change I've made to showthread.php - I've heavily modified it myself (which is why I'm still on 4.1.19), as well having a few plug ins. The white page happens on both logged in and logged out showthread.php. I'll start hoking through trying to find where my php logs are and maybe do a bit of trial and error disabling other custom plugins.

Thanks for your help.
Reply With Quote
  #36  
Old 11 Jul 2014, 03:02
cric2k cric2k is offline
 
Join Date: Jan 2010
ah, got an error


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

any ideas?
Reply With Quote
  #37  
Old 11 Jul 2014, 11:52
Morrus Morrus is offline
 
Join Date: Jan 2002
Originally Posted by tpearl5 View Post
Submit on posting a thread or registering? Do you have any other modifications installed that modify the register form?
On posting the thread. No other mods to modify reg form, except BoP's register.php rename, but it never makes it as far as register.php.
__________________
www.enworld.org
Reply With Quote
  #38  
Old 11 Jul 2014, 14:05
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by cric2k View Post
ah, got an error


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

any ideas?
Do you have the suite?


Originally Posted by Morrus View Post
On posting the thread. No other mods to modify reg form, except BoP's register.php rename, but it never makes it as far as register.php.
Hrm, It uses register.php, so it may be throwing that error because it's not finding it.
__________________
John
Reply With Quote
  #39  
Old 11 Jul 2014, 14:26
Morrus Morrus is offline
 
Join Date: Jan 2002
Originally Posted by tpearl5 View Post
Do you have the suite?

Hrm, It uses register.php, so it may be throwing that error because it's not finding it.
I changed all the references to register.php as you said earlier.

Ah, never mind. I'm not planning on turning this into additional work. Nothing to see here.
__________________
www.enworld.org
Reply With Quote
  #40  
Old 11 Jul 2014, 15:06
cric2k cric2k is offline
 
Join Date: Jan 2010
Originally Posted by tpearl5 View Post
Do you have the suite?
Yes, I do.
Reply With Quote
  #41  
Old 11 Jul 2014, 17:52
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by Morrus View Post
I changed all the references to register.php as you said earlier.

Ah, never mind. I'm not planning on turning this into additional work. Nothing to see here.
Dumb question, do you have a user with the name 'Unregistered' ?

Originally Posted by cric2k View Post
Yes, I do.
It seems like something is modifying vB_Types. It should be available by default.
__________________
John
Reply With Quote
  #42  
Old 24 Jul 2014, 11:58
Marv Marv is offline
 
Join Date: Jun 2002
Another one to test. Youre a sedulous man, John

Reply With Quote
  #43  
Old 26 Jul 2014, 10:51
Marv Marv is offline
 
Join Date: Jun 2002
I was running in the same problem Morrus did. In the meantime Ive found out, that this error occurs when the max. length of usernames is set. Mine was set to 25 and resulted in the error message, that the username would be to long.

Somehow AGP&R seems to check the textbody in the replybox against the max. username length.

But to make it more complicated: Ive changed the max. username length to 35 characters and you know what?! The bug is vanished. At least for the moment.
May be anyone can confirm this for his sites?

My ole man always told me "If you cant understand it, behave like you would love it." Okay, he was talking about women in general. Guess until John comes up with a bugfix Ill keep it that way
Reply With Quote
  #44  
Old 26 Jul 2014, 15:08
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by Marv View Post
I was running in the same problem Morrus did. In the meantime Ive found out, that this error occurs when the max. length of usernames is set. Mine was set to 25 and resulted in the error message, that the username would be to long.

Somehow AGP&R seems to check the textbody in the replybox against the max. username length.

But to make it more complicated: Ive changed the max. username length to 35 characters and you know what?! The bug is vanished. At least for the moment.
May be anyone can confirm this for his sites?

My ole man always told me "If you cant understand it, behave like you would love it." Okay, he was talking about women in general. Guess until John comes up with a bugfix Ill keep it that way
Ah, that makes sense. I'll have to put in a fix for this. Didn't you start getting this error when you put in the translation? "Unregistered" is 12 characters and "Schwebende Registrierung" is 24 though.
__________________
John
Reply With Quote
  #45  
Old 26 Jul 2014, 15:41
Marv Marv is offline
 
Join Date: Jun 2002
That makes total sense, John, because my max. username length was set to 20, not 25 as I wrote first. And yes, it first occured after Id translated the phrases
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:31.

Layout Options | Width: Wide Color: