Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Verify Email Before Registration Details »
Verify Email Before Registration
Mod Version: 2.0.8, by da_judge (Coder/Designer) da_judge is offline
Developer Last Online: Oct 2019 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (37 votes - 4.92 average) Installs: 236
Released: 20 Jan 2013 Last Update: 20 Jan 2015 Downloads: 1679
Supported DB Changes Uses Plugins Auto-Template Translations  

Tested and working in vb 4.2.3

Product Description:

Verify Mail before registration , and during update profile information (changing mail for members from usercp)

This Product:

Stop spam at the first order, it works to prevent the registration with anonymous mails, in order to ensure Forum mail arrives (Newsletters - Subscriptions - Contact members .. etc.), to emails properly and effectively.

no member will be registered , or admitted to the database (both in group waiting activation or any other group), unless the mail is true. As if there was not a failed attempt to register.

What are the anonymous mails?


Are the emails that can not access by its owner, and browsed. Whether it was a mail already exists (used by another person), or not.

As long as no member can or the new Registrar (who wrote this mail), access to the inbox in the mail will be an anonymous mail, and reject his request.


Installation:

Just Import The product from AdminCP.

The product Will begin work as soon as the product installed.

You can manage the product settings from AdminCP > Settings > Options > Verify Mail before registration.

Enjoy

Big thanks to ForceHSS for his help with ironing out the spelling issues


To update, just import via Products in admincp, tick overwrite

PLEASE UPDATE

Last version had SQL issue, this is fixed now in this version


IMPORTANT

If you running Rename register.php by BOP5 you need to edit 2 templates

http://www.vbulletin.org/forum/showthread.php?t=297834

1st search in languages for


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Edit register.php to what you renamed as and save

2nd edit in template : reg_ver_start


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

again look for register.php and change to what you renamed

After that all should be good

Note : CSS / FOOTER FIXED !!!


Mobile Theme Fix HERE

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	image.jpg
Views:	2273
Size:	31.9 KB
ID:	144936   Click image for larger version

Name:	image1.jpg
Views:	2280
Size:	62.5 KB
ID:	144937  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #301  
Old 22 Dec 2016, 12:38
carik carik is offline
 
Join Date: Jul 2010
after entering email, press - to complete the registration.
this opens the registration page.
how to fix?
thank you!
Reply With Quote
  #302  
Old 22 Dec 2016, 20:54
carik carik is offline
 
Join Date: Jul 2010
why it says "registration Page are available only to the link specified in the email which is sent to the specified e-mail!" and after entering the e-mail and click continue, then opens the registration page? why not return to index page? someone tell me?
Reply With Quote
  #303  
Old 03 Jan 2017, 16:14
K!nG K!nG is offline
 
Join Date: Dec 2010
I am not sure if my answer will be so helpful but even though it takes you to registration page but it still asks you for registration key and if you don't enter that you can't register. Once you hit continue it takes to registration page so you can check your email and either copy paste it or click on the link from email which will populate the registration key for you.
Reply With Quote
  #304  
Old 03 Jan 2017, 18:53
carik carik is offline
 
Join Date: Jul 2010
it should be so - a link with the verification code to complete the registration page should only be in e-mail! why do spammers and bots to load the registration page?
Reply With Quote
  #305  
Old 02 Feb 2017, 05:56
john7911 john7911 is offline
 
Join Date: Feb 2013
Question

Hi,
Some new users have problem to register:
" The activation code is Incorrect, or you used an old link.
please request the verification code again. "

Reply With Quote
  #306  
Old 07 Feb 2017, 13:23
tony2013 tony2013 is offline
 
Join Date: Mar 2013
Work great for my forum.

Many thanks
Reply With Quote
  #307  
Old 16 Apr 2017, 22:57
t3h3th32 t3h3th32 is offline
 
Join Date: Oct 2013
Hi,

any idea, if this works for vB 4.2.4?

Regards,
~t3h'PÔr4d0x
Reply With Quote
  #308  
Old 16 Apr 2017, 23:17
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by t3h3th32 View Post
Hi,

any idea, if this works for vB 4.2.4?

Regards,
~t3h'PÔr4d0x
The product description says it is working for vB 4.2.3, so it should work for 4.2.4+ as well.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #309  
Old 26 Apr 2017, 15:43
t3h3th32 t3h3th32 is offline
 
Join Date: Oct 2013
Doesn't seem to work for vB 4.2.4, is there a chance to request a help? I'd very much appreciate any suggestions. My best guess is, it's something small, like 1 line of code or something.

The product installs itself just fine, but there are no verification codes being sent to the emails. Quite strange.

Regards,
~t3h'PÔr4d0x
Reply With Quote
  #310  
Old 29 Apr 2017, 11:56
Inna Inna is offline
 
Join Date: Jul 2016
Originally Posted by MarkFL View Post
The product description says it is working for vB 4.2.3, so it should work for 4.2.4+ as well.
Hi Mark, the style is not shown well when a user wants to register.

It seems something is not OK with this product since only is shown well on the default style.
You may test it for yourself in a different style, rather than default one.

Would you please fix it?

The best
Reply With Quote
  #311  
Old 29 Apr 2017, 12:14
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Inna View Post
Hi Mark, the style is not shown well when a user wants to register.

It seems something is not OK with this product since only is shown well on the default style.
You may test it for yourself in a different style, rather than default one.

Would you please fix it?

The best
Only the author of the product can release an update. I recommend posting screenshots showing the issue you're having, and perhaps the developer can address it.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #312  
Old 29 Apr 2017, 12:24
Inna Inna is offline
 
Join Date: Jul 2016
Originally Posted by MarkFL View Post
Only the author of the product can release an update. I recommend posting screenshots showing the issue you're having, and perhaps the developer can address it.
No, I meant you release a fix for me (and anyone else who has this issue) on this post.

Shot is attached.

That's a test on my localhost, but the result was same on the real host (different styles)
Attached Images
File Type: jpg shot.jpg (31.8 KB, 22 views)

Last edited by Inna; 29 Apr 2017 at 12:55. Reason: removing img tag
Reply With Quote
  #313  
Old 29 Apr 2017, 12:32
t3h3th32 t3h3th32 is offline
 
Join Date: Oct 2013
I have the same issue (mod messes up the style), but it's not the mod to be blamed. The style / theme / skin needs to be tweaked. This happens a lot, when you're using mods and then install a custom style or vice versa.

I'd be more curious, if the mod works for you, for me, it doesn't send the verification emails.

Regards,
~t3h'PÔr4d0x
Reply With Quote
  #314  
Old 29 Apr 2017, 12:33
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
This product is marked as "Supported" and the developer has recently been online. The best thing to do is to give the developer a chance to address the issue you're experiencing.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #315  
Old 29 Apr 2017, 12:35
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by t3h3th32 View Post
I have the same issue (mod messes up the style), but it's not the mod to be blamed. The style / theme / skin needs to be tweaked. This happens a lot, when you're using mods and then install a custom style or vice versa.
This is very true...not all styles are created equally, or are as versatile as others.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:00.

Layout Options | Width: Wide Color: