Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 24 Sep 2016, 18:56
Zylantex Zylantex is offline
 
Join Date: Sep 2009
Real name: Chris
Migration phpBB to vB

Hi, I'm trying to migrate a forum with about 30 users and 5000 posts from phpbb 3.1.9 to vBulletin 4.2.2 using Impex.

In theory it should be easy but in practice it's breaking my heart. My host, Netfirms, is running php 5.3 and MySQL 5.6.32

Can this be done or am I doomed? Any suggestions please? Thanks.
Reply With Quote
  #2  
Old 25 Sep 2016, 09:14
WEBDosser's Avatar
WEBDosser WEBDosser is offline
 
Join Date: Oct 2001
Don't forget to backup everything first.

What problems are you having?.
Reply With Quote
  #3  
Old 25 Sep 2016, 10:03
Mattwhf Mattwhf is offline
 
Join Date: May 2016
Originally Posted by Zylantex View Post
Hi, I'm trying to migrate a forum with about 30 users and 5000 posts from phpbb 3.1.9 to vBulletin 4.2.2 using Impex.

In theory it should be easy but in practice it's breaking my heart. My host, is running php 5.3 and MySQL 5.6.32

Can this be done or am I doomed? Any suggestions please? Thanks.
I don't see any problem with php 5.3 and MySQL 5.6.32 to run vB4

If you want, you can upgrade your PHP and MySQL to higher versions in minutes.
__________________
Web Hosting Forum - Learn web hosting and offer your hosting services for FREE!
Reply With Quote
  #4  
Old 25 Sep 2016, 11:16
Zylantex Zylantex is offline
 
Join Date: Sep 2009
Real name: Chris
I've backed up everything first.

In the To/From selection in Impex I choose PHPBB3 and vB 4.2.2

When I run the convertor I see messages that mention phpBB 3.0.3 and I suspect there is where the problem starts. I'm running pbpBB 3.1.9 I can only imagine they are not 100% compatible.

If I ignore the messages and proceed I get a sort of half successful conversion but no attachments. Our forum depends on the attachments so this is a deal-breaker.

Would I have any success if I were to try to convert to 3.8.9 and then update to 4.4.2?

Another issue I faced was I got an error from my host saying more or less that the database was being hammered, it looked like a DOS attack, and I had to stop work and wait for the database to come back online. In the meantime this closed the forum which didn't go unnoticed by the users.

Edit I think there are limits on the Impex software that won't let me upgrade PHP / MySQL.
Reply With Quote
  #5  
Old 25 Sep 2016, 20:06
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Since you own a vB4 or 5 license, you can also download vBulletin 3 .

Want to avoid impex issues? Always go this route with older forums software i.e.

- Install vBulletin 3.
- Impex (import) from phpBB3 to vB3.
- Upgrade vB3 to vB4.

Extra steps yes however if you've been around long enough like most of us, you'll recall many threads and posts saying pretty much the same thing. Doing it that way should cause less issues for you but does require an extra step.
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #6  
Old 26 Sep 2016, 11:13
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Superman is right on here. Import to Vb3 first and then upgrade. That is the easiest way to import though this will not correct your server resource usage which is causing the issue that your host is saying is a ddos attack. The issue there is most likely your shared hosting account does not have the resources needed to accomplish the import.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:19.

Layout Options | Width: Wide Color: