Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Links and Downloads Manager Details »
Links and Downloads Manager
Mod Version: 2.2.8, by AndrewD (R.I.P) AndrewD is offline
Developer Last Online: Apr 2010 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.x Rating: (81 votes - 4.79 average) Installs: 659
Released: 19 Jun 2006 Last Update: 04 Feb 2008 Downloads: 8665
Not Supported DB Changes Uses Plugins Additional Files Translations  

Version 2.3.0 of LDM is now the official release. This works with both VB3.7 and VB3.8. You can obtain it here

Version 2.2.8 remains available here, with limited support.

04.02.08: patch-cat.xml 'extra' uploaded - see first post for information

27.10.07: Version 2.2.8-post1 uploaded
French translation of product installer uploaded (other language translations are in the main release zip)

Remember to back up your current database tables before upgrading.

What this is and does

LDM is a general-purpose link and file manager, which handles user uploads and downloads in a flexible way. A range of media players is integrated into LDM and others are included as plugin extras. LDM is described below in the first post of this thread, which also contains a brief list of the currently-known bugs.

This release of LDM works correctly with all VB versions 3.6.x and recent versions of vbadvanced.

Documentation, screen shots, etc, are provided as a Wiki at http://www.eirma.org/wikis/index.php...nloads_Manager

Thank you to everyone who has tested, given suggestions, helped with the translations, etc.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions Links and Downloads Manager AndrewD vBulletin 3.7 Add-ons 2047 26 Jun 2016 22:11
Links and Downloads Manager AndrewD vBulletin 3.5 Add-ons 2467 08 Apr 2010 17:24
Mini Mods [YouTube] Integration with Links & Downloads Manager (LDM 2.2.6) |oR|Greg vBulletin 3.6 Add-ons 41 26 Nov 2008 15:56

  #841  
Old 13 Dec 2006, 17:37
smoknz28's Avatar
smoknz28 smoknz28 is offline
 
Join Date: Sep 2005
Originally Posted by AndrewD View Post
I can't tell you any more without having admin access to your site.
Andrew, PM sent...
Reply With Quote
  #842  
Old 13 Dec 2006, 21:25
robihot robihot is offline
 
Join Date: Dec 2004
Originally Posted by AndrewD View Post
If the file points to an image, then LDM auto-generates the thumbnail without entering anything into the image url field. It will also do so for mp3s with embedded cover art, povided you have uploaded the getid3 code in the jukebox-enhancements 'extra'.

If you want to do something fancier (e.g. autolink a jpg to an avi or create a thumbnail by referring to an external source), then this needs a plugin. Maybe I missed something in your question?
Hi AndrewD.
Yes, this works, I know. But I like to use a Thumbnail Service to create the image (of the linked Webside). The idea is, that the thumbnail is created automatically if I enter a URL.
Reply With Quote
  #843  
Old 14 Dec 2006, 06:16
AndrewD AndrewD is offline
 
Join Date: Jul 2002
Real name: Andrew
Originally Posted by robihot View Post
Hi AndrewD.
Yes, this works, I know. But I like to use a Thumbnail Service to create the image (of the linked Webside). The idea is, that the thumbnail is created automatically if I enter a URL.
Now I understand. This is (I think) easy to do with a plugin. Send me a pm with details of the thumbnail service you want to use and I'll take a look.
Reply With Quote
  #844  
Old 14 Dec 2006, 12:37
sam anders sam anders is offline
 
Join Date: May 2006
installed this hack as per instructions and all loaded up all ok but when i go to update any settings in the admin section of local links the following is displayed:

The following setting(s) are invalid
upload_dir : forums/ldm_upload
Directory forums/ldm_upload (/var/www/vhosts/mydomain.com/httpdocs/_ldm/forums/ldm_upload) doesn't exist and I can't create it


i have the ldm_upload in the correct place but noticed in the full location the file says

httpdocs/_ldm/forums/ldm_upload


but the address should be

httpdocs/forums/ldm_upload which file do i edit to change this line?
Reply With Quote
  #845  
Old 14 Dec 2006, 17:43
AndrewD AndrewD is offline
 
Join Date: Jul 2002
Real name: Andrew
Originally Posted by sam anders View Post
installed this hack as per instructions and all loaded up all ok but when i go to update any settings in the admin section of local links the following is displayed:

The following setting(s) are invalid
upload_dir : forums/ldm_upload
Directory forums/ldm_upload (/var/www/vhosts/mydomain.com/httpdocs/_ldm/forums/ldm_upload) doesn't exist and I can't create it


i have the ldm_upload in the correct place but noticed in the full location the file says

httpdocs/_ldm/forums/ldm_upload


but the address should be

httpdocs/forums/ldm_upload which file do i edit to change this line?
That particular piece of code is using this logic:

-> if you've set the LDM/admin setting 'local_file_root', then it's simply concatenating 'local_file_root_prefix and 'upload_dir', both set on the LDM admin/settings page

-> Alternatively, it's concatenating LDM_DOCUMENT_ROOT, 'local_file_root_prefix' and 'upload_dir', where

LDM_DOCUMENT_ROOT is either:
-> taken from your php.ini' $_SERVER["DOCUMENT_ROOT"]
or
-> set in includes/local_init.php

My guess is that you've set local_file_root_prefix to _ldm on the ldm admin settings page.
Reply With Quote
  #846  
Old 14 Dec 2006, 22:36
sam anders sam anders is offline
 
Join Date: May 2006
thanks for the info makes sense about concatenating will reinstall and try again
Reply With Quote
  #847  
Old 15 Dec 2006, 00:05
Mr_Devlin Mr_Devlin is offline
 
Join Date: Nov 2005
Searched this forum but didn't find a solution or hint on an error.
When trying to access ldm I will get this error message:


Datenbankfehler in vBulletin 3.6.4:

Invalid SQL:

SELECT link.linkid AS linkid, link.linkname AS linkname, link.linkdoi AS linkdoi, link.linkuserid AS linkuserid,
link.linkusername AS linkusername, link.linkurl AS linkurl, link.linkimg AS linkimg,
link.linkimgthumb AS linkimgthumb, link.linkforum AS linkforum,
link.linkdesc AS linkdesc, link.numrate AS numrate, link.totrate AS totrate,
link.linkhits AS linkhits, link.linksize AS linksize, link.linkstatus AS linkstatus,
link.linkdate AS linkdate, link.linkmoderate AS linkmoderate,
ltoc.catid AS linkcatid, ltoc.displayorder AS linkdorder
, user.*, avatar.avatarpath, NOT ISNULL(customavatar.userid) AS hascustomavatar, customavatar.dateline AS avatardateline,customavatar.width AS avwidth,customavatar.height AS avheight

, COUNT(lhits.linkid) AS linkrecenthits

FROM local_linkslink AS link
LEFT JOIN local_linksltoc AS ltoc ON link.linkid = ltoc.linkid
LEFT JOIN user AS user ON (user.userid = link.linkuserid)
LEFT JOIN avatar AS avatar ON (avatar.avatarid = user.avatarid)
LEFT JOIN customavatar AS customavatar ON (customavatar.userid = user.userid)

LEFT JOIN local_linksdownloads AS lhits
ON link.linkid = lhits.linkid
WHERE lhits.usertime>=1163547774
GROUP BY linkid, linkcatid

ORDER BY linkhits DESC;

MySQL-Fehler : Got error 28 from storage engine
Fehler-Nr. : 1030
Datum : Thursday, December 14th 2006 @ 06:42:54 PM
Skript : http://www.*****.com/forum/local_links.php?
Referrer : http://www.*****.com/forum/showthrea...3082#post13082
IP-Adresse : **.***.***.***
Benutzername : ******
Klassenname : vb_database
ldm version: 2.2.6
MySQL: 4.1.10a
PHP: 4.4.3

Changing MySQL or PHP is not possible,
Any suggestions how to solve this problem?

#################

EDIT: OK, Problem solved by repairing tables...

Last edited by Mr_Devlin; 15 Dec 2006 at 11:53.
Reply With Quote
  #848  
Old 15 Dec 2006, 16:06
|oR|Greg |oR|Greg is offline
 
Join Date: May 2003
Request.

Andrew, I know you had a reason for this, but i'd love to see it as an option.

I'd like for the synchronization to be able to create threads. I don't add stuff all that often, but if you could specify an account, and then have it create based off that userid, it would be uber-sweet.
Reply With Quote
  #849  
Old 15 Dec 2006, 21:04
AndrewD AndrewD is offline
 
Join Date: Jul 2002
Real name: Andrew
Originally Posted by |oR|Greg View Post
Request.

Andrew, I know you had a reason for this, but i'd love to see it as an option.

I'd like for the synchronization to be able to create threads. I don't add stuff all that often, but if you could specify an account, and then have it create based off that userid, it would be uber-sweet.
No problem, will sort out how to make this an option.
Reply With Quote
  #850  
Old 15 Dec 2006, 21:24
Rouzbeh1 Rouzbeh1 is offline
 
Join Date: Sep 2006
hi,

i am using ldm_new.module, everything is perfect. the only thing is that, i have sub categories and when i specify the main category, it wont list the entries in the subcategories.
i need this for 3 levels subcategories (i.e. main cat-->sub cat 1-->sub cat 2-->entry)

could you please help me do this?

thanks in advance

ADD*: which template should i use to show thumbnails instead of text links. i am currently using links_vbathumbs, but Category Strips are not shown correctly. image attached
Attached Images
File Type: jpg cat-strip.jpg (18.1 KB, 18 views)

Last edited by Rouzbeh1; 15 Dec 2006 at 21:43.
Reply With Quote
  #851  
Old 15 Dec 2006, 21:31
|oR|Greg |oR|Greg is offline
 
Join Date: May 2003
Originally Posted by AndrewD View Post
No problem, will sort out how to make this an option.
Who's better than you?
Reply With Quote
  #852  
Old 15 Dec 2006, 21:33
WebmasterSimds WebmasterSimds is offline
 
Join Date: Sep 2006
Andrew

Sir, I am having a small problem. I have had this running for a long while. I upgraded the LDM system to the latest one when it came out. now i get weird messages. I think I remember how to correct this. but I cant remember. here is the message after somone posts a download.

"This page is not designed to be access directly."

if you can, or know how to fix this, can you please give me a clue how to fix this.

There is 1 more thing. and didnt notice this till someone pointed this out to me today. it seems every time we upgrade this LDM for some reason all of the pictures of the download has dissapeared on all of them.

the only way to correct it, is to go and press edit, and then just scroll down to the bottm and press submit and it will fix it. without any edits. its a weird weird one, I tried to look for a way to make sure the paths are ok, and other tings, but it seems that its a weird problem

Just in case for your FYI

VB Version is the latest release
Your version is the lates release

also my server stats

Kernel version 2.4.21-32.0.1.EL
Machine Type i686
Apache version 1.3.33 (Unix)
PERL version 5.8.0
PHP version 4.3.11
MySQL version 4.0.27-standard


Thanks in advance.

Ray
Reply With Quote
  #853  
Old 16 Dec 2006, 02:06
WebmasterSimds WebmasterSimds is offline
 
Join Date: Sep 2006
Update..

After Re - Installing the Product xml it took out the message "This page is not designed to be access directly."

That took care of it, but the problem is that it keeps doing it after so many weeks. I carry a large load of downloads in Your program like over 2500 and growing. I am wondering if that may or may not have anyting to do with it??

I remember when I had a other junk portal "xoops" it could not handle the large downloads, hence the reason I had to change. but they could not come up with a solution for larger type database for downloads.

Again I am wondering if that may or may not be a problem

Thanks again
Reply With Quote
  #854  
Old 16 Dec 2006, 05:51
xadoa xadoa is offline
 
Join Date: Nov 2003
Originally Posted by AndrewD View Post
Which linkbit are you using?
HI AndrewD,

hehe good question Andrew, i am a code sucker .. hehe i don't know what linkbit i am using, can u show me which one is that? ..

XD
Reply With Quote
  #855  
Old 16 Dec 2006, 07:09
AndrewD AndrewD is offline
 
Join Date: Jul 2002
Real name: Andrew
Originally Posted by WebmasterSimds View Post
Andrew

Sir, I am having a small problem. I have had this running for a long while. I upgraded the LDM system to the latest one when it came out. now i get weird messages. I think I remember how to correct this. but I cant remember. here is the message after somone posts a download.

"This page is not designed to be access directly."

if you can, or know how to fix this, can you please give me a clue how to fix this.
I recall your report in October. I've never seen this message - there is no such message in LDM and I can't find it in the VBulletin code anywhere either.

I did a search on Google for the text "This page is not designed to be access directly." There are two hits, your report fror LDM and this report in the VB Events Forum archive (http://www.vbulletin.org/forum/archi.../t-123416.html)

Lionel11. Oct 2006, 05:54
When I submit the Save Event button, I am getting this error:

link: http://www.mysite.com/forums/calendar.php?do=update&e=

This page is not designed to be access directly.


It looks is missing the info on the link, any idea what could casue this problem.

--------------------------------------------------------------------------------

Lionel11. Oct 2006, 06:21
Anyway, Gerakus I solved my issue. It was caused by the Talker Bot hack.
edited: - I took a look at the talker bot code. The message "This page is not designed to be access directly" appears at the start of one of its files. The code reads as follows:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The code is called from at least one plugin called "Talkerbot - Include The Bot", which hooks into the newpost_complete hook in VB. The newpost_complete hook is used in the code to create new posts, which is called when LDM 'autocreates' threads.

So what I think is happening is the following:
- you've installed talker bot
- you've also installed the autocreate_threads extra for LDM
talker_bot is not expecting this and gives you the error message you see.

Unfortunately, it's not a problem that I can fix - you'll have to take this up with the author of talker_bot


Originally Posted by WebmasterSimds View Post
There is 1 more thing. and didnt notice this till someone pointed this out to me today. it seems every time we upgrade this LDM for some reason all of the pictures of the download has dissapeared on all of them.

the only way to correct it, is to go and press edit, and then just scroll down to the bottm and press submit and it will fix it. without any edits. its a weird weird one, I tried to look for a way to make sure the paths are ok, and other tings, but it seems that its a weird problem
LDM creates a thumbnail whenever it thinks it needs one. If you've set up a 'thumbs_dir' on the admin page, it saves the thumbnail as a file in 'thumbs_dir' and keeps a record in the database. The problem you describe occurs when the record in the database points to a file which no longer exists, for example if the file structure for the website changes or (perhaps ) I have made a change in the logic. I don't know which is the case for your situation.

When you edit and save an entry, LDM always recreates the thumb, in case there are any changes.

One way to fix this for all entries is to go to LDM/admin/statistics/reset thumbs

Last edited by AndrewD; 16 Dec 2006 at 07:43.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 01:55.

Layout Options | Width: Wide Color: