Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 29 Sep 2014, 04:50
afterburn25 afterburn25 is offline
 
Join Date: Apr 2013
page errors

I have been getting errors in activity stream and little errors all over the place really when I try to access activity stream i get this

[29-Sep-2014 03:47:57 UTC] PHP Fatal error: Class 'vB_ActivityStream_View_Perm__' not found in /home/spicypan/public_html/vb/activitystream/view.php on line 589

any idea of how to fix this
Reply With Quote
  #2  
Old 29 Sep 2014, 07:11
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
You have made many topics about this problem can you please stop and stay with the one
Reply With Quote
  #3  
Old 29 Sep 2014, 13:50
afterburn25 afterburn25 is offline
 
Join Date: Apr 2013
Actually there different problems all of them completely different
Reply With Quote
  #4  
Old 29 Sep 2014, 14:24
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Aug 2009
Real name: Chris
Since you have so many issues, you should open a support ticket at vb.com, that would be the best way to get support on the core product. This site is is more for modifications and styling, not supporting the software.
__________________
You can get access to my 180 mods for vB 3.6 - 4.x at The Admin Zone as well as the professional support you are used to. New vBulletin Spider Definitions, vBulletin Spiders List Hits 1000 Spiders! ​ OzzModz down. Site has had a data breach, checking how the intrusion happened. Change your PW if you use the same one on my site and others.
Reply With Quote
  #5  
Old 29 Sep 2014, 15:39
afterburn25 afterburn25 is offline
 
Join Date: Apr 2013
I tried them but they offer no support unless I wanna wipe me database clean and that's not an option
Reply With Quote
  #6  
Old 29 Sep 2014, 15:56
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Aug 2009
Real name: Chris
Then perhaps you need to pay someone to fix all your issues if possible. Post a request in the paid section, http://www.vbulletin.org/forum/forumdisplay.php?f=30
__________________
You can get access to my 180 mods for vB 3.6 - 4.x at The Admin Zone as well as the professional support you are used to. New vBulletin Spider Definitions, vBulletin Spiders List Hits 1000 Spiders! ​ OzzModz down. Site has had a data breach, checking how the intrusion happened. Change your PW if you use the same one on my site and others.
Reply With Quote
  #7  
Old 29 Sep 2014, 19:02
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Originally Posted by afterburn25 View Post
I tried them but they offer no support unless I wanna wipe me database clean and that's not an option
We never tell someone to wipe their database in order to receive help. That would make no sense at all. We do ask you to disable all modifications, but that doesn't equate to wiping the database.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #8  
Old 29 Sep 2014, 19:13
afterburn25 afterburn25 is offline
 
Join Date: Apr 2013
I talked to a support guy there was an error in database and he said they don't support partial restores
Reply With Quote
  #9  
Old 29 Sep 2014, 19:40
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
What is the error in the database?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #10  
Old 29 Sep 2014, 19:55
afterburn25 afterburn25 is offline
 
Join Date: Apr 2013
Action segments were requested for an undefined route class 'vBCms_Route_Content' on line 716 in /home/spicypan/public_html/vb/router.php #0 /home/spicypan/public_html/packages/vbcms/route/content.php(210): vB_Router::getRouteActions('vBCms_Route_Con...') #1 /home/spicypan/public_html/vb/route.php(242): vBCms_Route_Content->buildSegmentScheme() #2 /home/spicypan/public_html/packages/vbcms/route/content.php(65): vB_Route->__construct('1/addcontent/') #3 /home/spicypan/public_html/vb/route.php(260): vBCms_Route_Content->__construct('1/addcontent/', false) #4 /home/spicypan/public_html/includes/class_postbit.php(420): vB_Route::create('vBCms_Route_Con...', '1/addcontent/') #5 /home/spicypan/public_html/showthread.php(1096): vB_Postbit->construct_postbit(Array) #6 {main}

I have traced it to the database cause when I put an older back db I don't get the error
Reply With Quote
  #11  
Old 29 Sep 2014, 23:19
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
That isn't a database error though. If you were getting a database error, then it should get emailed to you at the email entered into your config.php file. So, are you getting a database error or just that PHP error?

The error in your first post looks like a missing file. Run Maintenance > Diagnostics > Suspect File Versions and make sure no default vbulletin files are listed as missing or not containing expected content.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #12  
Old 29 Sep 2014, 23:47
tbworld tbworld is offline
 
Join Date: Oct 2008
Before I left on my business trip, I took a quick look at this problem. The file system was intact, the action segment, route classes, content tables were populated. His admin permissions were slightly askew (which was odd). I believe he has some slight data corruption in the CMS which needs to be pin-pointed.

If it was me I would be logging that error-position to discover who invoked it with what data. Something I could not due with the trace-back given and the short amount of time I had available.

I would suggest, he hire someone to track this down programmatically and fix the corruption. The problem is beyond the kind of assistance we can give verbally, in my opinion.



PS: I could fix it for you, but you would have to pass me a copy of your database. Solving this kind of problem remotely would require too much of my time.

Last edited by tbworld; 29 Sep 2014 at 23:52.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:20.

Layout Options | Width: Wide Color: