Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 09 Oct 2018, 20:36
seyed seyed is offline
 
Join Date: Aug 2018
Disable Ajax for Create Post / Reply VB5

Unfortunately since a few days ago vbulletin 5 is giving me :

Error while saving content: SyntaxError: Unexpected token E in JSON at position 65

for posting / creating content

BUT system is fine for removing posts

I just want to disable the AJAX for sending posts, I spent a lot of time fixing the problem but it doesn't work .. tried many things .. localhost it is fine but online ajax is not working so how can I disable ajax for create or send message

Thanks
Reply With Quote
  #2  
Old 09 Oct 2018, 22:01
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
If you disable ajax for posting then you wouldn't be able to post at all or you would get the raw JSON response displayed on the page or downloaded by the browser. There's no server-side code available to process posting without AJAX on vB5.

Whenever you get that error when posting, it usually means the server responds to the ajax request with an HTML output instead of JSON format. The HTML output probably states a generic server error message. You should check the server error logs for the exact error message or temporarily enable debug mode so that you can see the exact error message in the HTML output in the browser dev tools Network tab > Response tab for the AJAX request for submitting a post.
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #3  
Old 15 Oct 2018, 01:29
seyed seyed is offline
 
Join Date: Aug 2018
Originally Posted by noypiscripter View Post
If you disable ajax for posting then you wouldn't be able to post at all or you would get the raw JSON response displayed on the page or downloaded by the browser. There's no server-side code available to process posting without AJAX on vB5.

Whenever you get that error when posting, it usually means the server responds to the ajax request with an HTML output instead of JSON format. The HTML output probably states a generic server error message. You should check the server error logs for the exact error message or temporarily enable debug mode so that you can see the exact error message in the HTML output in the browser dev tools Network tab > Response tab for the AJAX request for submitting a post.
Thanks for your help .. unfortunately VB5 breaks so easy like if your mail server doesn't work properly you will experience such an error .. I resolved the issue and it works fine ... thanks for your suggestion
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Miscellaneous Hacks User Drop Down Icons + Message drop down icons (CSS only) - vb5.2.3/vb5.2.4 napy8gen vBulletin 5.x Template Modifications 13 24 Mar 2018 02:34
Forum Style [SultanTheme] Gadisku vb5 for vb5.2.4 napy8gen vBulletin 5.x Styles 1 03 Nov 2016 00:55
Forum Style [SultanTheme] Daysee vb5 for vb5.2.4 napy8gen vBulletin 5.x Styles 0 19 Oct 2016 08:25



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 07:50.

Layout Options | Width: Wide Color: