Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 13 May 2017, 00:11
loua_oz loua_oz is offline
 
Join Date: Dec 2010
VBuletin shows bare skeleton as home page

After failed upgrade to 4.2.5 , restored my site from backup. However, when going to www.sitename.com, it lands into skeleton like in the picture.

In "Script Name for Forum Home Page" i have "index".

In index.php I have:

if (defined('VB_RELATIVE_PATH'))
{
chdir('./' . VB_RELATIVE_PATH);
}

require('forum.php');


What could it be?
Attached Images
File Type: jpg 2017skeleton01.jpg (11.8 KB, 7 views)
Reply With Quote
  #2  
Old 13 May 2017, 00:39
loua_oz loua_oz is offline
 
Join Date: Dec 2010
In Navigation Manager the default is CSS.
Reply With Quote
  #3  
Old 13 May 2017, 00:53
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
If all the forum files are in the "forums" directory then you need to move everything up one folder.
Also if there's an index.php file but it's not loading it by default, you need to configure the DirectoryIndex to index.php in a .htaccess file.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #4  
Old 13 May 2017, 01:04
loua_oz loua_oz is offline
 
Join Date: Dec 2010
Thank you, I remember doing that years back with .htaccess file. Now, my .htaccess looks like this (autocreated when I blocked 3 IP addresses using cPanel that my provider gives).
What should it look like after the change you are telling me?


<Files 403.shtml>
order allow,deny
allow from all
</Files>

deny from 77.78.208.0/20
deny from 217.182.0.0/16
deny from 51.254.0.0/15
Reply With Quote
  #5  
Old 13 May 2017, 01:08
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Are you making use of the SEO rewrite rules? You have to upload the .htaccess file which you can find in the do_not_upload folder of the vBulletin installation files.

Adding DirectoryIndex index.php will load index.php whenever the root of the domain is requested, although most webservers should do this automatically.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #6  
Old 13 May 2017, 01:21
loua_oz loua_oz is offline
 
Join Date: Dec 2010
How do you add that? Just like this?


.htaccess:

RewriteEngine on

# If you are having problems or are using VirtualDocumentRoot, uncomment this line and set it to your vBulletin directory.
# RewriteBase /forum/

# If you are having problems with the rewrite from content/ to content.php, uncomment this line to turn MultiViews off.
# Options -MultiViews

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^.*$ - [NC,L]

# Forum
DirectoryIndex index.php
RewriteRule ^threads/.* showthread.php [QSA]
RewriteRule ^forums/.* forumdisplay.php [QSA]
RewriteRule ^members/.* member.php [QSA]
RewriteRule ^blogs/.* blog.php [QSA]
RewriteRule ^entries/.* entry.php [QSA]
.
.
.

--------------- Added 13 May 2017 at 03:20 ---------------

Looks like I have fixed it. Thanks for directing me to .htaccess

My site is installed in

public_html/forums

and tens of thousands of pictures are in peer directories like

public_html/pics1
public_html/pics2
...


Found my old

.htaccess which directs into that /forums directory where all VB files are.

.htaccess file contents:

DirectoryIndex index.php

RewriteEngine On
RewriteCond %{HTTP_HOST} ^(www.)?mysite.com$
RewriteRule ^(/)?$ forums [L]

#RewriteEngine on
#RewriteCond %{HTTP_HOST} ^mysite.com [NC]
#RewriteRule ^(.*)index.php$ http://forums.mysite.com/$1 [R=301,L]


#Options +FollowSymLinks
#RewriteCond %{THE_REQUEST} ^.*/index.php
#RewriteRule ^(.*)$ http://www.mysite.com/forums/$1 [R=301,L]


--------------- Added 13 May 2017 at 10:04 ---------------

My hosting site responded as well with even simpler method:

How to prevent the Index Of page

Log into your cPanel dashboard.
Once in the cPanel, click on the File Manager icon, located in the Files category.
Locate the .htaccess file and open it for editing.
At the top of the file, add the following code:

Options -Indexes
Save and close the file.
Now when someone visits a directory or folder that has no index file, it will receive a 403 Forbidden error instead of seeing a list of the directory's contents. The 403 error indicates the visitor does not have access permissions to view that area.

Last edited by loua_oz; 13 May 2017 at 03:24.
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forum Home Enhancements Product Development Skeleton Replicant vBulletin 5.x Products & Extensions 5 17 Jul 2017 11:53



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 01:52.

Layout Options | Width: Wide Color: