Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vB Nexus, Facebook & Google multiple login integration Details »
vB Nexus, Facebook & Google multiple login integration
Mod Version: 1.00, by ibautocommunity (Coder) ibautocommunity is offline
Developer Last Online: Jun 2020 I like it Show Printable Version Email this Page

vB Version: 3.8.3 Rating: (17 votes - 4.47 average) Installs: 154
Released: 13 Aug 2009 Last Update: 13 Aug 2009 Downloads: 1935
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Re-usable Code Translations External Content Is in Beta Stage  

vBulletin Nexus
Current project release: BETA
This works on vBulletin 3.7.X - 3.8.4

This product will allow visitors to join your community using their Facebook, Google, Yahoo or AIM account; and will allow your existing members to associate an existing forum account with one of the services - such as Facebook.

Please read the documentation and follow it exactly before requesting installation help. Please note, if you have heavily modified styles that are missing hooks - this product will not work and require additional installation steps.

DEMO: http://www.carblog.com/vbnexus

Basic Instructions for your forum's users: http://carblog.com/vbnexus/user-guide/

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #286  
Old 03 Sep 2009, 15:55
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Post #275. I have commented on this at least 4 times in the thread, as have others.

You can not get email from the providers. Most likely a security measure but honestly I have not researched it. For Facebook you get a proxy email that will work. The others get a somewhat random email with your site info in it. This will not work.
Reply With Quote
  #287  
Old 03 Sep 2009, 21:11
ZiG ZiG is offline
 
Join Date: Oct 2002
Real name: Zig
Originally Posted by Ryan Ashbrook View Post
Then you need something specific to assign to the $phrasegroups array, I can't help you. Sorry.

For those who are having issues regarding Facebook Wall Feeds (Sign Up, New Thread, New Reply, and Album) I have found a fix.

Because most of our servers are 32-bit, anything that is assigned as an Integer will be limited to 2147483647. Facebook Template ID's are way above this.

Therefor, to fix, close your board and place it into Debug Mode, by adding this line to your config.php, after <?php


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Go to your Admin CP -> vBulletin Options -> vB Nexus Configuration.

For all of the Template Bundle ID configs (there are four of them), click [Edit] and change it's Data Validation Type to Numeric, and save.

Once your done changing all four turn off debug mode by removing the line I noted before and re-open your board.

This isn't really a bug in vBulletin Nexus, it's a limitation in our servers. They way they had it set up is the correct way to do things.
yes, thank you very much for this fix
Reply With Quote
  #288  
Old 04 Sep 2009, 15:50
GoTTi GoTTi is offline
 
Join Date: Jun 2002
ok and how do i unlink a facebook account to a forum account? so when i am doing test or whatever, i dont want it to keep automatically logging in. i want it to ask the regular questions like what name do u want or do u have an account...

how do i unlink the facebook account from the forum account?
Reply With Quote
  #289  
Old 04 Sep 2009, 17:07
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Was the Forum account there and you linked it or was it created when you signed on using your Facebook account?

Simple way is to Delete the forum account, but if it is one you use then the best way to unlink it that I can think of is to edit the Database and remove the entry that has the Forum ID from the vbnexus_nonvbuser table.

This should be made easier. An option in the userCP or even something under the Admin tools.

Just as a general warning, make sure that the account has a valid email especially if it was created by Facebook or Google Friend Connect. The password local password is what appears to be a hash of some data and likely unknown so after you break the association you will need to reset the forum password to login.
Reply With Quote
  #290  
Old 07 Sep 2009, 03:31
wicked80 wicked80 is offline
 
Join Date: Feb 2008
Originally Posted by Calash View Post
At bare minimum your Wordpress will need to be using the header, headerinclude, and footer template to get it to work.
Thanks Calash,
I would really appreciate if you can tell how that step can be accomplished.

I have made a new plugin and made it global, and $vbnex_login works fine on vbulletin but when I use that on wordpress it's not working.

Thanks

Last edited by wicked80; 07 Sep 2009 at 04:02.
Reply With Quote
  #291  
Old 07 Sep 2009, 16:37
ZiG ZiG is offline
 
Join Date: Oct 2002
Real name: Zig
This mod conflicts with vbseo Live Stats RC1:

http://www.vbseo.com/f234/latest-ver...07/#post233539

any fix for this?
Reply With Quote
  #292  
Old 07 Sep 2009, 19:42
cherylferraro's Avatar
cherylferraro cherylferraro is offline
 
Join Date: Oct 2005
Any chance this will ever be fully developed or at least made more stable?

One of my site's facebook fan pages has been on fire lately and I'd be willing to pay for someone to fix this code so I can entice some of those facebook fans to use the forum over on my site...

Anyone that has good references and knows how to accomplish this can send me a pm.
Reply With Quote
  #293  
Old 08 Sep 2009, 14:14
cad2go cad2go is offline
 
Join Date: Feb 2009
Originally Posted by cherylferraro View Post
Any chance this will ever be fully developed or at least made more stable?

One of my site's facebook fan pages has been on fire lately and I'd be willing to pay for someone to fix this code so I can entice some of those facebook fans to use the forum over on my site...

Anyone that has good references and knows how to accomplish this can send me a pm.
the other facebook connect mod works better. Trickier to install but it does actually work.

This mod here will be fully developed as part of vb4 and as it stands is nothing more than an annoying teaser of what could've been.
Reply With Quote
  #294  
Old 08 Sep 2009, 15:34
cherylferraro's Avatar
cherylferraro cherylferraro is offline
 
Join Date: Oct 2005
Thanks for the info, I didn't know this would be a feature of vb4.

I looked at the other facebook mod but this one had more of the specific features that I want.

If I install either one of them will facebook users get kerfrumpled if the same type of feature is integrated into vb4? I don't like to do anything to disrupt forum users if I don't have to...
Reply With Quote
  #295  
Old 08 Sep 2009, 15:50
Ohiosweetheart Ohiosweetheart is offline
 
Join Date: Dec 2005
Real name: Peggy
No this mod will not be integrated into vB4, as far as I know. But it will be compatible with vB4, according to Anders. I'm not sure how they'll accomplish that when they can't get it to work properly with vB 3.8.4, but we'll see.
Reply With Quote
  #296  
Old 08 Sep 2009, 16:47
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Originally Posted by cherylferraro View Post
Any chance this will ever be fully developed or at least made more stable?

One of my site's facebook fan pages has been on fire lately and I'd be willing to pay for someone to fix this code so I can entice some of those facebook fans to use the forum over on my site...

Anyone that has good references and knows how to accomplish this can send me a pm.
There are some good bug fixes listed in this thread so far.

What problems are you seeing?
Reply With Quote
  #297  
Old 08 Sep 2009, 17:12
Sauk Sauk is offline
 
Join Date: Jul 2009
ok installed and it works great for facebook features. No issues at all...

But when clicking on the google, aim logo to join it does nothing. No box opens,nothing? Why would this be?
Reply With Quote
  #298  
Old 08 Sep 2009, 17:22
Sauk Sauk is offline
 
Join Date: Jul 2009
okay I believe I figured out my error...

I had put it to my main site instead of the subdomain my forum was on for the google connect stuff.
Reply With Quote
  #299  
Old 09 Sep 2009, 04:08
cherylferraro's Avatar
cherylferraro cherylferraro is offline
 
Join Date: Oct 2005
Originally Posted by Calash View Post
There are some good bug fixes listed in this thread so far.

What problems are you seeing?
Can't post when logged in from facebook on the demo site, can't even see the forum... After several attempts it just doesn't seem to work.

I don't want to create this kind of problem for my site's users.
Reply With Quote
  #300  
Old 09 Sep 2009, 12:52
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Odd. I was able to post fine just now. Had one of the annoying gray screens but once I told it not to post to my Facebook profile it went fine.

What browser are you running?

You are welcome to test on my site as well if you would like. I have it in a good running state there.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:15.

Layout Options | Width: Wide Color: