Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs Details »
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs
Mod Version: 2.5.6, by The Geek (Coder) The Geek is offline
Developer Last Online: Jan 2019 I like it Show Printable Version Email this Page

vB Version: 3.8.0 Rating: (192 votes - 4.75 average) Installs: 1968
Released: 20 Jan 2009 Last Update: 09 Dec 2009 Downloads: 12886
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

From the makers of the letters O and Yea comes the hottest 'must have mod' of the season: AME 2.5 - The Return of The Hot Mama.

Thanks everyone for making AME 2.5 Mod of the Month

AME is the multi award winning modification that smartly scans new and edited posts for URLs from a customisable variety of web sites (i.e. YouTube or Amazon or about 200 others). If it finds a match, AME will 'transform' the URL into inline embedded media without your users ever having to even think about it.

It was important for me to create a system that did not need updating (and subsequent reinstalling) every time one of the sites it supported decided to change the way it displayed its media (which is all the fricken time). Therefore I built a system in which the 'definitions' for each site could be imported, exported, tweaked and shared on a whim. This way, you only have to import the definitions that you want. It also allows the vB community to get creative and share definitions that I wouldn't of thought of!

Which sites are supported?

Included in the default installation is YouTube and Amazon. At time of posting this, I believe that there are over 180 sites supported that have been created by the vBulletin community. These range from sites that stream videos to Amazon referral links to locally hosted music and video files.

Check out the 'add ons' section of this post below to see availible add-ons.

For a total list of features and an FAQ, see click here.
For a post on troubleshooting, click here.

Though not tested on any version of vBulletin lower than 3.7.4, in theory it should work on versions 3.5 and higher (just dont quote this bit!).

Big thanks goes out to all those in the community that have supported this mod. Especially Digital Jedi who gives great support on this mod and has created over 160 definitions for this system alone!


Installation/Upgrade
  • Upload the contents of the forums folder into your forums directory and import the product-ame.xml file into your product manager (if upgrading, choose 'yes' to overwrite previous installation).
  • After installation, make sure that the system is on (admincp->AME CP->Settings)
  • Then you may want to try to rebuild old URLs via the tools option.

Change Log
nJoy

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	newpost.jpg
Views:	6637
Size:	26.4 KB
ID:	93148   Click image for larger version

Name:	newpost_result.jpg
Views:	9502
Size:	61.9 KB
ID:	93149  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases DJ's AMEs :: Media Definitions for AME 2.5 :: More Video, Twitter, Pinterest... Digital Jedi vBulletin 3.8 Add-ons 2086 05 Sep 2018 16:05
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Show Thread Enhancements AME 2.0 -Auto Media Embedding for posts, blogs, visitor and group messsages The Geek vBulletin 3.7 Add-ons 954 25 May 2014 10:58
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #31  
Old 20 Jan 2009, 18:41
Idawg's Avatar
Idawg Idawg is offline
 
Join Date: Nov 2006
Same here

It seems like you are missing some of the required AME files.
Please upload the contents of the upload/forums folder into your forums directory before installing this modification.
Sounds like you need to take out the file checker.. I mean if people cant read the README and get all kinds of errors, not your problem LOL
Reply With Quote
  #32  
Old 20 Jan 2009, 18:47
The Geek's Avatar
The Geek The Geek is offline
 
Join Date: Sep 2003
hehe, I removed the file checker

Download 2.5.1, upload all the files and reimport the product xml.

Sorry about the hassle, was trying to prevent plethora of silly troubleshooting posts and instead got 3 pages of troubleshooting posts about my solution!

Karma rocks!
Reply With Quote
  #33  
Old 20 Jan 2009, 18:48
Idawg's Avatar
Idawg Idawg is offline
 
Join Date: Nov 2006
hahahahaha. thanks.. I have ALWAYS liked your products and quick fixes like impress us
Reply With Quote
  #34  
Old 20 Jan 2009, 18:49
The Geek's Avatar
The Geek The Geek is offline
 
Join Date: Sep 2003
Originally Posted by jack the lad View Post
I cannot figure out where the "amecache-Index" folder/file goes, is it in the forum root directory?

I also get the file missing message, but I put that down to me ballsing up the upgrade

Nice mod though. Cheers.
Upload all the files in the forums folder into the folder on your server where vB is. the amecache folder (and the index file inside it) will go into your vB root directory (just like all the other files and folders).

HTHs!
Reply With Quote
  #35  
Old 20 Jan 2009, 18:58
smirkley smirkley is offline
 
Join Date: Apr 2008
Hey Geek,....

THANK YOU !!



(and the 251 installer works great, and I see the blog, social group issue I reported earlier is now in proper operation. thanks for a great product)
Reply With Quote
  #36  
Old 20 Jan 2009, 19:02
Mihalis Mihalis is offline
 
Join Date: Nov 2008
Thanx for the fix mate!
Reply With Quote
  #37  
Old 20 Jan 2009, 19:02
jack the lad jack the lad is offline
 
Join Date: Mar 2007
Works a treat

Cheers mate all working fine and dandy now. Many thanks
Reply With Quote
  #38  
Old 20 Jan 2009, 19:10
redlabour's Avatar
redlabour redlabour is offline
 
Join Date: Mar 2004
Real name: André
Bug in 2.5.1:

s. Screenshot - Videos posted double with broken Titles between them
Attached Images
File Type: jpg greenshot_2009-01-20_20-09-48.jpg (70.6 KB, 68 views)
Reply With Quote
  #39  
Old 20 Jan 2009, 19:16
txbritt txbritt is offline
 
Join Date: Dec 2008
Real name: Brittney
worked perfectly for me thanks for the upgrade
Reply With Quote
  #40  
Old 20 Jan 2009, 19:16
The Geek's Avatar
The Geek The Geek is offline
 
Join Date: Sep 2003
Do you have multiple versions of the same definition installed? If not, can you get me a link?
Reply With Quote
  #41  
Old 20 Jan 2009, 19:23
tei727's Avatar
tei727 tei727 is offline
 
Join Date: Feb 2006
my problem is fixed..
Reply With Quote
  #42  
Old 20 Jan 2009, 19:24
redlabour's Avatar
redlabour redlabour is offline
 
Join Date: Mar 2004
Real name: André
Originally Posted by The Geek View Post
Do you have multiple versions of the same definition installed? If not,
Yes - it added You Tube and Amazon again. Thanks for the Hint.
Reply With Quote
  #43  
Old 20 Jan 2009, 19:44
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Originally Posted by The Geek View Post
Thanks guys... just fixed it. It was a bug with the check to make sure files were uploaded first. It wont have affected your installs, but it also wont happen again.

Also, thanks to the lame-o who rated it 1 star. Can only assume its some disgruntled 'other media hack' coder who couldn't pull something as snazzy as this off
Or someone who reads left to right just assumed that five stars would be to the right and not the left and clicked one star while realizing it at the last minute he/she clicked the wrong star...

What, I didn't say it was ME. I'm just sayin'.


Originally Posted by jack the lad View Post
I cannot figure out where the "amecache-Index" folder/file goes, is it in the forum root directory?

I also get the file missing message, but I put that down to me ballsing up the upgrade

Nice mod though. Cheers.
You don't upload your files one at a time, you upload them all at once. That's why their already sorted where they're supposed to go.
__________________
Reply With Quote
  #44  
Old 20 Jan 2009, 19:50
Andyrew's Avatar
Andyrew Andyrew is offline
 
Join Date: Aug 2005
Real name: Andrew
Rebuild feature under tools wont complete on my forum it just does about four pages then stops.
Reply With Quote
  #45  
Old 20 Jan 2009, 19:58
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Hey, Geek, rather then bug ya in PM... Just upgraded and I'm still having trouble with the $url and $title parsing. They're still just being stripped out, along with $ameinfo[title] and $ameinfo[url].
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 19:09.

Layout Options | Width: Wide Color: