Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 27 Mar 2016, 22:53
ilrglen's Avatar
ilrglen ilrglen is offline
 
Join Date: Jun 2008
Real name: Glen Kohut
Can't save edited templates in version 3.8.3 - error 403 forbidden message

Recently I have encountered a problem saving templates I wish to edit. I am able to open a template in the style manager and make changes but when I click the SAVE or SAVE AND RELOAD I get redirected to an ERROR 430 FORBIDDEN message from the ISP's servers. Am I missing some file or component somewhere in the software package or is there a file that is supposed to be called for that it can no longer find? Somebody help please...
Reply With Quote
  #2  
Old 27 Mar 2016, 23:42
greigeh greigeh is offline
 
Join Date: Jan 2015
Real name: Greig David
Sounds like your being denied access, could be cause the CHMOD for your files are wrong.
Reply With Quote
  #3  
Old 27 Mar 2016, 23:55
Black Tiger's Avatar
Black Tiger Black Tiger is offline
 
Join Date: Apr 2004
If you are making template changes, you can better use the TMS mod which works perfectly and you won't have the forbidden issues.
http://www.vbulletin.org/forum/showthread.php?t=152931
Use the 1.1.5 zipfile this is for 3.8.x versions of vBulletin.
__________________
Greetings, Black Tiger
Reply With Quote
  #4  
Old 27 Mar 2016, 23:58
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
greigeh could be right above ^. I would also check file ownership i.e. are any files uploaded as a different user such as one under root and one under another name? If you recently updated any files via ftp this might be the case.

What exactly are you trying to save in the template? By chance are you using Google's pagespeed insights and trying to make changes, if so trying to save tons of javascript inline or similar is not advised (well they advise it is but only if a small snippet so if large = no no ect).
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #5  
Old 27 Mar 2016, 23:59
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Cool

Originally Posted by Black Tiger View Post
If you are making template changes, you can better use the TMS mod which works perfectly and you won't have the forbidden issues.
http://www.vbulletin.org/forum/showthread.php?t=152931
Use the 1.1.5 zipfile this is for 3.8.x versions of vBulletin.
Ahh now that I didn't realize i.e. TMS won't cause the forbidden error, pretty nifty and thanks for posting

"Sorry you're not allowed to like this post" but I'm allowed to comment and say thanks for info haha!
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #6  
Old 28 Mar 2016, 12:46
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by greigeh View Post
Sounds like your being denied access, could be cause the CHMOD for your files are wrong.
Templates are stored on the database, so unaffected by file permissions.

Sounds more like an over active security module on apache seeing something it doesnt like in the POST request.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #7  
Old 04 Apr 2016, 00:50
ilrglen's Avatar
ilrglen ilrglen is offline
 
Join Date: Jun 2008
Real name: Glen Kohut
I believe my ISP moved my site to a new server in the past month or two and this issue wasn't encountered until after that time
Reply With Quote
  #8  
Old 04 Apr 2016, 02:49
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Is Suhosin or mod_security enabled on this new server? (You will need to ask your host this and, at the same time, mention the problem and perhaps they can fix it.)
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #9  
Old 09 Jun 2016, 03:56
ilrglen's Avatar
ilrglen ilrglen is offline
 
Join Date: Jun 2008
Real name: Glen Kohut
Originally Posted by Lynne View Post
Is Suhosin or mod_security enabled on this new server? (You will need to ask your host this and, at the same time, mention the problem and perhaps they can fix it.)
I will check. The 403 Forbidden message continues...
"The page you are looking for might have been removed, had its name changed, or is temporarily unavailable." So I am wondering what page is being called for when I click SAVE or SAVE AND RELOAD that might even be missing with the move? Any help with that?
Reply With Quote
  #10  
Old 10 Jun 2016, 01:01
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Open the page outside of the frame and then when you click Save, the URL with change and you can see where it is going.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #11  
Old 10 Jun 2016, 13:05
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Again, nothing is missing, you would get a 404 error if it were.

The server (or firewall if you are routed via one) is intercepting the request and blocking it.

Speak to your host.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #12  
Old 22 Jun 2016, 02:47
ilrglen's Avatar
ilrglen ilrglen is offline
 
Join Date: Jun 2008
Real name: Glen Kohut
Originally Posted by Lynne View Post
Open the page outside of the frame and then when you click Save, the URL with change and you can see where it is going.
So it's looking for /template.php?do=updatetemplate
Reply With Quote
  #13  
Old 22 Jun 2016, 16:21
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
And that is correct.

You really need to talk to your host because I would guess suhosin or mod_security is causing the issue.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #14  
Old 30 Jun 2016, 04:27
ilrglen's Avatar
ilrglen ilrglen is offline
 
Join Date: Jun 2008
Real name: Glen Kohut
Originally Posted by Lynne View Post
And that is correct.

You really need to talk to your host because I would guess suhosin or mod_security is causing the issue.
Thank you. That's what I needed to know. They have told me that there was some new security installed and we are sorting in out together. Thanks for your help.
Reply With Quote
  #15  
Old 04 Jul 2016, 08:35
yahsuah yahsuah is offline
 
Join Date: Jul 2005
I had exactly same problem. The hosting company installed mod_security without informing me.

I put these codes at the top of the site's root htaccess file.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 05:23.

Layout Options | Width: Wide Color: