Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Social Group Emails Details »
Social Group Emails
Mod Version: 2.0, by Farcaster (Coder) Farcaster is offline
Developer Last Online: Jun 2014 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (8 votes - 4.88 average) Installs: 55
Released: 10 Mar 2010 Last Update: Never Downloads: 161
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

This modification will allow social group owners and administrators to send an email to all members of a social group. Each usergroup can be configured to specifically allow or disallow sending to groups they created, if you would like to limit this ability to specific trusted user groups. By default, admins will also be able to send emails to members of any group, regardless of whether they created the group or not.

Note: If a social group member has elected not to receive emails from other members or is invited to a group and has not accepted yet, they will not receive emails sent using this modification.

Installation

1. Upload bitfield_socialgroupemail.xml to your forum/includes/xml directory before you install the product.
2. Use the Product Manager to import the product file product-rah_socialgroup_email.xml.
3. Use the Style Manager to find and edit your socialgroups_group template:

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Below that ADD:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Configuration:
By default, regular members, moderators, super moderators and administrators are configured to be able to send emails to their own social groups. Additionally, administrators are configured to be able to send email to any group. To change these permissions for these or any other groups:

1. In the AdminCP, goto Usergroups -> Usergroup Manager.
2. Edit the user group.
3. Find the section "Social Groups Permissions," and set the permissions for emailing as desired.

Uninstallation (IMPORTANT)
To properly uninstall this product, follow these instructions exactly:

1. Delete the file bitfield_socialgroupemail.xml from your forum/includes/xml directory.
2. Uninstall the product.

Known Issues
  • [Unconfirmed] User group settings may need to be refreshed for permissions to be correctly set. [post]

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	social_group_email.png
Views:	433
Size:	14.7 KB
ID:	113772   Click image for larger version

Name:	social_group.jpg
Views:	559
Size:	53.1 KB
ID:	113773  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Comments
  #2  
Old 10 Mar 2010, 04:38
BlackJacket's Avatar
BlackJacket BlackJacket is offline
 
Join Date: Nov 2008
Real name: V
Thanks! Tagged for later.
Reply With Quote
  #3  
Old 10 Mar 2010, 06:45
starman™ starman™ is offline
 
Join Date: Apr 2008
Thanks for the mod, however, I've followed the instructions to the letter, uploaded, imported the product and edited the template and the email option does not show up in the group tools menu. Am I missing something?
Reply With Quote
  #4  
Old 10 Mar 2010, 06:52
Farcaster Farcaster is offline
 
Join Date: Dec 2005
Real name: Robert Howard
Originally Posted by starman™ View Post
Thanks for the mod, however, I've followed the instructions to the letter, uploaded, imported the product and edited the template and the email option does not show up in the group tools menu. Am I missing something?
Check the settings for the Administrators user group (as well as others) and make sure that under the Group permissions section, the options for "Can Send Mass Email to Own Groups" and "Can Send Mass Email to Any Group" are selected as "Yes." For other groups, set as appropriate.
Reply With Quote
  #5  
Old 10 Mar 2010, 07:22
starman™ starman™ is offline
 
Join Date: Apr 2008
Set by default
Reply With Quote
  #6  
Old 10 Mar 2010, 07:50
Farcaster Farcaster is offline
 
Join Date: Dec 2005
Real name: Robert Howard
Originally Posted by starman™ View Post
Set by default
Hmm.. Grab one of your group ID's and try directly going to the following address. Replace the domain with your own forum path, and replace the ### with a known good group ID. Let me know what the results are.

http://YOURDOMAIN.COM/sendmessage.ph...il&groupid=###
Reply With Quote
  #7  
Old 10 Mar 2010, 08:03
starman™ starman™ is offline
 
Join Date: Apr 2008
No need for that. I went to group permissions and set "Can Send Mass Email to Own Groups" and "Can Send Mass Email to Any Group" to "No." I then saved it. I went back in and changed to "Yes" and saved it and now it works.

It seems there is a small error during installation of the bitfield, but I'm just happy to have it working now. Thanks for a really necessary product.
Reply With Quote
  #8  
Old 10 Mar 2010, 16:49
Farcaster Farcaster is offline
 
Join Date: Dec 2005
Real name: Robert Howard
Originally Posted by starman™ View Post
No need for that. I went to group permissions and set "Can Send Mass Email to Own Groups" and "Can Send Mass Email to Any Group" to "No." I then saved it. I went back in and changed to "Yes" and saved it and now it works.
Did anyone else have this problem?
Reply With Quote
  #9  
Old 10 Mar 2010, 23:27
Jabong82 Jabong82 is offline
 
Join Date: Feb 2010
I had this same issue too.

I had to set permissions to no, set it back to yes, and then the email option showed up for me in the groups.

Great mod anyway installed thank you!
Reply With Quote
  #10  
Old 10 Mar 2010, 23:35
Jabong82 Jabong82 is offline
 
Join Date: Feb 2010
Oh I have a quick question. I just tested this in one o f my groups, and after I submit the message it says "You have successfully emailed 0 members". And then the no one receives the email. Isn't this just supposed to automatically email everyone in the group?

That being said, I didn't see an option to pick who to send the email to so I'm kinda lost here. Any help would be appreciated.
Reply With Quote
  #11  
Old 11 Mar 2010, 04:07
Farcaster Farcaster is offline
 
Join Date: Dec 2005
Real name: Robert Howard
Originally Posted by Jabong82 View Post
Oh I have a quick question. I just tested this in one o f my groups, and after I submit the message it says "You have successfully emailed 0 members". And then the no one receives the email. Isn't this just supposed to automatically email everyone in the group?

That being said, I didn't see an option to pick who to send the email to so I'm kinda lost here. Any help would be appreciated.
If the members are set to not receive email from other members, it won't send them an email at all. Check that out and see if that is it.
Reply With Quote
  #12  
Old 11 Mar 2010, 05:39
Jabong82 Jabong82 is offline
 
Join Date: Feb 2010
Ah yah that was it. Quick question, do you know what this is? In the social group email it gives the option to use a "form" in the email as well as provides the actual email address. But my form just comes out as /sendmessage.php yada yada. Am I supposed to set this somewhere? Thanks in advance.


=========================================
To email XXXXX, you can use this online form:
/sendmessage.php?do=mailmember&u=1

OR, by email:
mailto:[email protected]

This is the message:

Test Email.
Reply With Quote
  #13  
Old 13 Mar 2010, 18:14
AzzidReign's Avatar
AzzidReign AzzidReign is offline
 
Join Date: Apr 2006
Thank you.
__________________
Xbox 360 Mods
Reply With Quote
  #14  
Old 20 May 2010, 02:28
daggz daggz is offline
 
Join Date: Aug 2008
Same issue on install as http://www.vbulletin.org/forum/showp...29&postcount=7

Otherwise great addon. Good work
Reply With Quote
  #15  
Old 06 Jul 2010, 20:52
Xencored Xencored is offline
 
Join Date: Sep 2008
Real name: Mike
Thanks man awesome stuff
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 18:32.

Layout Options | Width: Wide Color: