Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 01 Jul 2015, 09:50
SerenaS SerenaS is offline
 
Join Date: Jun 2015
Issues with 'New user' and 'send email to user' 4.2.2 PL 4

Hi there,

I upgraded to 4.2.2 PL 4 a couple of weeks ago and have tried to send a monthly update to active members (using the same settings).

I ran a test email and all went well. I then ran the actual 'send email to users' and it seemed to go without any problem. However, we haven’t received a copy of the update and the email normally generates a lot of bouncebacks, automatic out-of-office responses as well as genuine responses from our members.

However, have seen a small trickle of responses from members with older user numbers, so it seems that the email is either being sent/received gradually or has stopped halfway through. We've also not received a 'new user' email since yesterday morning.

The hosting company are saying that emails are working, our mail servers seem okay, so I'm wondering if the upgrade to 4.2.2 has thrown up some other issues that I need to look into? Have I missed something?

Thanks,
Reply With Quote
  #2  
Old 01 Jul 2015, 12:34
kh99 kh99 is offline
 
Join Date: Aug 2009
Real name: Kevin
On the admincp home, in the box with the stats, do you see "Number of Queued Emails" (it should be at the bottom of the right column)? It could be that your emails are queued and being sent gradually, as you guessed. If you have queued emails, you can control how fast they're being sent by setting "Number of Emails to Send Per Batch" in the Email Options. If "Use Cron Based Sending" is set to yes, they are sent every 10 minutes, so you can control how many you're sending per hour (approximately) by setting "Number of Emails to Send Per Batch" to 1/6 that amount.

The "Use Cron Based Sending" was added at some point (maybe in 4.2.2, I don't remember), so that's probably why you started having the issue after the upgrade.
Reply With Quote
  #3  
Old 01 Jul 2015, 13:37
SerenaS SerenaS is offline
 
Join Date: Jun 2015
Bingo, kh99 - there are a fair few emails queued.

It looks like cron based sending is set to yes and the limit was pretty low, so I'm going to try to increase the limit and see if it eases things.

I'm loath to turn cron based sending off, in case it overwhelms the system - is that sensible thinking, or am I being too cautious?
Reply With Quote
  #4  
Old 01 Jul 2015, 13:52
kh99 kh99 is offline
 
Join Date: Aug 2009
Real name: Kevin
Well, I think you defintely want to leave "Use Mailqueue System" set to yes. You *could* turn off cron based sending, in which case you'd be going back to the way it worked before (which has obviously worked well enough for you in the past). (that's wrong - see post below). The cron based sending was originally a mod that got added into the product. In fact the mod page is here: http://www.vbulletin.org/forum/showthread.php?t=231715 so you can read about what it's supposed to do for you (in a nutshell, it allows you better control over how many emails get sent per hour, which can be important if you do mass mailing and/or your host has a limit on emails per hour).

In any case, if you decide to turn off cron based sending, you should set the batch size back to what it was.

Last edited by kh99; 01 Jul 2015 at 14:28.
Reply With Quote
  #5  
Old 01 Jul 2015, 14:15
SerenaS SerenaS is offline
 
Join Date: Jun 2015
Thanks, that's really helpful.
Reply With Quote
  #6  
Old 01 Jul 2015, 14:21
kh99 kh99 is offline
 
Join Date: Aug 2009
Real name: Kevin
Yeah, I just read it myself and learned that another thing it does is queue the mails sent from the admincp, so I guess previously your mass emailings weren't being queued. So that means I was wrong, turning off cron based sending won't put you back to the way it was previously. If you do turn it off, you still might have to adjust the batch size to get them sent faster.

Last edited by kh99; 01 Jul 2015 at 14:28.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 11:17.

Layout Options | Width: Wide Color: