Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 19 Oct 2006, 00:29
dchan dchan is offline
 
Join Date: May 2006
Bug found WOL problem caused by activity.php

Hi all,

In the process of troubleshooting a problem with our vbulletin installation, we found a problem with an external file that was causing our problem.

I have checked with our web designer who installed a modification that included a file called activity.php

I'm not sure he can remember exactly which mod included it and if it was supported after we began doing upgrades I suspect it was installed while we were still on VB 3.5.x We are currently on 3.6.2

The symptom was that every time the "most users online" record was broken the system would reset our counters to "1" and the date would be set to 1969 or 1970 depending on version of software.

We could reset the counter by running a query to reset the counter but the symptom kept coming back.

After working with the VB Dev group we found this line in the activity.php

build_datastore('maxloggedin', serialize($vbulletin->maxloggedin));

that was causing the problem. Correcting the syntax to

build_datastore('maxloggedin', serialize($vbulletin->maxloggedin), 1);

This did resolve the issue.

I also found the same info in "error" in try.php and am not sure where this file was used.

Hope that helps either the developers or users that might have noticed this symptom.

Thanks goes to the VB Dev team for helping me find and fix the problem on our forum and

Thanks to all you developers that keep coming up with these great mods..


Me, I'm just a hack trying to keep my forum running smooth..

DC
Reply With Quote
  #2  
Old 19 Oct 2006, 01:51
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Yes, this is a little known change between vb 3.5 and 3.6 - it's well known to me because it affected a couple of my released modifications.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #3  
Old 04 Nov 2006, 21:08
newbe_haselina newbe_haselina is offline
 
Join Date: May 2006
Hi to all,
I'm working on this issue for hours ... and I can't get it fixed :cross-eyed:

I have a lot of non-vb files and files that seems to belong to 3.6.1 and not to 3.6.2 ... I'm totaly confused and I really don't know what to do further.

I deactiveted all my plugins, but the issue still stays on.

I ran the sql query several times ... but the counter keeps on showing 1 max user since 1.1.1970 after a refresh ...

can anybody help me? I think I'm slightly going mad ... :alien:
Reply With Quote
  #4  
Old 04 Nov 2006, 22:37
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
What sql query did you run ?
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #5  
Old 05 Nov 2006, 07:04
newbe_haselina newbe_haselina is offline
 
Join Date: May 2006
Hi Paul,

thanks for the answer

For my unexperience the owner of the webspace and database told me, that we use 4.0.23. But I don't know where I can look it up?!

I looked up the table in the database and its kind of funny what is writte in there.

s:965:"1:956:"1:947:"1:938:"1:929:"1:920:"1:911:"1:902:"1:893:"1:884:"1:875:"1:8 66:"1:857:"1:848:"1:839:"< very long line removed>
It another post I found something totaly different to be written in there.

I'm appreciate your help.
Kind regards,
sabine

Last edited by Paul M; 06 Nov 2006 at 16:33.
Reply With Quote
  #6  
Old 05 Nov 2006, 07:20
newbe_haselina newbe_haselina is offline
 
Join Date: May 2006
Another thing, that might has something to do with the issue ... When I look at the stats, it seems that the numbers of the online user per day are gone. (please see screenshot). I don't know if this is because of the same problem, but it might be?

Kind regards,
sabine
Attached Images
File Type: jpg useronline_stat.jpg (63.3 KB, 13 views)
Reply With Quote
  #7  
Old 05 Nov 2006, 11:53
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by newbe_haselina
For my unexperience the owner of the webspace and database told me, that we use 4.0.23.
I don't think you understood the question - in your previous post you said ;

Originally Posted by newbe_haselina
I ran the sql query several times ...
I asked what query you ran, not what version of mysql you have.

Originally Posted by newbe_haselina
I looked up the table in the database and its kind of funny what is writte in there.
That looks messed up anyway, all those numbers should not be at the start.

Run this sql query to reset it all ;


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #8  
Old 05 Nov 2006, 13:05
newbe_haselina newbe_haselina is offline
 
Join Date: May 2006
Hi Paul,

sorry for getting you wrong ... *embarrassed* ... it's hard for me to talk about things in a foreign language I don't even understand in my native language :alien:

I run the following sql queries:

update datastore set unserialize = 1 where title = 'maxloggedin'

update datastore set unserialize = 1,data = ' ' where title = 'maxloggedin'
Excatly the same you told me to try.

The following happend.

1) Run your quere and the database table was empty. The online counter on my board was correct.

2.) Did a refresh, the counter changed to 1, and thats what is in the DB-table
s:61:"1:2:{s:9:"maxonline";i:22;s:13:"maxonlinedate";i:1162731274;}";
3.) refresh again
s:69:"1:61:"1:2:{s:9:"maxonline";i:22;s:13:"maxonlinedate";i:1162731274;}";";
4.) refresh again
s:85:"1:77:"1:69:"1:61:"1:2:{s:9:"maxonline";i:22;s:13:"maxonlinedate";i:1162731 274;}";";";";
It keeps up being messy again ... I guess even without refreshing the browser.

Any further ideas?
Reply With Quote
  #9  
Old 05 Nov 2006, 22:19
Kidswap Kidswap is offline
 
Join Date: Feb 2005
I'm having the same problem, and I'd love to hear a solution.
Reply With Quote
  #10  
Old 05 Nov 2006, 22:40
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by newbe_haselina
It keeps up being messy again ... I guess even without refreshing the browser.

Any further ideas?
You have a modification somewhere on your site that is screwing it up. You need to find it - and disable or fix it.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #11  
Old 06 Nov 2006, 05:41
newbe_haselina newbe_haselina is offline
 
Join Date: May 2006
Good morning Paul,

I already disabled every hack I find in admincp ... but it keeps coming up :cross-eyed: Is it possible that it is a modification I ran earlier, but did not remove all the files concerning to the mod?

Somebody told me to delete every non-vb file I find in admincp ... but that would mean, that I probably can't run any hack?? That would be "impossible", because I have a community for young people and they love those hacks I find especially here on this site


@Kidswap: As I can see, there are a lot of users having this issue ... it MUST be because of a mod, but I can't figure out which one ...

Thanks Paul for your support, it's really appreciated
Reply With Quote
  #12  
Old 06 Nov 2006, 14:01
jailer jailer is offline
 
Join Date: Jun 2006
Paul,

Cheers for the help (and a wave from cableforum from me )

haselina, I'm Bloke off Vbulletin.

I've posted here: http://www.vbulletin.org/forum/showthread.php?t=130907 about this. The only thing I have installed now is VBAdvanced.
Everything else is uninstalled, so I guess it can only be this?
Seeing this prob pop up a lot lately for people.
Reply With Quote
  #13  
Old 06 Nov 2006, 16:30
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by newbe_haselina
Somebody told me to delete every non-vb file I find in admincp ...
Hmm, not particularly useful advice.

What you need to do is download all your non standard files and scan them for code relating to 'maxloggedin'.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #14  
Old 06 Nov 2006, 17:12
Kidswap Kidswap is offline
 
Join Date: Feb 2005
I had vbadvanced too, and I uninstalled it along with ever other hack I had run recently.

I ran a check on every file that called 'maxloggedin':

index.php
online.php
global.php
stats.php
class_core.php
functions_legacy.php
onlineusers.php

I'm unsure whether any of them are 'wrong' or what exactly is going on.
Reply With Quote
  #15  
Old 07 Nov 2006, 05:18
newbe_haselina newbe_haselina is offline
 
Join Date: May 2006
[QUOTE=Paul M]Hmm, not particularly useful advice.

QUOTE]

Good morning Paul,
*smile
... that's what I thought

I will do as you supposed this evening, hopefully I will find something.

Another thing I mentioned when I'm looking for non-vb-files ... there are a lot of files named "found 3.6.1, expexted 3.6.2" (sorry for the worse translation)
Does this have something to do with the issue? Can't believe it, because I had the issue earlier, bevor updrading to 3.6.2.

@*wavetojailor* ... nice meeting you here
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:06.

Layout Options | Width: Wide Color: