Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
How to get blogs in new posts search Details »
How to get blogs in new posts search
Mod Version: 1.00, by optrex (Member) optrex is offline
Developer Last Online: Mar 2011 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.7.5 Rating: (1 vote - 5.00 average) Installs: 21
Released: 20 Mar 2008 Last Update: Never Downloads: 8
Not Supported Is in Beta Stage  

Many people are concerned over the lack of integration of the blog system with the main forum software. I see many posts asking "how do I get my blogs to show up in new posts?"

Basically you need to utilise the blog RSS feed and get it to post a blog as a post.

This is how to do it.

From your admincp - RSS Feed Manager
Add a new RSS Feed
Feed enabled: Yes
URL of feed: http://www.yoursite.com/blogs/feed.rss
Check every: 30 mins
Feeds to fetch: 0
Username: choose or make a new one - blog bot or something
Forum: chose an existing one or make a new forum and select options as you see fit, or see below.
Allow Smilies: yes
Display Signature: no
convert html to bb code: yes


Title template: {rss:title}
Body template:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

In the next sections, pick what you want but also make sure you do the following
Thread action delay 1
Close thread after delay: yes

Making a new forum
When making a new forum for your blog posts, chose the setting your want for other users, but make sure of the following:

Act as forum: yes
Index New Posts in Search Engine: yes
Forum is open: yes

You can chose whether the forum is hidden or visible, but make sure the username you specified above is in a group that can post to this forum.

Permissions

I didn't want others to post so they have no post permissions. To get to the blog, they click on the link in the post and get taken there directly. To be able to see the posts they must have.

Can View Forum: yes
Can View Thread Content: yes
Can View Others' Threads: yes
Can Search Forums: yes


A working version is at www.midlandsweather.org.uk
My blog forum (so that you can see an example of the posts made is at www.midlandsweather.org.uk/mwf-blog


Please click ***install*** if you use this.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Show Thread Enhancements AME 2.0 -Auto Media Embedding for posts, blogs, visitor and group messsages The Geek vBulletin 3.7 Add-ons 954 25 May 2014 10:58
vBulletin Blog New Blogs/Comments in Forum Search Results dartho vBulletin 3.7 Add-ons 113 08 Nov 2009 06:24

  #31  
Old 03 Dec 2008, 18:56
Problemsolver Problemsolver is offline
 
Join Date: Dec 2008
Great stuff! Works perfectly (3.7.4)
Reply With Quote
  #32  
Old 03 Dec 2008, 19:00
Problemsolver Problemsolver is offline
 
Join Date: Dec 2008
Wait a second, it shows the full post without letting you know who made the post or actually taking you to the blogpost itself :S?

Isnt there possible to get the robot to post a redirect (if you allow it to use html)?
Reply With Quote
  #33  
Old 04 Dec 2008, 15:32
wrang wrang is offline
 
Join Date: Nov 2004
Real name: Christian
What is it problem when this came up?
Nytt blogg inlägg XML-fel: not well-formed (invalid token) på rad 483
Reply With Quote
  #34  
Old 15 Dec 2008, 17:27
breakice breakice is offline
 
Join Date: Nov 2008
nice
Reply With Quote
  #35  
Old 15 Dec 2008, 17:41
breakice breakice is offline
 
Join Date: Nov 2008
but how it will work on vbadvanced
what module i have to add so it can show it on my vbadvanced
Reply With Quote
  #36  
Old 20 Jan 2009, 09:35
optrex optrex is offline
 
Join Date: Sep 2005
It comes into vbadvanced automatically on the recent threads module. No further work is needed.
Reply With Quote
  #37  
Old 27 Jan 2009, 19:12
hotwheels hotwheels is offline
 
Join Date: May 2005
Real name: Doug
Has anyone been able to get this to work on vbulletin 3.8? I really liked this set up, since it would make a new post, and then members could go to the blog. I am not good with rss and this just quit working out of the blue........any help would be greatly appreciated.
Reply With Quote
  #38  
Old 28 Jan 2009, 10:34
optrex optrex is offline
 
Join Date: Sep 2005
Works fine with 3.8.0. Instructions are exactly the same. As its picking up RSS it should be fairly future proof to be honest.
Reply With Quote
  #39  
Old 28 Jan 2009, 16:02
hotwheels hotwheels is offline
 
Join Date: May 2005
Real name: Doug
shoot, it just isn't working on my site........wierd.
Reply With Quote
  #40  
Old 02 Feb 2009, 15:18
hotwheels hotwheels is offline
 
Join Date: May 2005
Real name: Doug
Okay, i have it working somewhat. Right now, i have the setting set how they are described in the instructions, but it is only updating posts that i post in my blog. It ISN'T placing other blogs into the forums.

What am i missing?

Title: Insane Blogs

URL of Feed: http://www.mysite.com/forums/blog_external.php

User Name: DugDug (this is my site bot)

Title Template: {rss:title}

Body Template: {rss:content:encoded}
Click here to be taken to {rss:dc:creator}s Blog...
Insanemustangs

Thread Action Delay: 1

Close Thread After Delay: Yes

These are my settings, and i don't have an actual blog forum set up, i have them going to a very busy forum. Do i need to make a blog forum for this to work corretly? If so, i still don't understand how come the bot isn't posting other users blogs....?
Reply With Quote
  #41  
Old 05 Feb 2009, 02:08
optrex optrex is offline
 
Join Date: Sep 2005
Have you checked your blog RSS feed? To me it is only showing your blog posts, so the mod is working correctly. RSS feeds display what guests see, so make sure your permissions are correct for unregistered users
Reply With Quote
  #42  
Old 05 Feb 2009, 02:43
hotwheels hotwheels is offline
 
Join Date: May 2005
Real name: Doug
I have the guest permission set.....It works for my powertv channel. If someone posts a video, it will start a new thread with a link to the video and the usersname.

The blog mod for rssfeed, is only showing my blogs. When i have a user start a blog, that users blog isn't updating to the forum i selected.
Reply With Quote
  #43  
Old 05 Feb 2009, 23:10
optrex optrex is offline
 
Join Date: Sep 2005
The problem is it will only refect what is in your blog RSS, so you need to sort that out first for this mod to work for you.

http://www.insanemustangs.com/forums....php?type=RSS2 Your feed
which is a reflection of your blog page
http://www.insanemustangs.com/forums/blog.php?do=list

looking at both of them, it looks like no-one else has made a blog post. Have you got new blogs sitting in the moderation queue?
Reply With Quote
  #44  
Old 05 Feb 2009, 23:21
optrex optrex is offline
 
Join Date: Sep 2005
Just logged into your site - its a permissions issue. You need to look at your guest access
Reply With Quote
  #45  
Old 06 Feb 2009, 14:25
hotwheels hotwheels is offline
 
Join Date: May 2005
Real name: Doug
Thanks for looking at it.

Okay, here are my current settings:

Can View Forum
Yes

Can View Thread Content
Yes

Can View Others' Threads
Yes

Can Search Forums
Yes

Can View Calendar
Yes

Can View Others' Events
Yes

Can View Member Info
Yes

Can View Others' Profile Pictures
Yes

Can View Albums: Users without this permission will still be able to see picture in public and profile album if they know the exact URL.
Yes

This Usergroup is not a 'Banned' Group: (Setting this to no will cause the group to be treated as a banned group, this will prevent the sending of email notifications, show a banned error message on the permission error pages and other unspecified behaviors.)
Yes

Can View Social Groups
Yes

Can this usergroup view the vBPicGallery?
Yes

Can View Other's Blog
Yes

Can Search Blogs
Yes

Can View Attachments
Yes

That is everything i have set to yet in the unregistered usergroup.......As far as i can tell, that is everything. If you look at yours in the admincp, what do you have set different? I am at a total loss on what is missing here......Like i say, if i post a blog it will show in the forums, but if another member does, it won't show up.....
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:37.

Layout Options | Width: Wide Color: