Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vBTube LE 2.1.1 Media Library UPDATE vBulletin 4.2.x Details »
vBTube LE 2.1.1 Media Library UPDATE vBulletin 4.2.x
Mod Version: 2.1.1 Patc, by muratmunich (Coder) muratmunich is offline
Developer Last Online: Dec 2020 I like it Show Printable Version Email this Page

vB Version: 4.2.x Rating: (34 votes - 4.44 average) Installs: 186
Released: 10 Mar 2012 Last Update: 20 Nov 2012 Downloads: 1699
Not Supported  

vBTube.com is proud to present vBTube LE (Lite Edition)


vBTube LE Demo


What is vBTube ?
vBTube Media Gallery - Professional Video CMS for your vBulletin4 Community.
vBTube is the ultimate video sharing script for starting your own YouTube

Features

Embed Videos from:
YouTube, Dailymotion, MetaCafe, Veoh, Google Video, MySpace, MyVideo, Sevenload, Vidmax, Vimeo, Funnyordie.com, Izlesene

Installation / Default

Install Instructions (Comments are stored in a seperate DB Table):

Watch this video installation tutorial:
http://www.vbtube.com/videos/3/vbtube-install.html

1. Upload Contents of "Upload to Forums Root" Folder to Forums Root
2. Chmod 777 following Folders
/vbtube/tmp
/vbtube/upload/thumb_link

3. Import vBTubePRO_v2.0_LE vBx XML File with Product Manager
4. Enter Forum Path at admincp/vBTubePRO/options -> Forum Path
For Example mine here is : /var/srv/www/httpdocs/forum/

If you don't know your relative path go to:

admincp/maintance/view php info
and ook for:
_SERVER["DOCUMENT_ROOT"] /var/srv/www/httpdocs/forum

Don't forget to enter the trailling slash!

5. Click vbtube-db-check (admincp/vbtubepro/vbtube-db-check). Be sure all files are uploaded before
6. Set Permission Settings for each Usergroup. Edit the options however you like
7. Now you can add your Categories.

Admincp/vBTubePRO/Add Category

- Category Name
- Display Number (Start with 10, 100, 200, 300, 400...)

Finished: yourdomain.com/vbtube.php
_____________________________________________________________________

Installation / Comments are mixed up in vBulletin Posts

There are 2 ways to use vBTube.
This instruction will show you how to install vBTubePRO mixing the comments in your forum.

This means exactly: When adding videos, vBTube will create threads. When commenting videos, vBTube will create posts to that video thread.

Install Instructions:

Watch this video installation tutorial:
http://www.vbtube.com/videos/2/vbtube-install-mix.html

1. Upload Contents of "Upload to Forums Root" Folder to Forums Root
2. Chmod 777 following Folders
/vbtube/tmp
/vbtube/upload/thumb_link

3. Import vBTubePRO_v2.0_LE vBx XML File with Product Manager
4. Enter Forum Path at admincp/vBTubePRO/options -> Forum Path
For Example mine here is : /var/srv/www/httpdocs/forum/

If you don't know your relative path go to:

admincp/maintance/view php info
and ook for:
_SERVER["DOCUMENT_ROOT"] /var/srv/www/httpdocs/forum

Don't forget to enter the trailling slash!

5. Click vbtube-db-check (admincp/vbtubepro/vbtube-db-check). Be sure all files are uploaded before
6. Now, add a new Forum -> "Forums & Moderators" -> "Add new Forum"
Type "0" for the Display Order. So it is not visible in your forums list.

You got the option to add more Forums for Comments but it's highly recommended to use only 1 Forum for Comments !
We are supporting only the using of 1 ForumID. This means: Add only 1 ForumID to your categories... (You will see this step when adding categories).

7. Now we need the ForumID of the new added Forum for Comments.
Enter the ForumID here:
admincp/vbtubepro/Options/Latest vbTubePRO Postings/Comments ForumID

8. Set Permission Settings for each Usergroup. Edit the options however you like
9. Now you can add your Categories.

Admincp/vBTubePRO/Add Category

- Category Name
- Display Number (Start with 10, 100, 200, 300, 400...)

Finished: yourdomain.com/vbtube.php

LE v2.1

1. vBulletin 4.2.x compatible
2. Navigation Tab added to Navigation Manager
3. Mobile Style Bug
4. Background Color Admin Menu fixed
5. MyISAM Product XML included for newer MySQL Versions

Update Instructions:

1. Upload all Files (Content of Upload to Forums Root) to your Forum Root. Close your Board
2. Import vBTubePRO_v2.x.xml Product with vBulletin's Product Manager - Select Overwrite
3. Run DBCheck : admincp/vbtubepro/vbTubePRO DB-Check
4. Option to set Style for vbtube
5. Open your Board

If you like vBTube please click on installed and donate, Thank you.

v2.1 Patched:

This Update is for users who have warning error messages like this:
Warning: trim() expects parameter 1 to be string, array given in [path]/vbtube_add.php on line 139

Download the patched zip file and upload only vbtube_add.php (overwrite old file).

v2.1.1:

Facebook bug fixed
Keywords Array Warning fixed

Thanks

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #181  
Old 17 Jul 2012, 00:45
andyv72 andyv72 is offline
 
Join Date: Feb 2008
hi..

Cant install XML

Error:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Can anyone Help ??
Reply With Quote
  #182  
Old 04 Aug 2012, 17:40
Toorak Times's Avatar
Toorak Times Toorak Times is offline
 
Join Date: Jan 2011
Bunny! Looping Slideshow with mp3

Hi, Loving this mod! Added a track to a slideshow. May have done it wrong, added track to first pic. Got this anyway.

a. http://www.tooraktimes.com.au/media/...ng-Dong-Lounge

Cheers

Mick

edit: Can anyone help?

Last edited by Toorak Times; 12 Aug 2012 at 14:15.
Reply With Quote
  #183  
Old 08 Aug 2012, 20:58
Elenna Elenna is offline
 
Join Date: Jan 2006
Location: St. Charles, MO
Real name: Dana
I just installed on 4.2, and had the same issue with the overlapping menus.

I disabled the Menu plugin, but it still did it on my manually-created button.

So I went into vBTube Option, turns OFF "Tabs Menu" and turned ON "Usermenu". Then I could delete my manually-created button (do NOT disable the Menu plugin).

All is well.
Reply With Quote
  #184  
Old 08 Aug 2012, 21:19
Elenna Elenna is offline
 
Join Date: Jan 2006
Location: St. Charles, MO
Real name: Dana
I'm getting the following errors when trying to view a video:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I am also having the same issue. Video uploads just fine, plays just fine, etc.

The template edit to headinclude didn't fix it:
Change
<vb:if condition="$show['fb_opengraph']">
to
<vb:if condition="$show['fb_opengraph'] AND THIS_SCRIPT != 'vbtube'">
Reply With Quote
  #185  
Old 09 Aug 2012, 01:43
Elenna Elenna is offline
 
Join Date: Jan 2006
Location: St. Charles, MO
Real name: Dana
Strange, I enabled .htaccess re-write mode and then disabled it, and the error messages went away.
Reply With Quote
  #186  
Old 11 Aug 2012, 00:11
Fongool Fongool is offline
 
Join Date: Jan 2011
I'm getting the same error as Andy:
(I removed my Dbname and My IP from the error)
Can anyone help with this? I get this after uploading the files, chmodding the 2 folders to 777...then when I try to import the .xml file in the admin panel, I get the following error:

Database error in vBulletin 4.2.0:

Invalid SQL:

CREATE TABLE IF NOT EXISTS `vbtube_tubes` (
`tubeid` int(20) unsigned NOT NULL auto_increment,
`categoryid` int(3) unsigned NOT NULL default '0',
`forumid` int(10) unsigned NOT NULL default '0',
`userid` int(20) unsigned NOT NULL default '0',
`username` varchar(70) NOT NULL default '',
`email` varchar(70) NOT NULL default '',
`title` mediumtext,
`vidlang` varchar(50) NOT NULL default '',
`link` varchar(170) NOT NULL default '',
`link1` longtext NOT NULL,
`link2` longtext NOT NULL,
`link3` longtext NOT NULL,
`link1img` varchar(250) NOT NULL default '',
`thumb_type` int(1) unsigned NOT NULL default '0',
`filename` varchar(30) NOT NULL default '',
`mext` varchar(6) NOT NULL default '',
`msize` int(20) unsigned NOT NULL,
`filename_mp4` varchar(30) NOT NULL default '',
`filename_img` varchar(30) NOT NULL default '',
`filename_img2` varchar(30) NOT NULL default '',
`photo_mp3` varchar(30) NOT NULL default '',
`url_flv` varchar(150) NOT NULL default '',
`ofilename` varchar(20) NOT NULL default '',
`oext` varchar(6) NOT NULL default '',
`osize` int(20) unsigned NOT NULL,
`mediatype` varchar(50) NOT NULL default '',
`site` varchar(50) NOT NULL default '',
`aboutme` longtext,
`active` varchar(1) NOT NULL default '0',
`tube` varchar(50) NOT NULL default '',
`views` int(30) unsigned NOT NULL default '0',
`votes` int(10) unsigned NOT NULL default '0',
`rates` int(10) unsigned NOT NULL default '0',
`rating` double(5,2) unsigned NOT NULL default '0.00',
`duration` varchar(15) NOT NULL default '',
`keywords` varchar(250) NOT NULL default '',
`joindate` int(10) unsigned NOT NULL default '0',
`reviewid` int(10) unsigned NOT NULL default '0',
`positive` int(10) unsigned NOT NULL default '0',
`negative` int(10) unsigned NOT NULL default '0',
`reported` varchar(1) NOT NULL default '0',
`reporteruser` varchar(50) NOT NULL default '',
`reportreason` mediumtext,
`reportcategory` varchar(50) NOT NULL default '',
`lastpost` int(10) unsigned NOT NULL default '0',
`lastposter` int(10) unsigned NOT NULL default '0',
`totalcom` int(8) unsigned NOT NULL default '0',
`deleted` int(1) unsigned NOT NULL default '0',
PRIMARY KEY (`tubeid`)
) TYPE=MyISAM;

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 51
Error Number : 1064
Request Date : Friday, August 10th 2012 @ 07:08:27 PM
Error Date : Friday, August 10th 2012 @ 07:08:28 PM
Script :
Referrer :
IP Address :
Username :
Classname : vB_Database
MySQL Version : 5.5.23-55
Reply With Quote
  #187  
Old 11 Aug 2012, 21:12
Elenna Elenna is offline
 
Join Date: Jan 2006
Location: St. Charles, MO
Real name: Dana
From a different thread, I found this that might solve the issue?
http://www.vbulletin.org/forum/showp...postcount=1912

In the install XML file:

Find

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #188  
Old 12 Aug 2012, 08:59
extremeseo's Avatar
extremeseo extremeseo is offline
 
Join Date: Aug 2009
Real name: Nimalan
How to buy pro version ?
Reply With Quote
  #189  
Old 12 Aug 2012, 13:55
Fongool Fongool is offline
 
Join Date: Jan 2011
Talking

I was having the same trouble with Spam-O-Matic also...I tried what you posted and it worked perfectly!...Thank you so much...
(Edit)...I think I spoke too soon...LOL...It does work, and shows up as the "Media" tab on the forum...BUT, when I click on the Media tab, it gives me this:

you do not have permission to access this page. This could be due to one of several reasons:

1) Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
2) If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.

and I am the Administrator...I went through all the permissions, and there are no permissions for this....I'm going to keep looking...LOL...


F

Originally Posted by Elenna View Post
From a different thread, I found this that might solve the issue?
http://www.vbulletin.org/forum/showp...postcount=1912

In the install XML file:

Find

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Last edited by Fongool; 12 Aug 2012 at 14:30.
Reply With Quote
  #190  
Old 12 Aug 2012, 14:47
Elenna Elenna is offline
 
Join Date: Jan 2006
Location: St. Charles, MO
Real name: Dana
There are permissions for this on the Usergroups, for me it's the last item in the list. Make sure you give yourself (or your Admin usergroup) FULL permissions (YES to everything in the vB Tube section). I missed one, and it gave me the same error message.
Reply With Quote
  #191  
Old 12 Aug 2012, 16:30
legiondadon legiondadon is offline
 
Join Date: Aug 2012
i cant get rid of the automatic tab this mod creates even when i disable it in the admincp i would like to use the vbulletin's tab system instead of the auto tab...
Reply With Quote
  #192  
Old 12 Aug 2012, 16:54
Fongool Fongool is offline
 
Join Date: Jan 2011
Talking

Originally Posted by Elenna View Post
There are permissions for this on the Usergroups, for me it's the last item in the list. Make sure you give yourself (or your Admin usergroup) FULL permissions (YES to everything in the vB Tube section). I missed one, and it gave me the same error message.
Once again, thank you...I missed the permissions....Got them all...Now to just fix the overlapping text in the links above...Thank you again...Oh, and what if regular users want to post a video, or look at video's...Will they get the same error message, or will they be able to view them without admin permissions?

F
Reply With Quote
  #193  
Old 13 Aug 2012, 00:02
Elenna Elenna is offline
 
Join Date: Jan 2006
Location: St. Charles, MO
Real name: Dana
@Legion - In the AdminCP, go to the vBTube Options and choose "Use Tab Menu - NO", and "Usermenu - YES". That should add one "Media" button but NOT make the weird overlapping stuff happen.

@Fongool - You're welcome! You'll need to set permissions for ALL of your usergroups that you want to use it. By default it's turned OFF for all of them. If you only want someone to VIEW, give them the first permission in the group. If you want them to view and upload, give them the first and second ones. For the groups you want to be able to comment on the videos, change the second to last one ("Can Comment").
Reply With Quote
  #194  
Old 13 Aug 2012, 04:51
legiondadon legiondadon is offline
 
Join Date: Aug 2012
Elenna, is there anyway to disable the button all together...because using the vbulletin system i can go and add those links under the tab and it works fine...but cant seem to get rid of the button
Reply With Quote
  #195  
Old 13 Aug 2012, 14:09
Elenna Elenna is offline
 
Join Date: Jan 2006
Location: St. Charles, MO
Real name: Dana
I don't know, actually. I was never able to get the menu to work by creating it with the Navigation Manager. Someone else mentioned going into the Plugins and disabling the Menu one, but it still showed up on my board.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 15:27.

Layout Options | Width: Wide Color: