Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Thread Thumbnails Details »
Thread Thumbnails
Mod Version: 3.1.0, by Null Parameter (Member) Null Parameter is offline
Developer Last Online: Apr 2014 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (29 votes - 4.76 average) Installs: 243
Released: 03 Mar 2010 Last Update: 30 Apr 2010 Downloads: 1662
Not Supported DB Changes Uses Plugins Auto-Template Translations  

Thread Thumbnails
Created By: Null Parameter

The Thread Thumbnails mod allows users of a forum to specify, in several possible ways, a thumbnail for their thread to be displayed on Forumdisplay thread list.

I had created the mod for vB 3.8, but people we're crying out for a ported version to vB4, and, thanks to help from several of the members, here it is!


Description of Features

Thumbnails are displayed on the Forumdisplay next to the threadicon.
In the ACP Options, assuming you are using the Auto-Template Edits, you can choose which side of the icon to display it on.

Forum Display Screenshot


When submitting a new thread or editing the first post of a thread, a thumbnail can be specified directly if the User Entered URL option is chosen in the ACP. Another option is to Require the thumbnail. If the thumbnail isn't required, it may be left blank by the user, and it can either not be shown at all on forumdisplay or be replaced by a default thumbnail image specified in the ACP.

New Thread Screenshot

Edit Post Screenshot


All available options in the ACP include...
  • Turn Off/On Thumbnails
  • Turn Off/On Auto-Template Edits
  • Which forums to use thumbnails in
  • Turn Off/On thumbnails on sticky threads
  • Require thumbnails (doesn't work with attachment option)
  • Choose to retrieve thumbnails from one of the following
    • User Entered URL
    • First Attachment
    • First Image in Post
  • Choose where thumbnail is displayed in threadbit (relies on Auto-Template Edits)
  • Thumbnail CSS Style
  • Specify No Thumbnail Replacement Image
ACP Options Screenshot


This version is also now using phrases, so it can more easily be translated!


Installation

Install the product XML file. That's it!

If you have a highly customized style, there is a chance that the auto-template edits will not work. In that case, you will need to make the template edits manually. See the included README for more details.


Thumbnail Style

The style for thumbnails is specified in the ACP. It is used to choose exactly how thumbnails will be displayed, including width, height, margins, borders and many other attributes.

The style is specified in CSS, and is applied directly to the HTML img tag.

Here are some examples of possible thumbnail styles, along with a description of what they will do. If you don't know much about CSS, you can learn more here.
  • Every thumbnail will have a width of 100 pixels, but be constrained to being a maximum of 150 pixels in height
    • width:100px;max-height:150px;
  • Every thumbnail will have a width of 120 pixels and have a margin of 3 pixels around the thumbnail, so that it doesn't touch any of the other elements in the threadbit
    • width:120px;margin:3px;
  • Thumbnails aren't allowed to exceed 150 pixels in either dimension, and are also mildly transparent
    • max-width:150px;max-height:150px;opacity:0.8;filter:alpha(opacity=80);
Note: Using CSS positioning attributes (i.e. position, float, clear, etc.) could mess up the threadbit structure, so beware.


FAQs

The version of this mod for vB 3.8 showed thumbnails in the search results. Where did they go?
The search system between vB 3.x and vB4 changed significantly. I didn't have the time to figure out the complexity of it, and was unable to find any examples of other mods that integrated into the search results.

If you know how this is done, feel free to contact me and we can work to get this feature back in!
Does this mod work for RTL Languages, such as Arabic?
There is a separate product XML file available for download that has the appropriate changes to support RTL languages.
When I choose the First Image in Post option, no thumbnails show up in my current threads. Why?
Thumbnails are only updated when a new thread is created or when the first post is edited. Parsing through every forum/thread whenever the options are changed could be disastrous for performance.

Luckily, a user of this mod, megamoose, created a script that you can use to help this out. I want this method to be known, but because I didn't write this, I make no promises that it will work.

Originally Posted by megamoose View Post
This should enable batch processing. I have tested it.
Change the $STEP_AMOUNT at the top to something lower if you still get errors
Remember this is for vB version 3.8
Always backup your data before running scripts like these

TO THOSE WHO HAVEN'T BEEN FOLLOWING THE CONVERSATION:
This script will go through all your existing posts and give them thumbnails, based on the First IMG in post option.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Translations

Arabic

Versions

v3.1
  • Fix for Required Thumbnails
  • New feature to automatically use ALL Forums
v3.0
  • Support for vB4!
  • Use Phrases
  • Option to make Thumbnails Required
  • Option to select where to show the thumbnail on Forumdisplay
  • Option to specify the CSS Style of thumbnail images
Mod Support

I am fully willing to support this mod and continue to add new feature to it when they are desired enough to make them applicable to the product as a whole. The issue is that I do not have access to a vB4 installation, and therefore cannot develop.

Several people were gracious enough to offer up a test installation for me to use, and that is how this mod exists today. If any new features/fixes are wanted, other people will need to be just as gracious.

Also, since I don't own a vB4 instance, I'm supporting this strictly out of the kindness of my heart. So, if you wish to Support me as a developer, it would be much appreciated.

Enjoy!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	forumdisplay.png
Views:	8240
Size:	148.2 KB
ID:	113497   Click image for larger version

Name:	editpost.png
Views:	3060
Size:	24.6 KB
ID:	113498   Click image for larger version

Name:	newthread.png
Views:	2976
Size:	36.1 KB
ID:	113499   Click image for larger version

Name:	adminoptions.jpg
Views:	2446
Size:	121.5 KB
ID:	113500  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Posting Features Thread Thumbnails Null Parameter vBulletin 3.8 Add-ons 353 08 Sep 2021 17:23

  #151  
Old 24 Aug 2010, 15:01
baboo baboo is offline
 
Join Date: Aug 2007
thank you very much, it working now...
Reply With Quote
  #152  
Old 25 Aug 2010, 08:24
S!p S!p is offline
 
Join Date: May 2010
4.0.6 PL1
There is nothing changed manually.
I try on default style and same.
Reply With Quote
  #153  
Old 25 Aug 2010, 21:42
ChaFF's Avatar
ChaFF ChaFF is offline
 
Join Date: Jun 2010
Installed, nominated. Needed feature.
for some reason works fine on links, and attachments, but not when i choose "first image in post"
Reply With Quote
  #154  
Old 25 Aug 2010, 23:48
S!p S!p is offline
 
Join Date: May 2010
my mistake. Already running.
I have two questions.
What do I do that visitors viewed the thumbnails in the old topics?
Is it possible to show the image full-size mouse over the thumbnail?
Reply With Quote
  #155  
Old 28 Aug 2010, 13:31
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
@ S!p only way to get the old topic to show is to edit each post and save, this way it bring up the thumbnail in the threadlist As for the mouse-over, i'm currently playing with some codes to try that out! I will post some results if it works

@ChaFF Did you do the changes that i posted in here: http://www.vbulletin.org/forum/showp...&postcount=145 ??
Reply With Quote
  #156  
Old 02 Sep 2010, 17:35
baboo baboo is offline
 
Join Date: Aug 2007
Hi fxwoody,

I have a problem, there is two threadicon!

chech this link: http://www.world-gd.com/forumdisplay.php?4

Thank you very much.
Reply With Quote
  #157  
Old 04 Sep 2010, 15:13
Chris Ober Chris Ober is offline
 
Join Date: May 2006
We currently have a problem where every thread we move, shows an attachment thumbnail that's not related to the post at all and I can't figure out where in the templates it's adding it from to remove it. The thumbnail even shows for posts that don't include an image or attachment. I removed one for an image that no longer existed on the server and a different thumbnail took it's place. VB 4.0.4 on Linux, PHP 5.2.13, mysql 5.0.91, Apache 2.2.15

Example forum showing the issue:
http://www.birdphotographers.net/for...phy-Discussion

Any assistance will be greatly appreciated.

Thanks,
Chris
Reply With Quote
  #158  
Old 08 Sep 2010, 22:00
CrystaStarLight CrystaStarLight is offline
 
Join Date: Sep 2006
Thank you fxwoody! Your fix worked for me on a 4.0.6 version. =)

This is a cool hack! I'm marking installed.
Reply With Quote
  #159  
Old 09 Sep 2010, 16:36
krustyx krustyx is offline
 
Join Date: Jul 2007
I have a problem here.

First image in post selected.

When posting a message, the image doesnt show.

I have to go back in the thread, edit, save, then the image is showing.

Any fix for this? Thank you
Reply With Quote
  #160  
Old 10 Sep 2010, 19:29
Twikitero Twikitero is offline
 
Join Date: Aug 2010
Please help, I have vBulletin 4.0.6 PL1, can not find any code in any of the templates that are required to edit

Anyone know tell me that I have to change templates in vBulletin 4.0.6 PL1

Thanks
Reply With Quote
  #161  
Old 10 Sep 2010, 19:46
krustyx krustyx is offline
 
Join Date: Jul 2007
Originally Posted by krustyx View Post
I have a problem here.

First image in post selected.

When posting a message, the image doesnt show.

I have to go back in the thread, edit, save, then the image is showing.

Any fix for this? Thank you
http://www.vbulletin.org/forum/showp...&postcount=154
Reply With Quote
  #162  
Old 11 Sep 2010, 19:31
presyce presyce is offline
 
Join Date: Nov 2008
is it possible to make this available to only one forum section?
Reply With Quote
  #163  
Old 12 Sep 2010, 23:28
CrystaStarLight CrystaStarLight is offline
 
Join Date: Sep 2006
Wouldn't simply resizing the images to thumbnails make the forumdisplay.php page load slowly, or does this generate actual images in thumbnail size?

I wish the developer could add Woody's fixes in his post for 4.0.6 to the main page.
Reply With Quote
  #164  
Old 12 Sep 2010, 23:58
struff struff is offline
 
Join Date: Aug 2008
I can't seem to get this working. It installed perfectly and I made sure that it was turned on in the ACP options. But I don't get any input box for a thumbnail URL and the auto-thumbnail settings don't give me anything either.

I am using vB 4.0.6 and the default vB 4 style.

Thanks.
Reply With Quote
  #165  
Old 15 Sep 2010, 04:16
marianoblesa marianoblesa is offline
 
Join Date: Jan 2006
Originally Posted by krustyx
I have a problem here.

First image in post selected.

When posting a message, the image doesnt show.

I have to go back in the thread, edit, save, then the image is showing.

Any fix for this? Thank you
This is for VB 3.8, this does not apply to VB4.

Please Help
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:34.

Layout Options | Width: Wide Color: