Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Thread Thumbnails Details »
Thread Thumbnails
Mod Version: 3.1.0, by Null Parameter (Member) Null Parameter is offline
Developer Last Online: Apr 2014 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (29 votes - 4.76 average) Installs: 243
Released: 03 Mar 2010 Last Update: 30 Apr 2010 Downloads: 1662
Not Supported DB Changes Uses Plugins Auto-Template Translations  

Thread Thumbnails
Created By: Null Parameter

The Thread Thumbnails mod allows users of a forum to specify, in several possible ways, a thumbnail for their thread to be displayed on Forumdisplay thread list.

I had created the mod for vB 3.8, but people we're crying out for a ported version to vB4, and, thanks to help from several of the members, here it is!


Description of Features

Thumbnails are displayed on the Forumdisplay next to the threadicon.
In the ACP Options, assuming you are using the Auto-Template Edits, you can choose which side of the icon to display it on.

Forum Display Screenshot


When submitting a new thread or editing the first post of a thread, a thumbnail can be specified directly if the User Entered URL option is chosen in the ACP. Another option is to Require the thumbnail. If the thumbnail isn't required, it may be left blank by the user, and it can either not be shown at all on forumdisplay or be replaced by a default thumbnail image specified in the ACP.

New Thread Screenshot

Edit Post Screenshot


All available options in the ACP include...
  • Turn Off/On Thumbnails
  • Turn Off/On Auto-Template Edits
  • Which forums to use thumbnails in
  • Turn Off/On thumbnails on sticky threads
  • Require thumbnails (doesn't work with attachment option)
  • Choose to retrieve thumbnails from one of the following
    • User Entered URL
    • First Attachment
    • First Image in Post
  • Choose where thumbnail is displayed in threadbit (relies on Auto-Template Edits)
  • Thumbnail CSS Style
  • Specify No Thumbnail Replacement Image
ACP Options Screenshot


This version is also now using phrases, so it can more easily be translated!


Installation

Install the product XML file. That's it!

If you have a highly customized style, there is a chance that the auto-template edits will not work. In that case, you will need to make the template edits manually. See the included README for more details.


Thumbnail Style

The style for thumbnails is specified in the ACP. It is used to choose exactly how thumbnails will be displayed, including width, height, margins, borders and many other attributes.

The style is specified in CSS, and is applied directly to the HTML img tag.

Here are some examples of possible thumbnail styles, along with a description of what they will do. If you don't know much about CSS, you can learn more here.
  • Every thumbnail will have a width of 100 pixels, but be constrained to being a maximum of 150 pixels in height
    • width:100px;max-height:150px;
  • Every thumbnail will have a width of 120 pixels and have a margin of 3 pixels around the thumbnail, so that it doesn't touch any of the other elements in the threadbit
    • width:120px;margin:3px;
  • Thumbnails aren't allowed to exceed 150 pixels in either dimension, and are also mildly transparent
    • max-width:150px;max-height:150px;opacity:0.8;filter:alpha(opacity=80);
Note: Using CSS positioning attributes (i.e. position, float, clear, etc.) could mess up the threadbit structure, so beware.


FAQs

The version of this mod for vB 3.8 showed thumbnails in the search results. Where did they go?
The search system between vB 3.x and vB4 changed significantly. I didn't have the time to figure out the complexity of it, and was unable to find any examples of other mods that integrated into the search results.

If you know how this is done, feel free to contact me and we can work to get this feature back in!
Does this mod work for RTL Languages, such as Arabic?
There is a separate product XML file available for download that has the appropriate changes to support RTL languages.
When I choose the First Image in Post option, no thumbnails show up in my current threads. Why?
Thumbnails are only updated when a new thread is created or when the first post is edited. Parsing through every forum/thread whenever the options are changed could be disastrous for performance.

Luckily, a user of this mod, megamoose, created a script that you can use to help this out. I want this method to be known, but because I didn't write this, I make no promises that it will work.

Originally Posted by megamoose View Post
This should enable batch processing. I have tested it.
Change the $STEP_AMOUNT at the top to something lower if you still get errors
Remember this is for vB version 3.8
Always backup your data before running scripts like these

TO THOSE WHO HAVEN'T BEEN FOLLOWING THE CONVERSATION:
This script will go through all your existing posts and give them thumbnails, based on the First IMG in post option.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Translations

Arabic

Versions

v3.1
  • Fix for Required Thumbnails
  • New feature to automatically use ALL Forums
v3.0
  • Support for vB4!
  • Use Phrases
  • Option to make Thumbnails Required
  • Option to select where to show the thumbnail on Forumdisplay
  • Option to specify the CSS Style of thumbnail images
Mod Support

I am fully willing to support this mod and continue to add new feature to it when they are desired enough to make them applicable to the product as a whole. The issue is that I do not have access to a vB4 installation, and therefore cannot develop.

Several people were gracious enough to offer up a test installation for me to use, and that is how this mod exists today. If any new features/fixes are wanted, other people will need to be just as gracious.

Also, since I don't own a vB4 instance, I'm supporting this strictly out of the kindness of my heart. So, if you wish to Support me as a developer, it would be much appreciated.

Enjoy!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	forumdisplay.png
Views:	8240
Size:	148.2 KB
ID:	113497   Click image for larger version

Name:	editpost.png
Views:	3060
Size:	24.6 KB
ID:	113498   Click image for larger version

Name:	newthread.png
Views:	2976
Size:	36.1 KB
ID:	113499   Click image for larger version

Name:	adminoptions.jpg
Views:	2446
Size:	121.5 KB
ID:	113500  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Posting Features Thread Thumbnails Null Parameter vBulletin 3.8 Add-ons 353 08 Sep 2021 17:23

  #256  
Old 24 May 2011, 20:48
togotutor togotutor is offline
 
Join Date: May 2011
Later..
Reply With Quote
  #257  
Old 25 May 2011, 01:23
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
Originally Posted by Mikevet1984 View Post
fxwoody one smαll request please if possible....

As it was you here in thread that you released the alterations needed to make this mod work with the last version, and also you are a coder, could you please release an updated version of the xml file which will contain all the updated codes?

Or could you release a txt file with all the instructions on how to manually do the alteration to the original mod in a single document to have is as a tutorial and not need to reed some many pages of comments form the date of thread releasing.

Sorry for my bad english!
Ok Mikevet, i'll work this out like you said. Should be easier for everyone else also!

Tks for the support

Originally Posted by Tize. View Post
Hello.
My problem is that I have activated all right but the image never appears in the forums.
The permissions are correct and do not understand.
If I can help please would be great.
Thanks.
If images are not showing , it means you are probably missing this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I will repost this Plugin with every new information under one simple page soon
Hope NullP won't be to ....at me lolll
Reply With Quote
  #258  
Old 25 May 2011, 11:07
mwink mwink is offline
 
Join Date: Mar 2008
Originally Posted by Tize. View Post
Hello.
My problem is that I have activated all right but the image never appears in the forums.
The permissions are correct and do not understand.
If I can help please would be great.
Thanks.
Same problem here. The add-on seems to be installed properly. Settings ok, but nevertheless no thumbnails show up. Even if I turn on "Are Thumbnails Required?" , creating a thread does not show anything and can be done without specifying.

Any ideas what can be wrong??
Attached Images
File Type: jpg CapturFiles_11.jpg (143.9 KB, 12 views)
Reply With Quote
  #259  
Old 26 May 2011, 01:20
GrabMyWrist's Avatar
GrabMyWrist GrabMyWrist is offline
 
Join Date: Feb 2011
Any chance you could add an option to let the thumbnail be the users avatar?
Reply With Quote
  #260  
Old 26 May 2011, 12:23
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
Originally Posted by mwink View Post
Same problem here. The add-on seems to be installed properly. Settings ok, but nevertheless no thumbnails show up. Even if I turn on "Are Thumbnails Required?" , creating a thread does not show anything and can be done without specifying.

Any ideas what can be wrong??
I will see what i can do about this. I use to run this function before but ended up with problems too!

Originally Posted by GrabMyWrist View Post
Any chance you could add an option to let the thumbnail be the users avatar?
Not sure if it would work but i will check this out
Reply With Quote
  #261  
Old 26 May 2011, 18:36
GrabMyWrist's Avatar
GrabMyWrist GrabMyWrist is offline
 
Join Date: Feb 2011
Thanks!
Reply With Quote
  #262  
Old 26 May 2011, 19:29
acabator acabator is offline
 
Join Date: Dec 2009
You could try the option to have both First Attachment and First Image In Post, and at the same time.

That is, the ability to add the option to put in bold, please:
  • Choose to retrieve thumbnails from one of the following
    • User Entered URL
    • First Attachment
    • First Image in Post
    • First Attachment and First Image in Post


Sorry for my bad english!

Last edited by acabator; 26 May 2011 at 19:59.
Reply With Quote
  #263  
Old 26 May 2011, 19:34
Derapata Derapata is offline
 
Join Date: Aug 2007
Thank you
Reply With Quote
  #264  
Old 27 May 2011, 08:07
macroforum macroforum is offline
 
Join Date: Mar 2010
Originally Posted by mwink View Post
Same problem here. The add-on seems to be installed properly. Settings ok, but nevertheless no thumbnails show up. Even if I turn on "Are Thumbnails Required?" , creating a thread does not show anything and can be done without specifying.

Any ideas what can be wrong??
Same problem here.
This MOD works, for me, ( vb 4.1.3) only with attachments.
Antonio

[EDIT] The thumbnail appears after modification of the message....

Last edited by macroforum; 27 May 2011 at 08:13.
Reply With Quote
  #265  
Old 28 May 2011, 04:00
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
Guys! just shut it off for now till i come up with a clean slate for ya all!

It's working for sure
Give me a day or two and i will come up with something. Not my plugin but i will help out
Reply With Quote
  #266  
Old 28 May 2011, 05:45
joacocarp joacocarp is offline
 
Join Date: Mar 2011
First Thanks for the mod!

The mod found but I have now 2 pics on the forum display page 1 before thread icon and 1 after thread icon:




Uploaded with ImageShack.us


I use Vbulletin 4.1.2



Thanks and greetings
Reply With Quote
  #267  
Old 28 May 2011, 13:07
mwink mwink is offline
 
Join Date: Mar 2008
Originally Posted by fxwoody View Post
Guys! just shut it off for now till i come up with a clean slate for ya all!

It's working for sure
Give me a day or two and i will come up with something. Not my plugin but i will help out
Thanks! Will wait for that!
Reply With Quote
  #268  
Old 29 May 2011, 18:23
joacocarp joacocarp is offline
 
Join Date: Mar 2011
First Thanks for the mod!

The mod found but I have now 2 pics on the forum display page 1 before thread icon and 1 after thread icon:




Uploaded with ImageShack.us


I use Vbulletin 4.1.2



Thanks and greetings!
Reply With Quote
  #269  
Old 30 May 2011, 04:10
Khriz's Avatar
Khriz Khriz is offline
 
Join Date: Apr 2011
only works with images attached !!!!

U_U"

S.O.S.
Reply With Quote
  #270  
Old 30 May 2011, 06:44
Pionex Pionex is offline
 
Join Date: Apr 2011
does not work for me with user url, however first attached image works fine.
nice mod, thanks. installed.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 01:53.

Layout Options | Width: Wide Color: