Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Mid Post AdsMid Post Advertisements (middle of the post) Details »
Mid Post AdsMid Post Advertisements (middle of the post)
Mod Version: 1.9, by YankForum (Coder) YankForum is offline
Developer Last Online: Sep 2014 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (22 votes - 4.73 average) Installs: 144
Released: 07 Oct 2010 Last Update: 09 Aug 2014 Downloads: 992
Not Supported Uses Plugins Auto-Template  

Hello
i decided to share this mod with everybody else , this is a paid hack , i received several PMs asking to share it with everybody else , so i did all credits goes to original author SecondV

What does this hack do ?

This mod simply lets you put your desired ads or any other codes just in the middle of first post , in each page of a thread .
you can see a live demo here





Known Issues :
  • you shouldn't edit your first post , that causes real problems , and you lose all the contents of first post. (this is solved in version 1.1)
  • sometimes it's not exactly in the middle of posts , that's because in logic sometimes there is no real half point , while some posts have even number of lines and some posts have odd number of lines . but it tries to put it to the nearest location to the mid point!

Try not to mention following things :
if you think it's against google TOS then don't install it but keep in mind you can also use it with other network ads , and keep in mind at no point google directly mentioned it's against their TOS to put adsense in between content , so do not insist

Installation :
Just Import the Prodcut and configure settings in admincp ( no template edits needed )
DONE

Updates
version 1.1 : first post editing bug FIXED
version 1.2 : option ADDED to hide copyright AND adsense input field integrated into mod's settings page
version 1.3 : option ADDED to limit ads to be visible to guests only as requested by jrwap
version 1.4 : The ads get applied to article comments as well on the CMS articles bug FIXED
version 1.5 : option ADDED to disable ads in certain forums ( as requested by wastemytime )
version 1.6 : unicode characters bug FIXED
version 1.7 : option for enabling ads in extra post ADDED
version 1.8 : changed the structure of while loop to maintain performance and speed
version 1.9 : first post image only (no text) bug FIXED

Enjoy and please please try not to forget to click as Installed if you liked it you can also Nominate it for MOTM , that's optional but clicking as installed is a must

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	1.jpg
Views:	7055
Size:	101.5 KB
ID:	122630   Click image for larger version

Name:	2.jpg
Views:	6110
Size:	182.0 KB
ID:	123090  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #16  
Old 08 Oct 2010, 11:11
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
wait for the update , i'm putting the option to remove it
__________________
No more signature for me , Tnx!
Reply With Quote
  #17  
Old 08 Oct 2010, 12:06
adom7's Avatar
adom7 adom7 is offline
 
Join Date: Aug 2007
Nice one.
nominated
__________________
Need for mods
Reply With Quote
  #18  
Old 08 Oct 2010, 12:57
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Mod updated , no more template edits needed and also an option added to hide the footer copyright , although you are encouraged not to hide the authors copyright in order to support me!
__________________
No more signature for me , Tnx!
Reply With Quote
  #19  
Old 08 Oct 2010, 13:07
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by valdet View Post
Any chance you can also make this work for vB 3.x versions?
i'm sorry valdet there is a small hope to have the VB3.x version at this stage , although i'll bee looking forward to have it compatible with VB3.x version in near feature mayB
__________________
No more signature for me , Tnx!
Reply With Quote
  #20  
Old 08 Oct 2010, 13:10
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by adom7 View Post
Nice one.
nominated
Tnx
Originally Posted by LbR View Post
bad bad bad bad I am getting your forum links in my posts


Its conflicting with the Attachment code
Its conflicting with the buttons too check out the screenshot
try to see if this is working properly with the default style or not , this mayb is your template issue or 1 of your installed mods causing conflicts , although i added an option to hide the copyright , try installing version 1.2 and give me feedback again , Tnx
__________________
No more signature for me , Tnx!
Reply With Quote
  #21  
Old 08 Oct 2010, 13:37
MOGmartin MOGmartin is offline
 
Join Date: Feb 2008
installed, and thank you for sharing.

I recently moved my adsense to the above first post template area, having it within the first post will be interested as a CTR experiment.
__________________
Owner of SEO Forums.org
Reply With Quote
  #22  
Old 08 Oct 2010, 16:24
jrwap's Avatar
jrwap jrwap is offline
 
Join Date: Oct 2001
Great mod.... one quick question...

Can it be made to only show ads to unregistered/guests? I have eliminated all ads for members on my site.

Thanks,

-JRW
Reply With Quote
  #23  
Old 08 Oct 2010, 17:07
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by jrwap View Post
Great mod.... one quick question...

Can it be made to only show ads to unregistered/guests? I have eliminated all ads for members on my site.

Thanks,

-JRW
of course it's possible , i had lots of work today , hopefully i'll try to put some options to restrict ads to specific usergroups

installed, and thank you for sharing.

I recently moved my adsense to the above first post template area, having it within the first post will be interested as a CTR experiment.
i'm glad to hear u liked it , hope it works best for u
__________________
No more signature for me , Tnx!
Reply With Quote
  #24  
Old 08 Oct 2010, 17:17
NBL4277 NBL4277 is offline
 
Join Date: Jul 2010
Looks interesting. I'll give it a try!
__________________
Articles are a means of expressing an idea. Write one.
Reply With Quote
  #25  
Old 08 Oct 2010, 17:58
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
option added (limit ads to guests only) as requested by jrwap
---------
sorry to bother u guys with multiple updates , i'm just trying to make it perfect for u
__________________
No more signature for me , Tnx!
Reply With Quote
  #26  
Old 08 Oct 2010, 20:11
jrwap's Avatar
jrwap jrwap is offline
 
Join Date: Oct 2001
Originally Posted by YankForum View Post
option added (limit ads to guests only) as requested by jrwap
---------
sorry to bother u guys with multiple updates , i'm just trying to make it perfect for u
Wow, thanks... just installed it.

One little issue... I am getting the following error on some pages: Warning: preg_replace() [function.preg-replace]: Unknown modifier 'p' in [path]/includes/class_postbit.php(321) : eval()'d code on line 62

Example: http://www.club-tc.com/forums/member...log-1-a-4.html

It looks like the mod is having problems with a quote as the first part of the post.

Any ideas?

-JRW
Reply With Quote
  #27  
Old 08 Oct 2010, 20:31
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by jrwap View Post
Wow, thanks... just installed it.

One little issue... I am getting the following error on some pages: Warning: preg_replace() [function.preg-replace]: Unknown modifier 'p' in [path]/includes/class_postbit.php(321) : eval()'d code on line 62

Example: http://www.club-tc.com/forums/member...log-1-a-4.html

It looks like the mod is having problems with a quote as the first part of the post.

Any ideas?

-JRW
tnx for feedback , no , first post starting by quote won't cause any issue , i tried it , i don't know what's wrong with this mod in your boards but i'll be looking forward to find it out , also please click as installed if you installed it , tnx again
__________________
No more signature for me , Tnx!
Reply With Quote
  #28  
Old 08 Oct 2010, 20:52
nukeleo nukeleo is offline
 
Join Date: Sep 2007

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

this message appeared top of the forum page
Reply With Quote
  #29  
Old 08 Oct 2010, 21:44
aseer_al7ob's Avatar
aseer_al7ob aseer_al7ob is offline
 
Join Date: May 2007
Real name: AHED
Great work

But there is a problem I am encountering

When you activate the MOD works fine, but if any subject was the beginning of an image does not display content of the topic

I hope to solve this problem

Thank you
__________________
Reply With Quote
  #30  
Old 09 Oct 2010, 06:19
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by aseer_al7ob View Post
Great work

But there is a problem I am encountering

When you activate the MOD works fine, but if any subject was the beginning of an image does not display content of the topic

I hope to solve this problem

Thank you
i can't understand what exactly is the problem , can u provide me a link to what you say or explain a bit more ? mayb it's one of your mods conflicting with this one ?
__________________
No more signature for me , Tnx!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:13.

Layout Options | Width: Wide Color: