Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Memberlist Details »
Memberlist
Mod Version: 1.0.1, by TheAdminMarket (Member) TheAdminMarket is offline
Developer Last Online: Jul 2017 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 4.2.2 Rating: (12 votes - 5.00 average) Installs: 32
Released: 03 Jul 2015 Last Update: 05 Jul 2015 Downloads: 185
Not Supported DB Changes Uses Plugins Auto-Template Additional Files  

Since 2006 I was serving community members with my Free Mods
But as this site will starts operating by the company,
I'm no willing to support them

** File Removed **


Memberlist

A Better Memberlist for your Forum


I'm offering my hard work for free, without even a single copyright line in footer, expecting that some of you will appreciate the time that I spent for coding it and they will donate something.
Demo: http://www.teriakis.com/vb423/memberlist.php

1.- What's this?

Memberlist is a vBulletin 4x AddOns which replaces the standard Memberlist with a new one, more beatiful and with many more features.

2.- Features
  • You can set which Usergroups to show in Memberlist
  • Homepage with 3 sections where you can promote some Members of your site (eg The Support Team, The Site's Founder etc). You can assign userid(s) per section and also give a custom title for it.
  • Adds a new Menu in Usercp in Networking section where the user can set their ids in some popular social networks like:
    • Facebook
    • Twitter
    • Google Plus
    • Linkedin
  • In Frontend each Member Profile shows:
    • Avatar
    • Username
    • Online/Offline status
    • Usertitle
    • Location
    • Age
    • vB build-in messenger links: Icq, Aim, Msn, Skype, Yahoo
    • Social Links: Facebook, Twitter, Google+, Linkedin
    • Homepage link
    • Button-Link to add that member in your buddy list
  • Powerful Search by:
    • Username starting Letter
    • Partial Username
    • Usergroup
    • Location
    • Age range
    • Join in last xx days
    • Posts more than xx
    • All 10 messenger and social options
  • Other Information in Sidebar:
    • Ajax Tab for Member Statistics with 3 tabs:
      • Online Now
      • Just Join Us
      • Usergroups with totals
    • Ajax Tab for Top Posters with 3 tabs:
      • Top Posters this Week
      • Top Posters this Month
      • Top Posters this Year

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	homepage.jpg
Views:	530
Size:	94.4 KB
ID:	152758   Click image for larger version

Name:	search.png
Views:	307
Size:	27.7 KB
ID:	152759   Click image for larger version

Name:	socialnetworks.png
Views:	275
Size:	41.0 KB
ID:	152760   Click image for larger version

Name:	statistics.png
Views:	293
Size:	10.5 KB
ID:	152761  

Click image for larger version

Name:	topposters.png
Views:	220
Size:	9.5 KB
ID:	152762   Click image for larger version

Name:	usercp.png
Views:	265
Size:	21.8 KB
ID:	152763   Click image for larger version

Name:	usergrouplisting.jpg
Views:	359
Size:	121.7 KB
ID:	152764   Click image for larger version

Name:	options1.jpg
Views:	168
Size:	81.3 KB
ID:	152765  

Click image for larger version

Name:	options2.jpg
Views:	182
Size:	62.6 KB
ID:	152766  

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #46  
Old 27 Jul 2015, 18:52
TheAdminMarket's Avatar
TheAdminMarket TheAdminMarket is offline
 
Join Date: Jun 2013
Real name: Christos Teriakis
Originally Posted by louva-a-Deus View Post
I 've tried several times , not saved.
If not saved try a trick and keep it in memory as can happen for anymod. There is no explanation why it appears.

1.- Delete from forum_installation/includes/xml/bitfield_memberindex.xml
2.- Login to Admincp and goto Usergroup Permissions. Click to edit any usergroup, does not matters. You'll see a message "Rebuilding bitfields.."
3.- Goto any other part of admincp but stay at admincp.
4.- Upload file includes/xml/bitfield_memberindex.xml to forum_installation/includes/xml/bitfield_memberindex.xml
5.- Go again to Usergroup permissions and click edit to any usergroup. You'll see again the message "Rebuilding bitfields". Now the changes will be save.
Reply With Quote
  #47  
Old 27 Jul 2015, 21:11
louva-a-Deus louva-a-Deus is offline
 
Join Date: Aug 2011
I deleted the file forum_installation / includes / xml / bitfield_memberindex.xml

The message I saw was: Usergrups saved.
Reply With Quote
  #48  
Old 28 Jul 2015, 04:49
TheAdminMarket's Avatar
TheAdminMarket TheAdminMarket is offline
 
Join Date: Jun 2013
Real name: Christos Teriakis
Originally Posted by louva-a-Deus View Post
I deleted the file forum_installation / includes / xml / bitfield_memberindex.xml

The message I saw was: Usergrups saved.
This was the first step. After this message have you uploaded again the file bitfield_memberindex.xml?
Reply With Quote
  #49  
Old 28 Jul 2015, 14:25
louva-a-Deus louva-a-Deus is offline
 
Join Date: Aug 2011
Originally Posted by NickTheGreek View Post
This was the first step. After this message have you uploaded again the file bitfield_memberindex.xml?

Yes , I followed the tutorial rigorsamente but nothing happens. Thank you very much but I give up . It's a shame , the mod is awesome .
Reply With Quote
  #50  
Old 28 Jul 2015, 14:52
TheAdminMarket's Avatar
TheAdminMarket TheAdminMarket is offline
 
Join Date: Jun 2013
Real name: Christos Teriakis
Originally Posted by louva-a-Deus View Post
Yes , I followed the tutorial rigorsamente but nothing happens. Thank you very much but I give up . It's a shame , the mod is awesome .
Be sure that the trick works. If you want PM FTP details and Admincp details to check it. Sorry that's the only that I can do.
Reply With Quote
  #51  
Old 28 Jul 2015, 19:35
qpurser qpurser is offline
 
Join Date: Aug 2011
It installed without any issues however I am running into some issues:

I don't see the TABS as shown above in the details.
The user avatars are huge for some users. Way more as the 100 pixels. even setting them to 50 or so won't change anything.

I must say I am running vB 4.2.0
Any suggestions what could be wrong?
Thanks
Reply With Quote
  #52  
Old 29 Jul 2015, 08:07
TheAdminMarket's Avatar
TheAdminMarket TheAdminMarket is offline
 
Join Date: Jun 2013
Real name: Christos Teriakis
Originally Posted by qpurser View Post
It installed without any issues however I am running into some issues:

I don't see the TABS as shown above in the details.
The user avatars are huge for some users. Way more as the 100 pixels. even setting them to 50 or so won't change anything.

I must say I am running vB 4.2.0
Any suggestions what could be wrong?
Thanks
Please give me the installation URL or check your page's output code to see if there are multiple instances of jquery there. Most probably this causes also the avatar problem as it messes the screen.
Reply With Quote
  #53  
Old 03 Aug 2015, 21:37
akz645 akz645 is offline
 
Join Date: Jul 2015
I'm using vbulletin 4.2.3. I got it to work. Thank you for the Mod
I thought it didn't work at the start, but then I realised you must enable it from usergroups (this isn't in the screenshots in the original post).

These are my settings:

^ I honestly don't have a clue what that setting does. Mind telling me Nick?


AdminCP -> Usergroups -> Usergroup Manger -> [Select Group]
Right at the bottom:


Once installed, 'Members' Navtab didn't appear. It only appeared after I changed the setting to yes from usergroup (^administrator) & pressed saved on 'Members' from the Navigation Manger:


^ That's the default settings. If you don't see some of the fields, then you still need to change your usergroup permissions to yes.

If you can't make it work, I suggest doing exactly as I've done (same settings) in this post.

@Nick
P.S= I suggest having a installation guide either as a installation text file OR written down in the original post.
Also include a screenshot of the this in the original post.

Last edited by akz645; 04 Aug 2015 at 14:17.
Reply With Quote
  #54  
Old 04 Aug 2015, 23:02
louva-a-Deus louva-a-Deus is offline
 
Join Date: Aug 2011
I made an unsuccessful installation and did not install the mod but the tables were, how can I remove them?



Database error in vBulletin 4.2.3:

Invalid SQL:
ALTER TABLE usergroup ADD memberindex INT( 10 ) UNSIGNED DEFAULT '0' NOT NULL;

MySQL Error : Duplicate column name 'memberindex'
Error Number : 1060
Request Date : Tuesday, August 4th 2015 @ 07:57:21 PM
Error Date : Tuesday, August 4th 2015 @ 07:57:21 PM
Script : http://www.../admincp/plugin.php?do=productimport
Referrer : http://www..../admincp/plugin.php?do=productadd
IP Address : ...
Username : ...
Classname : vB_Database_MySQLi
MySQL Version : 5.5.42-cll-lve
Reply With Quote
  #55  
Old 05 Aug 2015, 05:50
TheAdminMarket's Avatar
TheAdminMarket TheAdminMarket is offline
 
Join Date: Jun 2013
Real name: Christos Teriakis
Originally Posted by louva-a-Deus View Post
I made an unsuccessful installation and did not install the mod but the tables were, how can I remove them?
If you're familiar using phpMyAdmin you must connect to your database and remove from table usergroup the field memberindex. Normally must be the last.

Another way is to modify the product-memberindex.xml and remove:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then save file and import it.

Most probably is not only that field but all. Don't know why the fields didn't removed during uninstall.
Reply With Quote
  #56  
Old 05 Aug 2015, 19:56
louva-a-Deus louva-a-Deus is offline
 
Join Date: Aug 2011
Hi NickTheGreek,

I sent him a private message
Reply With Quote
  #57  
Old 05 Aug 2015, 23:41
RSprinkel RSprinkel is offline
 
Join Date: Mar 2014
Awesome Mod. Installed it on 4.2.2 without issue. Thanks for your hard work.
Reply With Quote
  #58  
Old 09 Aug 2015, 20:58
qpurser qpurser is offline
 
Join Date: Aug 2011
Originally Posted by NickTheGreek View Post
Please give me the installation URL or check your page's output code to see if there are multiple instances of jquery there. Most probably this causes also the avatar problem as it messes the screen.
Just PM'd you the link.
Thanks for looking into it
Reply With Quote
  #59  
Old 18 Aug 2015, 17:34
blue6995 blue6995 is offline
 
Join Date: Oct 2005
Just can't get this working! I do not see the Member Index option in an Usergroup so can not grant permission to see the member list
Reply With Quote
  #60  
Old 18 Aug 2015, 19:26
ArcadeSyndicate's Avatar
ArcadeSyndicate ArcadeSyndicate is offline
 
Join Date: Oct 2008
another great addon, thank you very much
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 19:35.

Layout Options | Width: Wide Color: