Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
"See More" Google Custom Search (Lite) - Increase Adsense revenue! Details »
"See More" Google Custom Search (Lite) - Increase Adsense revenue!
Mod Version: 1.2.3, by tpearl5 (Coder/Designer) tpearl5 is offline
Developer Last Online: Feb 2021 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (3 votes - 5.00 average) Installs: 39
Released: 19 Jun 2014 Last Update: 16 Sep 2014 Downloads: 285
Supported Uses Plugins Auto-Template Additional Files External Content Is in Beta Stage  

ForumSetup.nets See More Google Custom Search will allow visitors to easily find similar content on your site and increase your Adsense revenue! Many sites that have this modification installed have also reported a bump in pages per visitor and a decreased bounce rate as well!

How does it do this? A See More link is inserted in the first post of a thread. If a user is coming from a search engine, the keyword they used to search will be used to link to a Google Custom Search to find more similar content on your site. If the modification cannot get the keyword or a user is browsing your site, the title of the thread will be used instead. The free version of Google Custom Search inserts relevant ads, increasing your Adsense revenue at the same time.

Features:
  • Displays search results within your site (does not go to Google)
  • Statistics in Google Analytics
  • Customize the See More font and link
  • Change See More text to whatever you want
  • Change the HTML around the See More link
  • Option to show popular queries & the time period they are from

Pro only features:
  • Option to show the See More link to members or specific usergroups
  • Turn off showing the thread title as the See More link
  • Choose from 4 different locations for the link (before/after first post, before/after signature)
  • Replace the default vBulletin search box with Google Custom Search
  • Option to show the replaced search box to members or specific usergroups
  • Removes link to ForumSetup.net in footer

Case Studies & Reviews

Case Study: cellphoneforums.net
Cell Phone Forums saw a number of different positive metrics immediately after installing See More Google Custom Search. The See More link is set to display just below the first post content and thread titles are turned on.

  • Bounce Rate decreased by 5.5%
  • Pages/Session increased 12%
  • Avg. Session Duration increased 10%
  • Search page RPM: $15.88
  • Adsense revenue: 64% increase


Case Study: nikonites.com
Nikonites also did well and saw better numbers with See More Google Custom Search installed.
  • Bounce Rate decreased by 2%
  • Search page RPM: $9.39
  • Adsense revenue: 23% increase

Review: http://www.vbulletin.org/forum/showp...2&postcount=89
Review 2: http://www.vbulletin.org/forum/showp...1&postcount=86

Results will vary depending on site traffic and subject matter.

Installation

Google Custom Search Setup
  1. First, you'll need to set things up with Google Custom Search if you haven't already. We are already assuming you have a Google Adsense account setup and it is linked with Custom Search
  2. Go to https://www.google.com/cse/create/new
  3. Enter all information and click Create
  4. Under "Edit search engine" go to "Look and feel"
  5. Click "Full width" and click Save
  6. Go to "Setup"
  7. Click the "Make money" tab, and make sure "Search Engine Monetization" is on and your AdSense account is hooked up
  8. On the "Basics" tab under the Details section click - "Search engine ID"
  9. Take note of your Search Engine ID


See More install & setup
  1. Once you download the package, unzip it
  2. Upload gsearch.php to your forum root
  3. Install the product xml under the admincp. Plugins & Projects > Manage Products > Add/Import Product (at the bottom)
  4. Go to Settings > Options > "See More" Google Custom Search
  5. Insert your pub id as noted in the last step of the previous section
  6. If you wish to change how the results page looks the template is named see_more_gsearch
  7. That's it!

Release Log
  • 6/18/14 - 1.0 - Initial Release
  • 6/20/14 - 1.0.1 - corrected issue with Google ID verification
  • 6/28/14 - 1.2.1 - Added option to display popular queries on search results page & choose the period of time they are from Caching of search page template Fixed validation error with Google Search ID - Fixed an issue where links were not appearing for some setups Removed search page centering Added support for different character encoding.
  • 7/24/14 - 1.2.2 - Fixed character encoding issue - Added Who's Online location
  • 9/16/13 - 1.2.3 - Fixed another character encoding issue - Added mobile style support

The lite version adds a link to ForumSetup.net to the footer of the search results page and thread pages. The pro version does not have this and adds some other features. To learn more, please see this page.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	see_more_postbit.PNG
Views:	804
Size:	28.8 KB
ID:	149423   Click image for larger version

Name:	see_more_results.PNG
Views:	742
Size:	72.7 KB
ID:	149424   Click image for larger version

Name:	see_more_admincp.jpg
Views:	503
Size:	126.9 KB
ID:	149425   Click image for larger version

Name:	see_more_search.PNG
Views:	516
Size:	4.0 KB
ID:	149426  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Display Enhancements Replace "Display Options" In Forum Display With "Google Adsense" ShawneyJ vBulletin 3.8 Template Modifications 2 25 Nov 2012 18:59

  #106  
Old 29 Jul 2014, 04:05
puertoblack2003's Avatar
puertoblack2003 puertoblack2003 is offline
 
Join Date: Aug 2005
Originally Posted by tpearl5 View Post
And you allowed overwrite, right? Are the templates the default ones?
yep to all of the above.
__________________
Android Custom Creations
Reply With Quote
  #107  
Old 29 Jul 2014, 04:14
puertoblack2003's Avatar
puertoblack2003 puertoblack2003 is offline
 
Join Date: Aug 2005
Originally Posted by tpearl5 View Post
And you allowed overwrite, right? Are the templates the default ones?

found the problem originally you asked to add the "partner-pub-xxxxxxxxxxxxxxxxxx:xxxxxxxxx" i removed the "partner-pub" prefix and viola it worked.
__________________
Android Custom Creations
Reply With Quote
  #108  
Old 29 Jul 2014, 06:12
fai99al99 fai99al99 is offline
 
Join Date: Sep 2011
Originally Posted by tpearl5 View Post
Thanks. I think I finally figured out the problem with this. Allow overwrite with the xml below...

In case anyone wants to know the details, google prefers we don't encode the special characters and that's what I was doing. I took out the urlencoding function that does this. This works: http://www.lejapon.org/forum/gsearch...B4%20gozaimasu
iam haveing a problem with Arabic language ,It returns a "windows-1256"
Reply With Quote
  #109  
Old 29 Jul 2014, 07:22
naisho naisho is offline
 
Join Date: Feb 2008
Originally Posted by tpearl5
In case anyone wants to know the details, google prefers we don't encode the special characters and that's what I was doing. I took out the urlencoding function that does this.
Sorry, but I tried the new xml file (overwritting the previous one) and it does'nt work:
http://www.lejapon.org/forum/threads...paration-au-N4

I also tried to remove the charset included in the link with no success.
Reply With Quote
  #110  
Old 29 Jul 2014, 12:37
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by puertoblack2003 View Post
found the problem originally you asked to add the "partner-pub-xxxxxxxxxxxxxxxxxx:xxxxxxxxx" i removed the "partner-pub" prefix and viola it worked.
Ah, yes. I realized that partner-pub is not in everyone's ID. Only earlier accounts.
Originally Posted by fai99al99 View Post
iam haveing a problem with Arabic language ,It returns a "windows-1256"
Did you try the xml above?
Originally Posted by naisho View Post
Sorry, but I tried the new xml file (overwritting the previous one) and it does'nt work:
http://www.lejapon.org/forum/threads...paration-au-N4

I also tried to remove the charset included in the link with no success.
It does the same thing as before? What does one of your see more links look like now? You need the charset in the link for Google.
__________________
John
Reply With Quote
  #111  
Old 29 Jul 2014, 14:05
fai99al99 fai99al99 is offline
 
Join Date: Sep 2011
Originally Posted by tpearl5 View Post
Did you try the xml above?
yes , I did.
english titles works good ,but if there is any
Arabic letter in the title It returns "windows-1256"
Reply With Quote
  #112  
Old 29 Jul 2014, 14:33
naisho naisho is offline
 
Join Date: Feb 2008
Originally Posted by tpearl5
It does the same thing as before?
Yes exactly the same.

Originally Posted by tpearl5
What does one of your see more links look like now?
I am using your last xml file so you can check this link:
http://www.lejapon.org/forum/threads...paration-au-N4
Reply With Quote
  #113  
Old 29 Jul 2014, 16:30
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by fai99al99 View Post
yes , I did.
english titles works good ,but if there is any
Arabic letter in the title It returns "windows-1256"
Originally Posted by naisho View Post
Yes exactly the same.



I am using your last xml file so you can check this link:
http://www.lejapon.org/forum/threads...paration-au-N4

Okay, try this one (allow overwrite)...

edit:removed
__________________
John

Last edited by tpearl5; 30 Jul 2014 at 15:42.
Reply With Quote
  #114  
Old 29 Jul 2014, 22:50
fai99al99 fai99al99 is offline
 
Join Date: Sep 2011
Originally Posted by tpearl5 View Post
Okay, try this one (allow overwrite)...
did not work.. now it returns letters like this " 30 "
Reply With Quote
  #115  
Old 30 Jul 2014, 15:42
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by fai99al99 View Post
did not work.. now it returns letters like this " 30 "
Alright I think I see what's going on now. Last try, then I give up on character encoding
__________________
John

Last edited by tpearl5; 04 Aug 2014 at 20:33.
Reply With Quote
  #116  
Old 30 Jul 2014, 18:21
fai99al99 fai99al99 is offline
 
Join Date: Sep 2011
Originally Posted by tpearl5 View Post
Alright I think I see what's going on now. Last try, then I give up on character encoding
didnt work .. return UTF-8
Reply With Quote
  #117  
Old 30 Jul 2014, 19:00
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by fai99al99 View Post
didnt work .. return UTF-8
Can you paste here or pm me a thread page that links to the search page?
__________________
John
Reply With Quote
  #118  
Old 31 Jul 2014, 12:19
naisho naisho is offline
 
Join Date: Feb 2008
OK I found a solution to make it work.
I just replaced urlencode with utf8_encode and everything is fine now on my site.
Reply With Quote
  #119  
Old 31 Jul 2014, 12:51
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by naisho View Post
OK I found a solution to make it work.
I just replaced urlencode with utf8_encode and everything is fine now on my site.
Ah! That's the one combination of encoding that I didn't try! But what happens if you have an &, question mark, or comma in your title?
__________________
John
Reply With Quote
  #120  
Old 31 Jul 2014, 14:20
naisho naisho is offline
 
Join Date: Feb 2008
With question marks and commas it works fine.
When there is a & in the title, the part starting from & is stripped. But it's not a big deal as this kind of titles are rare (0,5% on my forum)
Example here:
http://www.lejapon.org/forum/threads...en-train-metro
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 16:17.

Layout Options | Width: Wide Color: