Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Move smilies to below text area (and optionally add to Quick Reply) Details »
Move smilies to below text area (and optionally add to Quick Reply)
Mod Version: 1.4, by Lynne (Coder/Designer) Lynne is offline
Developer Last Online: Aug 2019 I like it Show Printable Version Email this Page

vB Version: 4.0.8 Rating: (26 votes - 4.73 average) Installs: 278
Released: 06 Dec 2009 Last Update: 21 Nov 2010 Downloads: 1448
Not Supported Uses Plugins Template Edits Auto-Template  

NOTE: This will break your 4.1.4 Quick Reply if you have smilies enabled there unless you do the edit below.

This moves the smilie box to below the text area when posting within threads, blogs, groups, PMs, and cms when using the Advanced Editor (new item or advanced reply). This is done using just CSS. The plugin simply appends the new CSS file to the editor.css file link in the page. It can also make the smiliebox show on the showthread page below the text box in Quick Reply if you do the Optional Edit below.

Attachment 107256

This mod is supported for the default style only as trying to debug other's site CSS issues is not easy.

This has been tested in firefox, Safari and IE7.


Version History:
1.0 2009-12-06: initial release by Lynne at vbulletin.org (pre 4.0.1)
1.1 2010-01-13: fixed issues with 4.0.1; made it move the smilies to the bottom for sending a new PM ('blog'), and for posting a New Discussion ('group') (4.0.1)
1.2 2010-01-23: fixed it to work if you store your css in the filesystem (4.0.1)
1.3 2010-05-05: added fields so it will work with vbcms and editpost (4.0.1)
1.4 2010-10-23: Modified CSS to use new stylevars - you do NOT need to upgrade to this version if your CSS is working just fine for you! (4.0.8 - see note below for 4.1PL1)


To install:

1. Import product-lynne_smilies_below.xml

2. Go to Settings > Options > Message Posting Interface Options > Put smilie box below textarea > Yes

3. Go to Settings > Options > Message Posting Interface Options and make sure you set these two settings:
Smiliebox Total Smilies - this is the total number of smilies you want to show
Smiliebox Rows (smilies below textarea) - this is the number of rows of smilies you would like

NOTE: The Total Smilies must be evenly divisible by the Rows, ie. you can't set the Total to 17 and have 2 Rows as that won't work.

4. OPTIONAL - If you also want the smiliebox to show on the showthread page under the Quick Reply, then you must do the following:
a. Go to Settings > Options > Message Posting Interface Options > Add smiliebox below Quick Reply on showthread page > Yes (Note that the above options, Put smilie box below textarea must also be set to Yes)
b. Make the following template edit in the template "showthread_quickreply".
Find the following:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add in the following line among the bottom divs (for 4.0.8):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


OR
Add in the following line among the bottom divs (for 4.1.0 PL1):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

OR in 4.1.10 forward, find this code in the SHOWTHREAD template:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add directly below there:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


To get this to work with 4.1.4 (and later) Quick Reply:
Edit the plugin "Add smilies to Quick Reply also" and remove, or comment out, the line:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


To uninstall:


1. Uninstall "Move smilies below textarea"
2. If you added the smiliebox to the showthread.php page in the Quick Reply, then remove the template edit done above.

This will not work for pre-beta 5 vB4.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	lynne_smilies_below.png
Views:	4359
Size:	34.0 KB
ID:	107256  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Find, Optionally Email and Optionally Delete Inactive Members amykhar vBulletin 2.x Beta Releases 94 23 Apr 2008 03:15

  #151  
Old 24 Feb 2010, 08:30
Mastergumble Mastergumble is offline
 
Join Date: Sep 2008
Same issue here on 4.0.2PL1
Reply With Quote
  #152  
Old 24 Feb 2010, 12:12
coberr coberr is offline
 
Join Date: May 2007
I have problem with the 4.0.2PL1 too.
The smilies are on the right side, with 4.0.2 works fine.
Reply With Quote
  #153  
Old 24 Feb 2010, 13:31
synseal's Avatar
synseal synseal is offline
 
Join Date: Apr 2009
Real name: Ben Dover.
Same here, when you edit a post 4.0.2PL1 the smiles are on the right hand side, thanks.
Reply With Quote
  #154  
Old 24 Feb 2010, 14:12
cloferba cloferba is offline
 
Join Date: Apr 2009
its ridiculus to update this mod every time vb launch a new version... u.u
Reply With Quote
  #155  
Old 24 Feb 2010, 22:53
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
You can't break something that wasn't working that way in the first place - it never worked in the Advanced Edit page. If you want it to work there, then you need to add 'editpost' to the THIS_SCRIPT array of pages in the "Add editor2.css to pages" plugin.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #156  
Old 24 Feb 2010, 23:30
synseal's Avatar
synseal synseal is offline
 
Join Date: Apr 2009
Real name: Ben Dover.
Originally Posted by Lynne View Post
You can't break something that wasn't working that way in the first place - it never worked in the Advanced Edit page. If you want it to work there, then you need to add 'editpost' to the THIS_SCRIPT array of pages in the "Add editor2.css to pages" plugin.
Thanks very much Lynne, done that and now working fine for the advance edit, maybe worth adding in the original mod?.
Reply With Quote
  #157  
Old 25 Feb 2010, 17:12
Mastergumble Mastergumble is offline
 
Join Date: Sep 2008
Nice, Lynne is any way to make the same for CMS Comments?

I was trying to find what to add but currently stuck with it.
Reply With Quote
  #158  
Old 26 Feb 2010, 02:02
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Originally Posted by Mastergumble View Post
Nice, Lynne is any way to make the same for CMS Comments?

I was trying to find what to add but currently stuck with it.
Just add 'vbcms' to the array.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #159  
Old 26 Feb 2010, 02:20
Mastergumble Mastergumble is offline
 
Join Date: Sep 2008
Tkx once more Lynne
Reply With Quote
  #160  
Old 03 Mar 2010, 10:41
EmAnh EmAnh is offline
 
Join Date: Aug 2007
Problem in Edit Mode

Dear Lyne,

I upgrade my forum from vB 4.0.1 to vB 4.0.2 ... I observed this in my forums .

In edit mode ( ie edit an old post) ... It shows like this (please see picture attached)

In reply (to post) , post (new thread) .. are ok ...

Would you give some guidance (how to fix this problem)

Regards,

EA

*** Edit: Problem fixed , my mistakes in setting smillies ....
Attached Images
File Type: png editmode.png (45.3 KB, 35 views)

Last edited by EmAnh; 03 Mar 2010 at 10:49.
Reply With Quote
  #161  
Old 05 Mar 2010, 15:18
cloferba cloferba is offline
 
Join Date: Apr 2009
i have smiles that are a bit bigger than default ones...

and they are "cutted" because they are big...is there a fix to solve this?
Reply With Quote
  #162  
Old 05 Mar 2010, 20:16
Leo Brazil's Avatar
Leo Brazil Leo Brazil is offline
 
Join Date: Dec 2007
Originally Posted by cloferba View Post
i have smiles that are a bit bigger than default ones...

and they are "cutted" because they are big...is there a fix to solve this?
It's my thing too. I know this is not related to her mod, but you know, as Lynne is great in giving us some tips may be she can do it again....lol...
Reply With Quote
  #163  
Old 05 Mar 2010, 22:36
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Did you guys edit the css as I posted in the first post - step 3?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #164  
Old 08 Mar 2010, 14:36
arco arco is offline
 
Join Date: Apr 2007
This mod seems to conflict with the following two mods:

http://www.vbulletin.org/forum/showthread.php?t=180330
http://www.vbulletin.org/forum/showthread.php?t=232730

Ie they stop working when it's installed.
Reply With Quote
  #165  
Old 11 Mar 2010, 04:43
cloferba cloferba is offline
 
Join Date: Apr 2009
ready! thanks lynne
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:51.

Layout Options | Width: Wide Color: