Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Move smilies to below text area (and optionally add to Quick Reply) Details »
Move smilies to below text area (and optionally add to Quick Reply)
Mod Version: 1.4, by Lynne (Coder/Designer) Lynne is offline
Developer Last Online: Aug 2019 I like it Show Printable Version Email this Page

vB Version: 4.0.8 Rating: (26 votes - 4.73 average) Installs: 278
Released: 06 Dec 2009 Last Update: 21 Nov 2010 Downloads: 1448
Not Supported Uses Plugins Template Edits Auto-Template  

NOTE: This will break your 4.1.4 Quick Reply if you have smilies enabled there unless you do the edit below.

This moves the smilie box to below the text area when posting within threads, blogs, groups, PMs, and cms when using the Advanced Editor (new item or advanced reply). This is done using just CSS. The plugin simply appends the new CSS file to the editor.css file link in the page. It can also make the smiliebox show on the showthread page below the text box in Quick Reply if you do the Optional Edit below.

Attachment 107256

This mod is supported for the default style only as trying to debug other's site CSS issues is not easy.

This has been tested in firefox, Safari and IE7.


Version History:
1.0 2009-12-06: initial release by Lynne at vbulletin.org (pre 4.0.1)
1.1 2010-01-13: fixed issues with 4.0.1; made it move the smilies to the bottom for sending a new PM ('blog'), and for posting a New Discussion ('group') (4.0.1)
1.2 2010-01-23: fixed it to work if you store your css in the filesystem (4.0.1)
1.3 2010-05-05: added fields so it will work with vbcms and editpost (4.0.1)
1.4 2010-10-23: Modified CSS to use new stylevars - you do NOT need to upgrade to this version if your CSS is working just fine for you! (4.0.8 - see note below for 4.1PL1)


To install:

1. Import product-lynne_smilies_below.xml

2. Go to Settings > Options > Message Posting Interface Options > Put smilie box below textarea > Yes

3. Go to Settings > Options > Message Posting Interface Options and make sure you set these two settings:
Smiliebox Total Smilies - this is the total number of smilies you want to show
Smiliebox Rows (smilies below textarea) - this is the number of rows of smilies you would like

NOTE: The Total Smilies must be evenly divisible by the Rows, ie. you can't set the Total to 17 and have 2 Rows as that won't work.

4. OPTIONAL - If you also want the smiliebox to show on the showthread page under the Quick Reply, then you must do the following:
a. Go to Settings > Options > Message Posting Interface Options > Add smiliebox below Quick Reply on showthread page > Yes (Note that the above options, Put smilie box below textarea must also be set to Yes)
b. Make the following template edit in the template "showthread_quickreply".
Find the following:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add in the following line among the bottom divs (for 4.0.8):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


OR
Add in the following line among the bottom divs (for 4.1.0 PL1):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

OR in 4.1.10 forward, find this code in the SHOWTHREAD template:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add directly below there:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


To get this to work with 4.1.4 (and later) Quick Reply:
Edit the plugin "Add smilies to Quick Reply also" and remove, or comment out, the line:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


To uninstall:


1. Uninstall "Move smilies below textarea"
2. If you added the smiliebox to the showthread.php page in the Quick Reply, then remove the template edit done above.

This will not work for pre-beta 5 vB4.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	lynne_smilies_below.png
Views:	4359
Size:	34.0 KB
ID:	107256  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Find, Optionally Email and Optionally Delete Inactive Members amykhar vBulletin 2.x Beta Releases 94 23 Apr 2008 03:15

  #271  
Old 09 Apr 2011, 14:14
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
Ok, i managed to make the smilies to show in the PM-Quickreply box!

Simple edit to make in the template "pm_quickreply"

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add under:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You don't have to set up the option in the main panel "Add smiliebox below Quick Reply on showthread page" to yes!
I have another Plugin that conflict with this option and .....Lynne is too busy to play around with these

I tried to add the same code in the showthread-quickreply but it only shows the space the the smilies would be in and no smilies are showing

It as to be something so simple.....but i'm not a top coder

Hope it helped out a bit
Attached Images
File Type: jpg forum1.jpg (54.5 KB, 18 views)
File Type: jpg forum.jpg (63.4 KB, 8 views)
Reply With Quote
  #272  
Old 09 Apr 2011, 14:28
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
Oups! Just found another solution for the quick-reply !

In the showthread-quick reply

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add under:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This will show the smilie icon in the toolbar and you will be able to select them for yor reply

Enjoy!
Attached Images
File Type: jpg forum.jpg (101.3 KB, 24 views)
Reply With Quote
  #273  
Old 03 May 2011, 23:18
Leo Brazil's Avatar
Leo Brazil Leo Brazil is offline
 
Join Date: Dec 2007
Hi Lynne,

I tried everything here but couldn't find a way out, can you help me with this ?

I'm getting an strage issue with this.
Running on 4.1.3
I have set:
5 smiliebox rows
10 smiliebox per row
50 smiliebox total smilies

On Vb4 Default Style all I can get is a single row with 10 smilies

On my own Style (all Editor Stylevars are just the same as Vb4 default) I get a single row with 50 smilies (breaking out the editor box).

If I change the number of rows, smilies per row and total smilies (even doing the right math) all I can get is a single line on my Style with the same number of total smilies like on set up but on Vb Style nothing changes, just a single row with 10 smilies.

Also, I have lots of different smilies sizes, what's the best way to display biggers sizes looking better ?

Thanks
Reply With Quote
  #274  
Old 04 May 2011, 00:08
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
I would need a link to see what is going on. I just tried this on my 4.1.3 test site and it is working just fine. Try less smilies and see if it works.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #275  
Old 04 May 2011, 13:23
Leo Brazil's Avatar
Leo Brazil Leo Brazil is offline
 
Join Date: Dec 2007
Hi Lynne,

I've tried less, more, smilies and any kind of combination between total similies x total rows.

I'm working on this is a closed test forum, I can make you a admin login if you can take a look.
Reply With Quote
  #276  
Old 04 May 2011, 18:12
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Originally Posted by Leo Brazil View Post
Hi Lynne,

I've tried less, more, smilies and any kind of combination between total similies x total rows.

I'm working on this is a closed test forum, I can make you a admin login if you can take a look.
You can PM the info and I can take a look.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #277  
Old 05 May 2011, 10:56
dlewisr dlewisr is offline
 
Join Date: Mar 2011
Great mod Lynne. Installed and working great. A member was only asking about smilies on the 'Quick Reply' a couple of days ago. Installed, rated and nominated.

Thank you.
Reply With Quote
  #278  
Old 10 May 2011, 21:20
Leo Brazil's Avatar
Leo Brazil Leo Brazil is offline
 
Join Date: Dec 2007
Originally Posted by Leo Brazil View Post
Hi Lynne,

I tried everything here but couldn't find a way out, can you help me with this ?

I'm getting an strage issue with this.
Running on 4.1.3
I have set:
5 smiliebox rows
10 smiliebox per row
50 smiliebox total smilies

On Vb4 Default Style all I can get is a single row with 10 smilies

On my own Style (all Editor Stylevars are just the same as Vb4 default) I get a single row with 50 smilies (breaking out the editor box).

If I change the number of rows, smilies per row and total smilies (even doing the right math) all I can get is a single line on my Style with the same number of total smilies like on set up but on Vb Style nothing changes, just a single row with 10 smilies.

Also, I have lots of different smilies sizes, what's the best way to display biggers sizes looking better ?

Thanks
Just a feed back for everyone here:

There wasn't an issue, I mean besides my self...

I was using Fire Fox on debug mode all the time as it helps a lot to indenty Stylevars and after making all changes I mentioned, I should get out of debug mode and so clear the cache. Clearing the cache on debug mode for some reason were keeping some CSS info on it messing up with my life.
Just a tip for you guys.

Lynne, you're the best.
Reply With Quote
  #279  
Old 10 May 2011, 21:57
billstelling's Avatar
billstelling billstelling is offline
 
Join Date: Apr 2011
hey Lynne, I can't find this in 4.1.3 ".editor_smiliebox ul.smiliebox " I want to have it show more than 6 a row.. Have allot of smileys for the members to chose from..
Reply With Quote
  #280  
Old 11 May 2011, 01:33
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Originally Posted by billstelling View Post
hey Lynne, I can't find this in 4.1.3 ".editor_smiliebox ul.smiliebox " I want to have it show more than 6 a row.. Have allot of smileys for the members to chose from..
It's definitely there in a default 4.1.3 style.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #281  
Old 13 May 2011, 22:24
boodog boodog is offline
 
Join Date: Nov 2006
Thumbs up

Thank you, Lynne. Working perfectly in 4.1.2. Have two rows of 15 smilies ea below text area and Quick Reply. Really nice mod
Reply With Quote
  #282  
Old 14 Jun 2011, 04:00
ComoEstaEso-com ComoEstaEso-com is offline
 
Join Date: Jul 2009
Real name: AJ
Question vB 4.1.4 upgrade issue

Hello Lynne, and everyone,

This mod has been working awesome for a long time.
I upgraded last night to vB 4.1.4
Today I realized the quick reply was "broken".

So I traced it down to the VaultWiki modification... and effectively, the great VaultWiki team is working on it. Here's an update thread.

So VaultWiki disabled, the vB installation is better.

Yet for some odd reason, when I disable this modification (Move Smilies below text area), everything works as it should.

Attached are two screen shots:
on both, VaultWiki is disabled.

On this first one, Move smilies below text area is disabled
disabled.jpg

On this second one, Move smilies below text area is enabled.
enabled.jpg

Any thoughts on what I can check?

I realize the issue might very possibly not be related to this mod, yet I can only trace it here, and if it is not here, I'm sure I'll be sent to the proper place for further investigation.

Thank you Lynne and everyone... your help is greately appreciated!!

-- AJ
.
Reply With Quote
  #283  
Old 14 Jun 2011, 05:36
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
AJ, I already posted in the first post of this thread that you need to make a change to one of the plugins to have this work in 4.1.4. I'll post it here also in case people don't read the first post:

NOTE: This will break your 4.1.4 Quick Reply if you have smilies enabled there unless you do the edit below.


To get this to work with 4.1.4 Quick Reply:
Edit the plugin "Add smilies to Quick Reply also" and remove, or comment out, the line:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #284  
Old 14 Jun 2011, 16:38
ComoEstaEso-com ComoEstaEso-com is offline
 
Join Date: Jul 2009
Real name: AJ
Lynne, as always, thank you very much.

It was my fault that I didn't read the 1st post, to see if you had edited it with the new information.
Should have done that.

I will do the modifications, and update later today.
Thank you for your help and work Lynne... greatly appreciated!!

-- AJ
.
Reply With Quote
  #285  
Old 17 Jul 2011, 15:40
MySaltyreef's Avatar
MySaltyreef MySaltyreef is offline
 
Join Date: Jun 2011
i am about to install this on 4.1.4 and would like to know if i still do step 4

4. OPTIONAL - If you also want the smiliebox to show on the showthread page under the Quick Reply, then you must do the following:
a. Go to Settings > Options > Message Posting Interface Options > Add smiliebox below Quick Reply on showthread page > Yes (Note that the above options, Put smilie box below textarea must also be set to Yes)
b. Make the following template edit in the template "showthread_quickreply".

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

aswell as this

To get this to work with 4.1.4 Quick Reply:
Edit the plugin "Add smilies to Quick Reply also" and remove, or comment out, the line:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

just confirming i must actually do both ? and not just the last one ?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:51.

Layout Options | Width: Wide Color: