Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs Details »
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs
Mod Version: 2.5.6, by The Geek (Coder) The Geek is offline
Developer Last Online: Jan 2019 I like it Show Printable Version Email this Page

vB Version: 3.8.0 Rating: (192 votes - 4.75 average) Installs: 1968
Released: 20 Jan 2009 Last Update: 09 Dec 2009 Downloads: 12887
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

From the makers of the letters O and Yea comes the hottest 'must have mod' of the season: AME 2.5 - The Return of The Hot Mama.

Thanks everyone for making AME 2.5 Mod of the Month

AME is the multi award winning modification that smartly scans new and edited posts for URLs from a customisable variety of web sites (i.e. YouTube or Amazon or about 200 others). If it finds a match, AME will 'transform' the URL into inline embedded media without your users ever having to even think about it.

It was important for me to create a system that did not need updating (and subsequent reinstalling) every time one of the sites it supported decided to change the way it displayed its media (which is all the fricken time). Therefore I built a system in which the 'definitions' for each site could be imported, exported, tweaked and shared on a whim. This way, you only have to import the definitions that you want. It also allows the vB community to get creative and share definitions that I wouldn't of thought of!

Which sites are supported?

Included in the default installation is YouTube and Amazon. At time of posting this, I believe that there are over 180 sites supported that have been created by the vBulletin community. These range from sites that stream videos to Amazon referral links to locally hosted music and video files.

Check out the 'add ons' section of this post below to see availible add-ons.

For a total list of features and an FAQ, see click here.
For a post on troubleshooting, click here.

Though not tested on any version of vBulletin lower than 3.7.4, in theory it should work on versions 3.5 and higher (just dont quote this bit!).

Big thanks goes out to all those in the community that have supported this mod. Especially Digital Jedi who gives great support on this mod and has created over 160 definitions for this system alone!


Installation/Upgrade
  • Upload the contents of the forums folder into your forums directory and import the product-ame.xml file into your product manager (if upgrading, choose 'yes' to overwrite previous installation).
  • After installation, make sure that the system is on (admincp->AME CP->Settings)
  • Then you may want to try to rebuild old URLs via the tools option.

Change Log
nJoy

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	newpost.jpg
Views:	6638
Size:	26.4 KB
ID:	93148   Click image for larger version

Name:	newpost_result.jpg
Views:	9503
Size:	61.9 KB
ID:	93149  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases DJ's AMEs :: Media Definitions for AME 2.5 :: More Video, Twitter, Pinterest... Digital Jedi vBulletin 3.8 Add-ons 2086 05 Sep 2018 16:05
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Show Thread Enhancements AME 2.0 -Auto Media Embedding for posts, blogs, visitor and group messsages The Geek vBulletin 3.7 Add-ons 954 25 May 2014 10:58
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #1621  
Old 18 Mar 2012, 16:08
sailnet sailnet is offline
 
Join Date: Oct 2009
this mod does not work with the android or iphone apps sold by vbulletin. has anyone tacked this problem - the code displayed for a link to a youtube video seems to have a problem right at the end of the link and displays (ame?) non underlined after the link.

has anyone tried to fix this problem?

I'm running 3.8.4
Reply With Quote
  #1622  
Old 17 May 2012, 03:29
emdee emdee is offline
 
Join Date: Jul 2006
hi

not able to embed videos, (youtube for example), unless im using [ame] .... [/ ame] bb code.

what am i doing wrong?

im running version 3.8.4
Reply With Quote
  #1623  
Old 10 Jun 2012, 00:38
seanadl seanadl is offline
 
Join Date: Jan 2007
Something odd has happened. I've had this mod working on my forum for a number of months now. I had to use vbulletins internal "rebuild the post cache". Ever since doing that some posts in the forum which contained media are either showing blank or the videos that are embedded within them while everything else does.

The tags are still there. If i go to edit an affected post and then re-save the videos appear again.

I'm not sure what has happened. Is there an easy way to fix this which doesn't involve me trawling through the forum and manually editing broken posts as and when i see them?
Reply With Quote
  #1624  
Old 10 Jun 2012, 01:39
ehd ehd is offline
 
Join Date: Jun 2009
Please try this:

http://www.vbulletin.org/forum/showt...99#post1796799
Reply With Quote
  #1625  
Old 24 Jul 2012, 19:15
basketmen's Avatar
basketmen basketmen is offline
 
Join Date: Nov 2006
Hi guys, i already searching in this thread and other threads, but still cant found it :

the url using https is not embeding, for example :

https://www.youtube.com/watch?v=D6s5l2PVvug


currently google and youtube are using secure urls (https) for they members


please try in your forum and share solution if you have
__________________
I am SEO specialist and forum coordinator
Reply With Quote
  #1626  
Old 24 Jul 2012, 21:56
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by basketmen View Post
Hi guys, i already searching in this thread and other threads, but still cant found it :

the url using https is not embeding, for example :

https://www.youtube.com/watch?v=D6s5l2PVvug


currently google and youtube are using secure urls (https) for they members


please try in your forum and share solution if you have
I'm logged into Youtube and am not having any https URLs... that said it should be a fairly simple fix...

What do you have in the Regular expression box for the YouTube definition?

If it starts with http:// just change it to https*:// and that should work with both http and https links.
__________________
-Joe
Former vb.org Moderator. Retired.

@BirdOPrey5 | All Things BOP5 | Joe's Ultimate Off Topic
Note - I no longer making new VB mods, sorry.
Reply With Quote
  #1627  
Old 26 Jul 2012, 20:37
Dark_Sirius Dark_Sirius is offline
 
Join Date: Aug 2006
This is an issue with Vimeo also... they are moving over to all https and AME won't embed the https. Also, AME won't embed youtube vids that are not of this format:

http://www.youtube.com/watch?v=0MOlGyeE6ps

If it has anything like below, such as &feature, or &related, they won't embed. They have to be the 'long link' as shown above.

http://www.youtube.com/watch?v=0MOlG...eature=g-all-u
__________________
Admin @ M3Forum.net
Reply With Quote
  #1628  
Old 31 Jul 2012, 20:52
jl255 jl255 is offline
 
Join Date: May 2007
indeed, any solution for https youtube links???

if i removed AME now, will all my past youtube videos stop displaying too?
Reply With Quote
  #1629  
Old 31 Jul 2012, 22:32
ChiNa ChiNa is offline
 
Join Date: Jul 2012
Real name: CM
Jl255, Well yes your vides will not show up! Only the link will display! But not the videos!

But have you seen this link, supports other sites, which I installed last night on my site, its amazing! Its totally the best and my favorit ADDON so far Check it out: http://www.vbulletin.org/forum/showt...&highlight=ame

If you wanted to remove it then, You will need have another Addon if you want your videos to show and not edit them all again! Else you will have to use a BBCODE, and edit each and every post again! Here is a link to a full Youtube BBCODE embed:
http://www.vbulletin.org/forum/showthread.php?t=216048

There is one more addon that you will have to edit some of your files too, If I find it, I will send it to you!

But if you want my advice, dont delete the AME Embedder, its not using any memory or space! Only if you have the CACHE enabled!
__________________
I am having a little break from vB Developing. I am trying to finish my PHP and MYSQL courses for now. I will answer all my PM's if anyone needed help for my products, but only when I can be online on vB.org. Its great to see new and old developers keeping vB.org alive! Thank you all for your support!CM
Reply With Quote
  #1630  
Old 31 Jul 2012, 22:39
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Can someone please post a URL of an "https" youtube link you are trying to embed? I can't find any.
__________________
-Joe
Former vb.org Moderator. Retired.

@BirdOPrey5 | All Things BOP5 | Joe's Ultimate Off Topic
Note - I no longer making new VB mods, sorry.
Reply With Quote
  #1631  
Old 01 Aug 2012, 00:25
Crazihorse2 Crazihorse2 is offline
 
Join Date: Jun 2009
Very nice, thank you so much!
Reply With Quote
  #1632  
Old 10 Sep 2012, 18:59
eJM's Avatar
eJM eJM is offline
 
Join Date: Sep 2004
Real name: Jim McClain
Originally Posted by BirdOPrey5 View Post
Can someone please post a URL of an "https" youtube link you are trying to embed? I can't find any.
I think that may be a "feature" of a particular browser. I set this up for a client yesterday and he complained that his videos weren't showing. As he was explaining, he said he was using Chrome and the sites he visited were all https://. His main concern was Vimeo. I use FF, so when I clicked an https:// link he sent me in an email, I found that the page was NOT https:// in my browser.

However, I did add that s* code you provided in the regex box and it works fine. Thanks for that.

Jim
__________________
Always a work in progress:
The Floor Pro Community
Reply With Quote
  #1633  
Old 11 Sep 2012, 13:37
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Jim, I know there is an "https everywhere" extension for Chrome that tries to use https wherever possible, that might be it.
__________________
-Joe
Former vb.org Moderator. Retired.

@BirdOPrey5 | All Things BOP5 | Joe's Ultimate Off Topic
Note - I no longer making new VB mods, sorry.
Reply With Quote
  #1634  
Old 04 Oct 2012, 03:36
JoshPet JoshPet is offline
 
Join Date: Sep 2004
If I run the ultility to regnerate the embed codes, I do see embeded Youtube codes. If I make a new post, with a Youtube link, it doesn't show as embedded.

I've got Extract destination data set to Yes
and Disable New Items set to No.
Reply With Quote
  #1635  
Old 22 Nov 2012, 08:57
J4CKT J4CKT is offline
 
Join Date: Aug 2009
Hi guys,

I have an issue where if a regular user posts a youtube link it will not embed and just show the link as it normally would.

But once an admin comes in and clicks edit then save on that post the video shows like it should.

Has anyone had this happen on their site?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 18:31.

Layout Options | Width: Wide Color: