Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 29 Oct 2014, 10:14
Peter Cook's Avatar
Peter Cook Peter Cook is offline
 
Join Date: Aug 2010
Server issues?

Not sure if this is the right place, but, our website has been having extremely slow loading times and sometimes being reported database errors! below are a couple of reported errors.

example 1:
Invalid SQL:

SELECT *
FROM session
WHERE userid = 0
AND host = '62.4.27.91'
AND idhash = '64519265b60532704e960889f9c10763'
LIMIT 1;

MySQL Error : MySQL server has gone away
Error Number : 2006

example 2:

mysql_connect(): User lswukcouk already has more than 'max_user_connections' active connections
/hermes/waloraweb044/b1061/moo.lswukcouk/includes/class_core.php on line 317

MySQL Error :
Error Number :


Can anyone help with this as the hosting company says it's loading fine at their end.

thanks all.
Reply With Quote
  #2  
Old 29 Oct 2014, 10:24
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
The first one is a hosting problem
the 2nd one tell your hosts to change max connections in the php.ini file
either way your hosts need to fix the problems
Reply With Quote
  #3  
Old 30 Oct 2014, 10:29
Peter Cook's Avatar
Peter Cook Peter Cook is offline
 
Join Date: Aug 2010
I had a feeling that was the issue but according to them there are no problems!
Reply With Quote
  #4  
Old 30 Oct 2014, 11:20
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
the 2nd one you could fix yourself but only if you have access to where the php.ini is stored
Reply With Quote
  #5  
Old 30 Oct 2014, 18:08
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Originally Posted by Peter Cook View Post
I had a feeling that was the issue but according to them there are no problems!
If you are on a shared host then they are most likely limiting your resource usage. You need to try to lessen those query connections or upgrade to a bigger hosting package.

if you are on a dedi then adjust php.ini max connections as Force mentioned.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #6  
Old 01 Nov 2014, 15:54
Peter Cook's Avatar
Peter Cook Peter Cook is offline
 
Join Date: Aug 2010
My package is unlimited but the sql server is shared, the hosting company said they have had instances of large corperates taking up all the resources unneccessarily and are in touch with them which I thought strange.
Reply With Quote
  #7  
Old 01 Nov 2014, 18:56
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Yeah, they say unlimited but you are sharing with who knows how many other websites. There are probably some ways you can reduce those connections though. Do they happen at a certain time of day? many times these happen when running back ups, sitemap generation, mass email, etc. if that is the case adjust your cron task times to make those processes run at slower times.

There are also some good threads here on reducing server load. Look them up and follow the advice and it may help you with this. I do not see your host being particularly helpful.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 06:39.

Layout Options | Width: Wide Color: