Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
DownloadsII Details »
DownloadsII
Mod Version: 6.0.9, by RS_Jelle (Coder) RS_Jelle is offline
Developer Last Online: May 2016 I like it Show Printable Version Email this Page

vB Version: 4.0.4 Rating: (269 votes - 4.79 average) Installs: 1644
Released: 28 Dec 2009 Last Update: 02 Dec 2011 Downloads: 10876
Not Supported DB Changes Uses Plugins Auto-Template Additional Files  

DownloadsII

DownloadsII is a download database that integrates into vBulletin. It allows you to upload files, add images to them, create categories, link to external files - and more. It is very flexible and has many options.

It's also coded 100% XHTML 1.0 Transitional valid, just like vBulletin itself.



Instructions & Support

Requires vBulletin 4.0.4 or higher. Not fully compatible with lower vB 4 versions.
It works fine with both the new editor in vB 4.1.4 or higher and the old one in previous vB versions.

Read the instructions in the next two posts before installing/upgrading this mod!

You can find an installation/upgrade manual in the zip package (Readme.txt).

I try to answer most questions asked in this thread. Please don't send any pm's if I don't ask for them. Don't forget to click the install link, so you will receive important update notifications.

Screenshots & Live demo

At the bottom of this post, you can find some screenshots of the front-end and back-end (AdminCP part) of the DownloadsII software.

You can find a live demo on my own site: Minatica.be Downloads (Dutch).
Though keep in mind that we are running a restyled and modified version of it.

Changelog (version 6.0.9)

Jelle
  • Added support for vB 4.1.8 bit processing with 'each' construct (backwards compatible)
  • Fixed comma listing for vB 4.1.8 (using "old" method)
Older changelogs are included in the zip package.

Help!!! I can't upload large files??

This is probably the most asked question. It's mostly caused by some default PHP settings: check "PHP Max Post Size" and "PHP Maximum Upload Size" at your AdminCP home.

Then have a look at this post for the solution to up these values.
Also have a look at this post at vB.com (but ignore the MySQL part as DownloadsII is only using the file system).

Add-ons

There are currently no official add-ons. Unofficial add-ons are listed below.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	DownloadsII_v6_Main.jpg
Views:	11261
Size:	74.2 KB
ID:	108404   Click image for larger version

Name:	DownloadsII_v6_Category.jpg
Views:	9976
Size:	96.7 KB
ID:	108405   Click image for larger version

Name:	DownloadsII_v6_File.jpg
Views:	9578
Size:	75.3 KB
ID:	108406   Click image for larger version

Name:	DownloadsII_v6_Add_File.jpg
Views:	5876
Size:	58.3 KB
ID:	108407  

Click image for larger version

Name:	DownloadsII_v6_Search.jpg
Views:	5762
Size:	72.2 KB
ID:	108409   Click image for larger version

Name:	DownloadsII_v6_AdminCP_Settings.jpg
Views:	5384
Size:	84.3 KB
ID:	108410   Click image for larger version

Name:	DownloadsII_v6_AdminCP_Categories.jpg
Views:	4474
Size:	62.9 KB
ID:	108411  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions DownloadsII RS_Jelle vBulletin 3.8 Add-ons 4347 13 Apr 2016 22:17
Add-On Releases DownloadsII ver 5.0 vbAdvanced Add-On CyberRanger vBulletin 3.6 Add-ons 159 01 Jul 2011 19:15

  #1156  
Old 05 Jan 2011, 09:18
Louva-Deus Louva-Deus is offline
 
Join Date: Jan 2008
Liking the mod so far. Found a bug that has existed at least since 6.0.5 that causes an Internal Service Error 500 for non-linked files.

To fix it make the following changes in downloads.php:

Line 688:
$ctype = "application/force-download";
Line 764:
header("Content-Type: $ctype; name=\"".basename($dlfilename)."\";");
Cheers!

Last edited by Louva-Deus; 05 Jan 2011 at 09:25.
Reply With Quote
  #1157  
Old 05 Jan 2011, 13:20
abdulbasitsaeed's Avatar
abdulbasitsaeed abdulbasitsaeed is offline
 
Join Date: Mar 2009
Also, how can I change the length of the name of the uploaded file. Currently, it seems to be something like 50 characters.
Reply With Quote
  #1158  
Old 05 Jan 2011, 16:12
RK KINGKONG RK KINGKONG is offline
 
Join Date: May 2010
Real name: ROBB
ive checked

yes the permissions are set for me the owner , then under attachment permissions i have it set to 370 mb in bytes numbers cause thats how you have to type it in , and when i check my viewPHPinfo under site Maintenance it shows me ine the PHP CORE BLOCK that all the changes i made took ... so i dont know but im sure someone will help me figure this out , cause since im the biggest noob here im positive im missing something or did something wrong or maybe just my host sucks that bad
Originally Posted by TeknoSounds View Post
have you limited the filesize upload in the usergroup settings?
Reply With Quote
  #1159  
Old 05 Jan 2011, 20:49
TeknoSounds TeknoSounds is offline
 
Join Date: Nov 2006
Originally Posted by RK KINGKONG View Post
yes the permissions are set for me the owner , then under attachment permissions i have it set to 370 mb in bytes numbers cause thats how you have to type it in , and when i check my viewPHPinfo under site Maintenance it shows me ine the PHP CORE BLOCK that all the changes i made took ... so i dont know but im sure someone will help me figure this out , cause since im the biggest noob here im positive im missing something or did something wrong or maybe just my host sucks that bad
try increasing the limit you set for the owner group, sometimes I found I had to bump up the file size even though the file I was uploading *should* have been under the limit, but kept saying it wasn't.
Reply With Quote
  #1160  
Old 05 Jan 2011, 21:35
hmccaig hmccaig is offline
 
Join Date: Feb 2007
lots of threads to go through, but perhaps I missed it, is there a way to set permissions on which groups can "download" or see it or see the download categories? Thanks in advance. great plugin!
Reply With Quote
  #1161  
Old 05 Jan 2011, 22:28
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
RK KINGKONG file size is set in the php.ini
you will have to ask your host to increase the max upload
and post so you will be able to upload those size files....
default is 2 and 8 megs...
Reply With Quote
  #1162  
Old 06 Jan 2011, 01:36
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
Originally Posted by RK KINGKONG View Post
wow this is crazy well i have ti all running and well now images,files categories ETC.... now i followed the links here for the file max upload .. :

memory_limit = 128M
post_max_size = 300M
file_uploads = On
upload_max_filesize = 500M
max_execution_time = 3600
max_input_time = 1700

and GODADDY.com tells me that should change it , but still when i try to upload a file thats 191 MB in size its telling me :
The uploaded file is too big. The file size may be maximum 86.29 MB.

I NOTICE RS_JELLE HAS FILES AS BIG 370MB , I almost passed out , being though it wont let me do bigger than 86 MB

I also seen somewhere that you have to restart your server or something for the difference to take place but GODADDY says though im on an unlimited plan , im also on a shared plan so they cant just restart the server .. what can i do please ?

also rs_jelle method to create a .htaccess file with the following and adjust the numbers :
You need to create a file named .htaccess (note the period in front of the name). Put the following two lines into the file:
Code:
php_value upload_max_filesize 30M
php_value post_max_size 30M

that doesnt work for me cause once i drop that .htaccess into the root of my ftp , then it gives me a fatal error like the site wont load unless i take that out of there ................
found this on a google search to help explain it a little for you

Most of the web servers are configured such a way that a user can only upload the maximum file size of 2MB. So there might be the problem for the people who wants to upload the .zip files of size around 150MB.
increse the maximum upload file size limit by using .htaccess file.


upload such a large file using file field of the form and move_uploaded_file() function in PHP.

1) Create a .htaccess file in the root folder of web server.

2) Put the following code in side the .htaccess file and save it.

php_value upload_max_filesize 200M
php_value post_max_size 200M
php_value max_execution_time 200
php_value max_input_time 200
Now you can upload the file-size up-to 200MB in a simple way using file field in your html form and move_uploaded_file() function available in PHP. In the above .htaccess file, uploading capability is increased by the four parameter first one is maximum file size for uploading, second one is maximum size of the post data , third one is maximum time in seconds a script is allowed to run before it is terminated by the parser and last one is maximum time in seconds a script is allowed to parse input data such as like file uploads, POST and GET data.

You can change the above parameter to upload the bigger file size than 200MB.
Reply With Quote
  #1163  
Old 06 Jan 2011, 03:47
TeknoSounds TeknoSounds is offline
 
Join Date: Nov 2006
If you look in his post, hes already changed it to appropriate sizes and his phpinfo page is reflecting that.
Reply With Quote
  #1164  
Old 06 Jan 2011, 22:01
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
TeknoSounds
This was only for the htaccess issue he mentioned..
about not being able to access his site after adding .htaccess
htaccess does not work.. with out the dot.

maybe he made the file wrong or missed something simple..
Just trying to help as you are..
Reply With Quote
  #1165  
Old 06 Jan 2011, 23:41
TeknoSounds TeknoSounds is offline
 
Join Date: Nov 2006
oh no hippy don't mistake me, I'm not trying to come down on you or anything just pointed out he had changed it...its saying he did in his phpinfo file and godaddy is telling him the same. The only reason you need to modify the htaccess file is whenever you can't change your php.ini file.

RK KingKong: I'm curious in seeing 1) your phpinfo page to verify these changes are made and 2) WHERE is the error appearing saying you can't upload the file because its too big. Is it showing you in DownloadsII or are you getting a timeout page or something in your browser?
Reply With Quote
  #1166  
Old 07 Jan 2011, 00:30
RK KINGKONG RK KINGKONG is offline
 
Join Date: May 2010
Real name: ROBB
I seriously appreciate the help ppl have been trying to give me but , creating a .htaccess file isnt helping no matter where i put it , i have tried in the main root , and also within the downloads folder .. neither works..
I only have a php5.ini in my root , i have set the settings to show increased sizes within the php info n php5.ini .
which shows this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I have also tried creating my own php.ini file without the 5 and putting it into my root .. ive been on the phone with GODADDY numerous time all they can say is , if its changing in your php info it should make the change the restarting of the server isnt possible cause im on a shared plan but also not needed .....
Im at a stand still with this unless i wind up getting some expert to help me with it .. I know someone out there can pin point whats happening , im sure im not the only one who has had this problem..
this is where i lack the experience . i just started working with this whole website and VB thing overnight ...

further more i have a download on my site right now that was allowed
437 Styles for Photoshop : (153.82 MB)
but when i try one that 191.mb is tells me my max is only 86.mb im loosing sleep over this i swear
Reply With Quote
  #1167  
Old 07 Jan 2011, 00:45
RK KINGKONG RK KINGKONG is offline
 
Join Date: May 2010
Real name: ROBB
Question Thanks For Caring First Off

Ill show you here
is the phpinfo

here is my FTP and GODADDY PHP5.INI side by side :

so it shows the changes have been made ..
the error comes from within the downloads mod page on my site , so for example i go to add a file , then i choose the file add it .. it starts what seems to be the upload with the percentage showing in the bottom left hand corner .. once it reaches 100% it refreshes and tells me that the file is to big and that my limit is only like 86.MB

Originally Posted by TeknoSounds View Post
oh no hippy don't mistake me, I'm not trying to come down on you or anything just pointed out he had changed it...its saying he did in his phpinfo file and godaddy is telling him the same. The only reason you need to modify the htaccess file is whenever you can't change your php.ini file.

RK KingKong: I'm curious in seeing 1) your phpinfo page to verify these changes are made and 2) WHERE is the error appearing saying you can't upload the file because its too big. Is it showing you in DownloadsII or are you getting a timeout page or something in your browser?
Attached Images
File Type: jpg PHPINFO.jpg (62.1 KB, 1 views)
File Type: jpg PHPINFO2.jpg (127.7 KB, 2 views)
Reply With Quote
  #1168  
Old 07 Jan 2011, 02:16
TeknoSounds TeknoSounds is offline
 
Join Date: Nov 2006
okay awesome. you can take those down if you want

The issue is def within the usergroup settings, try increasing the max upload size limit there. There's an issue I've noticed where the filesize you put in ends up limiting you lower.

This setting here: This is the maximum MB that a user can upload. Set this to -1 for there to be NO limit.

I would try setting that to -1 for testing purposes. Then try increasing the limit until it gives you the actual number you desire.

Btw, RS_Jelle....bug in the usergroup filesize limit settings. :-/
Reply With Quote
  #1169  
Old 07 Jan 2011, 02:51
RK KINGKONG RK KINGKONG is offline
 
Join Date: May 2010
Real name: ROBB
Question thanks again but

the correct setting was already in there :

so still i dont know what to do

Originally Posted by TeknoSounds View Post
okay awesome. you can take those down if you want

The issue is def within the usergroup settings, try increasing the max upload size limit there. There's an issue I've noticed where the filesize you put in ends up limiting you lower.

This setting here: This is the maximum MB that a user can upload. Set this to -1 for there to be NO limit.

I would try setting that to -1 for testing purposes. Then try increasing the limit until it gives you the actual number you desire.

Btw, RS_Jelle....bug in the usergroup filesize limit settings. :-/
Reply With Quote
  #1170  
Old 07 Jan 2011, 03:48
TeknoSounds TeknoSounds is offline
 
Join Date: Nov 2006
Oh silly me.

What about in your Extensions settings? Whats the max file size there? That's the one you'll prolly have to play with, not the usergroup settings. My apologies, I got them confused.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 18:56.

Layout Options | Width: Wide Color: