Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Email Integration (New threads/replies by email) Details »
Email Integration (New threads/replies by email)
Mod Version: 2.6, by Cyricx (Member) Cyricx is offline
Developer Last Online: Dec 2011 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (36 votes - 4.72 average) Installs: 190
Released: 02 Jul 2007 Last Update: 29 Feb 2008 Downloads: 1978
Not Supported DB Changes Uses Plugins Template Edits Auto-Template Code Changes Additional Files  

This mod is based off of the Mail Reply modification by Colin F to which I have obtained permission to rewrite and release.

This modification allows you to mimic email lists such as yahoo groups through your forums!

After installing this modification you will have new settings in your forum manager where for each forum you can enable this modification and setup a separate email address to use for each forum that you have this enabled for.

Just like how there is a separate email address for each yahoo group.

After doing so, members can subscribe to each forum that this mod is enabled for to receive notifications for new threads and replies.

Any posts in that forum, will be sent to them via email. (Example email attached below). The users can then reply to that email (which will then be processed and posted to the forums through the cron job that runs every 10 minutes), or they can send a new email to the email address and a brand new thread will be created!

Essentially mimicing an email list! Suddenly those users that hate forums, can still be dragged into the conversations and help keep the forum's activity level up!


BUGS!
These are the known bugs to date:
  • Confirmed bug that email processing does not handle Japanese characters.
Unsupported Items
These are the items that are not currently supported:
  • Some custom bbcode modifications will not display like they do on the forums in the html emails. Like glow, and the table mod.
TO UPGRADE
  • Please see the file in the zip for upgrading!! If your upgrading from version 2.3.X you will need to reverse some file edits that are no longer nessecary!
NEW INSTALL
  • See instructions in the zip file.
VERSION HISTORY!
(See the file in the zip for a complete history!)
  • 2.6 Release
    • Bug Fixes
      • Joining an unmoderated public group will now auto subscribe you per the usergroup settings.
      • NO CONFLICTS with Instant Thread Subscription! See details in below post.
    • New Stuff
      • User Option Allow Auto Subscribe - This is an admin allowable, user option that let's the user choose to not be auto subscribed.
      • User Option not receive own posts - A new user option that lets them select to NOT receive their own posts via email.
      • Editted the phrase for the Auto Subscription script to tell people what to do if there are no listings.
      • Added error checks when saving a usergroup for if auto subscriptioin is entered with a forumid for a forum that does not have email integration enabled and also checks that the usergroup you are saing is entered in the forum manager as allowed to use email integration.
  • 2.6.1 Release (BETA VERSION)
    • Hot Fix
      • It appears I was unseting a variable too soon. I've corrected this and it has resolved the issue with multiple posted replies on my test server.
Most of these will be slow to make it in til I know I've got the code to handle just about every type of email we could receive But in anycase, here are the ideas for future versions!
  • End User Option to subscribe to just receive new thread emails, or receive all new thread & reply emails (current version does all new threads & replies).
Thanks to RedTyger, Bob Denny, Ed Kohwley and Chris McKeever for their additions and assistance with portions of this code.

Huge thanks also goes to the many individuals that have helped test various incarnations of this mod.

MAD PROPS TO: cgmckeever for a great quoting regex for the old format, and all the mods at www.4winmobile.com for helping test version 2.4 prior to release!!

You guys rock!

Please feel free to donate to my continued work on this modification!! It let's me spend more time on it!
Make a Donation!


Version 2.6 will work with both 3.6.8 and 3.7!


The #.X versions are the solid tested versions.

The #.X.X versions are the beta versions. New features and bug fixes will be worked in there and then when I have a solid version it'll be released as the next #.X

Thank you!!

~ Cyricx

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	exampleemailnewformat.jpg
Views:	1951
Size:	90.0 KB
ID:	74777   Click image for larger version

Name:	exampleemailoldformat.jpg
Views:	2119
Size:	42.7 KB
ID:	74778   Click image for larger version

Name:	examplesubforum.jpg
Views:	1450
Size:	26.2 KB
ID:	75917  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions Email Integration (New Threads/Replies by and through email!) Cyricx vBulletin 3.7 Add-ons 357 24 Jun 2014 21:05

  #1051  
Old 05 Jan 2012, 14:21
bumper2011 bumper2011 is offline
 
Join Date: Feb 2011
this "invalid email" error happens when I use an Exchange 2010 mail account for the forum email integration. But I have just tested with Gmail IMAP, it works. Could anyone help on this? Thanks a lot.


Originally Posted by bumper2011 View Post
hi everyone, may I have your help & advice? I have configured & tested the email integration feature. I did receive email when there is new post in the forum. However, there is no reply post if I replied the email with content.

I have enabled the log in Scheduled Task Manager, and tried with a few runs. the log just show "Email Integration results Opened mailbox for <MYFORUM> Invalid email @" or "Email Integration results Opened mailbox for <MYFORUM> No messages found for <MYFORUM>"

I think the "no message" in log is regarded as normal as it deletes the message after grabbing. But why does it say "Invalid email"? what is the possibility of the problem?

thanks.
Reply With Quote
  #1052  
Old 14 Jan 2012, 06:14
bumper2011 bumper2011 is offline
 
Join Date: Feb 2011
ok, i set to use POP and working now with the Exchange server.
Reply With Quote
  #1053  
Old 04 Feb 2012, 21:35
digeditor digeditor is offline
 
Join Date: Jan 2012
Real name: Jim
I'm trying to make this work in vb 4.1.10.
However when I run the script to check for errors it gives the following messages:

Warning: require_once([path]/includes/functions_wysiwyg.php) [function.require-once]: failed to open stream: No such file or directory in [path]/includes/cron/emailintegration.php on line 40

Fatal error: require_once() [function.require]: Failed opening required '/homepages/41/d397870833/htdocs/includes/functions_wysiwyg.php' (include_path='.:/usr/lib/php5') in /homepages/41/d397870833/htdocs/includes/cron/emailintegration.php on line 40

which I think means that there is no wysiwyg.php file. I check the includes dir and sure enough that file doesn't exist. It wasn't in the BETA zip file either. Can someone point me to it?

Jim
Reply With Quote
  #1054  
Old 06 Feb 2012, 14:23
jdj jdj is offline
 
Join Date: Sep 2009
Real name: JJ
Originally Posted by digeditor View Post
there is no wysiwyg.php file. I check the includes dir and sure enough that file doesn't exist. It wasn't in the BETA zip file either. Can someone point me to it?
I gave up on this mod, although I'd still be interested if it worked. I haven't checked but have you looked for a functions_wysiwyg.php file as opposed to a wysiwyg.php file?
Reply With Quote
  #1055  
Old 12 Feb 2012, 18:09
digeditor digeditor is offline
 
Join Date: Jan 2012
Real name: Jim
I've checked every directory in the install. Doesn't seem to be there.

Any other ideas?
Reply With Quote
  #1056  
Old 13 Feb 2012, 14:38
tdarvill tdarvill is offline
 
Join Date: Mar 2011
For 4.x it appears the "functions_wysiwyg.php" file is no longer present.
Have you tried editing emailintegration.php to use "functions_editor.php" instead?
Not sure if this is the right fix however.
Reply With Quote
  #1057  
Old 15 Feb 2012, 18:08
digeditor digeditor is offline
 
Join Date: Jan 2012
Real name: Jim
Thanks. I tried that. I guess it worked. Now some of my listserv's posts are showing up so it looks like whatever was the problem, this was the cure!!?

I think the problem for the rest of them not showing up is unrelated, more likely that I haven't loaded those users into the forum yet.
Reply With Quote
  #1058  
Old 15 Feb 2012, 18:32
digeditor digeditor is offline
 
Join Date: Jan 2012
Real name: Jim
Registration form is a mess

After I installed this Mod, when someone attempt to register for my forum it becomes impossible as they get the form overlaid with all of the following and the entry fields become unusable:

Username is valid and not in use.

Please enter the name by which you would like to log-in and be known on this site.

Password:
Confirm Password:

Please enter a password for your user account. Note that passwords are case-sensitive.

Email Address:
Confirm Email Address:

Please enter a valid email address for yourself.
Image Verification:

Please enter the six letters or digits that appear in the image opposite.
Registration Image Refresh Image
Additional Required Information (profile)
Street Address:

Location:

Where you live
Additional Information
Referrer:

If you were referred to this site by an existing member of Answer Line, enter their username here.
Time Zone:

All timestamps displayed on the forums can be automatically corrected to show the correct time for your location in the world. Simply select the appropriate time zone from the list below.
DST Correction Option:

In addition, you may set the appropriate option to allow for daylight savings time in your part of the world.
Receive Email...

Receive Email from Administrators
Receive Email from Other Members

From time to time, the administrators and/or other members may want to send you email notifications or messages. If you do not want to receive email from certain people then you may disable the options here
Forum Rules

In order to proceed, you must agree with the following rules:

Forum Rules

Registration to this forum is free! We do insist that you abide by the rules and policies detailed below. If you agree to the terms, please check the 'I agree' checkbox and press the 'Complete Registration' button below. If you would like to cancel the registration, click here to return to the forums index.

Although the administrators and moderators of Answer Line will attempt to keep all objectionable messages off this site, it is impossible for us to review all messages. All messages express the views of the author, and neither the owners of Answer Line, nor vBulletin Solutions, Inc. (developers of vBulletin) will be held responsible for the content of any message.

By agreeing to these rules, you warrant that you will not post any messages that are obscene, vulgar, sexually-oriented, hateful, threatening, or otherwise violative of any laws.

The owners of Answer Line reserve the right to remove, edit, move or close any content item for any reason.
I have read, and agree to abide by the Answer Line rules.

Contact Us
DIG Answer LineCopyright
Archive
Top

All times are GMT. The time now is 05:58 PM.
Powered by vBulletin® Versi

If someone can point me to where all this comes from, I'll attempt to solve the problem.

TIA
Reply With Quote
  #1059  
Old 26 Jul 2012, 21:00
reedness reedness is offline
 
Join Date: Jul 2012
Has anybody had any luck with 4.2.0?
Reply With Quote
  #1060  
Old 09 Aug 2012, 16:13
ahobilam's Avatar
ahobilam ahobilam is offline
 
Join Date: Aug 2011
Real name: NVS
I also seeking such mod for 4.2.x
Please inform if anybody got succeeded!
Reply With Quote
  #1061  
Old 09 Aug 2012, 16:24
neil00027 neil00027 is offline
 
Join Date: Dec 2007
I also would be keen to use this mod if it was updated for 4.2.x

Cyricx can we persuade you back to do some work on it?
Reply With Quote
  #1062  
Old 12 Sep 2012, 12:09
washingtonboise washingtonboise is offline
 
Join Date: Mar 2009
Offering $300 for viable, 4.x update without bugs. Who wants to join in by offering a collective bounty in the section for developer requests? Together, we can make it worth their time.

Cyrix, original post mentions donation to continue your work/support. Is that offer still viable?

Notice. The administration of vbulletin.org is going to lock posting to version 3.7 and lower forums. If you care about reply by email for 4.x, then you've got to act now and show you're serious. This thread is going to get locked.

I have started a new thread here for vbulletin 4.x reply by email addon.

I am also contacting Cyrix so he's aware that I would like him to keep providing support or give permission for updating the code which he modified from Colin to get this working in 3.x.
Reply With Quote
  #1063  
Old 20 Sep 2012, 16:24
filipo filipo is offline
 
Join Date: Mar 2008
I'd be happy to support this as a paid mod. BTW, for some reason I can't post a reply to the new 4.x thread.
__________________
Cheers,
Omar Filipovic
Reply With Quote
  #1064  
Old 28 Sep 2012, 16:59
unfv unfv is offline
 
Join Date: Apr 2008
I see that the last update was on 29 Feb 2008, so it seems to be unsupported, but, do you know if it will be compatible with VB5?
__________________
UNFV
Reply With Quote
  #1065  
Old 29 Sep 2012, 22:54
digeditor digeditor is offline
 
Join Date: Jan 2012
Real name: Jim
I believe I have this working in 4.2 (you can send that $300 to.... :-> )

However, I'm struggling with the parameters to use in the Forum Manager and in trying to get the email settings to work

Here's what it says in the original writeup:

In your forummanager use the following settings:

email address to reply to: username@gmail.com
hostname: pop.gmail.com
username: username@gmail.com
password: password
Type of connection: select "POP3 with SSL (Self signed certificate)"


my forum is hosted at 1and1.com so here's what I believe I should be entering:

email address to reply to: answerline@diganswerline.org
hostname: pop.1and1.com
username:answerline@diganswerline.org
password: password

I don't see the SSL option anywhere:
Type of connection: select "POP3 with SSL (Self signed certificate)" I have it set as POP3

I've also tried every combination of 1and1.com and diganswerline.org with no success.

Here's what I get when I test it with the email integrations Forum Settings Help

Warning: imap_open() [function.imap-open]: Couldn't open stream {diganswerline.org:110/pop3/notls}INBOX in [path]/admincp/admin_ei_search_settings.php on line 132

Which makes sense as 1and1 wants it to be pop.1and1.com not diganswerline.org as the hostname

When I replace it with 1and1 I get:

Warning: imap_open() [function.imap-open]: Couldn't open stream {1and1.com:110/pop3/notls}INBOX in [path]/admincp/admin_ei_search_settings.php on line 132

Yes I have looked to see if IMAP is on by going to Admincp-> Maintenence -> View PHP Info
The IMAP block shows up as c client version = 2007 and SSL and kereros support as "Enabled"

Any ideas what I'm not doing?


Jim
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:04.

Layout Options | Width: Wide Color: