Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Photobucket Image Uploader Details »
Photobucket Image Uploader
Mod Version: 2.0, by Dannyloski (Member) Dannyloski is offline
Developer Last Online: Mar 2012 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.x Rating: (22 votes - 4.64 average) Installs: 242
Released: 28 Dec 2007 Last Update: 15 Apr 2008 Downloads: 833
Not Supported Uses Plugins Auto-Template External Content  

This Modification works in both vB 3.6.x and vB 3.7.x

Introduction:
Well this is my first official "hack" for vBulletin , so cheers to me! Anyways, I want to apologize in advanced if for some reason this post or the instructions are not clear enough - I am trying my best to explain as elaborate as possible. With this being my first modification, I have dedicated a lot of time and effort into it and I can say that I am 99.9% sure that there are no bugs with this hack, as I have tested it numerous times - but we all know how that goes ... With that said, if you do find a bug or something, just let me know and I'll look into it. Also, I want to thank Mosh for letting me use his ImageHack as a Framework for mine, thanks bro!

NOTE: This hack works in total harmony with the latest version of Mosh's ImageShack Image Upload hack.

PHOTOBUCKET IMAGE UPLOADER
... BROUGHT TO YOU BY: DANNY ...

Description:
This hack will allow you to have access to your Photobucket Account from inside vBulletin, so that you can post up your pictures or videos without the need of opening a new window. It will allow you to display this Hack in the New Thread, New Post/Reply, Quick Reply, and Quick Edit Windows. This hack also provides the user with multiple options/settings to make this Add-on blend in with the site's color scheme. It has many benefits and options, so for more info just take a look at the Screenshots provided or download and install the Add-on to see and explore its settings.

Installation Instructions:
1) Download the attached .XML Product.
2) Import the .XML Product via Admin CP > Plugins & Products > Manage Products > [Add/Import Product]
3) Edit the Settings accordingly and Enable Hack where desired. Go to Admin CP > vBulletin Options > vBulletin Options > Photobucket Image Uploader to manage the settings. Remember to also enter the Usergroup IDs of those who you wish to be able to use the Hack or this Mod will not work!
4) Your Done! Its that easy ...

Upgrade Instructions:
1) Download the attached .XML Product.
2) Import the .XML Product via Admin CP > Plugins & Products > Manage Products > [Add/Import Product] and Select the "Overwrite" option ...
3) Your Done! Its that easy ...

IMPORTANT NOTE:
Originally Posted by Dannyloski View Post
Guys/Gals,

I want to make a note for those who said they were having trouble with this Hack, please make sure that you enter all the Usergroup IDs of the Usergroups who you want to be able to use this Hack in the "Allowed Usergroups" Settings Section.

I have a feeling that most of you left "0" in there. What the "0" does is "not force any usergroups". What that means is that no usergroup will be able to use the Hack, basically if you enter "0" there, then you are disabling the Hack completely.

I think that this is the solution to most (if not all) the problems for those who were claiming that this hack wasnt working. Please enter the Usergroup IDs and report back if it works for you or not.

PS. Some of you might be wondering how I figured this out, well one of the members on here who installed this Hack and was having problems, sent me a PM with Admin Login Info into their site and upon checking out the settings, this was the problem. They forgot to enter the Usergroup IDs in the specified Setting. I entered "6" for the Usergroup ID to test if Administrators could view the Hack and voila, it worked!
Version History:
  • v1.0
    • Official "Hack" Release
    • No known bugs
  • v2.0
    • Page no longer jumps to the Top when clicking on the "Display" or "Hide" Text.
    • Using vBulletin's fetch_object() function instead of document.getElementById() to take advantage of vBulletin's Browser Compatibility features.

Special thanks to Code Monkey for assisting me with the Code Fixes for v2.0 ... Now this Hack rocks even more

If you like then [Mark As Installed] or [Donate]


IFRAME RELOADING IN BLANK PAGE? READ THIS!
You need to clear your Browser's Cache (all if it) & Flush your DNS. This is a server-side issue with Photobucket, not with the Modification. This is Photobucket Support Team's response ...

Originally Posted by Photobucket Support Team
Dear Danny,

Please log out, clear your cache, refresh, close your browser window, then flush your DNS and reboot your entire system, including the modem and router.

http://pic.pbsrc.com/help/Content/Tr...ClearCache.htm

http://pic.pbsrc.com/help/Content/Tr...g/FlushDNS.htm

Thank you.

Sincerely,
Your Photobucket Support Team

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	PhotobucketUploader_2.jpg
Views:	2150
Size:	28.5 KB
ID:	73885   Click image for larger version

Name:	PhotobucketUploader_3.jpg
Views:	2015
Size:	37.3 KB
ID:	73886   Click image for larger version

Name:	PhotobucketUploader_4.jpg
Views:	1015
Size:	139.8 KB
ID:	73887   Click image for larger version

Name:	PhotobucketUploader_1.jpg
Views:	1474
Size:	32.5 KB
ID:	73888  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #46  
Old 06 Jan 2008, 16:54
michael5472's Avatar
michael5472 michael5472 is offline
 
Join Date: Mar 2004
Real name: Michael
great worked like a charm
__________________
pMod. PromodPlayers.com - Call Of Duty 4 Promod Community
Reply With Quote
  #47  
Old 06 Jan 2008, 17:17
Dannyloski Dannyloski is offline
 
Join Date: Jun 2006
Real name: Danny
Glad all of you guys are enjoying it ...

kiennt718, I do not undestand the "bug" you said you found. This Hack does not do anything to the Message Box from vBulletin, so the source of that problem must be something else. I am running vB 3.6.8 with WYSIWYG off on my Forums, and it works fine. As far as the other request you had to make it so that it stays in the Photobucket Area and not scroll up to the top when you click the link, that cannot happen - sorry. I was working on it, but it wont work properly, so this is why I had to release the hack like this.

wolfyman, if you can give me access to your AdminCP with a Temp Login, I can try and see why its not working for you.
Reply With Quote
  #48  
Old 09 Jan 2008, 04:00
Dannyloski Dannyloski is offline
 
Join Date: Jun 2006
Real name: Danny
Guys/Gals,

I want to make a note for those who said they were having trouble with this Hack, please make sure that you enter all the Usergroup IDs of the Usergroups who you want to be able to use this Hack in the "Allowed Usergroups" Settings Section.

I have a feeling that most of you left "0" in there. What the "0" does is "not force any usergroups". What that means is that no usergroup will be able to use the Hack, basically if you enter "0" there, then you are disabling the Hack completely.

I think that this is the solution to most (if not all) the problems for those who were claiming that this hack wasnt working. Please enter the Usergroup IDs and report back if it works for you or not.

PS. Some of you might be wondering how I figured this out, well one of the members on here who installed this Hack and was having problems, sent me a PM with Admin Login Info into their site and upon checking out the settings, this was the problem. They forgot to enter the Usergroup IDs in the specified Setting. I entered "6" for the USergroup ID to test if Administrators could view the Hack and voila, it worked!
Reply With Quote
  #49  
Old 09 Jan 2008, 06:19
kiennt718 kiennt718 is offline
 
Join Date: Oct 2007
Originally Posted by Dannyloski View Post
Glad all of you guys are enjoying it ...

kiennt718, I do not undestand the "bug" you said you found. This Hack does not do anything to the Message Box from vBulletin, so the source of that problem must be something else. I am running vB 3.6.8 with WYSIWYG off on my Forums, and it works fine. As far as the other request you had to make it so that it stays in the Photobucket Area and not scroll up to the top when you click the link, that cannot happen - sorry. I was working on it, but it wont work properly, so this is why I had to release the hack like this.
Have you test it with Internet Explorer 7? My problem "can not select text" occurred in IE7 only. Not in Firefox.
Reply With Quote
  #50  
Old 09 Jan 2008, 07:15
Kaycee123 Kaycee123 is offline
 
Join Date: Jun 2007
Fantastic mod - great work!! Installed in seconds, and works beautifully - thanks for your efforts!
Reply With Quote
  #51  
Old 09 Jan 2008, 15:42
wolfyman's Avatar
wolfyman wolfyman is offline
 
Join Date: Apr 2005
Real name: James
Thanks for the help Danny

I can't figure out where to turn off forum attachments. I want to only allow users to use this hack, and completely disable the "Attach Files" option.

can i remove the $attachmentoption bit from my templates? Or is there a button I didn't see in the admincp?
__________________
see sig.
Reply With Quote
  #52  
Old 09 Jan 2008, 15:58
Alibass's Avatar
Alibass Alibass is offline
 
Join Date: Mar 2007
Question

Are you planning on upgrading this hack to work on 3.7?
__________________
Alibass
Reply With Quote
  #53  
Old 09 Jan 2008, 18:08
SVTCobraLTD SVTCobraLTD is offline
 
Join Date: Jul 2007
Originally Posted by wolfyman View Post
Thanks for the help Danny

I can't figure out where to turn off forum attachments. I want to only allow users to use this hack, and completely disable the "Attach Files" option.

can i remove the $attachmentoption bit from my templates? Or is there a button I didn't see in the admincp?
AdminCP > Attachments > Attachment Permissions
Reply With Quote
  #54  
Old 09 Jan 2008, 22:42
Classico Classico is offline
 
Join Date: Dec 2007
Works Fine!!!

Thanks!
Reply With Quote
  #55  
Old 10 Jan 2008, 08:18
Gez Gez is offline
 
Join Date: Jan 2003
This is excellent and works like a charm!

Thank you!
Reply With Quote
  #56  
Old 10 Jan 2008, 12:31
Dannyloski Dannyloski is offline
 
Join Date: Jun 2006
Real name: Danny
Glad its working for everyone

Originally Posted by kiennt718 View Post
Have you test it with Internet Explorer 7? My problem "can not select text" occurred in IE7 only. Not in Firefox.
I will test it today, but when I used my friend's Laptop (has IE7) the forum was working fine. Will check again and report back ...




Originally Posted by wolfyman View Post
can i remove the $attachmentoption bit from my templates? Or is there a button I didn't see in the admincp?
No do not remove the $attachmentoption bit from the templates as that will disable this Hack as well. Do what SVTCobraLTD suggested:
Originally Posted by SVTCobraLTD View Post
AdminCP > Attachments > Attachment Permissions



Originally Posted by Alibass View Post
Are you planning on upgrading this hack to work on 3.7?
Have you tested it to see if it works on vB3.7? It might work without any modification, I do not know yet because I do not have vB 3.7 installed on my forums yet, so I cannot test it ... Once vB 3.6.7 is out of beta stage I will install on my forums to check and see.
Reply With Quote
  #57  
Old 10 Jan 2008, 15:56
ericgray's Avatar
ericgray ericgray is offline
 
Join Date: Aug 2006
thisis very, very good -- thank you!
__________________
site: www.spbr.org
forum: www.pbsmiles.com
Reply With Quote
  #58  
Old 10 Jan 2008, 16:08
Dannyloski Dannyloski is offline
 
Join Date: Jun 2006
Real name: Danny
^ Thanks

Originally Posted by Dannyloski
Originally Posted by kiennt718 View Post
Have you test it with Internet Explorer 7? My problem "can not select text" occurred in IE7 only. Not in Firefox.
I will test it today, but when I used my friend's Laptop (has IE7) the forum was working fine. Will check again and report back ...
kiennt718, just checked again on IE7 and its working perfectly. Like I told you before, this Hack has nothing to do with the Message Box, it does not touch its code at all. Please check your other plugins/hacks because this Hack is not the cause to your problem.
Reply With Quote
  #59  
Old 01 Feb 2008, 00:33
Classico Classico is offline
 
Join Date: Dec 2007
Hi,

Im very glad with this hack. Works really good in 3.6.8. Thanks Danny!

Has anyone tryed it in th 3.7?

Last edited by Classico; 01 Feb 2008 at 10:09.
Reply With Quote
  #60  
Old 01 Feb 2008, 09:50
shavedaccord shavedaccord is offline
 
Join Date: Apr 2006
Awesome hack I had requested this in the past! looks like someone might have seen the request!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:50.

Layout Options | Width: Wide Color: