Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Show Subforum Threads Details »
Show Subforum Threads
Mod Version: 1.3, by MarkFL (Coder) MarkFL is offline
Developer Last Online: Oct 2019 I like it Show Printable Version Email this Page

vB Version: 4.2.x Rating: (1 vote - 5.00 average) Installs: 10
Released: 14 Jan 2017 Last Update: 02 Feb 2017 Downloads: 50
Not Supported Uses Plugins Auto-Template Translations  

This product is in response to a thread posted here:

Display subforum threads in parent forumdisplay thread list

by:

mchll9898

Overview:

This product allows you to designate forums in which all threads in that forum's child forums will be displayed in the thread listing. Threads that are in a child forum will display a "child forum" icon which links to the forum in which the thread resides. The mouseover tooltip for the icon is phrased in 'markfl_showsubforumthreads_icontitle'.



Updates:

Version 1.1:
  • Resolved reported issue of child-forum icon displaying on all threads.

Version 1.2:
  • Added setting for whether to include sticky threads in subforums.
  • Added setting for cutoff in days for the date of last post to include threads in subforums.

Version 1.3:
  • Added option to hide subforums.

Compatibility:

Tested and working on VB 4.2.x and may work on all 4.x versions of vBulletin.

Backup/Warning:

This product does alter your database, however it is always good practice to make regular backups and you should make a backup before installing ANY new mod.

As always, products are USE AT YOUR OWN RISK. I will provide support and do my best to help but no absolute guarantee is offered.

To Install:
  1. Download and extract the attached .zip file.
  2. Follow AdminCP -> Plugins & Products -> Manage Products -> Add/Import Product.
  3. Click on "Choose File" and browse to the product .xml file that was packaged in the .zip file.
  4. Click "Import."
  5. You MUST enable the product in the settings before it will function.
  6. Configure the remaining settings to your liking. Each setting has a detailed explanation of its use.



Support for this product can be found here:

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	markfl_sst_icon.png
Views:	572
Size:	50.8 KB
ID:	155691   Click image for larger version

Name:	markfl_sst_acp.png
Views:	381
Size:	48.3 KB
ID:	155771  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #16  
Old 02 Feb 2017, 18:07
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by mobster46 View Post
It does not look very nice. Is there a solution? Can we hide child of childx?
I added the option to hide in the product for which this thread is the subject.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #17  
Old 02 Feb 2017, 18:17
mobster46 mobster46 is offline
 
Join Date: Dec 2016
Originally Posted by MarkFL View Post
I added the option to hide in the product for which this thread is the subject.
But the plugin hides all the subforums. I want to close only child of child forum.
Reply With Quote
  #18  
Old 02 Feb 2017, 18:22
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by mobster46 View Post
But the plugin hides all the subforums. I want to close only child of child forum.
Okay, follow:

AdminCP -> Settings -> Options -> Forum Listings Display Options

Then locate the settings:
  • Depth of Forums - Forum Display
  • Depth of Sub-Forums
And set both of those to 0.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #19  
Old 02 Feb 2017, 18:26
mobster46 mobster46 is offline
 
Join Date: Dec 2016
Originally Posted by MarkFL View Post
Okay, follow:

AdminCP -> Settings -> Options -> Forum Listings Display Options

Then locate the settings:
  • Depth of Forums - Forum Display
  • Depth of Sub-Forums
And set both of those to 0.
Worked( I use 1-1). Thank you so much
Reply With Quote
  #20  
Old 28 Jan 2019, 23:04
Visual010 Visual010 is offline
 
Join Date: Sep 2012
Hello,

I installed this plugin but it doesn't expand the threads at all.
If I select the option to hide sub forums though, it does hide them as intended.

I'm using vBulletin 4.2.2.

Regards,
Visual
Reply With Quote
  #21  
Old 29 Jan 2019, 02:16
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Visual010 View Post
Hello,

I installed this plugin but it doesn't expand the threads at all.
If I select the option to hide sub forums though, it does hide them as intended.

I'm using vBulletin 4.2.2.

Regards,
Visual
Have you tried it with the default style?
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #22  
Old 29 Jan 2019, 07:38
Visual010 Visual010 is offline
 
Join Date: Sep 2012
Originally Posted by MarkFL View Post
Have you tried it with the default style?
Hello,

Yes, at first I thought it had to do with the styles but the same issue appears with the default style.

Thanks for the quick response!
Visual
Reply With Quote
  #23  
Old 29 Jan 2019, 07:47
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Can you attach screenshots of what you're getting and your forum structure related to the screenshot? I don't use this myself, and it's been two years since I coded it, so I will need to see what you're getting and try to go from there.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #24  
Old 29 Jan 2019, 17:05
Visual010 Visual010 is offline
 
Join Date: Sep 2012
Hello,

I am attaching the screenshots of the plugin options, how my forum looks and the forum structure.

https://i.gyazo.com/ce0742508de3c680...1a4ffc821b.png
https://i.gyazo.com/042a1cc8804ce8d8...9a1f210182.png
https://i.gyazo.com/1d04cc9dcc574094...f59f90dd75.png

Regards,
visual
Reply With Quote
  #25  
Old 29 Jan 2019, 18:36
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Okay, it appears that you have selected a forum that has no child forums, and so there is nothing for the product to do.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #26  
Old 29 Jan 2019, 21:43
Visual010 Visual010 is offline
 
Join Date: Sep 2012
Hello,

Yes, sorry it was the last configuration I tried but I forgot to tell you I tried all of them. As of now, a forum with child forums is selected and the issue stands.

Thanks for your help so far!
Visual
Reply With Quote
  #27  
Old 30 Jan 2019, 00:11
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
I just tested it again on my local dev site and it functions as it should. I have no idea why it's not working for you.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #28  
Old 30 Jan 2019, 01:46
Visual010 Visual010 is offline
 
Join Date: Sep 2012
Hello.

Just for the record, this is how the default style looks like.

https://i.gyazo.com/ee302b9efe3bdf4f...d7ab11d4c0.png

I have no idea what's wrong.
Regards,
visual
Reply With Quote
  #29  
Old 30 Jan 2019, 03:18
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
If you want, send me (via PM) the login credentials to an admin account and I can come to your site and try to troubleshoot.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #30  
Old 30 Jan 2019, 19:43
Visual010 Visual010 is offline
 
Join Date: Sep 2012
Hello,

I dm'd you! Thanks for this, I truly appreciate it.

Regards,
Visual
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:12.

Layout Options | Width: Wide Color: