Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Module CMPS: PhotoPost vBGallery Details »
Module CMPS: PhotoPost vBGallery
Mod Version: 2.6, by Zachariah (Coder/Designer) Zachariah is offline
Developer Last Online: Dec 2017 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (10 votes - 4.90 average) Installs: 132
Released: 15 Sep 2006 Last Update: 28 Aug 2007 Downloads: 1249
Not Supported Template Edits  

/* ----------------- 8/28/2007 6:41pm -----------------

Add Gallery Images to your vBAdvanced CMPS 3.x
Do you have PhotoPost vBGallery v2.0 + installed ?

Looking @ changes in the gallery. This hack will work with vbgallery 2.2, 2.3 out of the box.
- you can get a patch if you have 2.0, 2.1 - here.

Tested on:
- vBulletin 3.6.8
- PhotoPost vBGallery v2.3
- vBadvanced CMPS v3.0 RC1

1 query added to CMPS

Zachariah @ http://www.szone.us/

EX: 3 CMPS blocks 3 different settings
http://www.szone.us/index.php?id=gallery

--------------------------------------------------*/


Change Log
===========
2.6
- Added option for module title.
- Added option for module link.
- Added option to choose from thumbnail, normal, origianal


2.5
- Added Template: adv_portal_vbgallery_imagebit
- Edited Template: adv_portal_vbgallery_nav - added search dropdown
- Edited Template: adv_portal_vbgallery - changed to work with standard CMPS wrapper
- Multi-Modules can be used on the same page using the same php file with different settings
EX: 3 CMPS blocks 3 different settings http://www.szone.us/index.php?id=gallery


2.2
- reworked to work on CMPS 3.0

2.1
- Package added to: imagegallery.module
- Block settings per CMPS page
- Permissions fixed


2.0
- adv_gallery_images -> ppgal_images

1.9
- Added vb3.6

1.8
- Added functions_gallery_store.php
- Added column span support

1.7
- Install w/ product in 1 file.
- Killed the need for FORUMHOME template edit.
- AdminCP options to change the hack settings
- Added: Parts of the gallery's Nav bar w/ dropdowns
(My Stuff*, What's New, What's Popular,Search) to the hack with on/off option.

* My Stuff will not be seen if you are a guest.

1.6
- Added: If the gallery is off or disabled the hack not show up.
- Added: templates to support the hack vs. gallery templates
(allows you to customize the templates for the look and feel you want vs. mess up the way your gallery templates look.)


1.5
- <If> usergroup can not see thunbnails FORUMHOME edit will not show up.

1.4
- Removed Phrase to name gallery <table> now use $vba_options[gallery_title]
- Added 3 prases in "global" - filesize,category,dimensions

1.3
- Display images from specific categories.

1.2
- added Phrase support

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	admin.jpg
Views:	1118
Size:	61.4 KB
ID:	59673   Click image for larger version

Name:	all_options.jpg
Views:	1664
Size:	47.1 KB
ID:	59674   Click image for larger version

Name:	no_data.jpg
Views:	1165
Size:	24.5 KB
ID:	59675  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Module CMPS: PhotoPost vBGallery Zachariah vBulletin 3.5 Add-ons 379 01 Aug 2010 08:36
Add-On Releases Module CMPS: Add vBGallery Image comments Zachariah vBulletin 3.6 Add-ons 13 21 Jul 2008 02:31
Module CMPS: Add vBGallery Image comments Zachariah vBulletin 3.5 Add-ons 23 24 Nov 2007 05:28

Comments
  #2  
Old 15 Sep 2006, 13:26
Zachariah's Avatar
Zachariah Zachariah is offline
 
Join Date: Feb 2002
Location: Canoga Park, CA
Looking @ changes in the gallery. This hack will work with vbgallery 2.2, 2.3 out of the box.
- you can get a patch if you have 2.0, 2.1 - here.


*** How to Install:
======================

In your Admin Control Panel

1)
AdminCP => Plugins & Products => [Add/Import Product]
- Import Product:
- Browse "product-sz1_gallery_cmps.xml"
- [Import]

2)
Admincp => vBa CMPS => Download / Upload Module
Click [Browse]
Browse for the file "imagegallery.module"

3)
Settings can be set per page.
Admincp => vBa CMPS => edit/add Page
- Image Gallery
__________________
http://www.szone.us |

Facebook | My:Hacks @ vBulletin.org

Last edited by Zachariah; 20 Aug 2007 at 18:20.
Reply With Quote
  #3  
Old 15 Sep 2006, 13:37
Betablocker Betablocker is offline
 
Join Date: Oct 2004
Install clicked
Reply With Quote
  #4  
Old 15 Sep 2006, 13:40
maroceve maroceve is offline
 
Join Date: Oct 2005
hi ..i have this problem since i updated to 3.6 :[


Fatal error: Cannot redeclare empty_category() (previously declared in /home/maroceve/public_html/forums/includes/functions_gallery.php:2069) in /home/maroceve/public_html/forums/includes/local_links_include.php on line 2935

So i disabled the module.

Can you please help ?
Reply With Quote
  #5  
Old 15 Sep 2006, 13:41
Snake's Avatar
Snake Snake is offline
 
Join Date: Mar 2005
Location: Cleveland, OH
Real name: Josh
Awesome! It's finally here for 3.6.1. Thank you!
Reply With Quote
  #6  
Old 15 Sep 2006, 14:25
FleaBag's Avatar
FleaBag FleaBag is offline
 
Join Date: Dec 2001
About time punk! :P
__________________
AndroidETC.com :: Android, and other stuff.
Reply With Quote
  #7  
Old 15 Sep 2006, 14:39
SgtTechHead's Avatar
SgtTechHead SgtTechHead is offline
 
Join Date: Apr 2005
Thank You! *installed*
Reply With Quote
  #8  
Old 15 Sep 2006, 15:34
MotoUp MotoUp is offline
 
Join Date: Jul 2004
What I want to do is only show "Posted by User" underneath the images in the module. What template do I edit to take the border off of the table that it includes when you turn on the user bit?

Installed! Thank you.
Reply With Quote
  #9  
Old 15 Sep 2006, 16:18
SgtTechHead's Avatar
SgtTechHead SgtTechHead is offline
 
Join Date: Apr 2005
I have installed and everything, with the exception of two items, seems to be working great.

When I choose to show "Last Post", or "Posts", in the options, it will not reflect any data. Even if a picture does have replies, the "Posts" always shows as zero, and the "Last Post" always appears blank.

Last edited by SgtTechHead; 15 Sep 2006 at 16:21.
Reply With Quote
  #10  
Old 15 Sep 2006, 16:52
Zachariah's Avatar
Zachariah Zachariah is offline
 
Join Date: Feb 2002
Location: Canoga Park, CA
Originally Posted by SgtTechHead
I have installed and everything, with the exception of two items, seems to be working great.

When I choose to show "Last Post", or "Posts", in the options, it will not reflect any data. Even if a picture does have replies, the "Posts" always shows as zero, and the "Last Post" always appears blank.
I'll take a look.
__________________
http://www.szone.us |

Facebook | My:Hacks @ vBulletin.org
Reply With Quote
  #11  
Old 15 Sep 2006, 20:15
MotoUp MotoUp is offline
 
Join Date: Jul 2004
Originally Posted by MotoUp
What I want to do is only show "Posted by User" underneath the images in the module. What template do I edit to take the border off of the table that it includes when you turn on the user bit?
I've looked everywhere for this template and just can't find it. Any suggestions?
Reply With Quote
  #12  
Old 15 Sep 2006, 20:26
Zachariah's Avatar
Zachariah Zachariah is offline
 
Join Date: Feb 2002
Location: Canoga Park, CA
It's not a template fix it is code.
- I'll have an update soon.
__________________
http://www.szone.us |

Facebook | My:Hacks @ vBulletin.org
Reply With Quote
  #13  
Old 15 Sep 2006, 20:38
MotoUp MotoUp is offline
 
Join Date: Jul 2004
Ah! Thanks Zach, appreciate it. Not a huge deal, I just got a wild hair is all.
Reply With Quote
  #14  
Old 15 Sep 2006, 23:16
SMO's Avatar
SMO SMO is offline
 
Join Date: Sep 2005
Real name: Geoff
thx brotha...was looking forward to this
Reply With Quote
  #15  
Old 16 Sep 2006, 01:08
bolly.beats's Avatar
bolly.beats bolly.beats is offline
 
Join Date: Aug 2006
hiii thank you for this and someone help me in installin this please.. i downloaded zipp. When I do this changes in init.php file:

- Edit:
forums/includes/init.php

- Find:
require_once(CWD . '/includes/class_core.php');

- Below Add:
require_once(CWD . '/includes/functions_gallery_store.php');

I get an error, but when i remove this :
- Below Add:
require_once(CWD . '/includes/functions_gallery_store.php');

when i remove code it starts working. Someone help me please.

Last edited by bolly.beats; 16 Sep 2006 at 04:03.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 20:20.

Layout Options | Width: Wide Color: