Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Chrome Browser Notice (For Quick Reply Editor) - How to fix non-working space bar Details »
Chrome Browser Notice (For Quick Reply Editor) - How to fix non-working space bar
Mod Version: 1.0.0, by BirdOPrey5 (IB Staff) BirdOPrey5 is offline
Developer Last Online: Nov 2019 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (2 votes - 5.00 average) Installs: 40
Released: 05 Nov 2016 Last Update: 05 Nov 2016 Downloads: 130
Supported Uses Plugins Auto-Template Re-usable Code  

If you are not already aware the latest version of Chrome browser (Version 54.0.2840.71, possibly others) has introduced a bug or incompatibility with the version of CKEditor used in VB 4.x.

If a user attempts to use the "Reply With Quote" feature on an existing post and begins to type their reply under the existing quote without hitting the Enter key first, the space bar will not work.

The issue is talked about on vBulletin.com here: http://www.vbulletin.com/forum/forum...rking-on-reply

While this is not a true fix, it does display a notice above the quick reply editor advising Chrome users that they can fix the problem simply by hitting the Enter key. (See Screenshot.)



The actual text displayed is held in a Global phrase called chrome_editor_message_bop5 so it is easily edited or translated as needed using Phrase Manager in the Admin CP.

There are no options, just install it and it will become active. Disable or remove the product to stop using it.

Notice will only be displayed in Chrome browser and when the enhanced WYSIWYG editor is enabled in the user's options. The Standard Editor and Basic Editor do not have this bug.

The function that attempts to determine the browser version was publicly available, location it can be found is a comment in the Functions plugin.

This mod will only install on VB 4.x versions and is only useful with VB 4.x versions 4.1.12 and above. May not work on heavily customized styles.

------------------------------------------------------

Please "Mark as Installed" if you use this.
Donations always appreciated.
Nominate MOTM if you LOVE it!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	chrome_browser_warn_ss.jpg
Views:	185
Size:	62.3 KB
ID:	155457  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Show Thread Enhancements [CKEditor] MARCO1 Advanced Editor - Quick Reply & Quick Edit With Full Editor Control MARCO1 vBulletin 4.x Add-ons 469 20 May 2019 09:04

  #31  
Old 10 Dec 2016, 10:07
Kane@airrifle's Avatar
Kane@airrifle Kane@airrifle is offline
 
Join Date: Jun 2011
Real name: Kane
Originally Posted by sticky View Post
Hey! This works. LOL, you're better than Vbulletin support.

The only problem is the issue still persists in PM's. Forum posting is fixed though when quoting.
I take no credit, this kludge was posted elsewhere by man1c.

To get it to work in PMs and Quick reply add this to the bottom of editor_contents.css.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #32  
Old 10 Dec 2016, 13:00
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by Kane@airrifle View Post
Adding this to to the bottom of editor_contents.css seems to get the space bar working with the WYSIWYG editor on my board.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The added blank lines that appear in the quoted post disappear on posting.

YMMV
If you like it, then that's great. For me I feel like if I have to explain to my users to not worry about the extra blank lines I might as well just tell them to hit the enter key to get the space bar working again.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #33  
Old 10 Dec 2016, 19:46
z3r0's Avatar
z3r0 z3r0 is offline
 
Join Date: Apr 2005
Location: Lancashire, UK
Originally Posted by Kane@airrifle View Post
I take no credit, this kludge was posted elsewhere by man1c.

To get it to work in PMs and Quick reply add this to the bottom of editor_contents.css.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
That wasn't what I (man1c) posted, this was:-


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You also need to turn off quick edit for it to work properly without any extra whitespace issues for anybody.
Reply With Quote
  #34  
Old 10 Dec 2016, 20:19
Kane@airrifle's Avatar
Kane@airrifle Kane@airrifle is offline
 
Join Date: Jun 2011
Real name: Kane
Quick edit, on or off, the white space is there while replying on my board. On posting the whitespace goes away in any event.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The added line above is to get rid of the issue in the PM system.

If you like it, then that's great. For me I feel like if I have to explain to my users to not worry about the extra blank lines I might as well just tell them to hit the enter key to get the space bar working again.
Sadly, it's been my experience that the average user takes zero notice of stickies, notices or announcements. This is the case on my board where this mod is implemented but nevertheless got threads and PMs asking about the spacebar.

It is what it is....
Reply With Quote
  #35  
Old 10 Dec 2016, 20:54
z3r0's Avatar
z3r0 z3r0 is offline
 
Join Date: Apr 2005
Location: Lancashire, UK
Strange, all my sites absolutely fine after the edits & QE off - could be a combination of other stuff that's been installed/modded though.
Reply With Quote
  #36  
Old 11 Dec 2016, 03:52
sticky sticky is offline
 
Join Date: Sep 2003
Originally Posted by z3r0 View Post
That wasn't what I (man1c) posted, this was:-


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You also need to turn off quick edit for it to work properly without any extra whitespace issues for anybody.
If you remove quick edit then the extra spaces disappear?
Reply With Quote
  #37  
Old 11 Dec 2016, 03:54
sticky sticky is offline
 
Join Date: Sep 2003
Originally Posted by Kane@airrifle View Post

Sadly, it's been my experience that the average user takes zero notice of stickies, notices or announcements. This is the case on my board where this mod is implemented but nevertheless got threads and PMs asking about the spacebar.

It is what it is....
Exactly the same way on my board. Even if the issue is sticky'd and in my sig people still kept complaining and asking what was wrong.

Thank you so much! Seriously, thank you. You're a lifesaver.
Reply With Quote
  #38  
Old 12 Dec 2016, 02:10
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Off topic posts removed.
Last warning, any more digs, or other posts not related to support or use of this mod will get you a suspension.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #39  
Old 30 Dec 2016, 15:49
andryus andryus is offline
 
Join Date: Jan 2006
How i can use it only for PM? because i have issues only with PM ( space bar not working when you send a PM )

Thanks!
Reply With Quote
  #40  
Old 30 Dec 2016, 15:55
andryus andryus is offline
 
Join Date: Jan 2006
Originally Posted by Kane@airrifle View Post
I take no credit, this kludge was posted elsewhere by man1c.

To get it to work in PMs and Quick reply add this to the bottom of editor_contents.css.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
This worked also for me, PM works great now

Thanks!!!
Reply With Quote
  #41  
Old 25 Jan 2017, 13:33
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by Kane@airrifle View Post
I take no credit, this kludge was posted elsewhere by man1c.

To get it to work in PMs and Quick reply add this to the bottom of editor_contents.css.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Thanks for this! Is it just putting the cursor before the quote tag, or am I missing something?
__________________
John
Reply With Quote
  #42  
Old 30 Jan 2017, 03:52
sticky sticky is offline
 
Join Date: Sep 2003
Anyone know if the latest chrome update resolves this?
Reply With Quote
  #43  
Old 01 Feb 2017, 06:09
Kane@airrifle's Avatar
Kane@airrifle Kane@airrifle is offline
 
Join Date: Jun 2011
Real name: Kane
Originally Posted by tpearl5 View Post
Thanks for this! Is it just putting the cursor before the quote tag, or am I missing something?
Other than occasionally testing I never use the WYSIWYG editor myself so I do not really know what the usual cursor position is for it.

After complaints about the massive amount of whitespace the above css kludge adds to quoted contents while editing, particularly irksome when the post is long, I went another route in the end.

I removed the css from editor_contents.css and kept Quick Edit turned off. In New Posting Templates/newpost_quote I simply added 3 blank lines below:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It has the same effect as the css kludge without the aggravation of the white space in the quoted content. Users imply move the cursor to the 1st, 2nd or 3rd line below the quote and reply. If you can live an under quote you can put the blank lines above the code.

Originally Posted by sticky View Post
Anyone know if the latest chrome update resolves this?
BirdOPrey5's mod is still relevant with the latest version of Chrome ( 56.0.2924.76 ). I don't think Google will fix it. I don't think the baked in CKEditor needs a complete overhaul either, as far as I know only two files need updating, ckeditor.js and the enhancedsourcearea plugin.
Reply With Quote
  #44  
Old 01 Feb 2017, 13:37
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by Kane@airrifle View Post
Other than occasionally testing I never use the WYSIWYG editor myself so I do not really know what the usual cursor position is for it.

After complaints about the massive amount of whitespace the above css kludge adds to quoted contents while editing, particularly irksome when the post is long, I went another route in the end.

I removed the css from editor_contents.css and kept Quick Edit turned off. In New Posting Templates/newpost_quote I simply added 3 blank lines below:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It has the same effect as the css kludge without the aggravation of the white space in the quoted content. Users imply move the cursor to the 1st, 2nd or 3rd line below the quote and reply. If you can live an under quote you can put the blank lines above the code.



BirdOPrey5's mod is still relevant with the latest version of Chrome ( 56.0.2924.76 ). I don't think Google will fix it. I don't think the baked in CKEditor needs a complete overhaul either, as far as I know only two files need updating, ckeditor.js and the enhancedsourcearea plugin.
Yes, I noticed the extra line breaks too.

I'm going to do some testing with the updated ckeditor rar (v3.6.6) file posted here: http://www.vbulletin-ressources.com/...10-et-ckeditor

and see if it makes a difference.
__________________
John
Reply With Quote
  #45  
Old 01 Feb 2017, 15:36
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Okay, yeah, that rar isn't going to work without modifying things further. It looks like they just merged the vbulletin plugin with the latest ckeditor code, but by default vbulletin doesn't use the core directory.

Originally Posted by Kane@airrifle View Post
I don't think the baked in CKEditor needs a complete overhaul either, as far as I know only two files need updating, ckeditor.js and the enhancedsourcearea plugin.
In ckeditor.js there's actually a function to insert the enter key

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If that were to be used after clicking reply with quote that would probably solve the issue. Unfortunately I don't know enough JavaScript to modify things myself.
__________________
John
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:22.

Layout Options | Width: Wide Color: