Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VB Pro Garage Timeslips Details »
VB Pro Garage Timeslips
Mod Version: 3.0.9, by Dylanblitz (Contributor) Dylanblitz is offline
Developer Last Online: Feb 2017 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (43 votes - 4.70 average) Installs: 259
Released: 25 Feb 2010 Last Update: 29 Sep 2012 Downloads: 1665
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations  

Description
VB Pro Garage Timeslips (formerly CND Garage/Timeslips) is a free vehicle and timeslips add on for vBulletin 4. This is a great way to allow members to show off their rides, whether they are cars, motorcycles, atv's, etc. Site administrators have dozens of options to tailor the way the garage is displayed and the number of vehicles, images and timeslips the user can enter. User vehicle creation is done through a simple screen with dropdowns and simple text fields. Users can enter either miles or km and system will automatically calculate differences for front page statistics.

** New Features **

* SEO Friendly URLs (htaccess only)
* Page Caching - physical html files which make a HUGE reduction in sql queries
* Front Categories - a category system as an alternate front page to the block layout. I believe it will increase the garage ranking in search engines greatly when used with SEO URL's and the included dynamic meta tags.
* Thread Creation - Automatically create new threads in the forum of your choosing with the text of your choosing when a new vehicle is created in the garage.

Main Features

* No vb template modification needed
* Ajax driven menu's to keep load time down if you have a very large lists of makes/models
* Usergroup level permissions to set the amount of vehicles, images, timeslips allowed
* 99.9% of the text is phrased so that it can be translated for multinational sites
* On the fly image/text watermarking ability to make sure images are tied to your site
* Lytebox image presentation

Installation
Instructions, tips and more are now in the included chm file. If you have problems with the chm I have the document published at:
http://www.vbprogarage.com/forums/docs/html_vb4_ts_300/

The quick and dirty install:
1) Upload all files in the upload folder
2) Import vb_pro_garage.xml into Product Manager
3) Import vb_pro_garage_language_english.xml into Languages & Phrases
4) If you want all makes and models I've collected, import vb_pro_garage_vehicles^^new_install_only.xml into Product Manager

Post Installation
So you don't have to find it in the instructions. After install, there is a button up top in the navbar. This button by default is admin only. This is so you can configure and test without having to close the garage. When you are ready to deploy to the community:
ACP->Settings->Options->Garage General Settings - Set Garage Menu Button to Enabled.

The garage is developed on vb 4.0.7 and tested back to 4.0.0. The garage will run on PHP 5.x+ compiled with GD/GD2 and MySQL 5.x+

Additional options for the garage like adding featured businesses that support your site, fuel tracking, dyno charts, modifications and lots more are included in the commercial version.

Many thanks to Coroner for his stylebridge which led me on a path that saved me hours and hours of template editing

There are a few bugs that you might run into on this version. Instead of working on correcting them in the files and working on getting a new package up here, I'm working on the next version and including the posts that fix the errors here.

Change Log:
v3.0.9 - 09/29/2012
-----------------------------
Fixed sql injection problem
Replaced depreciated split function usage
Fixed sql error on image comments
Fixed Make/Model count on front page resetting to 1
Fixed extra unlabeled field on vehicle create/edit (Timeslips only)
Fixed postbit dropdown showing character code
Fixed tables incorrectly set with TYPE instead of ENGINE
Added navigation manager links to product xml

v3.0.8 - 12/9/2010
-----------------------------
Fixed missing vehicle comment code

v3.0.7 - 12/1/2010
-----------------------------
Fixed error with non existant garage_special_track table

v3.0.6 - 11/21/2010
-----------------------------
Fixed who's online error
Fixed map infowindow colors

v3.0.5 - 11/15/2010
-----------------------------
Fixed error with member profile vehicle block
Fixed member tab url path
Fixed error on vehicle map with apostrophes in title

v3.0.4a - 11/12/2010
-----------------------------
Corrected package error

v3.0.4 - 11/11/2010
-----------------------------
Fixed error with front blocks
Fixed style error with vB4.0.8 changes

v3.0.3 - 11/2/2010
-----------------------------
Fixed duplicate countries
Fixed vehicle view slideshow image size
Fixed username browse error
Fixed geocode error on missing zip
Fixed postbit error with vehicles that have a apostrophe in the name

v3.0.2 - 10/25/2010
-----------------------------
Fixed missing add vehicle button on member profile
Added bbcode capabilities to welcome box on garage front page
Moved vehicle count to db table to ease db queries
Added notification scheduled task to send message to new users about adding a garage entry
Added default clear image for watermark
Fixed code to disregard watermark option if image is missing
Fixed search username error
Updated obsolete data queries
Added SEO Friendly URLS
Added page caching capabilities
Fixed sql error with moving vehicle class and color to new selection on deletion in ACP
Added function to replace non english characters with english characters in ajax selection lists
Added image comments
Added notification for image and vehicle comments
Added option to add page title
Added zip code to vehicle and googlemap
Added ability to disable and ability to hide info for googlemap

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	01_front_cat.png
Views:	4119
Size:	133.0 KB
ID:	123185   Click image for larger version

Name:	01_front.jpg
Views:	2308
Size:	63.1 KB
ID:	123186   Click image for larger version

Name:	02_ajax_image_data.png
Views:	1793
Size:	62.1 KB
ID:	123187   Click image for larger version

Name:	02a_browse.jpg
Views:	1931
Size:	86.8 KB
ID:	123188  

Click image for larger version

Name:	03_add_vehicle.jpg
Views:	1122
Size:	94.5 KB
ID:	123189   Click image for larger version

Name:	04_view_vehicle.jpg
Views:	1425
Size:	89.1 KB
ID:	123190   Click image for larger version

Name:	05_add_timeslip.png
Views:	901
Size:	24.6 KB
ID:	123191   Click image for larger version

Name:	06_view_timeslip.png
Views:	784
Size:	18.3 KB
ID:	123192  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases CND Garage - Timeslips Dylanblitz vBulletin 3.8 Add-ons 227 24 May 2015 21:29

  #511  
Old 02 Mar 2011, 08:16
deadbolt80 deadbolt80 is offline
 
Join Date: Jan 2010
Hey Dylan,

Long time no talk. I recently updated to 4.1.2 vB and the garage is not working at all. I remember you helped me install it, and i'm not sure where to begin or how you did it...

Any tips would be appreciated. I already uploaded the .xml file for your latest version in my products section.. but I think somewhere in my database transfer to the new server, the language .xml isn't uploaded and it won't let me upload it.

PM me please so we can figure this out.

Thanks for everything.
Reply With Quote
  #512  
Old 03 Mar 2011, 01:09
venom2124's Avatar
venom2124 venom2124 is offline
 
Join Date: Feb 2009
Originally Posted by Dylanblitz View Post
Is this on one specific jpg or any jpg you try and upload? It looks like I see a bunch of vehicles with images on your site so I'm not sure.
I think it was one specific picture I was trying to upload. It wasn't on my site it was on another site that I'm working as an admin on. I was able to upload the same picture from a different site.
Reply With Quote
  #513  
Old 05 Mar 2011, 19:30
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by deadbolt80 View Post
Hey Dylan,

Long time no talk. I recently updated to 4.1.2 vB and the garage is not working at all. I remember you helped me install it, and i'm not sure where to begin or how you did it...

Any tips would be appreciated. I already uploaded the .xml file for your latest version in my products section.. but I think somewhere in my database transfer to the new server, the language .xml isn't uploaded and it won't let me upload it.

PM me please so we can figure this out.

Thanks for everything.
Did you install the language file through the language area?

http://www.vbprogarage.com/forums/do...on_script2.htm

Make sure you install it like the images in the instructions. If it doesn't work you can pm me with a temp admin account and I'll work on it.
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #514  
Old 07 Mar 2011, 15:12
cTak cTak is offline
 
Join Date: Sep 2006
Originally Posted by Dylanblitz View Post
Are you sure you edited the template in the right style? It should match the style of the forum. PM me a link and I'll take a look. If the garage requires an account to view it send me one with access as well
I tweaked the style a little bit, removed some {vb:stylevar} code and used this to get what I want.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Version 4.1.2 User
Reply With Quote
  #515  
Old 16 Mar 2011, 00:46
cTak cTak is offline
 
Join Date: Sep 2006
Feature request.

Dylanblitz,

I like the feature that creates a thread for new vehicles. I also like that you can edit the thread subject and body. BUT, Can you make it so you can use things like {username} and {vehicle} in the subject as well as the body?

I have a thread just for new vehicles, and all I see on the page is thread after thread of the same thing. "A new vehicle has been created in the garage!" I want it to be more specific! Like
"John has added a Corvette to his garage!"

Can you make this change in the next release? Or post how to make the changes to do that?

Thanks!!!
__________________
Version 4.1.2 User
Reply With Quote
  #516  
Old 16 Mar 2011, 08:19
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by cTak View Post
Feature request.

Dylanblitz,

I like the feature that creates a thread for new vehicles. I also like that you can edit the thread subject and body. BUT, Can you make it so you can use things like {username} and {vehicle} in the subject as well as the body?

I have a thread just for new vehicles, and all I see on the page is thread after thread of the same thing. "A new vehicle has been created in the garage!" I want it to be more specific! Like
"John has added a Corvette to his garage!"

Can you make this change in the next release? Or post how to make the changes to do that?

Thanks!!!
I can add it with the next release. If you want to do it for now, change the text in the subject to have the {username} and {vehicle} and then
open includes/garage_func_var.php
Find
$pagetext = str_replace('{vehicle}', $full_veh_link, $pagetext);
After add

$title = str_replace('{username}', $new_veh_user['username'], $title);
$title = str_replace('{vehicle}', $veh_name, $title);
That will show the username and the full vehicle name in the subject. If you want to just display part of the vehicle name you will need to write some code in there to select just the part you want.
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #517  
Old 16 Mar 2011, 11:15
Club XJ Club XJ is offline
 
Join Date: Mar 2011
Installed on 4.1.2 in less than 10 minutes. So far so good.
Reply With Quote
  #518  
Old 16 Mar 2011, 15:12
cTak cTak is offline
 
Join Date: Sep 2006
Originally Posted by Dylanblitz View Post
I can add it with the next release. If you want to do it for now, change the text in the subject to have the {username} and {vehicle} and then
open includes/garage_func_var.php
Find
After add

That will show the username and the full vehicle name in the subject. If you want to just display part of the vehicle name you will need to write some code in there to select just the part you want.
Thanks! That works perfectly now! Now instead of seeing a page full of threads all with the same boring name over and over, we can easily take a glance at the page and see WHO added WHAT to the garage, and view the ones that spark our interest!

Thanks again!
__________________
Version 4.1.2 User
Reply With Quote
  #519  
Old 16 Mar 2011, 15:47
cTak cTak is offline
 
Join Date: Sep 2006
Well after looking it over, it works but doesn't.


It does show the name and vehicle in the subject title, but, the thread body text is using the same text as the thread subject.

In my admin, I have
title: {username} added their {vehicle} to the garage!
body: {username} has created a new vehicle in the garage. Go check out their {vehicle}!

But the thread shows up as:
title - brian added their 2011 BMW M3 to the garage!
body - brian added their 2011 BMW M3 to the garage!
__________________
Version 4.1.2 User
Reply With Quote
  #520  
Old 16 Mar 2011, 16:41
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by cTak View Post
Well after looking it over, it works but doesn't.


It does show the name and vehicle in the subject title, but, the thread body text is using the same text as the thread subject.

In my admin, I have
title: {username} added their {vehicle} to the garage!
body: {username} has created a new vehicle in the garage. Go check out their {vehicle}!

But the thread shows up as:
title - brian added their 2011 BMW M3 to the garage!
body - brian added their 2011 BMW M3 to the garage!
Hmm, does the code look like this now? I just tried it in my dev and it works

$pagetext = str_replace('{username}', $full_user_link, $vbulletin->options[garage_post_text]);
$pagetext = str_replace('{vehicle}', $full_veh_link, $pagetext);

$title = str_replace('{username}', $new_veh_user['username'], $title);
$title = str_replace('{vehicle}', $veh_name, $title);

$threaddm->set_info('forum', $foruminfo);
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #521  
Old 16 Mar 2011, 21:46
cTak cTak is offline
 
Join Date: Sep 2006
Whoops, I had an error from me playing with it before hand.

Reloaded the original garage_func_var.php and added the code above and it works as intended!

Thanks!
__________________
Version 4.1.2 User
Reply With Quote
  #522  
Old 16 Mar 2011, 23:43
southeastminis southeastminis is offline
 
Join Date: Mar 2011
I keep getting the following error message when trying to upload a picture to the garage.

Warning: mkdir() [function.mkdir]: Permission denied in [path]\includes\garage_func_var.php on line 2744

Warning: move_uploaded_file(images/garage/attach/1/garage_vehicle-3-13003189071_full.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in [path]\includes\garage_func_var.php on line 2821

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move 'D:\Temp\php\php5A27.tmp' to 'images/garage/attach/1/garage_vehicle-3-13003189071_full.jpg' in [path]\includes\garage_func_var.php on line 2821

any help would be appreciated@!
Reply With Quote
  #523  
Old 17 Mar 2011, 00:17
southeastminis southeastminis is offline
 
Join Date: Mar 2011
Forgot to put that I tried to change the permissions to 777, but got the following error message with my FTP.

Response: 500 'SITE CHMOD 777 attach': command not understood
Reply With Quote
  #524  
Old 20 Mar 2011, 20:05
Club XJ Club XJ is offline
 
Join Date: Mar 2011
Found one issue. I'm not sure if its been discussed before or not. When you're on the main garage page the facebook connect icon does not show up. When you are connected with facebook as normal its also not there.
Reply With Quote
  #525  
Old 24 Mar 2011, 01:36
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Club XJ View Post
Found one issue. I'm not sure if its been discussed before or not. When you're on the main garage page the facebook connect icon does not show up. When you are connected with facebook as normal its also not there.
If you edit the template garage_main and change the top to be the following it should show it after that.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
VB Pro Garage with Timeslips
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 16:40.

Layout Options | Width: Wide Color: