Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Who has read this thread Details »
Who has read this thread
Mod Version: 1.3a, by delicjous (Coder/Designer) delicjous is offline
Developer Last Online: Nov 2018 I like it Show Printable Version Email this Page

vB Version: 5.3.2 Rating: (5 votes - 5.00 average) Installs: 26
Released: 31 Jul 2017 Last Update: 11 Dec 2017 Downloads: 155
Supported Uses Plugins Additional Files Translations  

A small mod to display all users who have read that thread.

The free version display all user-avatars with a title of username - readtime if you mouseover the avatar.

Useful Information: [I]the readnode data is deleted by cron every hour and delete all data older then ten days. So if you have a lot of readers... they don't all show up at the module.
You could set it up at Settings -> Options -> General Settings -> Database Read Marking Limit

Version 1.3a
  • Add another Version to files. This version is only visible for admins, super-mods and mods.

Version 1.3
  • correction of a template-condition -> show userspecific avatars and not only the default.

Version 1.2
  • change all the typos like MarkFL suggust in comments.
  • delete the auto generated MAC_OSX files
  • add folders like path to upload (core/packages/whohasreadthisthread/)
  • add a readme. Even it is self-understanding.

Version 1.1
  • some small template changes
  • add the phrase to change the text of the title

There will be a pro-version soon with some more options.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	whohasreadthis.jpg
Views:	714
Size:	20.7 KB
ID:	156555  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Display members who have recently read a thread Paul M Modification Graveyard 212 21 Aug 2009 04:15

  #31  
Old 08 Aug 2018, 10:52
Tamara-Jasmin Tamara-Jasmin is offline
 
Join Date: Jun 2010
da steht tatsächlich was drin - aber nicht von Dir, sondern 2 Einträge von Duckway.

Ich habe mich bei deinem AddOn gerade auch gefragt ob vielleicht durch mein Testsystem - da ich die einzige Nutzerin bin - das vielleicht gar nicht angezeigt wird wenn nur ein Nutzer das Thema gelesen hat.

wie schon gesagt kenne ich die Variablen noch nicht und habe einfach mal in der readers.php nodeid auf > 0 gesetzt für den fall dass dies die NutzerId ist, kam aber auch nix.

Hab auch heute erst festgestellt dass "Plug-ins" jetzt Hooks heissen und kann da nun manuell evtl. Restbestände löschen.

Werde alles jetzt mal zurücksetzen und von vorne beginnen mit den AddOns.
Wie schon gesagt steht das Teil beim installieren fest.
Es geht nach einer Deinstallation auch nur nur mit Überschreiben, weil er es trotzdem erkennt und behauptet es wäre schon installiert.

LG: Tammy


Nachtrag:

Alles entfernt, reste gab es nicht. Viel Code ist ja bei Dir auch nicht vorhanden, viel falsch laufen kann eigentlich nicht.

Bei einer Neuinstallation - ohne weitere AddOns - ist das selbe. Er würde den ganzen Tag stehen bleiben bei "Installiere - bitte warten ...".



Bei PHP-Hooks sind absolut keine Einträge von Dir. Bei Hooks 2 Zeilen:

Wer hat das Thema gelesen - und
WerhatdasThemagelesen_copyright


Das AddOn ist eingetragen (aber keine Konfigurationsoptionen, nur text).



Sollte soweit passen.


Nachtrag zum Nachtrag:

0:40 Uhr --> Fehler beim Aufrufen eines Beitrages: " Ein interner Fehler ist aufgetreten und das Modul kann nicht angezeigt werden."


Hatte den ganzen Abend am Style gearbeitet. Mit einem Schlag diese Meldung. Ich gehe mal davon aus das irgendeine zeitgesteuerte Aufgabe das verursacht hat. Die additional.css hab ich nämlich aus Testgründen mal komplett geleert, da dies der einzige Sektor war woran ich gearbeitet habe. Hat sich nichts geändert ... Fehler immer noch da.

Hab Dein AddOn deaktiviert - und alles geht wieder.

Ist schon sehr mysteriös das ganze ... werde wohl leider verzichten müssen... auch wenn mich das ziemlich wurmt.


LG: Tammy

Last edited by Tamara-Jasmin; 10 Aug 2018 at 10:02.
Reply With Quote
  #32  
Old 11 Aug 2018, 10:51
delicjous's Avatar
delicjous delicjous is offline
 
Join Date: Nov 2014
Schau mal bitte in Einstellungen -> Optionen in den beiden Einstellungen:

-Art der Markierung von gelesenen Themen/Foren
(Hier sollte Datenbank ausgewählt sein)
-Speicherdauer für gelesene Inhalte in der Datenbank
(ist hier keine Zahl größer 0 hinterlegt, werden die Beiträge womöglich garnicht gespeichert)
__________________
vBulletin-forum.de | Das deutschsprachige vBulletin 5 Forum! | Widgets, Mods und Anleitungen auf deutsch.
Team online, Latest Profile-Visitors, Disable-Postcount, Auto-close Threads, Latest Likes, Top-Posters PRO, New&Free: vB5 MemberMap
Reply With Quote
  #33  
Old 11 Aug 2018, 19:54
Tamara-Jasmin Tamara-Jasmin is offline
 
Join Date: Jun 2010
Ja, danke. Das passt alles. Bei mir stand eine 10 drin. Hab diese auf 300 gestellt, und nun steht zumindest der Text über den Themen: Wer hat das Thema gelesen.
Habs auf 10 zurück gestellt - und steht immer noch da.

Aber keine Einträge. Bin mit einem anderen Account rein (Testaccount als Standarduser) - und wird auch nichts weiter angezeigt.

Gestern um Mitternacht übrigens wieder das selbe Phänomen. Beiträge lassen sich nach der Fehlermeldung erst wieder aufrufen wenn ich Dein AddOn deaktiviere.

Ich schau nächste Woche mal in der Datenbank ob da noch reste von der vB4 vorhanden sind - da war nämlich zu Anfangszeiten ein Tool mit der selben Funktion und dem selben Namen vorhanden! Auch wenn in den Hooks nichts mehr gelistet ist, kann es ja sein das irgendwo in der datenbank was abgefragt wird was sich beisst.

LG: Tammy


Nachtrag:

In der 'querydefs.php' sind die abschnitte nicht mit geschweiften Klammern geschrieben, sondern mit eckigen?
Das sehe ich das erste mal. Habe dies geändert, passiert aber trotzdem nichts. Die Tabellen und Spalten exitieren und sollten somit auch abrufbar sein. Nun weiss ich auch was 'nodeid' ist - die Themen-ID.
Also von dem her sehe ich keine Fehler im Code.

Last edited by Tamara-Jasmin; 12 Aug 2018 at 10:07.
Reply With Quote
  #34  
Old 12 Aug 2018, 11:35
Tamara-Jasmin Tamara-Jasmin is offline
 
Join Date: Jun 2010
Lass gut sein,

ich habe das AddOn gerade nochmal überschrieben - und nun keine Startseite mehr.

Nur noch der "editor" um etwas einzugeben. Die ganze Startseite ist verschwunden.



Ist aber Fairerweise gesagt wohl gerade mein Fehler, da ich die Hookordernummer auf 102500 (oder so ähnlich) abgeändert habe, weil ich dachte dass vielleicht die Zahl einfach zu hoch angegeben ist (100000000).
Hab einfach nur den Fehler in Deinem Code gesucht.


Nun muss ich nochmal von 0 an das ganze Forum neu aufsetzen .... aber von diesem Addon lass ich danach definitiv die Finger! Schade.


Im übrigen habe ich festgestellt das die Templates in meinem Style als "vererbt" eingefügt wurden. Mein Style ist aber definitiv als eigener Style erstellt worden. Auch wenn er sich von Anfang an nicht sortieren lässt (leider ganz unten, womit ich alle anderen styles löschen muss um ihn nach oben zu bekommen), funktioniert er sonst aber m.E.n. relativ Problemlos.


LG: Tammy

Last edited by Tamara-Jasmin; 12 Aug 2018 at 11:43.
Reply With Quote
  #35  
Old 12 Aug 2018, 13:16
delicjous's Avatar
delicjous delicjous is offline
 
Join Date: Nov 2014
Also ich weiß ja nicht was Du da machst und oder gemacht hast... Die Installation ist eigentlich sehr einfach und das Addon KANN DEFINITIV NICHT zu solchen Problemen führen. Falls Du immer noch vB4 Dateien in deinem ForumROOT liegen hast, solltest Du diese ebenso definitiv entfernen!!!
__________________
vBulletin-forum.de | Das deutschsprachige vBulletin 5 Forum! | Widgets, Mods und Anleitungen auf deutsch.
Team online, Latest Profile-Visitors, Disable-Postcount, Auto-close Threads, Latest Likes, Top-Posters PRO, New&Free: vB5 MemberMap
Reply With Quote
  #36  
Old 12 Aug 2018, 20:03
Tamara-Jasmin Tamara-Jasmin is offline
 
Join Date: Jun 2010
Hi,

da sind keine Reste - wurde alles nach (wie Du ja weist eh fehlerhafte) Anleitung gemacht.

Das Problem ist auch sicher nicht Dein AddOn. Nicht dass das hier falsch rüber kommt.

Das Problem ist einfach dieses vB5 Gemurkse das aus mehr Fehlern als Funktionen besteht.

Bin gerade dabei zu XenForo zu wechseln, das vB5 ist völlig untauglich und - wie hat man in einem anderen Forum geschrieben? - völlig dilettantisch programmiert.

Kein Wunder das sich seit Jahren da nichts mehr tut.

Wirklich FAST alle negativbeiträge im Internet über vB5 haben sich in der Praxis leider bestätigt - und es war sogar noch schlimmer!
Schade um das Geld.



LG: Tammy
Reply With Quote
  #37  
Old 08 Nov 2018, 19:18
AMArtinez AMArtinez is offline
 
Join Date: Nov 2018
Can somebody please confirm if this extension 1.3a works with 5.4.4?, thanks.
Reply With Quote
  #38  
Old 08 Nov 2018, 19:24
delicjous's Avatar
delicjous delicjous is offline
 
Join Date: Nov 2014
Yes, it works with 5.4.4. Did you try?
__________________
vBulletin-forum.de | Das deutschsprachige vBulletin 5 Forum! | Widgets, Mods und Anleitungen auf deutsch.
Team online, Latest Profile-Visitors, Disable-Postcount, Auto-close Threads, Latest Likes, Top-Posters PRO, New&Free: vB5 MemberMap
Reply With Quote
Reply

Tags
read, thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 07:22.

Layout Options | Width: Wide Color: