Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Advanced Warning System 3.6.7 Details »
Advanced Warning System 3.6.7
Mod Version: 3.6.9(C), by Delphiprogrammi (Member) Delphiprogrammi is offline
Developer Last Online: Aug 2015 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (8 votes - 4.25 average) Installs: 210
Released: 20 Aug 2006 Last Update: 03 Oct 2007 Downloads: 2114
Not Supported DB Changes Uses Plugins Template Edits Code Changes Additional Files Is in Beta Stage  

Advaned Warning System

This is a port of aws and i release this with permission...(yes i did ask the original author)

This version of the warning includes
  • 1 vbulletin 3.6.x product file (XML)
  • 1 admincp navigation XML
  • 1 functions file(functions_warning.php)
  • 3 images
  • 3 cronjobs
  • 1 modcp file to allow moderators to view warnings information without having to give admincp access(mod_warn.php)
  • 1 admincp file to manage the system options(admin_warn.php)
  • 1 XML to control permissions(bitfield_aws.xml)
For a completer list of the system features you can refer to this

This version will also require vbulletin 3.6.x to run.If you run 3.5.x or any other release then 3.6.x you will see a message.

This system is tested for a long time and i believe it's stable enough for a public release HOWEVER since this is a major hack and i'm just human please consider this first public run still as "beta"

instructions ow howto install can be found in the docs directory within the zip

statistics
  • 25 plugins
  • 27 templates
  • 5 new MySQL tables
  • 3 standard vbulletin tables alterd (user,post,and usergroup)
  • 827 phrases
  • 47 settings
updates

A problem has been found where no link is provided to view your own warnings(normal users) in the member profile only i fixed this.To get the fix you will need to reedit your "MEMBERINFO" template and reimport product-aws.xml (set allow overwrite to yes)

15-9-2006
I moved the cron jobs from the install/uinstall code to the product file.
version check url now uses http://www.vbulletin.org/forum/misc....rsion&t=124477

to upgrade read upgrade.txt in the docs directory

24-9-2006

a product depency whas added the system will no longer install on PHP 5 (in response to continued error reports on that PHP version)

to report a possible bug

please go the system bugtracker here you can use the folowwing account

username:bugreporter
password:awsbug

no need to register yourself


30-11-2006
People on PHP 5 can follow this instructions to avoid the PHP version related error message BUT remember you are on your own if you do this.I won't upgrade my PHP until PHP 5 is there main stable release (www.php.net)


1-1-2007
A bug has been reported in the system.This bug whas causing vbulletin to throw an error when you try to use admincp => users=> add a new user

Fatal error: Call to a member function clean_gpc() on a non-object in class_dm_user.php(2385) : eval()'d code on line 35
Solution

Edit plugin "AWS:warn link in usermanager" and replace all code with this


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

i'll update the package when i get home


Another Bug is fixed

This release includes a fix for the problem "call to member function on a non object class_dm_user.php)" when you try to add a new user manaually (after submitting the form)

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	warninglog.png
Views:	6490
Size:	35.0 KB
ID:	52367   Click image for larger version

Name:	postbit.png
Views:	5403
Size:	29.4 KB
ID:	52368   Click image for larger version

Name:	addwarn.png
Views:	5080
Size:	27.1 KB
ID:	52369   Click image for larger version

Name:	ban.png
Views:	3045
Size:	13.7 KB
ID:	52370  

Click image for larger version

Name:	ban_view.png
Views:	2603
Size:	14.5 KB
ID:	52371  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Advanced Warning System (AWS) sv1cec vBulletin 3.0 Full Releases 1042 16 Jul 2007 04:50

  #121  
Old 12 Oct 2006, 16:59
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by nir
it works to the version 3.6.2?
yeah
Reply With Quote
  #122  
Old 12 Oct 2006, 17:05
nir nir is offline
 
Join Date: Aug 2005
Real name: itzik
This product is not compatible with version 4.3.10 of PHP. (Compatible starting with 4.4.4 / Incompatible with 5.0.0 Beta 1 and greater)

this is does not work
Reply With Quote
  #123  
Old 12 Oct 2006, 17:16
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by nir
This product is not compatible with version 4.3.10 of PHP. (Compatible starting with 4.4.4 / Incompatible with 5.0.0 Beta 1 and greater)

this is does not work
your profile says you are using vbulletin 3.5.3 it will not work on that version of vbulletin.Also everything below PHP 4.4.4 have known security holes and i strongly urge you to upgrade
Reply With Quote
  #124  
Old 12 Oct 2006, 17:21
nir nir is offline
 
Join Date: Aug 2005
Real name: itzik
the version my is 3.5.2
what to do in order installing?
Reply With Quote
  #125  
Old 12 Oct 2006, 17:36
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by nir
the version my is 3.5.2
what to do in order installing?
you can't it does not work on 3.5.x however there is a 3.5.x version here

Last edited by Delphiprogrammi; 12 Oct 2006 at 17:38.
Reply With Quote
  #126  
Old 12 Oct 2006, 17:45
nir nir is offline
 
Join Date: Aug 2005
Real name: itzik
i'm sorry my erring
the version my is 3.6.0
unmistakable i registered 5

Last edited by nir; 12 Oct 2006 at 18:41.
Reply With Quote
  #127  
Old 12 Oct 2006, 17:58
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by nir
i'm sorry my erring
the version my is 3.6.2
unmistakable i registered 5
then you will need PHP 4.4.4 see this for important updates since your version .... OR you can try the folowwing open product-aws.xml and find


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and remove that line after that (and you did that correctly) you should be able to import the product XML

however this is not supported if you do this you are on your own
Reply With Quote
  #128  
Old 14 Oct 2006, 16:59
SupermanInNY SupermanInNY is offline
 
Join Date: Oct 2005
I've upgraded the board from 3.5.4 to 3.6.2.

I was using AWS 3.5.0 and now I need to upgrade it to the current 3.6.1.

I've uploaded the files (overwrote existing files) and then went to the Plugin and Products --> Manage Products --> Add / Import Products --> Browesed to product-aws.xml + Selected YES to overwrite and pressed the Import button.

It went OK,. but when I wanted to check on the AWS group I noticed it still carried the Advanced Warning System 3.5.0 .

Shouldn't that have shown me 3.6.1 instead of the 3.5.0?

I forgot to mention that when I click on the Check Version in the Plugin and Products System, it shows: Installed version 3.6.1 and latest version 3.6.1

So I think it is just a matter of wrong tag/field that has not been updated?

I believe there is a problem with the following table:

vb3_setting It is the one that has:

defaultvalue 3.6.1
but
value 3.5.0

Any chance this is not updating correctly?


I think I followed the instructions to the letter.
Do I need to do something else?

-Alon.

Last edited by SupermanInNY; 15 Oct 2006 at 05:17.
Reply With Quote
  #129  
Old 14 Oct 2006, 17:03
Shazz's Avatar
Shazz Shazz is offline
 
Join Date: Jun 2006
Location: Utah
Real name: Shawn
Whats the difference between Infractions and This?
Sorry if this has been asked
Reply With Quote
  #130  
Old 16 Oct 2006, 11:56
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by SupermanInNY
I've upgraded the board from 3.5.4 to 3.6.2.

I was using AWS 3.5.0 and now I need to upgrade it to the current 3.6.1.

I've uploaded the files (overwrote existing files) and then went to the Plugin and Products --> Manage Products --> Add / Import Products --> Browesed to product-aws.xml + Selected YES to overwrite and pressed the Import button.

It went OK,. but when I wanted to check on the AWS group I noticed it still carried the Advanced Warning System 3.5.0 .

Shouldn't that have shown me 3.6.1 instead of the 3.5.0?

I forgot to mention that when I click on the Check Version in the Plugin and Products System, it shows: Installed version 3.6.1 and latest version 3.6.1

So I think it is just a matter of wrong tag/field that has not been updated?

I believe there is a problem with the following table:

vb3_setting It is the one that has:

defaultvalue 3.6.1
but
value 3.5.0

Any chance this is not updating correctly?


I think I followed the instructions to the letter.
Do I need to do something else?

-Alon.
the warn_version thing is indeed stored in the setting table but that should be autoupdated when you import the new product XML why it doesn't update ??

you should be ready to go now create a testuser and give him a warning ...
Reply With Quote
  #131  
Old 16 Oct 2006, 11:59
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by Shazz
Whats the difference between Infractions and This?
Sorry if this has been asked
Well some people call me nuts because i ported this to 3.6.x.I did because i love the system.I'm using this from the day it was born in the old 3.0x series.Vbulletin infractions are far much more complicated.If you want something simple you can take a look at this.
Reply With Quote
  #132  
Old 18 Oct 2006, 16:50
rinkrat's Avatar
rinkrat rinkrat is offline
 
Join Date: Jan 2002
When I enable this hack, I get errors from the quickreply box. either it doesn't go to the next page upon submission or it reports a double post.
__________________
Los Angeles Kings Fan Page
Reply With Quote
  #133  
Old 30 Oct 2006, 06:44
Masters Masters is offline
 
Join Date: Jan 2006
Hide warning points from registered users?

My registered users can see everyone's warning points.
How do I hide this?
Reply With Quote
  #134  
Old 31 Oct 2006, 16:00
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by rinkrat
When I enable this hack, I get errors from the quickreply box. either it doesn't go to the next page upon submission or it reports a double post.
impossible this hack does not interfere with QR at all
Reply With Quote
  #135  
Old 31 Oct 2006, 16:00
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by Masters
My registered users can see everyone's warning points.
How do I hide this?
under manage warning options => who can see the warning points and bans => set this to Mgm (this means moderators and up will see it)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 04:10.

Layout Options | Width: Wide Color: