Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 15 Jul 2017, 01:01
creative-friend creative-friend is offline
 
Join Date: Feb 2009
cannot send session cookies

I have upgrade my fourm form 4.2.2 to 4.2.5. After that forum work fine from my admin id. when i delete cookies of my pc following error shown




navbar tabs looks like this



After that i cannot access forum. when i tried to open the forum only blank page appear.


error logs shown following error



PHP Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/***************/includes/config.php:1) in /home/***************/includes/facebook/facebook.php on line 49
PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/**************/includes/config.php:1) in /home/****************/includes/facebook/facebook.php on line 49
PHP Fatal error: Call to undefined method stdClass::set() in /home/***************/includes/functions.php on line 7549
Reply With Quote
  #2  
Old 15 Jul 2017, 02:02
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
I'm thinking this may have to do with PHP version and/or a modification. What is your PHP version set to when running vB4.2.5?

You can try disabling each modification you have installed one-by-one, to see which is causing the issue.
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #3  
Old 15 Jul 2017, 02:09
creative-friend creative-friend is offline
 
Join Date: Feb 2009
Originally Posted by TheLastSuperman View Post

You can try disabling each modification you have installed one-by-one, to see which is causing the issue.
I cannnot access forum

Originally Posted by TheLastSuperman View Post
I'm thinking this may have to do with PHP version and/or a modification. What is your PHP version set to when running vB4.2.5?
Current PHP version: 5.6.31
Reply With Quote
  #4  
Old 15 Jul 2017, 02:19
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Can you access the back-end i.e. the Administrator Control Panel?

If you can't access admincp to disable each mod one-by-one then try my article info here, it shows you how to disable mods without admincp access.
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #5  
Old 15 Jul 2017, 02:33
creative-friend creative-friend is offline
 
Join Date: Feb 2009
Originally Posted by TheLastSuperman View Post
Can you access the back-end i.e. the Administrator Control Panel?

If you can't access admincp to disable each mod one-by-one then try my article info here, it shows you how to disable mods without admincp access.
nothing happen by disable mods
Reply With Quote
  #6  
Old 15 Jul 2017, 02:34
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Okay then its a matter of older php version conflicting with newer version of vBulletin. Have your host place you on PHP7 (7.0 not 7.1 for now).

If your cpanel has an option "Select PHP Version" you can try that yourself before asking your host for assistance. *Screenshot the old modules before changing in case you need to revert back to PHP5.6 etc.
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #7  
Old 15 Jul 2017, 03:27
creative-friend creative-friend is offline
 
Join Date: Feb 2009
Originally Posted by TheLastSuperman View Post
Okay then its a matter of older php version conflicting with newer version of vBulletin. Have your host place you on PHP7 (7.0 not 7.1 for now).

If your cpanel has an option "Select PHP Version" you can try that yourself before asking your host for assistance. *Screenshot the old modules before changing in case you need to revert back to PHP5.6 etc.
I could not find "select php version" option in cpanel. Now i ask host provider for this.
thanks for your help

--------------- Added 15 Jul 2017 at 04:17 ---------------

the following error shown on php 7.0.21

Error: Call to undefined method stdClass::set() in ..../includes/functions.php on line 7549

--------------- Added 15 Jul 2017 at 12:19 ---------------

error log shown follwing error. above error showm on opening forum

UTC] PHP Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/************/includes/config.php:1) in /home/*********/includes/facebook/facebook.php on line 49
PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home**************/includes/config.php:1) in /home/****************/includes/facebook/facebook.php on line 49

--------------- Added 15 Jul 2017 at 12:23 ---------------

I also tried PHP 7.1.7. but same error occur

Last edited by creative-friend; 15 Jul 2017 at 04:56.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 21:10.

Layout Options | Width: Wide Color: