Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Favorite Smilies Details »
Favorite Smilies
Mod Version: 1.0.5, by Darwinist (Member) Darwinist is offline
Developer Last Online: May 2009 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (34 votes - 4.71 average) Installs: 392
Released: 05 Aug 2006 Last Update: 24 Jul 2007 Downloads: 2422
Not Supported Uses Plugins Template Edits Code Changes Additional Files  

This add-on will allow members to create their own favorite smilies list, which can be useful on boards with lots of smilies. If a member creates a list, it will be displayed in place of the normal smilie box.

Maximum number of smilies is based on the 'Smilie Menu Total Smilies' option in 'Message Posting Interface Options'.


Features:
  • Edit List in UserCP
  • Javascript Enforced Limit
  • Ignore Certain Smilie Categories
  • Allow/Disallow usage based on usergroup
  • Admin CP Help
Installation Overview:
Files to Modify: 1
Templates to Modify: 1
Files to Upload: 2
Product:
-Plug-Ins: 6
-Templates: 5
-vB Options: 4
-Phrases: 29

NOTICE: If you're upgrading to version 1.0.4 from a previous version, please read the 'Upgrade.htm' file. Otherwise, read the 'Install_3.6.0.htm' for vBulletin 3.6.0 installations or 'Install_3.6.1.htm' file for vBulletin 3.6.1 or newer installations for the installation procedure.

Version History:
1.0.5 - Fixed vulnerability.
1.0.4 - Added smilie selection count under smilie selection menu. One less template to edit.
1.0.3 - Added option to hide smilie titles on the selection menu (for boards with a very large number of smilies). Icon link to edit the list on the editor toolbar. Admin CP help text. Improved integration with the UserCP. One less file to edit. Fixed some text that wasn't phrased.
1.0.2 - Added option to limit who can use the Favorite Smilies listed based on usergroup permissions. Changed smilie selection page to include category names. Fixed Missing 'More' link in Smilie dropdown menu.
1.0.1 - Fixed problem with missing table prefixes.
1.0.0 - Initial release.

A version for 3.5 can be found Here
A version for 3.7 can be found Here

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	favoritesmilies1.jpg
Views:	2028
Size:	178.5 KB
ID:	54356   Click image for larger version

Name:	favoritesmilies2.jpg
Views:	7143
Size:	107.7 KB
ID:	54357   Click image for larger version

Name:	favoritesmilies3.jpg
Views:	3876
Size:	87.9 KB
ID:	54358  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
End-User Options Favorite Smilies Darwinist vBulletin 3.7 Add-ons 128 19 Dec 2015 15:00
Favorite Smilies Darwinist vBulletin 3.5 Add-ons 12 20 Sep 2007 00:01

  #61  
Old 17 Sep 2006, 18:03
radarhunter radarhunter is offline
 
Join Date: Jul 2006
sorry posted by mistake editing the post

Last edited by radarhunter; 17 Sep 2006 at 18:05.
Reply With Quote
  #62  
Old 17 Sep 2006, 18:35
Gripemaster Gripemaster is offline
 
Join Date: Oct 2005
Seems to have installed fine. Tested it on a regular member account, and it allowed me to select favorite smilies. However, after submitting my favorites, when I hit the reply button it returns the VB database error. Went back in and cleared the list of favorites, and no database error. Did everything by the book and had no errors on install. Where did I go wrong?

EDIT: OK either I did something wrong (which is more likely), or it doesn't like the Order By rand line, that is what returned the DB error. Used your original code and it works fine. Where might I have gone wrong?

Last edited by Gripemaster; 17 Sep 2006 at 18:58.
Reply With Quote
  #63  
Old 17 Sep 2006, 20:34
Gripemaster Gripemaster is offline
 
Join Date: Oct 2005
I figured our where I went wrong...typing on one computer while reading from the other...LOL I had a space between rand and ()... I had:

rand ()

Instead of:

rand()

One little space...LMAO.

*Gripemaster clicks Install and says Thank You*
Reply With Quote
  #64  
Old 17 Sep 2006, 20:39
SCRIPT3R SCRIPT3R is offline
 
Join Date: Jan 2005
Question

anyone else getting an ncwoodworker.net login prompt when the 1st page of this thread loads?
Reply With Quote
  #65  
Old 13 Oct 2006, 07:46
jw00dy's Avatar
jw00dy jw00dy is offline
 
Join Date: Dec 2004
Thanks for the update. I like the added smilie on the new post/reply... very nice.
__________________
Just another squirrel trying to get a nut
Reply With Quote
  #66  
Old 14 Oct 2006, 12:37
goodguy goodguy is offline
 
Join Date: Jul 2004
I'm being dumb here, I can see the smilies when replying to a post but cant work out how to select them in the control panel, any ideas?

Thanks
Reply With Quote
  #67  
Old 14 Oct 2006, 12:44
Darwinist Darwinist is offline
 
Join Date: Apr 2002
Real name: Steve
Just click on 'edit favorite smilies' and then click the check boxes next to the smilies you want added to your favorites list and click 'save'.
Reply With Quote
  #68  
Old 14 Oct 2006, 12:47
goodguy goodguy is offline
 
Join Date: Jul 2004
Originally Posted by Darwinist
Just click on 'edit favorite smilies' and then click the check boxes next to the smilies you want added to your favorites list and click 'save'.
I dont seem to have that in the control panel, as I said I've done something dumb, first time of trying hack though so I thought I'd do two at once
Reply With Quote
  #69  
Old 14 Oct 2006, 14:17
Darwinist Darwinist is offline
 
Join Date: Apr 2002
Real name: Steve
Confirm you completed step #2 in the install instructions (editing the 'USERCP_SHELL' template). Also confirm that your usergroup permissions have the favorite smilies option set to 'on' (it's on by default, but may have been changed).
Reply With Quote
  #70  
Old 14 Oct 2006, 14:36
goodguy goodguy is offline
 
Join Date: Jul 2004
Originally Posted by Darwinist
Confirm you completed step #2 in the install instructions (editing the 'USERCP_SHELL' template). Also confirm that your usergroup permissions have the favorite smilies option set to 'on' (it's on by default, but may have been changed).
All seems to be done but it still isnt there, cant see an option in the user group manager either though?
Reply With Quote
  #71  
Old 14 Oct 2006, 14:36
goodguy goodguy is offline
 
Join Date: Jul 2004
Originally Posted by Darwinist
Confirm you completed step #2 in the install instructions (editing the 'USERCP_SHELL' template). Also confirm that your usergroup permissions have the favorite smilies option set to 'on' (it's on by default, but may have been changed).
All seems to be done but it still isnt there, cant see an option in the user group manager either though?
Reply With Quote
  #72  
Old 14 Oct 2006, 22:08
Darwinist Darwinist is offline
 
Join Date: Apr 2002
Real name: Steve
At the very bottom of the usergroup permissions page, in the 'Usergroup Options' section, there should be the option 'Allow Users to Select Favorite Smilies'. If it's not there, then you'll have to make sure the 'bitfield_favoritesmilies.xml' file has been uploaded to the includes/xml directory.
Reply With Quote
  #73  
Old 19 Oct 2006, 22:11
BrandiDup's Avatar
BrandiDup BrandiDup is offline
 
Join Date: Jun 2005
Real name: Brandi
I installed this and it was working perfectly fine until several members who upgraded to Internet Explorer 7 started complaining that their smilie box was cut off. I didn't have problems with mine because I was using the previous version of IE but now that I just upgraded, the box is being cut off on mine also. It doesn't matter what I set the number of rows to, it still cuts them off. If I set it to 5 rows, it only shows 4 of them. If I set it to 4 rows, it only shows 3 of them. But it only does this for a new reply and new thread. When PMing, it seems to be okay :ermm:

Here are the two screen shots so you can see what I'm talking about. One is of the smilies being cut off and the other is with them showing fine when I'm PMing someone. This seems to only be an error with IE 7 because it works fine on the other browsers. Any idea how to correct this?
Attached Images
File Type: gif smilieerror.gif (41.4 KB, 45 views)
File Type: gif smilienoerror.gif (52.0 KB, 40 views)
__________________
MilitarySOS.com - November 2007 Board of the Month
TheWomanHood.com - vote us for May's Board of the Month
Reply With Quote
  #74  
Old 20 Oct 2006, 16:25
BrandiDup's Avatar
BrandiDup BrandiDup is offline
 
Join Date: Jun 2005
Real name: Brandi
no ideas? :/
__________________
MilitarySOS.com - November 2007 Board of the Month
TheWomanHood.com - vote us for May's Board of the Month
Reply With Quote
  #75  
Old 20 Oct 2006, 19:21
Ricardo Ricardo is offline
 
Join Date: Oct 2006
First: I love the mod ! I am using it ! Second: Is there a way to go one step further and add the Favorites to a Quick-Reply post form ? That would be great !!! There is a mod already for Quick-Reply smilies, but I would like to use the favorite ones there ! Thanks ...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:21.

Layout Options | Width: Wide Color: