Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Advanced Application Forms Details »
Advanced Application Forms
Mod Version: 1.4.7, by nhawk (Member) nhawk is offline
Developer Last Online: Oct 2019 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 4.1.1 Rating: (53 votes - 4.89 average) Installs: 408
Released: 20 May 2011 Last Update: 07 Sep 2015 Downloads: 2882
Not Supported Translations  

THIS ADD-ON IS NO LONGER AVAILABLE AND IS NOT SUPPORTED

* General Information *
------------------------------
This is an add-on that is designed for vBulletin 4.1.1 or later. It may not work on earlier versions of vBulletin.


Nominated twice for MOTM (October 2011, January 2012)


Features
  • Unlimited Application Types*
  • Unlimited Application Positions*
  • Unlimited Questions*
  • Different Application Positions for each Application Type
  • Different Questions for each Application Position.
  • Allow others to add/edit Application Types by permissions.
  • Allow others to edit Positions/Questions by permissions.
  • Edit Application Types, Positions and Questions in either ACP or from board.
  • Show Multiple Application Types in Community Menu or direct link to them.
  • Control Application Type access by Usergroup, Postcount
  • Control Application Position access by Usergroup, Postcount
  • Notification of an application via Forum Thread and/or Email and/or Private Message
  • Specify Different Forums for Reports by Application Position.
  • Define a default question set that can be included on all applications.
  • Much, much more!

* Limited only if you are limited in database size and/or free disk space.


* INSTALLATION *
-------------------
1) Upload the contents of the 'upload' folder to your forum's root.
(If your forum's location is http://www.example.com/forums/, the root is /forums/)

2) Depending on your server configuration, you will need to change the permissions of the advappfiles folder to either 775 or 777

3) Import the product XML file (product-advapp.xml) into the Product Manager in AdminCP.

4) Take some time to set the options, application types and application postions in the new Application Forms area of AdminCP.
(It's really not that hard!)

5) Make sure this modification is marked as 'Installed' on vBulletin.org!
(If you want to get notices from me about updates for this modification.)

* UPGRADE INSTRUCTIONS *
-----------------------------
1) Upload the contents of the 'upload' folder to your forum's root.
(If your forum's location is http://www.example.com/forums/, the root is /forums/)

2) Import the product XML file (product-advapp.xml) into the Product Manager in AdminCP and be sure "Allow Overwrite" is set to 'Yes'.

3) vB 4.2.x ONLY - Go to ACP->Settings->Options->Application Form Settings and set 'vB 4.2 Community Menu Update' to 'Yes'.

UPGRADING TO VERSION 1.3.8 or HiGHER
Depending on your server configuration, you will need to change the permissions of the advappfiles folder to either 775 or 777

If you have edited the advapp_application template, you need to revert the template before upgrading to 1.3.8 or higher.
Once the upgrade is complete, you can re-apply your changes to that template.


* History (Changelog) *
-------------------------
1.4.7 (September 7, 2015)
- Fix Certain characters not being stored/displayed properly.

1.4.6 (January 2, 2014)
- Fix Certain non-english characters not being stored/displayed properly.

1.4.5 (October 11, 2013) (not released vB.org)
- Fix No thread status showing in new threads when Thread Status Pro version 1.0.3 is installed.

1.4.4 (August 5, 2013)
- Fix Change single MySQL call to vB database call for systems that don't play well with direct MySQL calls.

1.4.3 (July 15, 2013)
- Fix Extra tabs in first response line in email notificactions.

1.4.2 (June 18, 2013)
- Fix Applications still able to be submitted after member logs out when unusual usergroup settings are used.

1.4.1 (June 8, 2013)
- Fix regex error missing from query.

1.4.0 (June 4, 2013) (not released on vB.org)
- Fix community menu not updating properly with vB 4.2.1

1.3.9 (May 2, 2013)
- Fix thread starter not showing when new thread is created and using actual userid to post new thread.

1.3.8 (May 2, 2013) (not released on vB.org)
- Add file upload option to application questions.(Available from ACP ONLY)

1.3.7 (May 1, 2013)
- Add error field in question editor for validation failure.

1.3.6 (May 1, 2013) (not released on vB.org)
- Fix moderated threads not showing as moderated in ACP.
- Change regex validated fields are now optional if no error message is defined for the field.
- Change streamline code for displaying applications forms.

1.3.5 (April 29, 2013)
- Change question save routine to prevent misnumbering of question order.
- Add single line text answers now allow regular expression matching.(Editing regex available from ACP ONLY)
- Add flood check for new threads
- Add flood check for new posts.

1.3.4 (April 22, 2013) (not released on vB.org)
- Fix header/title phrase input on application type screen not showing properly on forum application screens.
- Fix several typographical errors in phrases.

1.3.3 (March 2, 2013)
- Fix database error if Thread Status Pro is not installed.
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.2 JUST UPLOAD FILES TO YOUR SERVER)

1.3.2 (February 28, 2013) (not released on vB.org)
- Add support for default forum thread status from Thread Status PRO
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.1 JUST UPLOAD FILES TO YOUR SERVER)

1.3.1 (November 20, 2012)
- Fix database error when saving application type with some punctuated admin usernames.
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.0 JUST UPLOAD FILES TO YOUR SERVER)

1.3.0 (November 19, 2012) (never released on vB.org)
- Fix item selection problems with Firefox browser
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.2.9 JUST UPLOAD FILES TO YOUR SERVER)

1.2.9 (July 30, 2012)
- Fix error when editing application types in board (was not happening in ACP edit)
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.2.8 JUST UPLOAD application-types.php to your server)

1.2.8 (May 23, 2012)
- Improved work around for vB 4.2 bug pertaining to navigation menu items (JIRA VBIV-14959).

1.2.7 (May 21, 2012)
- Work around for vB 4.2 bug pertaining to navigation menu items (JIRA VBIV-14959).

1.2.6 (May 20, 2012) (never released on vB.org)
- Made system compatible with vB 4.2.0

1.2.5 (February 27, 2012)
- Fix IP address not being displayed when answer color option is used.
- Fix overlap of nav tab with nav menu.

1.2.4 (January 17, 2012)
- Fix URL not being parsed when answer color is defined and URL is the only thing in the answer.

1.2.3 (January 11, 2012)
- Add replacement variables to PM after submitting application.
- Add answer color option to main settings.
- Add multiple choice answers in column format option to main settings.
- Add 'All of the above' Multiple Choice question type.

1.2.2 (December 16, 2011) (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.2.1, JUST UPLOAD FILES TO SERVER)
- Fix UTF-8 character display for expected answers.
- Fix sorting problem with first application questions.

1.2.1 (December 15, 2011) (not uploaded on vBulletin.org)
- Add option to PM a member after submitting an application.
- Add numeric ordering to edit position questions in ACP ONLY. (NOTE: Numbering MUST stay as 1,2,3.. NEVER use 10, 20, 30...)

1.2.0 (December 7, 2011)
- Fix database error when single quote is used in expected responses. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.9, JUST UPLOAD FILES TO SERVER)

1.1.9 (December 5, 2011) (Not uploaded on vBulletin.org)
- Fix quote character not being displayed properly in posts. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.8, JUST UPLOAD FILES TO SERVER)

1.1.8 (December 2, 2011)
- Fix 'not enough posts' now displays when it should. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.7, JUST UPLOAD FILES TO SERVER)

1.1.7 (November 5, 2011)
- Added single selection dropdown box for questions.

1.1.6 (October 13, 2011) (Not uploaded on vBulletin.org)
- Code enhancements for future expansion.

1.1.5 (September 4, 2011)
- Repair forum based application group type editor. (NO NEED TO IMPORT XML WHEN UPDATING FROM 1.1.4 to 1.1.5, JUST UPLOAD FILES TO SERVER - NO NEED TO UPDATE IF YOU DON'T USE THE FORUM BASED EDITOR)

1.1.4 (August 27, 2011)
- Change hard coded Yes/No answers to standard vBulletin Yes/No phrases (thanks to Ellendway for testing).

1.1.3 (August 15, 2011)
- Corrected post format problems.
- Changed human verify portion of template.
- Changed hard coded Yes/No questions to standard vBulletin Yes/No Phrases.

1.1.2 (July 30, 2011)
- Code enhancements to allow for future expansion.

1.1.1 (July 6, 2011)
- Fix human verification. (problem found while converting mod to vB 3.8.7)

1.1.0 (June 29, 2011)
- Installation script change to correct installation problem where plugin was not importing completely for some people.

1.0.9 (June 21, 2011)
- Removed odd credit line for skin.

1.0.8 (June 14, 2011)
- Changed URL parse option so URLs are now parsed in all text fields.
- Changed 'Use First Text Answer As Subject' to subject replacement variable.
- Added option to remove member name from first line of reports.
- Added option to post application reports in an existing thread.
- Moved 'Start Application' button label to advapp vBulletin Phrase.
- Moved 'I am applying for the postion of' text from template to advapp vBulletin Phrase.
- Changed template so 'Member Name' now uses advapp vBulletin Phrase.
- Changed CSS so 'Start Application' button is centered on page.
- Removed remnant heading phrase from application form template.

1.0.7 (June 8, 2011)
- Fix minor bug where multi-line text was being cut into smaller sections.
- Added option to parse URLs. (it is in the position editor)

1.0.6 (June 6, 2011)
- Added option to use first single line text answer as report subject.
- Added option to require approval of the thread created when a member submits an application.
- Added options to redirect member to different locations after submitting an application.

1.0.5 (June 4, 2011)
- Fix default questions were carrying over their display positions causing answers to record improperly.
- Added option to show applications in navbar tabs.

1.0.4 (June 1, 2011)
- Database table creation change to make it compatible with MySQL 5.5.8
(NO NEED TO UPDATE IF YOU ARE ALREADY RUNNING VERSION 1.0.3)

1.0.3 (May 23, 2011)
- Added note about default email/pm user ids to position editors.
- Added Delete All Questions to ACP question editor.
- Added the ability to use a Thread Prefix for report threads.

1.0.2 (May 20, 2011)
- Fix rewind error.

1.0.1 (May 20, 2011)
- Changed database creation method for those that might be having problems.

1.0.0 (May 20, 2011)
- Initial Release

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Posting Features Easy Forms v4.x - Create a form or multiple forms without php or html knowledge bananalive vBulletin 4.x Add-ons 2069 23 Sep 2019 02:17
New Posting Features Easy Forms - Create a form or multiple forms without php or html knowledge bananalive vBulletin 3.8 Add-ons 1671 20 Dec 2018 00:02
Add-On Releases Forms Pack *** Forms Hack add-on Deepdog009 vBulletin 3.6 Template Modifications 2 27 Jul 2007 00:52
Forms Pack + (4) *** Forms Hack add-on Deepdog009 vBulletin 3.5 Template Modifications 1 08 May 2007 23:12

  #31  
Old 23 May 2011, 10:06
aouni_tahech aouni_tahech is offline
 
Join Date: Jan 2006
Hi. Great mod!

I have an Arabic forum. I'm trying to edit the application form page so that the questions and the text fields are viewed from right to left, but it's not working.

I added the following CSS code to a couple of <div> inside the advapp_application template:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

But nothing is changing.

I need the questions to appear to the right of the page and the text fields to the left of them.

Thanks!
__________________
A man walking alone on a deserted beach, brandishing a lantern in his outstretched hand might be a fool. But, for a ship that went astray on a stormy night, the same man is a savior.
Reply With Quote
  #32  
Old 23 May 2011, 11:00
Mariner1 Mariner1 is offline
 
Join Date: Jan 2009
How do i change the forum name from Forum 1,Forum 2 etc.Im wanting to replace that with the name of the catogories on my forum.Cant get it to change,still says Forum 1,Forum 2 etc
Reply With Quote
  #33  
Old 23 May 2011, 11:16
Mariner1 Mariner1 is offline
 
Join Date: Jan 2009
Managed to work it out
Reply With Quote
  #34  
Old 23 May 2011, 14:50
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by Alan_SP View Post
Excellent mod, I really like it and I think I'll use it for many things, or at least enable possible uses for my users. It could be used for classifieds, for opening new threads in certain forums in certain forum, for users to introduce themselves to community, there is so many possible uses that I really can't think of all of them.

I have two suggestions:

1. (more important) To have more than one set of default questions. If you enable this, please make that every set of default questions has name and description. In settings add option who could create default set.

In this way some applications can be created much faster as they could reuse same question sets, but be for other things, positions, forums or what not. It makes mod easer to use for more than one thing. Not that we couldn't use it right now for zillion things.

2. Approving applications. I think I'll even enable users to make their own applications. In that case I'll like to be able to approve them. If you enable approving, it would be good that we have option where new applications would be submitted for approval and that user who submit application have field for reason why he created application as well as where he wants it to appear after applications are filled up.
I'll see what I can do for these. They will require additional coding.

Originally Posted by Alan_SP View Post
Another suggestion (minor one, but could be useful):

Ability to use thread prefix when creating thread after application submission. In this way we could use same forum and more easily discern what application is in question.
Included in today's release.
Reply With Quote
  #35  
Old 23 May 2011, 14:51
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by aouni_tahech View Post
Hi. Great mod!

I have an Arabic forum. I'm trying to edit the application form page so that the questions and the text fields are viewed from right to left, but it's not working.

I added the following CSS code to a couple of <div> inside the advapp_application template:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

But nothing is changing.

I need the questions to appear to the right of the page and the text fields to the left of them.

Thanks!
This would require re-coding of the add-on. It's not something that can be changed in the CSS.

Last edited by nhawk; 23 May 2011 at 16:02.
Reply With Quote
  #36  
Old 23 May 2011, 17:30
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
Originally Posted by nhawk View Post
Included in today's release.
Thanks, you're fast.
Reply With Quote
  #37  
Old 27 May 2011, 22:41
Mukashi's Avatar
Mukashi Mukashi is offline
 
Join Date: Jan 2004
Real name: Liam Pomfret
Get an error when I install it. I'm guessing maybe a conflict with an existing mod on my forums, but I'm not certain. Error (with personal info removed) below.

Parse error: syntax error, unexpected T_STRING in /home/[serveraccount]/public_html/[forumsdirectory]/includes/class_bootstrap.php(414) : eval()'d code on line 47
__________________
Webmaster, Bulbagarden.net / Bulbapedia
Reply With Quote
  #38  
Old 27 May 2011, 22:54
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by Mukashi View Post
Get an error when I install it. I'm guessing maybe a conflict with an existing mod on my forums, but I'm not certain. Error (with personal info removed) below.
So I can try to duplicate the problem...

When do you get this error?

And

What version of vB are you running?
Reply With Quote
  #39  
Old 29 May 2011, 08:44
vapid2323 vapid2323 is offline
 
Join Date: Jan 2011
Might be an odd request but is it possible to allow applications from people that are NOT members of my forum?

I removed Usergroup #1 from the configuration on who cant use the system but I still cant use the application system unless I am logged in.
Reply With Quote
  #40  
Old 29 May 2011, 09:15
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by vapid2323 View Post
Might be an odd request but is it possible to allow applications from people that are NOT members of my forum?

I removed Usergroup #1 from the configuration on who cant use the system but I still cant use the application system unless I am logged in.
This can already be done.

You need to edit the Application Type and give them permission to view the application type.

Then you need to edit the Application Position and give them permission to apply for the position.
Reply With Quote
  #41  
Old 29 May 2011, 13:22
Manoel Júnior's Avatar
Manoel Júnior Manoel Júnior is offline
 
Join Date: Feb 2009
Real name: Manoel Júnior
Please, product in 3.8.7 please!
Reply With Quote
  #42  
Old 29 May 2011, 16:44
vapid2323 vapid2323 is offline
 
Join Date: Jan 2011
Originally Posted by nhawk View Post
This can already be done.

You need to edit the Application Type and give them permission to view the application type.

Then you need to edit the Application Position and give them permission to apply for the position.
Thanks! I missed one setting sorry about that!
Reply With Quote
  #43  
Old 30 May 2011, 01:03
JasonP38's Avatar
JasonP38 JasonP38 is offline
 
Join Date: Oct 2010
Real name: Jason
installed,.

great job, thanks.
Reply With Quote
  #44  
Old 01 Jun 2011, 11:43
Gn_Snake Gn_Snake is offline
 
Join Date: Feb 2006
I get an error when I follow the link the application with the browser

The error is:
"Sorry, we are currently not accepting applications."

What's this?

Thx
Reply With Quote
  #45  
Old 01 Jun 2011, 11:55
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by Gn_Snake View Post
I get an error when I follow the link the application with the browser

The error is:
"Sorry, we are currently not accepting applications."

What's this?

Thx
It sounds like you turned off the application system in Application Form Settings and didn't refresh your screen to get rid of the application link. Or, you haven't given yourself permissions to view the application form.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:34.

Layout Options | Width: Wide Color: