Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
IPV6 Support in VB3 Details »
IPV6 Support in VB3
Mod Version: 1.0.0, by wootalyzer (Member) wootalyzer is offline
Developer Last Online: Apr 2012 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (6 votes - 5.00 average) Installs: 31
Released: 29 Jul 2009 Last Update: 29 Jul 2009 Downloads: 259
Not Supported Code Changes Additional Files Re-usable Code  

UPDATE - This mod works with vBulletin 3 AND vBulletin 4!

About

Ok, so let's get started. Got a web server that resolves IP addresses as ipv6? Don't want to remove that ipv6 functionality just so vBulletin will work well? Well, this mod will take care of all of that for you.

How it works

vBulletin 3 and 4 are (from a coding standpoint) completely reliant upon ipv4. Classes are coded all over the place which expect addresses to be in ipv4 format. This mod runs before ANYTHING in vB gets a chance to load and does the following:

- If the address is in ipv4-over-ipv6 format, it simply dumps the ipv4 portion of the address into vbulletin. Done. Simple as pie.
- If the address is in standard ipv6 format (it's a real ipv6 address), it generates a "psudo-ipv4" address to represent the ipv6 address. This "psudo-ipv4" address is in a reserved ipv4 address space, so it shouldn't interfere with any of the real ipv4 addresses, and is generated from a hash of the ipv6 address (so each of the ipv6 addresses should hopefully resolve to their own, unique ipv4 address).

And... that's about it! vB continues on it's merry way treating everyone's ip as a standard ipv4 address.

WATCH OUT!

See someone on your forum with an IP address starting in 204. after installing this mod? That means they are actually accessing your site via an ipv6 address, and the address LISTED doesn't really mean anything.

Installation

Not scared about what we just covered? Good, let's get started.

1. Upload ipv6_fix.php to your forum/includes directory.
2. Edit your includes/init.php file (VERY carefully)

Find


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

And insert JUST ABOVE IT


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

3. Every time you upgrade vB, repeat step 2.

And you're done!

This mod should have no effect if your web server is handling connections as ipv4 addresses. This mod is no replacement for the REAL ipv6 support coming in vB4, so upgrade as soon as it is released! Looks like ipv6 didn't make it into vB4 either -- On lives the mod!

Have fun

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #16  
Old 30 Jun 2014, 10:52
TMM-TT's Avatar
TMM-TT TMM-TT is offline
 
Join Date: Jun 2005
Real name: Tomas
The actual problem seems to be a very simple variable in core - SESSION_HOST, at least for the "who's online"-part. Or are there more different methods that has to be changed also?

I have described the problem here: https://tornevall.net/forum/showthre...9-ipv6-support.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:22.

Layout Options | Width: Wide Color: