Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
  #16  
Old 27 Dec 2004, 04:50
Michael Morris's Avatar
Michael Morris Michael Morris is offline
 
Join Date: Nov 2003
Real name: Michael Morris
Try this


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

That will remove unnecessary spaces.

Hence


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If $newsflash has even a single space, it isn't empty. If it's nothing but spaces are there trim will removed them and leave it null.
Reply With Quote
  #17  
Old 12 Jan 2005, 13:39
wirewolf's Avatar
wirewolf wirewolf is offline
 
Join Date: Jun 2004
Real name: John
Michael, great tutorial. I've added the "Annoucements" and the "My Links". Both are working. I added one other conditional for those interested. I have a few members whose email keeps bouncing. So I created a new usergroup (Bounced Email), and added these members to it. Then created a new annoucement (announcement_bouncedmail) and added it to the array of annoucements in phpinclude_start. See below (XX is the number of this new group):
else if (is_member_of($bbuserinfo, XX)) // Bounced Mail
{
eval('$announcement = "' . fetch_template('announcement_bouncedmail') . '";');
}
How do I know if it works? I have a couple of "test" users accounts invisible to the other members. One has an email address that I know will bounce. After logging myself off and clearing cookies, I logged on as this test user, and there was the "Bounced Email" message. Part of this message is for these users to correct (update) their email address(s). I changed the permissions for this group so they can't post until they fix their email problem. If they fail to visit the forum after awhile, and after repeated attempts to contact them, I'll just delete the users' accounts.

BTW, these messages have had the desired effect. Especially for the "noposts" and the "noposts14days". Quite a few of my users that have not posted or not posted in awhile, and have visited the forum, have gotten the message and made a post. In part of my nopost and nopost14days messages I put in a link to my "Indroduction" forum as a suggestion, and it's worked!

I also created new phrases for insertion into the different announcement templates. Makes it easier to make message changes later on.

One question. I have two new required profile fields on registration (forces new registrants, but not old members). Part of the messages for members (all old exsisting members) that I have now is for them to check these new fields in the UserCP, but it does not force them to fill these out. I guess I could create another usergroup for those members that have not filled out these fields and include it in the phpinclude_start as another annoucement or is there a way do include the conditional for these "$post[fieldX]'s" into the annoucement templates I have now? I was looking at Revan's "Newbie Lock mod" and thinking of adapting it for this purpose. But his mod forces the user to a particular forum, not reguired profile fields. It's never easy!
Thanks, wirewolf
Reply With Quote
  #18  
Old 20 Jan 2005, 18:53
Sooner95 Sooner95 is offline
 
Join Date: Apr 2003
Nice stuff, good work.. Added the My Links to my site, works great.. thx!
Reply With Quote
  #19  
Old 21 Jan 2005, 05:21
Michael Morris's Avatar
Michael Morris Michael Morris is offline
 
Join Date: Nov 2003
Real name: Michael Morris
Originally Posted by wirewolf
Michael, great tutorial. I've added the "Annoucements" and the "My Links". Both are working. I added one other conditional for those interested. I have a few members whose email keeps bouncing. So I created a new usergroup (Bounced Email), and added these members to it. Then created a new annoucement (announcement_bouncedmail) and added it to the array of annoucements in phpinclude_start. See below (XX is the number of this new group):
How do I know if it works? I have a couple of "test" users accounts invisible to the other members. One has an email address that I know will bounce. After logging myself off and clearing cookies, I logged on as this test user, and there was the "Bounced Email" message. Part of this message is for these users to correct (update) their email address(s). I changed the permissions for this group so they can't post until they fix their email problem. If they fail to visit the forum after awhile, and after repeated attempts to contact them, I'll just delete the users' accounts.

BTW, these messages have had the desired effect. Especially for the "noposts" and the "noposts14days". Quite a few of my users that have not posted or not posted in awhile, and have visited the forum, have gotten the message and made a post. In part of my nopost and nopost14days messages I put in a link to my "Indroduction" forum as a suggestion, and it's worked!

I also created new phrases for insertion into the different announcement templates. Makes it easier to make message changes later on.

One question. I have two new required profile fields on registration (forces new registrants, but not old members). Part of the messages for members (all old exsisting members) that I have now is for them to check these new fields in the UserCP, but it does not force them to fill these out. I guess I could create another usergroup for those members that have not filled out these fields and include it in the phpinclude_start as another annoucement or is there a way do include the conditional for these "$post[fieldX]'s" into the annoucement templates I have now? I was looking at Revan's "Newbie Lock mod" and thinking of adapting it for this purpose. But his mod forces the user to a particular forum, not reguired profile fields. It's never easy!
Thanks, wirewolf
I'm in the middle of switching the servers at ENWorld - when I'm done with that (hopefully by this time next week) I'll take a closer look at your questions and answer them if I can.

@Sooner95 - thx.
Reply With Quote
  #20  
Old 01 Mar 2005, 21:11
wirewolf's Avatar
wirewolf wirewolf is offline
 
Join Date: Jun 2004
Real name: John
Hi Michael.
This is a weird one. I've had "My Links" installed on my site (vb v.3.0.7) for awhile. Today I noticed something strange happening with the "My Links". If I view a post, any post, while logged in, select the "View Single Post" link, close that window, refresh the original post, I then see the list of "My Links" in the post. This happens with any post, no matter who posted it, not just mine. If I go to the edit box for that post and hit the Save Changes button, the post reverts back to normal.
I asked one of my members that uses "My Links" also, to log in to the forum, pick out any post, and repeat the same sequence. He PM'd me and reported , in dis-believe, that he too saw his "Links" in the post. I had to go and open the edit box for that post, hit save changes, and the post reverted back to normal.
Best way is to see some screen shots.
Any clues to this one?
BTW, checked the code in phpinclude_start, it's fine.
Reply With Quote
  #21  
Old 02 Mar 2005, 02:20
Michael Morris's Avatar
Michael Morris Michael Morris is offline
 
Join Date: Nov 2003
Real name: Michael Morris
This happened to me too - I uninstalled this hack after that started happening.
Reply With Quote
  #22  
Old 02 Mar 2005, 02:41
wirewolf's Avatar
wirewolf wirewolf is offline
 
Join Date: Jun 2004
Real name: John
I didn't uninstall mine, but disabled the profilefield, and commented out the codes in the navbar and phpinclude_start templates. Posted a note to my members that were using "My Links" that it was now disabled.
Do you have any clue as to how it happened?
John
Reply With Quote
  #23  
Old 03 Mar 2005, 07:29
Michael Morris's Avatar
Michael Morris Michael Morris is offline
 
Join Date: Nov 2003
Real name: Michael Morris
Nope. If I did I'd a fixed it instead of removing it.
Reply With Quote
  #24  
Old 09 Jun 2005, 06:39
zetetic's Avatar
zetetic zetetic is offline
 
Join Date: Apr 2004
Real name: Tom
Excellent tutorial, Michael. I had already stumbled on much of the info you gave, but if I'd found this thread a month ago I would've saved a lot of trial and error. I think it should be a sticky, even if the MyLinks hack isn't working properly anymore.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 10:07.

Layout Options | Width: Wide Color: