Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 07 Jun 2016, 15:41
silvertouring silvertouring is offline
 
Join Date: Jun 2016
Post sharing link gives wrong post number

Hi all,

Whenever I generate the link to share a single post i get a wrong post number.

For example, I want to share post number 55. I get a link as follows:

http://xxxxxxx.com/forum/xxxxxxxx/xx...?p=224#post224

i got post 224 instead of 55.

Has anybody faced this issue?

Thanks
Reply With Quote
  #2  
Old 08 Jun 2016, 01:03
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
The 224 is not the post number but the nodeid of the post as stored in the database. If a post in a thread is deleted, the post number displayed in the upper right of the succeeding posts changes but the nodeid does not. So obviously you can't rely on using the post number in the link to associate to a specific post.
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:40.

Layout Options | Width: Wide Color: