Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
[VB3-RC2] vBRedirect v1.1 - Redirect to external pages with your banner above Details »
[VB3-RC2] vBRedirect v1.1 - Redirect to external pages with your banner above
Mod Version: 1.00, by JustJonno (Member) JustJonno is offline
Developer Last Online: Mar 2008 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.0.0 Rating: (0 vote - 0 average) Installs: 15
Released: 10 Mar 2004 Last Update: Never Downloads: 16
Not Supported  

What It Does:
This script will provide you with a redirect page for all the links people put on your site using the URL tags.
It opens a new page with your own customisable banner and text on top and the external link opens within a seperate frame setup by the script. Useful if you want users to stay on your site but still check out posted links. All the banner .gif header attributes are setup from within a template so you don't need to go editing php files to change the look of it.

Installation Type:
Installation is easy and will take approx 5 mins when following the install.html included.
Experiance Level: Amature
Install Time: 5 mins
PHP Edit?: No file edits needed, AdminCP access needed.

Support:
Support for this script is available and will be answered either here or On Our Forums.

Hope you like my first mod, i normally write full code, not hack other peoples

JJ

---------------------------------------------------------------------------
[edit] 11-march-04 01:29 ; Fixed the www and http problem with the links, its recommended you update the redirect.php if you have already installed, or install this again.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	screenie.gif
Views:	547
Size:	99.7 KB
ID:	17232  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Comments
  #2  
Old 10 Mar 2004, 02:14
draculanowaday draculanowaday is offline
 
Join Date: Feb 2004
Thanks, I'll try it
Reply With Quote
  #3  
Old 10 Mar 2004, 02:43
dirtymerc dirtymerc is offline
 
Join Date: Sep 2002
installed, mad some changes, not bad overall, but you should really merge the two cells and make the image be top aligned and left aligned.
Reply With Quote
  #4  
Old 10 Mar 2004, 02:49
JustJonno JustJonno is offline
 
Join Date: Jan 2004
Originally Posted by dirtymerc
installed, mad some changes, not bad overall, but you should really merge the two cells and make the image be top aligned and left aligned.
notice taken i'm going to see what other kind of response i get from it and then i'll go about updating it for positions etc..

thanks for the comments so far

JustJonno
Reply With Quote
  #5  
Old 10 Mar 2004, 03:10
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Can we get a screenshot of what this will look like?
Reply With Quote
  #6  
Old 10 Mar 2004, 11:56
ryancooper's Avatar
ryancooper ryancooper is offline
 
Join Date: Jul 2002
This will be great for my board!
Reply With Quote
  #7  
Old 10 Mar 2004, 14:59
Vb-Hispano's Avatar
Vb-Hispano Vb-Hispano is offline
 
Join Date: Feb 2003
installed

thanks is lol
Reply With Quote
  #8  
Old 10 Mar 2004, 17:26
stonecold1203 stonecold1203 is offline
 
Join Date: Jul 2003
Nice hack...

I get this error though

Not Found
The requested URL /forum/www.google.com was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Reply With Quote
  #9  
Old 10 Mar 2004, 18:13
JustJonno JustJonno is offline
 
Join Date: Jan 2004
Originally Posted by stonecold1203
Nice hack...

I get this error though

Not Found
The requested URL /forum/www.google.com was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
hmmm.. thats strange.. are you sure you copied the templates and phrases across correctly? If you want me to see the error PM me with a link to your forum and i'll take a look

JJ
Reply With Quote
  #10  
Old 10 Mar 2004, 18:49
Fi_InCogNiTo Fi_InCogNiTo is offline
 
Join Date: Jan 2003
I get the same. It has to be some sorta bug I think.

When you post an url like this on the forums:

www.clanboard.com

It won't work. It will add a / in front and look for /www.clanboard.com

But if you post the url as:

http://www.clanboard.com

It works fine.

You can test it on my board: www.pc-nerd.com

I looked over some code. Looks like this code in functions_bbcodeparse.php may be a prob or not?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Also, when you click"Click HERE to go back to the post" it takes you back to the last page you looked at if you visit links inside the new page. It only takes you back to the post if you don't visit any links inside the new page.

See attached screenshot for the /www error.
Attached Images
File Type: gif error.gif (28.0 KB, 82 views)

Last edited by Fi_InCogNiTo; 10 Mar 2004 at 19:48.
Reply With Quote
  #11  
Old 10 Mar 2004, 22:08
JustJonno JustJonno is offline
 
Join Date: Jan 2004
Originally Posted by Fi_InCogNiTo
I looked over some code. Looks like this code in functions_bbcodeparse.php may be a prob or not?
This shouldn't cause a problem if you remembered to turn off the LINKS statement in vB Options/BB Code Settings..

As for the http:// problem, i'm on that and will upload an update zip and a new version tomorrow morning after strenuous bug testing and time test.. (beer and a sleep :P )

JJ
Reply With Quote
  #12  
Old 10 Mar 2004, 22:38
stonecold1203 stonecold1203 is offline
 
Join Date: Jul 2003
Originally Posted by JustJonno
hmmm.. thats strange.. are you sure you copied the templates and phrases across correctly? If you want me to see the error PM me with a link to your forum and i'll take a look

JJ
Yes i copied them exactly. I'll give them another try though.
Reply With Quote
  #13  
Old 10 Mar 2004, 22:45
stonecold1203 stonecold1203 is offline
 
Join Date: Jul 2003
Didn't work..

Could it be because my forum directory is /forum instead of /forums
Reply With Quote
  #14  
Old 10 Mar 2004, 23:34
Fi_InCogNiTo Fi_InCogNiTo is offline
 
Join Date: Jan 2003
@stonecold1203:
Originally Posted by JustJonno
As for the http:// problem, i'm on that and will upload an update zip and a new version tomorrow morning after strenuous bug testing and time test.. (beer and a sleep :P )

JJ
It's not you. It's a bug and he's workin on it
Reply With Quote
  #15  
Old 10 Mar 2004, 23:40
stonecold1203 stonecold1203 is offline
 
Join Date: Jul 2003
I didn't know if i had a http:// problem

But i read his post
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:18.

Layout Options | Width: Wide Color: