Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android) Details »
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android)
Mod Version: 1.0.3, by dartho (Coder/Designer) dartho is offline
Developer Last Online: Apr 2019 I like it Show Printable Version Email this Page

vB Version: 4.1.8 Rating: (98 votes - 4.82 average) Installs: 894
Released: 25 Aug 2010 Last Update: 16 Dec 2011 Downloads: 6211
Not Supported Re-usable Code  

A lightweight *forum only style aimed at small screen devices such as Windows Smartphones, Nokias and even iPhones. It has VERY low bandwidth requirements - 15 times less on my site - 20K as opposed to 300K for forumhome.

*forum only - I have done a very small amount of rough work on CMS templates, a simple single column CMS *could* be created to work with this style without too much effort. However I am not sure if you can have a different CMS layout dependent on which style you are using?

This is an update to the mobile style I have previously released.

The changes are predominantly aesthetic to take advantage of larger screens.

It is also much easier to change colour schemes by editing the commented CSS file.


Demo: http://vbdev.org/forum.php?styleid=7

This is a a lightweight style and as such has much reduced functionality/information over the default vBulletin style.

Install instructions:
  • Firstly, if upgrading, I recommend installing this as a new style rather than overwriting your previous install. This way you get to test it first without trashing your existing style.
  • BACKUP YOUR EXISTING lightweight.css.php FILE IF YOU HAVE CSS CUSTOMISATIONS
  • Download ZIP file
  • Unzip to a local/temp directory
  • Edit lightweight.css.php file to customise colours if required
  • Upload contents of the upload directory in the zip file folder to your forum root.
  • Install style XML via Style Manager in your ADMINCP
  • **Install and configure "LightWeight Style Options"
  • See post 2 for a FAQ
  • Click "Mark as Installed"
  • Test it out
  • Leave a rating
  • Leave feedback
  • Enjoy checking your site from your mobile phone without the need to pinch/zoom/wait etc...
Version Control:
1.0.0 - 25 AUG 2010 - Initial Release on vBulletin.org
1.0.1 - 26 AUG 2010 - Fixed "Mark All Forums Read" link in Search results. Released Lightweight Style Options to customise this
1.0.2 - 21 MAR 2011 - Updated to 4.1.2, removed short tags from CSS, fixed some issues discovered since last release, added some stuff.
1.0.3 - 16 DEC 2011 - Updated to 1.0.3, tried to fix all known issues. Nothing new. If you have updated your site as bugs have been found, probably no need to upgrade. But if you're upgrading your site from to 4.1.9, might be worthwhile.
1.0.3a - 16 DEC 2011 - remove test ad hook code accidently left in postbit_legacy template
Branding Free:
The style is free to use. However I ask that you keep links in the footer. If you want to remove them - send me a donation of an amount you can afford, or that you think is fair/reasonable, it's up to you how much.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	lightweight-screenshot.png
Views:	41121
Size:	30.6 KB
ID:	121268  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.8 Add-ons 144 12 Aug 2017 04:52
Forum Display Enhancements Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.7 Add-ons 407 19 Mar 2015 15:53
Mobile, Cell, Phone, PDA, iPhone Style dartho vBulletin 3.7 Styles 795 16 Aug 2012 14:39
Mobile/Cell Phone Style dartho vBulletin 3.6 Styles 313 21 Aug 2011 23:04

  #1111  
Old 17 Sep 2014, 16:12
Azum Azum is offline
 
Join Date: Jun 2013
I found that just using the below by itself along with built in VB mobile detection works fine. There was no need for the plugin.

Originally Posted by dartho View Post
If you wanted to make this simpler, and don;t mind going into debug mode on your site, you could edit the Option Code for Mobile Style boxes in AdminCP so that all styles (both mobile and standard) show up and then you could replace the styleid numbers in the plugin above with $vbulletin->options['mobilestyleid_basic'], $vbulletin->options['mobilestyleid_advanced'] and $vbulletin->options['styleid'] then if you changed styles down the track you wouldn;t need to edit the plugin by hand. You would still need the above plugin to make it work.

To do this change the Option Code to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Reply With Quote
  #1112  
Old 18 Sep 2014, 00:00
Azum Azum is offline
 
Join Date: Jun 2013
Small contribution for deleting PMs. The code provided almost works, but need to change it to:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Originally Posted by dartho View Post
Adding something like:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

to the bottom of the pm_showpm template should do it, I think ...
Reply With Quote
  #1113  
Old 23 Sep 2014, 05:25
Azum Azum is offline
 
Join Date: Jun 2013
How do you get preview reply to work? I'm failing so far.

Edit: Nevermind, not really sure how, but I got it to work copying bits and pieces of other style templates.

Last edited by Azum; 24 Sep 2014 at 02:29.
Reply With Quote
  #1114  
Old 30 Sep 2014, 06:13
duniabebas duniabebas is offline
 
Join Date: Apr 2013
anyone have this style support 4.2.2?
Reply With Quote
  #1115  
Old 04 Oct 2014, 16:54
Azum Azum is offline
 
Join Date: Jun 2013
Originally Posted by duniabebas View Post
anyone have this style support 4.2.2?
Works fine with 4.2.2.
Reply With Quote
  #1116  
Old 18 Oct 2014, 16:18
Azum Azum is offline
 
Join Date: Jun 2013
One thing I haven't been able to figure out is how to insert inline image attachments with this style.
Reply With Quote
  #1117  
Old 20 Oct 2014, 03:56
dartho dartho is offline
 
Join Date: Sep 2005
Do you mean "inline" as in inserting an image, such as , in the middle of of a post ?
Reply With Quote
  #1118  
Old 23 Oct 2014, 00:05
Azum Azum is offline
 
Join Date: Jun 2013
Originally Posted by dartho View Post
Do you mean "inline" as in inserting an image, such as , in the middle of of a post ?
Yeah, I can't seem to get the image to insert into the body of the message after it's uploaded...
Reply With Quote
  #1119  
Old 24 Oct 2014, 04:31
dartho dartho is offline
 
Join Date: Sep 2005
I've had a bit of a look, and I don't think there is any easy way to do that without bringing in the full ckeditor ...
Reply With Quote
  #1120  
Old 24 Oct 2014, 17:53
Azum Azum is offline
 
Join Date: Jun 2013
Originally Posted by dartho View Post
I've had a bit of a look, and I don't think there is any easy way to do that without bringing in the full ckeditor ...
Thanks anyway...

On another note, I've noticed that line breaks aren't preserved when quoting. Any fix for that aside from disabling the WYSIWYG editor?
Reply With Quote
  #1121  
Old 24 Oct 2014, 21:35
Mark.B Mark.B is offline
 
Join Date: Feb 2004
Ok you need to create a new plugin at newreply_start. I called mine Line Break Fix which helped me locate it years later.

Add this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
MARK.B (Member of the vB Support Team)
Reply With Quote
  #1122  
Old 24 Oct 2014, 21:44
Azum Azum is offline
 
Join Date: Jun 2013
Originally Posted by Mark.B View Post
Ok you need to create a new plugin at newreply_start. I called mine Line Break Fix which helped me locate it years later.

Add this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
I saw your earlier post about that, and it works... but then my checkbox for AME convert URLs to videos doesn't show up because it kills the newpost_disablesmilies hook.
Reply With Quote
  #1123  
Old 24 Oct 2014, 21:53
Mark.B Mark.B is offline
 
Join Date: Feb 2004
That's a weird one....I don't have any AME options showing anywhere (although I do use AME) so haven't run into this.

I can't understand why it would affect code run at another hook. It's just an if conditional, which is closed off. So whether it returns true or false, it ought not to affect any other hooks.

Could it be that the AME checkbox only shows on the WYSIWYG? That would explain it, as you've turned the WYSIWIG off with my code.....though only in the mobile style. Shouldn't affect a normal style.

Slightly baffled, I'm afraid.
__________________
MARK.B (Member of the vB Support Team)
Reply With Quote
  #1124  
Old 24 Oct 2014, 22:18
Azum Azum is offline
 
Join Date: Jun 2013
Originally Posted by Mark.B View Post
That's a weird one....I don't have any AME options showing anywhere (although I do use AME) so haven't run into this.

I can't understand why it would affect code run at another hook. It's just an if conditional, which is closed off. So whether it returns true or false, it ought not to affect any other hooks.

Could it be that the AME checkbox only shows on the WYSIWYG? That would explain it, as you've turned the WYSIWIG off with my code.....though only in the mobile style. Shouldn't affect a normal style.

Slightly baffled, I'm afraid.
Took me awhile to figure it out, but AME adds the convert URLs to video checkbox by looking for the newpost_disablesmilies hook, if present, it injects the checkbox before the smilies checkbox... and from what I can tell the newpost_disablesmilies hook only gets called in the WYSIWYG editor.

I'm working on trying to change it to something else, like attachments... maybe you could help.

Like this code here works, but I want it to show up after the attachments box, not before it... which is what it currently does. (note newpost_attachment was newpost_disablesmilies until I changed it).


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #1125  
Old 25 Oct 2014, 01:17
Azum Azum is offline
 
Join Date: Jun 2013
nevermind, didn't work correctly.

Last edited by Azum; 25 Oct 2014 at 01:57.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 01:00.

Layout Options | Width: Wide Color: