Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
PHPSpellchecker for VB2.x! (Beta) Details »
PHPSpellchecker for VB2.x! (Beta)
Mod Version: 1.00, by Raz (Member) Raz is offline
Developer Last Online: Aug 2006 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 2.2.x Rating: (0 vote - 0 average) Installs: 13
Released: 14 Jul 2002 Last Update: Never Downloads: 2
Not Supported Is in Beta Stage  

OK, finally here is the code for the PHPSpellchecker!
If you find any bugs, please post your findings here

Check out the Zip file for more info.

Enjoy!
Raz

Note: You will require PSpell (inc ASpell) installed.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
[Beta Release] VB2 TranslateIT V1 Dave# vBulletin 2.x Full Releases 3 27 Aug 2001 06:48

  #31  
Old 16 Jul 2002, 08:55
Raz's Avatar
Raz Raz is offline
 
Join Date: Oct 2001
Originally posted by Virix


I disagree, if the host is this willing to just try something out on a production box, then I wouldn't trust my data with them...

What if they install something that causes wide spread data coruption, 'whoops, it was a customers request...'

You don't install everything a customer wants.. Thats why it shared hosting.. If you want certain software, get a dedicated box...
PSpell has no known problems.
__________________
~Raz~
Reply With Quote
  #32  
Old 16 Jul 2002, 14:44
Prince Prince is offline
 
Join Date: Oct 2001
Originally posted by Virix
I disagree, if the host is this willing to just try something out on a production box, then I wouldn't trust my data with them...

What if they install something that causes wide spread data coruption, 'whoops, it was a customers request...'

You don't install everything a customer wants.. Thats why it shared hosting.. If you want certain software, get a dedicated box...
If your web host is competent there should not be any problems installing the aspell libraries.
__________________
www.ironmagazineforums.com
Reply With Quote
  #33  
Old 19 Jul 2002, 01:20
Steve St.Lauren Steve St.Lauren is offline
 
Join Date: May 2002
I'm running FreeBSD 4.5 and have done the make install on pspell and aspell. When I run phpinfo() it doesn't show pspell as being installed. When I click on spell check I just get a blank window. It seems as though pspell isn't compiled into php yet (I'm running on a stand alone box btw). Looking at your instructions it looks like I should go to my /usr/ports/www/mod_php4 directory and run you the configure command to add pspell along with the rest of the config commands listed in phpinfo - however, there's no configure command in the mod_php4 directory. Any ideas?
Reply With Quote
  #34  
Old 19 Jul 2002, 02:23
Paul Paul is offline
 
Join Date: Jan 2002
You need to compile php --with-pspell. See my earlier post in this thread.
Reply With Quote
  #35  
Old 19 Jul 2002, 08:05
Velocd's Avatar
Velocd Velocd is offline
 
Join Date: Mar 2002
Real name: Mike
Well my great webhost finally (I was in no rush) compiled PHP with the pspell libraries. So quickily I uncommented my code and gave the spellchecker a shot, and it defiantly worked different this time--but, I'm still getting database errors! Help!

In the attachment are the errors I am getting, any help would be most appreciative because this hack is SOOO needed on my forums ^_^
Attached Images
File Type: gif problem.gif (25.6 KB, 58 views)
Reply With Quote
  #36  
Old 19 Jul 2002, 14:29
Raz's Avatar
Raz Raz is offline
 
Join Date: Oct 2001
The prerequistes of pspell are that aspell are installed (usually are on linux).

Tell your host to install pspell in the aspell dir so it can use its words list.
__________________
~Raz~
Reply With Quote
  #37  
Old 19 Jul 2002, 18:06
Velocd's Avatar
Velocd Velocd is offline
 
Join Date: Mar 2002
Real name: Mike
*dies* Ok, dang, they're not going to be happy
Wish I knew this earlier...
Reply With Quote
  #38  
Old 19 Jul 2002, 18:08
Velocd's Avatar
Velocd Velocd is offline
 
Join Date: Mar 2002
Real name: Mike
Being that it's a prerequiste, you may want to edit your first post saying aspell also is required...
Reply With Quote
  #39  
Old 19 Jul 2002, 22:52
Velocd's Avatar
Velocd Velocd is offline
 
Join Date: Mar 2002
Real name: Mike
Sorry for the triple post..

I finally got everything working together and I must say this hack looks great, thanks for releasing it again Raz.

Now if this only had a grammar check....

Attached is a screehshot of what this spellcheck looks like, for those interested. You can see what I mean by grammar check by the word "wit" (commonly used on forums) that is passed up, since it is a real word.
Attached Images
File Type: gif spellchecker.gif (35.3 KB, 86 views)
Reply With Quote
  #40  
Old 19 Jul 2002, 23:55
Steve St.Lauren Steve St.Lauren is offline
 
Join Date: May 2002
I'm still having one heck of a time getting this to run. I've install aspell and pspell on our server and I've recompiled PHP with pspell included and have verified it through phpinfo.php that it is there in the config command (did this on our backup server so I didn't have problems on the main site). I've restarted apache and when I click on the spell check button I just get an empty window. Anyone have any ideas?
Reply With Quote
  #41  
Old 20 Jul 2002, 00:35
Velocd's Avatar
Velocd Velocd is offline
 
Join Date: Mar 2002
Real name: Mike
Blank page eh? How strange....you seem to have done everyone I could have suggested, so I'm not sure. Maybe Raz will get back to you.
Reply With Quote
  #42  
Old 20 Jul 2002, 01:00
Steve St.Lauren Steve St.Lauren is offline
 
Join Date: May 2002
When I run phpinfo.php here is what I show on the Configure Command line:

'./configure' '--with-apxs=/usr/local/sbin/apxs' '--with-config-file-path=/usr/local/etc' '--enable-versioning' '--with-regex=system' '--with-pspell=/usr/local/share/pspell' '--without-gd' '--with-zlib' '--with-mysql=/usr/local' '--enable-ftp' '--with-pspell=/usr/local' '--prefix=/usr/local' 'i386-portbld-freebsd4.6'

pspell is actually installed at /usr/local/share/pspell which is the default for FreeBSD's port install - I've tried setting the destination to that as well but it also didn't work.
Reply With Quote
  #43  
Old 20 Jul 2002, 02:49
Paul Paul is offline
 
Join Date: Jan 2002
Originally posted by Steve St.Lauren
[B]When I run phpinfo.php here is what I show on the Configure Command line:

'./configure' '--with-apxs=/usr/local/sbin/apxs' '--with-config-file-path=/usr/local/etc' '--enable-versioning' '--with-regex=system' '--with-pspell=/usr/local/share/pspell' '--without-gd' '--with-zlib' '--with-mysql=/usr/local' '--enable-ftp' '--with-pspell=/usr/local' '--prefix=/usr/local' 'i386-portbld-freebsd4.6'

pspell is actually installed at /usr/local/share/pspell which is the default for FreeBSD's port install - I've tried setting the destination to that as well but it also didn't work.
Aren't they the same? To change the directory where it's installed, compile --with-pspell=/path/to/pspell. See the pspell docs on www.php.net ... it's clearly outlined there.

I seem to remember an issue with a user of this hack getting blank pages because they did not upload blank.html (or a similar file--I haven't looked in the archive to see what it's called) thinking that it was not a part of the hack. Did you perhaps do this as well?

Paul
Reply With Quote
  #44  
Old 20 Jul 2002, 02:50
Steve St.Lauren Steve St.Lauren is offline
 
Join Date: May 2002
I got it working! Don't ask me how though.
Reply With Quote
  #45  
Old 20 Jul 2002, 05:17
Velocd's Avatar
Velocd Velocd is offline
 
Join Date: Mar 2002
Real name: Mike
Hey Raz, or anybody else, what is the easiest way to get this to also check the title field of the post. I'm sure most of us have experienced when you mispell a word in a thread title, mostly new threads, and then you feel like an idiot because everyone see's the title is wrong and there is nothing you can do to change it. (unless you're the admin/mod).

So, any thoughts of how this could be done?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:05.

Layout Options | Width: Wide Color: