Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Watermark Attachments Details »
Watermark Attachments
Mod Version: 1.00, by bjhuang (Member) bjhuang is offline
Developer Last Online: Jun 2013 I like it Show Printable Version Email this Page

vB Version: 3.8.0 Rating: (6 votes - 4.50 average) Installs: 140
Released: 16 Jan 2009 Last Update: 16 Jan 2009 Downloads: 1216
Not Supported Uses Plugins Re-usable Code  

Product: 1
Plugin: 2
Query: 0

tested only on the pure installation of vbulletin. install at your own risk to work with other attachment mods.

Feature

* put a logo (watermark) on your attachments.
* option to watermark only attachments after X days of creation. this helps your hotlinked images become free ads.
* option to watermark thumbnails but stop hotlinking to full size image (return a blank image instead)
* option NOT to watermark images for traffic from certain sites

Install

Step 1: import product-watermark.xml
Step 2: create and upload your own watermark logos. one for top and one for bottom.
Step 3: put the absolute path of watermark images into options. (/var/www/html/.../watermark.png)
Step 4 (optional) : if you don't want the attachments watermarked viewing on your own site or some other friend sites (like google image), just put the domains into "Skip Referer" option.

Not working
1. set the "Days Delay" option to 0
2. refresh your cache by press Ctrl-F5.
3. the watermark images should be in PNG format with transparent background.
4. check the "Safe Mode Temporary Directory" option. the directory should be writable.
5. only works for PNG, GIF, JPG attachments.
6. only works if the attachments are stored in the filesystem.
7. GD library should be installed.

Todo
* currently, we have to create a temp file while sending a watermarked attachment. It will be appreciate if anybody can help me to get rid of this.




The most famous travel forum in chinese world - www.bbkz.com

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	example_watermark_bottom.png
Views:	354
Size:	4.5 KB
ID:	92799  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #31  
Old 19 Jan 2009, 11:34
elmark elmark is offline
 
Join Date: Feb 2007
It`s Work.
Thanks!

I have ver. 3.7.4 PL

BY

Marko
Reply With Quote
  #32  
Old 19 Jan 2009, 14:41
spyhidden spyhidden is offline
 
Join Date: Feb 2006
Working good thx
Reply With Quote
  #33  
Old 20 Jan 2009, 15:14
sleepyboy2004 sleepyboy2004 is offline
 
Join Date: Nov 2008
Any tips to make this work?? Wont work on my forum, or my test forum either..
Reply With Quote
  #34  
Old 20 Jan 2009, 15:20
Leo Brazil's Avatar
Leo Brazil Leo Brazil is offline
 
Join Date: Dec 2007
Are your images on file system or database ?

This mod will only work for those with images on filesystem.
Reply With Quote
  #35  
Old 20 Jan 2009, 16:05
sleepyboy2004 sleepyboy2004 is offline
 
Join Date: Nov 2008
Originally Posted by Leo Brazil View Post
Are your images on file system or database ?

This mod will only work for those with images on filesystem.
I think I'm a noob when it comes to that . My images are on the the forum directory's. /forum/images/misc/watermark.png
Hope that makes sense!
Reply With Quote
  #36  
Old 21 Jan 2009, 06:29
WreckRman2 WreckRman2 is offline
 
Join Date: Dec 2001
Real name: David Smith
Does it permanently watermark the image?
Reply With Quote
  #37  
Old 22 Jan 2009, 01:29
dmknights dmknights is offline
 
Join Date: Jul 2007
Real name: Darren
followed the instructions, but does not work on 3.8.0
Reply With Quote
  #38  
Old 22 Jan 2009, 05:11
ComputerVitals ComputerVitals is offline
 
Join Date: Oct 2005
Lightbox option on here,
Watermark doesn't work.
__________________
ComputerVitals.com
Your Online Computer Helpline ~ Go ahead and join!
Reply With Quote
  #39  
Old 22 Jan 2009, 15:59
myown myown is offline
 
Join Date: Jan 2007
looks interesting ... sure will be installing
__________________
http://pak.net
Urdu Forums - Articles, Jokes, Poetry and lots more
Reply With Quote
  #40  
Old 22 Jan 2009, 22:17
CrashfAB CrashfAB is offline
 
Join Date: Mar 2006
So does this not work on 3.8?

I am in dier need of something like this...
Reply With Quote
  #41  
Old 23 Jan 2009, 11:45
smooth-c smooth-c is offline
 
Join Date: Jan 2008
Can someone please answer the question that's been asked, does this permanently watermark images? I see it does them on the fly but if I uninstall this app, will the watermark remain?
Reply With Quote
  #42  
Old 23 Jan 2009, 12:19
smooth-c smooth-c is offline
 
Join Date: Jan 2008
Okay, now everytime I upload an image to my album I get an error;

Connection Interrupted

The document contains no data.

The network link was interrupted while negotiating a connection. Please try again.


Fair enough this is at my own risk but what the hell is going on?
Reply With Quote
  #43  
Old 23 Jan 2009, 16:13
bjhuang bjhuang is offline
 
Join Date: Jul 2006
no, nothing changed after you uninstall it.

Originally Posted by smooth-c View Post
Can someone please answer the question that's been asked, does this permanently watermark images? I see it does them on the fly but if I uninstall this app, will the watermark remain?

Last edited by bjhuang; 23 Jan 2009 at 16:37.
Reply With Quote
  #44  
Old 23 Jan 2009, 16:21
bjhuang bjhuang is offline
 
Join Date: Jul 2006
the only two hooks used by this mod are attachment_complete and attachment_display. that means no code from this mod will be ran while uploading somehing to the album.

seems like a connection problem. check your configuration of php and web server.

Originally Posted by smooth-c View Post
Okay, now everytime I upload an image to my album I get an error;

Connection Interrupted

The document contains no data.

The network link was interrupted while negotiating a connection. Please try again.


Fair enough this is at my own risk but what the hell is going on?
Reply With Quote
  #45  
Old 24 Jan 2009, 01:16
The4um's Avatar
The4um The4um is offline
 
Join Date: Nov 2008
where should I upload my logo??? my forum is at my.forum.xx/forum
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:45.

Layout Options | Width: Wide Color: