Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vB Nexus, Facebook & Google multiple login integration Details »
vB Nexus, Facebook & Google multiple login integration
Mod Version: 1.00, by ibautocommunity (Coder) ibautocommunity is offline
Developer Last Online: Jan 2020 I like it Show Printable Version Email this Page

vB Version: 3.8.3 Rating: (17 votes - 4.47 average) Installs: 154
Released: 13 Aug 2009 Last Update: 13 Aug 2009 Downloads: 1929
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Re-usable Code Translations External Content Is in Beta Stage  

vBulletin Nexus
Current project release: BETA
This works on vBulletin 3.7.X - 3.8.4

This product will allow visitors to join your community using their Facebook, Google, Yahoo or AIM account; and will allow your existing members to associate an existing forum account with one of the services - such as Facebook.

Please read the documentation and follow it exactly before requesting installation help. Please note, if you have heavily modified styles that are missing hooks - this product will not work and require additional installation steps.

DEMO: http://www.carblog.com/vbnexus

Basic Instructions for your forum's users: http://carblog.com/vbnexus/user-guide/

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #376  
Old 22 Sep 2009, 13:23
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
While it has not been integrated into the actual product the IE6 fix was posted earlier in this thread by the developer.

Really hoping for a product update soon to address some of the fixes.

I run IE6 at work and have had no problems, but it has been documented and there is a fix out there.
Reply With Quote
  #377  
Old 22 Sep 2009, 13:39
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Originally Posted by kall View Post

It could be a very powerful way to grow Forum membership/interaction. Thanks to the coder.

If we can get some updates rolled out to us it will be a great mod as it is the only current one that also offers Google Friend Connect.
Reply With Quote
  #378  
Old 22 Sep 2009, 14:14
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
I am attaching a new product file that includes the following fixes.


- Template bundle ID's for 32bit servers. Changes value type of bundle entries to Numeric
- Javascript fix to allow Google Connect to work outside of forum directory, such vb Advanced.
- Default usergroup when joining fix.
- Various other path errors fixed. Mostly for point #2
- Fix for posting polls while connected via Facebook. Will not try to submit to Facebook when it is a new poll

I have never made a product before so this may or may not work correctly. Use at your own risk and all that fun stuff.
Attached Files
File Type: xml product-vbnexus.xml (79.7 KB, 18 views)

Last edited by Calash; 22 Sep 2009 at 17:08.
Reply With Quote
  #379  
Old 23 Sep 2009, 16:53
Wayne Luke's Avatar
Wayne Luke Wayne Luke is offline
 
Join Date: Jan 2002
Real name: Wayne
Thanks Calash. Will try out your fixes. Through community development of this re-usable code we can make it a strong feature.
__________________
Wayne Luke
Get started with your own social network. Purchase and download vBulletin today.
Reply With Quote
  #380  
Old 23 Sep 2009, 17:04
redlabour's Avatar
redlabour redlabour is offline
 
Join Date: Mar 2004
Real name: André
1. BUG at Installation:

Fatal error: Uncaught exception 'FacebookRestClientException' with message 'All one line story templates must be nonempty' in /XXXX/www.politikstube.de/forum/vbnexus/facebook/facebookapi_php5_restlib.php:3017 Stack trace: #0 /XXXX/www.politikstube.de/forum/vbnexus/facebook/facebookapi_php5_restlib.php(747): FacebookRestClient->call_method('facebook.feed.r...', Array) #1 /XXXX/www.politikstube.de/forum/admincp/global.php(243) : eval()'d code(100): FacebookRestClient->feed_registerTemplateBundle(Array, Array, NULL, Array) #2 /XXXX/www.politikstube.de/forum/admincp/global.php(243): eval() #3 /XXXX/www.politikstube.de/forum/admincp/index.php(24): require_once('/poltbofu/www.p...') #4 {main} thrown in /XXXX/www.politikstube.de/forum/vbnexus/facebook/facebookapi_php5_restlib.php on line 3017
at Facebook Wall Feed Template Configuration if i try to edit and save "newreply feed" and "newalbum feed".

2. BUG after Installation:

There is no navbar Icon shown up after proceeding the whole Installationprocess.

Feature Request:

1. IM Card for Facebook at Postbit and Userprofile (like Skype, Yahoo, AIM, MSN)
Reply With Quote
  #381  
Old 23 Sep 2009, 17:27
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Originally Posted by Wayne Luke View Post
Thanks Calash. Will try out your fixes. Through community development of this re-usable code we can make it a strong feature.
Let me know if there is anything wrong with it. Like I said it is my first attempt to put together a product so there may be mistakes.

I think I found a fix for some of the staying logged in problems. The specific behavior I am seeing is that, from some networks, after authenticating via Facebook you close the browser for some time. Upon returning to the site you find that you are logged in fine until you click a link or refresh. At that point you lose authentication and have to login in a second time.


I edited one of the plugins to remove what appeared to be a near random logout() call when Facebook is not sure that your cookie is valid. I believe this check was to disconnect you from the forum should you logout of Facebook, however it seemed to cause more harm than good. Removing this has eliminated the auto-logout problems for me. Manual logout still works fine.

I still want to test it for a day or so before throwing it up.



redlabour


1 - Ether try the product file I posted above or search the thread for the template bundle ID fix. I think that will clear up the problem.

2 - I looked at the site in your sig and could not see any of the vBNexus code in it. If you are missing some of the hooks and/or have a heavily modified theme this may be part of your problem.

Last edited by Calash; 23 Sep 2009 at 17:33.
Reply With Quote
  #382  
Old 23 Sep 2009, 18:23
Ohiosweetheart Ohiosweetheart is offline
 
Join Date: Dec 2005
Real name: Peggy
You're a good person, Calash!
Reply With Quote
  #383  
Old 23 Sep 2009, 19:06
cherylferraro's Avatar
cherylferraro cherylferraro is offline
 
Join Date: Oct 2005
Thank you Calash!
Reply With Quote
  #384  
Old 23 Sep 2009, 19:21
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
The fix I am currently testing, if anybody wants to give it a try by hand

Plugin: Is user a facebook user?

Locate the following lines

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Comment them out, so they look like the following


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #385  
Old 24 Sep 2009, 03:44
mikeB's Avatar
mikeB mikeB is offline
 
Join Date: Dec 2001
hi can anyone tell me what might cause a white/blank page after trying to log in w/ facebook connect - IE goes to internal server error, FF goes white, safari goes white?

http://www.nickdip.com/forum/

(I tried the debug mode trick and followed all of the directions) not sure if this has come up
__________________
mikeB
BakerMedia
Reply With Quote
  #386  
Old 24 Sep 2009, 04:00
mikeB's Avatar
mikeB mikeB is offline
 
Join Date: Dec 2001
ps if anyone would like credit or plug for helping me install this to comedian nick dipaolo's forum I can do that for you
__________________
mikeB
BakerMedia
Reply With Quote
  #387  
Old 24 Sep 2009, 13:25
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Originally Posted by mikeB View Post
hi can anyone tell me what might cause a white/blank page after trying to log in w/ facebook connect - IE goes to internal server error, FF goes white, safari goes white?

http://www.nickdip.com/forum/

(I tried the debug mode trick and followed all of the directions) not sure if this has come up
I am not seeing any of the vB Nexus code on your page. Did you disable the plugin?

A blank page may be due to forum path settings in the Facebook application. Check there first and make sure everything is setup right.
Reply With Quote
  #388  
Old 24 Sep 2009, 15:20
Calash's Avatar
Calash Calash is offline
 
Join Date: Jun 2006
Attached is the new product file with the following fixes

- Logout issue after clicking on a link is resolved. If you still have issues check your cookie settings as I found this can cause some odd issues, especially if you run more than 1 forum on the web host.
- Login buttons are now in a template and eval to the navbar_buttons_right hook. This looks good on my site but may not be the best place for them. Paths are relative using the $vboptions[bburl] variable so this should work well for people who run external scripts, such as CMPS. Using the template hook seems a bit more stable than the previous system.


Use at your own risk. This is not an official update but an export of what is currently running on my website. Please let me know if you see any problems or have any suggestions as to how I can improve. I am still very new at vB products.
Attached Files
File Type: xml product-vbnexus(2).xml (79.3 KB, 14 views)
Reply With Quote
  #389  
Old 25 Sep 2009, 00:52
thefarg thefarg is offline
 
Join Date: Aug 2009
Hi Im having a problem with the facebook connect side of it. When I try to use it, the window it pops up is directed to
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

. I have VB CMPS installed to root with VB installed in the forum directory. (along with VBnexus). If running CMPS should i install VBnexus to the root folder or forum? Any help with this would be much appreciated.
Reply With Quote
  #390  
Old 25 Sep 2009, 01:02
thefarg thefarg is offline
 
Join Date: Aug 2009
Hi Im having a problem with the facebook connect side of it. When I try to use it, the window it pops up is directed to " http://youoriginal.com/vb/vbnexus/facebook/xd_receiver.htm?fb_login&fname=_opener&guid=0.42088404297828674&session=%7B%22session_key%22%3A %223.X8XEhFYBK42HkA9Z5OC96Q__.86400.1253923200-1372989372%22%2C%22uid%22%3A%221372989372%22%2C%22expires%22%3A1253923200%2C%22s ecret%22%3A%22kAYnWoxMZeExJB_M7MQyfw__%22%2C%22base_domain%22%3A%22youoriginal.c om%22%2C%22sig%22%3A%2253406980a9f8e5003d4381a47219aac1%22%7D " . I have VB CMPS installed to root with VB installed in the forum directory, (along with VBnexus). So vbnexus and forum is at http://youoriginal.com/forum . If running CMPS should i install VBnexus to the root folder or forum? Is there a better way (i.e) change all instances of
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

to
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in the product file? Any help with this would be much appreciated.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 18:17.

Layout Options | Width: Wide Color: